Publikowanie hostowanych warstw kafli z plików

Warstwy kafli publikowane i hostowane w usłudze ArcGIS Online zapewniają szybką wizualizację dużych zestawów danych za pomocą zestawu wcześniej przygotowanych rastrów map lub kafli. Hostowane kafle zapewniają odniesienie geograficzne dla warstw operacyjnych. Na przykład użytkownik może dodać kafle ulic swojej okolicy w celu utworzenia wizualnego odwołania do znaków drogowych na warstwie obiektowej.

Warstwy kafli hostowane w usłudze ArcGIS Online są przydatne w przypadku konieczności wyświetlenia mapy w sieci w celu wizualizacji, gdy użytkownik nie dysponuje własnym serwerem ArcGIS Server. Pozwalają również udostępnić określone mapy użytkownikom Internetu w przypadku, gdy nie można udostępnić publicznie własnego serwera ArcGIS Server. Usługa WMTS jest dostępna dla warstw kafli hostowanych w usłudze ArcGIS Online, które są udostępniane publicznie.

Warstwę kafli można opublikować z istniejącej hostowanej warstwy obiektowej lub, korzystając z jednej z następujących metod, utworzyć plik w aplikacji ArcGIS Pro lub ArcMap i użyć go do opublikowania hostowanej warstwy kafli w usłudzeArcGIS Online:

Aby opublikować hostowaną warstwę kafli, użytkownik musi mieć przypisaną w instytucji jedną z następujących ról:

Podczas publikowania z aplikacji ArcGIS Pro, ArcMap lub pakietu kafli plik pakietu kafli jest dodawany jako element do Twoich zasobów. Gdy potwierdzisz, że warstwa kafli działa, możesz usunąć pakiet warstwy kafli z usługi ArcGIS Online, aby zaoszczędzić przestrzeń do przechowywania (ale tylko wtedy, gdy masz pewność, że nie potrzebujesz już tego pakietu kafli).

Definiowanie i publikowanie mapy w aplikacji ArcGIS Pro

Z poziomu mapy w aplikacji ArcGIS Pro można opublikować warstwę kafli, która będzie hostowana w usłudze ArcGIS Online. W tym celu wymagane jest połączenie internetowe.

Notatka:

Jeśli do warstw w aplikacji ArcGIS Pro zastosowano zapytania definiujące, system ArcGIS stosuje te zapytania definiujące do opublikowanych hostowanych warstw kafli. Jednak wszystkie dane są przesyłane do usługi ArcGIS Online. Aby opublikować i przesłać do usługi ArcGIS Online tylko podzestaw danych, należy wyeksportować ten podzestaw danych do innej klasy obiektów i ją opublikować.

Prędkość i przepustowość połączenia mają wpływ na szybkość publikowania warstwy kafli.

Należy również pamiętać, że przeglądarki internetowe nie wyświetlają niektórych bardziej złożonych symboli kartograficznych, które mogły zostać zastosowane przez użytkownika podczas tworzenia mapy. Większość rodzajów symboli jest dostępna, jednak w niektórych przypadkach symbole mogą zostać uproszczone po publikacji. Zapoznaj się z tematem Tworzenie map w celu publikowania usług obiektowych w systemie pomocy serwera ArcGIS Server, aby uzyskać więcej informacji o obsługiwanych symbolach, a następnie przed publikacją wprowadź niezbędne zmiany w symbolach mapy.

  1. Uruchom aplikację ArcGIS Pro i otwórz projekt zawierający mapę, którą chcesz opublikować.
  2. Zaloguj się do swojej instytucji w aplikacji ArcGIS Pro za pomocą konta mającego uprawnienia do tworzenia zasobów i publikowania hostowanych warstw kafli.
  3. Kliknij pozycję Warstwa internetowa znajdującą się w sekcji Udostępnij jako w karcie Udostępnianie.
  4. Wpisz nazwę warstwy kafli.
  5. Wpisz podsumowanie i znaczniki warstwy kafli.
  6. Wybierz opcję Kafel jako wartość opcji Typ warstwy.
    Domyślnie warstwy są zapisywane na stronie Moje zasoby. Można je zapisać w folderze znajdującym się w obszarze Moje zasoby, wpisując nazwę folderu lub przechodząc do istniejącego folderu.
  7. Określ, kto ma mieć dostęp do tych hostowanych warstw kafli.

    Wszystkie opublikowane przez Ciebie warstwy są automatycznie udostępniane w Twojej osobistej przestrzeni roboczej w instytucji (Moje zasoby). Inni użytkownicy nie mogą korzystać z zasobów należących do bieżącego użytkownika ani ich wyświetlać, dopóki nie zostaną one udostępnione im za pomocą jednej z poniższych opcji:

    • Każdy — po zaznaczeniu tej opcji warstwa będzie dostępna publicznie.
    • Nazwa instytucji — ta opcja jest widoczna dla użytkowników zalogowanych na koncie instytucji. Po wybraniu tej opcji warstwa zostaje udostępniona wszystkim uwierzytelnionym użytkownikom w instytucji.
    • Grupy — warstwę można udostępnić członkom grup, do których należy bieżący użytkownik, wybierając grupy z listy rozwijanej.
  8. Aby skonfigurować ustawienia pamięci podręcznej, kliknij kartę Konfiguracja.
  9. Wybierz opcję Schemat kafli.
  10. Aby określić odpowiednią wartość minimalną i maksymalną skali dla warstwy kafli, zmień rozmiar suwaka Poziomy szczegółowości i przesuń go.

    Szacowana wielkość wynikowej pamięci podręcznej zmienia się, gdy jest zmieniana wartość minimalna i maksymalna skali.

  11. W sekcji Opcje wybierz miejsce i czas budowania pamięci podręcznej kafli.
    • Wybierz opcję Utwórz pamięć podręczną automatycznie na serwerze, jeśli kafle mają być budowane w usłudze ArcGIS Online podczas publikowania warstwy.
    • Jeśli pamięć podręczna ma zostać zbudowana i zapisana w usłudze ArcGIS Online, ale chcesz ją zbudować samodzielnie po opublikowaniu, wybierz opcję Utwórz pamięć podręczną ręcznie na serwerze, otwórz warstwę kafli w witrynie ArcGIS Online po opublikowaniu warstwy, a następnie ręcznie utwórz pamięć podręczną.
    • Jeśli chcesz zminimalizować liczbę kredytów wykorzystywanych podczas publikowania warstwy kafli w usłudze ArcGIS Online, wybierz opcję Utwórz pamięć podręczną lokalnie i podaj lokalizację na urządzeniu z aplikacją ArcGIS Pro, w której zostanie zapisany tymczasowy pakiet kafli. Pamięć podręczna jest budowana i umieszczana w pakiecie na urządzeniu z aplikacją ArcGIS Pro, pakiet kafli jest automatycznie przesyłany do usługi ArcGIS Online w celu rozpakowania, a pamięć podręczna jest zapisywana w usłudze ArcGIS Online.
  12. Aby zezwolić innym osobom na pobieranie kafli mapy do użytku w trybie offline, zaznacz opcję Zezwalaj klientom na eksport pamięci podręcznej kafli.
  13. W przypadku zaznaczenia opcji Zezwalaj klientom na eksport pamięci podręcznej kafli użyj pola Ogranicz eksport do, aby określić maksymalną liczbę kafli, których klienci mogą jednocześnie używać w trybie offline.
  14. Aby wyznaczyć liczbę kafli oraz wielkość pamięci na potrzeby opcji buforowania, otwórz sekcję Oszacuj i kliknij przycisk Oblicz.

    Możesz zmienić ustawienia pamięci podręcznej i wykonać obliczenie ponownie, aby zobaczyć, jaki wpływ na pamięć podręczną mają ustawienia.

  15. Aby upewnić się, czy warstwa kafli będzie zawierać odpowiednie warstwy danych, kliknij kartę Zasoby.
  16. Aby sprawdzić, czy nie wystąpiły problemy lub błędy, kliknij przycisk Analizuj.

    Na karcie Komunikaty wyświetlane są wszystkie problemy znalezione przez analizatory. Kliknij prawym przyciskiem myszy każdy z komunikatów, aby uzyskać więcej informacji, zapoznać się z treścią pomocy dotyczącej błędu lub ostrzeżenia oraz uzyskać dostęp do sugerowanych rozwiązań problemu. Opublikowanie elementu będzie możliwe dopiero po usunięciu błędów. Ponadto można rozwiązać problemy sygnalizowane ostrzeżeniami, aby zwiększyć wydajność i zoptymalizować wygląd danej hostowanej warstwy kafli.

  17. Po usunięciu błędów i (opcjonalnie) ostrzeżeń kliknij przycisk Publikuj.
    Notatka:

    Dane użytkownika zostaną skopiowane do usługi ArcGIS Online. Rozmiar danych i prędkość połączenia internetowego mają wpływ na czas publikacji.

Po zakończeniu publikacji możesz kliknąć opcję Zarządzaj warstwą internetową, aby otworzyć usługę ArcGIS Online.

Tworzenie pakietu kafli w aplikacji ArcGIS Pro i przesyłanie go do instytucji

Użyj narzędzia do geoprzetwarzania Utwórz pakiet kafli mapy, aby utworzyć pakiet kafli, dodać pakiet do instytucji oraz opublikować warstwę kafli.

W wersji 2.3 lub nowszej aplikacji ArcGIS Pro formatem danych wynikowych tego narzędzia geoprzetwarzania może być plik .tpk lub plik .tpkx. W nowym formacie .tpkx używana jest uproszczona struktura pliku, która zapewnia lepszą wydajność podczas działania w chmurze lub współdzielonych lokalizacjach sieciowych. Jest to format o otwartej specyfikacji. W tej procedurze wykonywania zadań możesz użyć obu formatów.

  1. Otwórz projekt zawierający dane, które zostaną dodane do pakietu.
  2. Otwórz i uruchom narzędzie do geoprzetwarzania Create Map Tile Package.
  3. Gdy tworzenie pakietu kafli się zakończy, zaloguj się do instytucji przy użyciu konta z uprawnieniami do tworzenia zasobów i publikowania hostowanych warstw kafli, a następnie kliknij opcję Zasoby > Moje zasoby > Nowy element.
  4. Kliknij Twoje urządzenie, aby dodać pakiet kafli
  5. Wybierz Dodaj pakiet kafli i utwórz hostowaną warstwę kafli.
  6. Kliknij przycisk Dalej.
  7. Wpisz tytuł.
  8. Wybierz folder, w którym chcesz zapisać element.
  9. Jeśli w instytucji są skonfigurowane kategorie zasobów, kliknij opcję Przypisz kategorie i wybierz maksymalnie 20 kategorii pomocnych w wyszukaniu tego elementu.

    Aby zawęzić listę kategorii, możesz też zacząć wpisywać nazwę kategorii.

  10. Opcjonalnie wpisz rozdzielane przecinkami terminy znaczników.

    Znaczniki to wyrazy lub krótkie frazy opisujące dany element i pomagające go znaleźć podczas wyszukiwania. Wartość Obszar federalny jest traktowana jako pojedynczy znacznik, natomiast Obszar, federalny — jako dwa znaczniki.

  11. Kliknij przycisk Zapisz.

Kafle zostaną rozpakowane i zostanie utworzona hostowana warstwa kafli. Kafle mapy i pakiet kafli są widoczne na stronie Moje zasoby.

Po sprawdzeniu, czy warstwa kafli istnieje i działa, można opcjonalnie usunąć oryginalny pakiet kafli, aby nie zużywać kredytów na jego przechowywanie.

Publikowanie dużych pakietów kafli

Jeśli budowane i udostępniane są duże ilości danych, firma Esri zaleca skorzystanie z zestawu narzędzi do tworzenia Kafli w pamięci podręcznej zamiast postępowania według powyższej procedury wykonywania zadań. Te narzędzia wykorzystują wiele rdzeni przetwarzających, dzięki czemu zwiększa się wydajność operacji generowania i publikowania kafli.

W aplikacji ArcGIS Pro uruchom narzędzia geoprzetwarzania.

  1. Uruchom narzędzie geoprzetwarzania Utwórz pakiet kafli mapy, aby utworzyć pakiet kafli w jednym etapie albo uruchom poniższe narzędzia geoprzetwarzania w następującej kolejności:
    1. Uruchom narzędzie Generuj schemat kafli pamięci podręcznej kafli w celu zdefiniowania siatki kafli i formatu rastra.
    2. Uruchom narzędzie Zarządzaj pamięcią podręczną kafli w celu utworzenia kafli.
    3. Uruchom narzędzie Eksportuj pamięć podręczną kafli w celu utworzenia pakietu kafli.

    Aby wygenerować pamięć podręczną o określonych zasięgach lub poziomach szczegółowości, należy użyć trzech narzędzi wymienionych powyżej.

  2. Uruchom narzędzie Udostępnij pakiet (w zestawie narzędzi Pakiet) w celu przesłania kafli do oprogramowania ArcGIS Online.
  3. Gdy pakiet kafli jest gotowy, zaloguj się do instytucji przy użyciu tego samego konta, którego użyto do utworzenia pakietu kafli w aplikacji ArcGIS Pro, a następnie kliknij opcję Zasoby > Moje zasoby.
  4. Kliknij pakiet kafli, aby wyświetlić stronę szczegółów elementu.
  5. Kliknij element Publikuj.
  6. Wpisz tytuł i znaczniki.
  7. Jeśli w instytucji są skonfigurowane kategorie zasobów, kliknij opcję Przypisz kategorię i wybierz maksymalnie 20 kategorii pomocnych w wyszukaniu tego elementu.

    Aby zawęzić listę kategorii, można również wpisać wartość w polu Filtruj kategorie.

  8. Kliknij element Publikuj.

Kafle zostaną rozpakowane i zostanie utworzona hostowana warstwa kafli. Warstwa jest wyświetlana na stronie Moje zasoby.

Po sprawdzeniu, czy warstwa kafli istnieje i działa, można opcjonalnie usunąć oryginalny pakiet kafli, aby nie zużywać kredytów na jego przechowywanie.

Definiowanie i publikowanie mapy w aplikacji ArcMap

Z poziomu aplikacji ArcMap można opublikować warstwę kafli, która ma być hostowana w usłudze ArcGIS Online. W tym celu wymagane jest połączenie internetowe.

Notatka:

Jeśli do warstw w aplikacji ArcMap zastosowano zapytania definiujące, system ArcGIS stosuje te zapytania definiujące do opublikowanych hostowanych warstw kafli. Jednak wszystkie dane są przesyłane do usługi ArcGIS Online. Aby opublikować i przesłać do usługi ArcGIS Online tylko podzestaw danych, należy wyeksportować ten podzestaw danych do innej klasy obiektów i ją opublikować.

Prędkość i przepustowość połączenia mają wpływ na szybkość publikowania usługi.

  1. Uruchom aplikację ArcMap i otwórz mapę, którą chcesz opublikować.
  2. Zaloguj się w usłudze ArcGIS Online za pomocą konta instytucji z uprawnieniami do tworzenia zasobów i publikowania hostowanych warstw kafli.
    1. Kliknij Plik > Zaloguj.
    2. Wpisz nazwę użytkownika i hasło usługi ArcGIS Online, a następnie kliknij przycisk Zaloguj.
  3. Opublikuj mapę.
  4. Kliknij kolejno elementy Plik > Udostępnij jako > Usługa.
  5. Wybierz opcję Publikuj usługę i kliknij przycisk Dalej.
    Uwaga:

    Jeżeli użytkownik zdecyduje się zastąpić usługę, istniejący element kafla mapy zostanie usunięty z usługi ArcGIS Online i utworzony będzie nowy o takiej samej nazwie. W folderze głównym tworzony jest nowy element, któremu zostaje przypisany nowy identyfikator. Należy ponownie skonfigurować funkcję udostępniania, a w razie potrzeby przenieść element z powrotem do folderu, w którym znajdował się przed ponownym opublikowaniem.

  6. Na liście rozwijanej typów połączenia, wybierz Moje hostowane usługi. Wpisz nazwę kafli i kliknij przycisk Kontynuuj.
  7. Skonfiguruj wymagane właściwości w oknie Edytora usługi.

    Użytkownik może zdecydować, jakie operacje są dopuszczalne w przypadku kafli oraz szczegółowo dostosować sposób ich prezentacji użytkownikom końcowym. Informacje na temat najlepszej konfiguracji kafli na potrzeby wdrożenia zawiera sekcja Optymalizacja i konfigurowanie usług w pomocy dla serwera ArcGIS Server. Niektóre z właściwości wspomniane w tym temacie odnoszą się wyłącznie do serwera ArcGIS Server i nie mają zastosowania w pracy z hostowanymi warstwami kafli. W przypadku warstw kafli hostowanych w usłudze ArcGIS Online nie ma możliwości skonfigurowania minimalnej i maksymalnej liczby instancji usługi, ponieważ skalowanie usług obsługuje firma Esri.

    Wskazówka:

    Jeżeli okno Edytor usługi zostanie zamknięte w trakcie sesji, wyświetlony zostanie monit o zapisanie pracy jako projektu usługi. Projekty usług umożliwiają powrót do konfiguracji usług w późniejszym czasie. Domyślnie, wersje robocze usługi są zapisywane w folderze Projekty połączenia z Moimi hostowanymi usługami. Szczegółowe informacje znajdują się w temacie O projektach usług w pomocy do serwera ArcGIS Server.

  8. Należy skonfigurować kilka właściwości specjalnych w przypadku hostowanych warstw kafli. Zostały one szczegółowo opisane w dalszej części.
  9. W oknie Edytor usługi, kliknij kartę Funkcje, następnie zaznacz opcję Mapa kafelkowa, aby ustawić mapę jako warstwę kafli. Zaznacz opcję Dostęp do obiektów, aby opublikować warstwę obiektową razem z kaflami, jeżeli chcesz dla warstwy skonfigurować okna podręczne po dodaniu jej do przeglądarki Map Viewer.

    Możesz kliknąć element podrzędny Tworzenie map kafelkowych dostępny w oknie Edytor usługi, aby ustawić zaawansowane właściwości dotyczące operacji na opublikowanej warstwie kafli, które mogą wykonać użytkownicy.

  10. Kliknij element Tworzenie pamięci podręcznej, aby skonfigurować właściwości dla pamięci podręcznej kafli.

    Więcej szczegółowych instrukcji zawiera sekcja Tworzenie pamięci podręcznej mapy w pomocy dla serwera ArcGIS Server. Należy pamiętać o tym, że niektóre zaawansowane ustawienia pamięci podręcznej są dostępne tylko podczas bezpośredniego publikowania na serwerze ArcGIS Server.

  11. W oknie Edytor usługi kliknij opcję Opis elementu i wprowadź podsumowanie oraz znaczniki tej warstwy kafli.

    Przed opublikowaniem konieczne jest podanie tych informacji.

    Szczegółowe informacje, znajdują się w sekcji poświęconej szczegółom elementu w temacie Konfiguracja właściwości usług mapowych w pomocy dla serwera ArcGIS Server.

  12. Kliknij znajdującą się w oknie Edytor usługi opcję ArcGIS Online, a następnie wybierz, komu ma być udostępniana hostowana warstwa kafli.

    Domyślnie hostowana warstwa kafli jest prywatna, co oznacza że jest dostępna wyłącznie dla jej właściciela. Można udostępnić ją wszystkim użytkownikom, wszystkim członkom instytucji lub członkom określonych grup usługi ArcGIS Online.

  13. W oknie Edytor usługi kliknij przycisk Analizuj Analizuj.

    Nastąpi sprawdzenie mapy, czy może zostać opublikowana. Aby było możliwe opublikowanie, musisz usunąć błędy wymienione na liście Błędy Błąd w oknie Przygotowanie. Ponadto można usunąć ostrzeżenia oraz komunikaty, aby podnieść wydajność i zoptymalizować wygląd swoich opublikowanych kafli.

  14. Możesz również kliknąć opcję Podgląd Podgląd znajdującą się w oknie Edytor usługi.

    Tutaj możesz sprawdzić, jak wygląda Twoja warstwa kafli w internecie.

  15. Po usunięciu błędów oraz opcjonalnie ostrzeżeń i komunikatów kliknij przycisk Publikuj Publikuj.
    Notatka:

    Dane użytkownika zostaną skopiowane do usługi ArcGIS Online. Rozmiar danych i prędkość połączenia internetowego mają wpływ na czas publikacji. Zaczekaj chwilę na wygenerowanie kafli.

Gdy kafle zostaną opublikowane w usłudze ArcGIS Online, będą widoczne po rozwinięciu węzła Moje hostowane usługi w oknie Katalog.

Hostowana warstwa kafli jest przedstawiana jako dwa niezależne elementy na karcie Moje zasoby w witrynie usługi ArcGIS Online: Kafle i Definicja usługi. Definicja usługi to skompresowany plik zawierający mapę, dane i szczegóły dotyczące sposobu publikacji kafli. Definicje usług można przenieść i opublikować na dowolnym komputerze obsługującym oprogramowanie ArcGIS Server 10.1 lub wersję nowszą.

Tworzenie i udostępnianie pakietu kafli w aplikacji ArcMap i publikowanie go

Aplikacja ArcMap umożliwia tworzenie kafli przeznaczonych dla dokumentu mapy i przechowywanie ich w pliku pakietu kafli, który można przenosić. Pakiet kafli można utworzyć w aplikacji ArcMap, udostępnić w usłudze ArcGIS Online, a następnie opublikować jako hostowaną warstwę kafli. Ta procedura wykonywania zadań umożliwia budowanie kafli z zastosowaniem mocy obliczeniowej własnego komputera, a nie kredytów w usłudze ArcGIS Online.

Wskazówka:

Należy zauważyć, że w celu konfiguracji okien podręcznych wymagane jest opublikowanie warstwy obiektowej wraz z hostowaną warstwą kafli.

Istnieją dwie metody pozwalające na utworzenie i udostępnienie pakietu kafli w aplikacji ArcMap.

  • Aby spakować i udostępnić małą ilość danych (mniej niż 1 GB), można utworzyć i udostępnić pakiet kafli bezpośrednio z poziomu mapy. Podczas publikowania pakietu w usłudze ArcGIS Online elementy dokumentu mapy, takie jak legenda i elementy tekstowe, są zachowywane.
  • Aby spakować i udostępnić kafle, w przypadku których ilość danych przekracza 1 GB, użyj narzędzi geoprzetwarzania. Jeśli w przypadku użycia tej metody kafle zostaną opublikowane z pakietu kafli, zachowane zostaną tylko dane, co poprawi wydajność tworzenia kafli.

W aplikacji ArcMap 10.7 formatem danych wynikowych każdej procedury wykonywania zadań może być plik .tpk lub plik .tpkx. W nowym formacie .tpkx używana jest uproszczona struktura pliku, która zapewnia lepszą wydajność podczas działania w chmurze lub współdzielonych lokalizacjach sieciowych. Jest to format o otwartej specyfikacji. W obu tych procedurach wykonywania zadań możesz użyć obu formatów.

Publikowanie małych pakietów kafli

Jeśli pakiet kafli utworzony w aplikacji ArcMap jest mniejszy niż 1 GB, opublikuj go, wykonując następujące czynności:

  1. Otwórz mapę w aplikacji ArcMap.
  2. Zaloguj się za pomocą konta instytucji z uprawnieniami do tworzenia zasobów i publikowania hostowanych warstw kafli.
  3. Kliknij kolejno elementy Dostosuj > Opcje aplikacji ArcMap > Udostępnianie i upewnij się, że zaznaczona została opcja Włącz narzędzia ArcGIS Runtime.

    Spowoduje to włączenie opcji menu niezbędnej w kolejnym etapie.

  4. W aplikacji ArcMap kliknij opcję Plik > Udostępnij jako > Pakiet kafli.
  5. Skonfiguruj wszystkie ustawienia opisane poniżej. Pozostałe opcje można ustawić według uznania.
    1. W karcie Pakiet kafli zaznacz opcję Prześlij pakiet na moje konto w usłudze ArcGIS Online.
    2. W karcie Format kafli zaznacz opcję ArcGIS Online / Bing Maps / Google Maps jako Schemat kafli.
    3. W karcie Opis elementu wprowadź elementy oznaczone jako wymagane.
    4. Na karcie Udostępnianie wybierz, czy pakiet ma być udostępniany publicznie, czy tylko określonym grupom.
  6. Kliknij polecenie Udostępnij.

    Może zostać wyświetlony monit informujący o konieczności zapisania mapy przed utworzeniem pakietu kafli przez aplikację ArcMap.

    Wygenerowanie pakietu kafli może potrwać dłuższą chwilę, szczególnie jeśli użyto dużych skal.

  7. Po zakończeniu generowania pakietu kafli zaloguj się w usłudze ArcGIS Online za pomocą konta instytucji i kliknij opcję Zasoby > Moje zasoby.
  8. Kliknij pakiet kafli, aby wyświetlić stronę szczegółów elementu.
  9. Kliknij element Publikuj.
  10. Wprowadź tytuł i znaczniki, a następnie kliknij przycisk Publikuj.

Kafle zostają rozpakowane i udostępnione w usłudze ArcGIS Online. Hostowana warstwa kafli jest wyświetlana w oknie Moje zasoby.

Po sprawdzeniu, czy warstwa kafli istnieje i działa, można opcjonalnie usunąć oryginalny pakiet kafli, aby nie zużywać kredytów na jego przechowywanie.

Publikowanie dużych pakietów kafli

Jeśli budowane i udostępniane są duże ilości danych, firma Esri zaleca skorzystanie z zestawu narzędzi do tworzenia Kafli w pamięci podręcznej zamiast postępowania według powyższej procedury wykonywania zadań. Te narzędzia wykorzystują wiele rdzeni przetwarzających, dzięki czemu zwiększa się wydajność operacji generowania i publikowania kafli.

Uruchom te narzędzia w następującej kolejności.

  1. Uruchom narzędzie Generuj schemat kafli pamięci podręcznej kafli w celu zdefiniowania siatki kafli i formatu rastra.
  2. Uruchom narzędzie Zarządzaj pamięcią podręczną kafli w celu utworzenia kafli.
  3. Uruchom narzędzie Eksportuj pamięć podręczną kafli w celu utworzenia pakietu kafli.
  4. Uruchom opcję Udostępnij pakiet (w zestawie narzędzi Pakiet) w celu przesłania kafli do usługi ArcGIS Online.
  5. Po zakończeniu generowania pakietu kafli zaloguj się w usłudze ArcGIS Online za pomocą konta instytucji i kliknij opcję Zasoby > Moje zasoby.
  6. Kliknij pakiet kafli, aby wyświetlić stronę szczegółów elementu.
  7. Kliknij element Publikuj.
  8. Wpisz tytuł i znaczniki.
  9. Jeśli w instytucji są skonfigurowane kategorie zasobów, kliknij opcję Przypisz kategorię i wybierz maksymalnie 20 kategorii pomocnych w wyszukaniu tego elementu.

    Aby zawęzić listę kategorii, można również wpisać wartość w polu Filtruj kategorie.

  10. Kliknij element Publikuj.

Kafle zostają rozpakowane i udostępnione w usłudze ArcGIS Online. Hostowana warstwa kafli jest wyświetlana w oknie Moje zasoby.

Po sprawdzeniu, czy warstwa kafli istnieje i działa, można opcjonalnie usunąć oryginalny pakiet kafli, aby nie zużywać kredytów na jego przechowywanie.

Publikowanie z poziomu pliku definicji usługi

Innym sposobem na udostępnienie warstw kafli i danych innym użytkownikom jest utworzenie pliku definicji usługi i przesłanie go do usługi ArcGIS Online. Autor mapy definiuje dane i symbolizację wymagane przez hostowaną warstwę kafli oraz umieszcza je w pliku definicji usługi.

Tworzenie pliku definicji usługi

Temat Zapisywanie pliku definicji usługi zawiera instrukcje dotyczące tworzenia pliku definicji usługi w aplikacji ArcGIS Pro.

Postępuj zgodnie z tymi wskazówkami, aby utworzyć plik definicji usługi w aplikacji ArcMap.

  1. Uruchom aplikację ArcMap i zaloguj się za pomocą konta instytucji.
  2. Utwórz i zapisz mapę.

    Aby uzyskać więcej informacji o tworzeniu i publikowaniu mapy, zapoznaj się z tematami dotyczącymi usług mapowych w pomocy do serwera ArcGIS Server.

  3. Teraz utwórz plik definicji usługi.
  4. Kliknij kolejno elementy Plik > Udostępnij jako > Usługa.
  5. Wybierz opcję Zapisz plik definicji usługi i kliknij przycisk Dalej.
  6. Kliknij element Wybierz połączenie i z listy rozwijanej wybierz opcję Moje hostowane usługi.
  7. Wpisz nazwę pliku i kliknij przycisk Dalej.
  8. Podaj katalog na komputerze klienckim, w którym utworzony zostanie plik definicji usługi i kliknij przycisk Kontynuuj.

    Zostanie wyświetlone okno Edytor usługi.

  9. W panelu po lewej stronie okna Edytor usługi kliknij pozycję Tworzenie pamięci podręcznej.
  10. Wybierz Schemat kafli.
  11. Wybierz minimalną i maksymalną skalę dla kafli i kliknij przycisk Oblicz rozmiar pamięci podręcznej.
  12. Kliknij pozycję Utwórz pamięć podręczną ręcznie po opublikowaniu usługi.
  13. Można również kliknąć opcję Ustawienia zaawansowane i skonfigurować dodatkowe ustawienia pamięci podręcznej kafli.
  14. W lewym panelu okna Edytor usługi kliknij opcję Opis elementu i wprowadź informacje dotyczące warstwy kafli.

    Przed utworzeniem pliku definicji usługi należy wprowadzić przynajmniej podsumowanie i znaczniki.

  15. Aby upewnić się, czy nie ma błędów, kliknij przycisk AnalizujAnalizuj.

    Przed przygotowaniem pliku definicji usługi należy usunąć wszystkie błędy. Można również wprowadzić poprawki związane ze zwróconymi ostrzeżeniami oraz komunikatami.

  16. Po usunięciu błędów oraz (opcjonalnie) ostrzeżeń i komunikatów kliknij przycisk Przygotuj Etap.

Plik definicji usługi zostanie zapisany we wskazanej lokalizacji.

Wczytanie definicji usługi i publikacja

Po uzyskaniu pliku definicji usługi od autora możesz przesłać go do usługi ArcGIS Online i opublikować warstwę kafli.

  1. Zaloguj się za pomocą konta instytucji z uprawnieniami pozwalającymi na tworzenie zasobów i publikowanie hostowanych warstw kafli, a następnie kliknij opcję Zasoby > Moje zasoby.
  2. Kliknij Nowy element.
  3. Wybierz Twoje urządzenie.
  4. Wybierz plik definicji usługi.
  5. Wybierz Dodaj definicję usługi i utwórz hostowaną warstwę obiektową.
  6. Kliknij przycisk Dalej.
  7. Jeśli w instytucji są skonfigurowane kategorie zasobów, kliknij opcję Przypisz kategorie i wybierz maksymalnie 20 kategorii pomocnych w wyszukaniu tego elementu.

    Aby zawęzić listę kategorii, możesz też zacząć wpisywać nazwę kategorii.

  8. Opcjonalnie wpisz rozdzielane przecinkami terminy znaczników.

    Znaczniki to wyrazy lub krótkie frazy opisujące dany element i ułatwiające jego odszukiwanie. Wartość Obszar federalny jest traktowana jako pojedynczy znacznik, natomiast Obszar, federalny — jako dwa znaczniki.

  9. Kliknij przycisk Zapisz, aby dodać plik definicji usługi i opublikować warstwę kafli.

    Warstwa kafli zostaje opublikowana, a plik definicji usługi i kafle zostają dodane na stronie Moje zasoby.

  10. Po zakończeniu publikowania warstwy kafli kliknij opcję Rozpocznij tworzenie kafli, aby utworzyć kafle.

Dostęp do pliku definicji usługi i hostowanej warstwy kafli jest domyślnie przypisany tylko do bieżącego użytkownika. Plik i kafle można udostępniać wszystkim użytkownikom, innym osobom z instytucji lub wybranym grupom.