Web マップおよびレイヤー

Web マップおよびレイヤーから、ArcGIS Online または ArcGIS Enterprise の Web マップとフィーチャ サービス レイヤーおよび ArcGIS Living Atlas of the World にアクセスすることができます。

このワークフローを開くには、[マップ] > [データの追加] > [Web マップおよびレイヤー] の順にクリックします。

Web マップおよびレイヤー

[Web マップおよびレイヤー] ダイアログが開きます。

マイ コンテンツ

[マイ コンテンツ] タブがデフォルトで開き、自分が作成した Web マップとフィーチャ サービスがすべて表示されます。

注意:

組織の管理者がカスタム タブを追加すると、そのタブはデフォルトで開かれる 1 つ目のタブ (たとえば、上の図の [Curated content] タブ)になります。

このコンテンツは [タイトル] で並べ替えられています。 [並べ替え] ドロップダウン メニューを使用すると、別の並べ替え方法を選択できます。 [リスト ビュー] リスト ビュー をクリックして、リスト ビューに切り替えます。 [グリッド ビュー] グリッド ビュー をクリックして、デフォルトのグリッド ビューに戻ります。 [更新] コンテンツの更新 をクリックして、コンテンツを更新します。

サムネイルにポインターを合わせると、その Web マップまたはフィーチャ サービスに関する詳細を含むポップアップ メニューが表示されます。

  • [変数を含む Web マップ] オプション 変数を含む Web マップ は、[カラーコード マップ] ワークフローと [スマート マップ サーチ] ワークフローでマップを作成する際に使用できる変数が該当する Web マップに含まれていることを示します。 詳細
  • [Web マップ レイヤー] Web マップ レイヤー オプションは、サイトに変換できるレイヤーが該当する Web マップに含まれていることを示します。

この Web マップまたはフィーチャ サービス データを現在のプロジェクトに追加するには、[開く] をクリックします。 Web マップがプロジェクトに追加され、マップ上で開きます。 または、チェックボックスを 1 つ以上オンにし、[選択の追加] をクリックして追加します。 追加した Web マップにサイトに変換できるフィーチャが含まれている場合は、マップ上のレイヤーをすぐに操作して、変換を実行できます。 プロジェクト パネルにある [レイヤーの設定] オプションを使用すると、解析とレポートで使用するレイヤーを設定することもできます。この場合は、Web マップと Web レイヤーが [Web マップおよびレイヤー] セクションに追加されます。 テリトリー レイヤーは [テリトリー] セクションに追加されます。

ヒント:

[フィルター] カテゴリのフィルター処理 をクリックし、[テリトリー] / [Web マップおよびレイヤー] を選択して、これらのアイテムだけが表示されるようにプロジェクト パネルを調整します。

カテゴリのプロジェクト リスト

ソース別に参照

上部にある各タブをクリックして、Web マップとフィーチャ サービスをそれぞれのソースから表示します。

  • [マイ コンテンツ] - 自分が作成したコンテンツ。
  • [マイ グループ] - 所属しているグループの他のユーザーが作成し、共有しているコンテンツ。
  • [組織] - 組織内の他のユーザーが作成し、共有しているコンテンツ。
  • [Living Atlas] - ArcGIS Living Atlas of the World 内のコンテンツ。 タブは、組織の管理者によって有効化された場合に使用できます。
  • [ArcGIS] - ArcGIS Online 上でパブリックに共有されているコンテンツ。 タブは、組織の管理者によって有効化された場合に使用できます。
  • [サブスクリプション レイヤー] - マーケットプレイス コンテンツのライセンスを所有している場合は、該当する Web マップと Web レイヤーがこのタブに一覧表示されます。
  • [最近追加] - 最近追加された Web マップと Web レイヤー。
注意:

組織の管理者がタブを無効にしている場合、そのタブは使用できません。

検索

現在選択されているタブに含まれるコンテンツを検索するには、検索語句を入力して、[検索] 検索語句の入力 をクリックするか Enter キーを押します。 追加する ArcGIS Web マップまたはレイヤーの URL またはアイテム ID を入力することもできます。URL は、指定された形式 (https://host/instance/rest/services/serviceName/FeatureServer) で入力する必要があります。 [検索解除] 検索語句の消去 をクリックして、検索語句を消去します。

注意:

組織の管理者が URL またはアイテム ID を入力するオプションを無効にしている場合、そのオプションを使用することはできません。

マイ コンテンツを検索

フィルター

デフォルトでは、選択されたタブのすべてのコンテンツが表示されます。 1 つまたは複数のフィルターを適用して、表示されたコンテンツをさらに絞り込むことができます。

  • [マップ範囲によるフィルター] チェックボックスをオンにして、現在のマップ範囲を基準にフィルター処理します。つまり、マップ範囲の一部または全体が現在のマップ範囲と重複している Web マップとフィーチャ サービスだけが表示されます。
    注意:

    組織の管理者がこのオプションを設定している場合、デフォルトで有効になります。

  • [フォルダー]: [マイ コンテンツ] タブでのみ使用できます。 個別のフォルダーをクリックして、そのコンテンツだけを表示します。 Business Analyst に固有のフォルダーの詳細については、こちらをご参照ください。
  • [アイテム タイプ]: [Web マップ] または [フィーチャ レイヤー] をクリックして、これらのアイテムだけを表示します。
    アイテム タイプによるフィルタリング
  • [最終変更日]: 利用可能なフィルターのいずれかを選択するか、カスタム日付範囲を選択します。
    変更日によるフィルタリング
  • [ステータスの共有]: アイテムの共有ステータスを基準にフィルター処理します。 たとえば、[組織] を選択すると、[組織] 内のすべてのユーザーと共有しているアイテムだけが表示され、[未共有] を選択すると、他のユーザーと共有していないアイテムだけが表示されます。
    共有ステータスによるフィルタリング
  • [評価]: 特定の評価を受けたアイテムまたは評価されていないアイテムだけが表示されるようにコンテンツをフィルター処理します。評価の詳細。
    評価によるフィルタリング
  • [タグ]: 特定の条件でタグ付けされたアイテムをフィルター処理します。 1 つのタグを入力するか、複数のタグをカンマで区切って入力します。
    タグによるフィルタリング
上記の [フォルダー] フィルターと同様に、次に示す一部の追加フィルターは特定のタブにのみ使用できます。
  • [マイ グループ]: [マイ グループ] タブでのみ使用できます。 いずれかのグループをクリックして、そのグループのコンテンツだけを表示します。
    [マイ グループ] によるフィルタリング
  • [カテゴリ]: [Living Atlas] タブにのみ使用できます。 リストに含まれるカテゴリのいずれかをクリックして、そのカテゴリ内のアイテムだけを表示します。
    [カテゴリ] によるフィルタリング

すべての適用済みフィルターがグリッドの上部またはコンテンツのリスト ビューに一覧表示されます。

フィルター処理された Web マップと Web レイヤー

適用済みフィルターを解除するには、レイヤーの選択解除 をクリックするか、そのフィルターの [すべて表示] オプションを選択します。 [すべてをクリア] をクリックすると、適用済みフィルターがすべてクリアされます。

組織の選択

[初期設定] > [マップ] > [データの追加][Web マップおよびレイヤー] の順に選択して、別の組織を追加することができます。 この場合には、[Web マップおよびレイヤー] ダイアログ ボックスでソース組織を選択できます。

[組織] 内のレイヤー

追加した Web マップの表示

[追加] をクリックして Web マップまたはフィーチャ サービス データを追加すると、そのデータがマップ上で開き、現在のプロジェクトの [Web マップおよびレイヤー] セクションに追加されます。 Web マップまたはレイヤーに変数が含まれている場合は、その変数を他のワークフローで使用することができます。 マップ上のフィーチャをすぐに操作するか、プロジェクト パネルからアクセスして後で操作することができます。 左上にあるプロジェクトをクリックして、プロジェクト パネルを開きます。

Web マップを展開して、それに含まれるレイヤーを表示し、Web マップまたはレイヤーの横にある [展開] 展開 をクリックして、追加処理を実行できます。たとえば、[Web マップにズーム] を使用すると、マップが Web マップのコンテンツにズームします。

バッファーの作成

サイトを保存しないで解析とレポートで使用する Web マップ レイヤーを設定するには、プロジェクト パネルの [レイヤーの設定] オプションを使用します。 サイトに変換できるフィーチャが Web マップに含まれている場合は、そのフィーチャからサイトを作成できます。 マップ上のフィーチャをクリックすると、ポップアップ ウィンドウが開き、そのフィーチャの名前、属性、その他のオプションが表示されます。

  • ポイント フィーチャの場合、[バッファーの作成] をクリックすると、そのポイントの周囲にリング、運転時間、または徒歩時間が適用されます。 その後、インフォグラフィックスとレポートを実行できます。 サイトとして保存するには、[サイトの作成] をクリックします。
  • ポリゴン フィーチャの場合、インフォグラフィックスとレポートを実行できます。 サイトとして保存するには、[サイトの作成] をクリックします。
    ポリゴン フィーチャ サイトを作成します。
    [作成したサイトの保存] ダイアログ ボックスで、サイトが保存されるレイヤーを指定するように求められます。

追加したテリトリー レイヤーの表示

[追加] をクリックしてテリトリー レイヤーを追加すると、そのレイヤーがマップ上で開き、現在のプロジェクトの [テリトリー] セクションに追加されます。 [テリトリー デザイン] レイヤーは、複数のレイヤーを含むフィーチャ サービスです。 複数のレイヤーは、レイヤー (ベース レイヤーとテリトリー レイヤー) の階層を示します。 ベース レイヤーは下位レベルの区画を表し、テリトリー レイヤーは上位レベルの区画 (ベース レイヤーの集約) を表します。 レベル レイヤーはテリトリー ソリューションのメタデータです。

注意:

テリトリーは ArcGIS Pro でのみ作成できますが、ArcGIS Online で共有されている場合は、ArcGIS Business Analyst Web App でテリトリー フィーチャ レイヤーをプロジェクトに追加することができます。

次に示された [Portland] テリトリー デザイン フィーチャでは、Portland_AlcoholSales がベース レイヤーであり、上位の [テリトリー] レイヤーに集約されます。 テリトリー レイヤーを展開して、それに含まれるレイヤーを表示し、いずれかのレイヤーの横にある [展開] 展開 をクリックして、追加処理を実行できます。 たとえば、[属性テーブルの表示] をクリックして、そのレイヤーの属性テーブルを開くことができます。 ポリゴン テリトリーの場合に限り、マップ上のテリトリーをクリックして、そのテリトリーの名前、属性、その他のオプションを含むサイト情報ポップアップ ウィンドウを開くことができます。たとえば、[インフォグラフィックス] をクリックして、サイトに関するインフォグラフィックスを実行するか、[レポート] をクリックして、サイトに関するレポートを実行します。 [サイトの作成] をクリックして、ポリゴンをサイトに変換します。 テリトリー レイヤーに変数が含まれている場合は、その変数を他のワークフローで使用することができます。 プロジェクト パネルにある [レイヤーの設定] オプションを使用すると、解析とレポートで使用する Web マップ レイヤーを設定できます。

Portland テリトリー

追加したレイヤーから変数を作成

変数を含む Web マップまたはテリトリー レイヤーを追加した場合は、[カラーコード マップ] ワークフローと [スマート マップ サーチ] ワークフローで変数を使用することができます。 [データ ブラウザー] で、[標準データ] > [マップ レイヤー] の順に選択して、レイヤーの変数を表示します。

注意:

現在マップ上に存在するレイヤーの変数だけが一覧表示されます。 プロジェクト パネルからレイヤーを有効にすることができます。

レイヤーがマップ上にないときにそのレイヤーの変数を使用できるようにする場合、[カスタム データの設定] を使用してレイヤーを設定する必要があります。 追加されたデータは、[標準データ] > [マイ データ][データ ブラウザー] で使用できます。

標準データの参照

[マップ レイヤー] をクリックして、現在マップ上に存在するレイヤーに使用できる変数を表示します。

マップ レイヤーの参照

レイヤーの設定

[レイヤーの設定] オプションを使用すると、サイトを作成またはプロジェクトに保存しなくても、解析とレポートで使用するレイヤーを設定できます。 設定が終了したら、[レポートの実行][比較レポート][適合性解析]、および [空隙解析] ワークフローで、レイヤー内のフィーチャを現在のセッションのサイトとして使用することができます。

注意:

このオプションは、レイヤー内のフィーチャを設定しますが、データは設定しません。 そのため、レイヤー内のデータ変数を使用する場合 (たとえば、カスタム レポート テンプレートでの使用)、この [レイヤーの設定] オプションでは設定を有効化できません。 そのためには、[カスタム データの設定] を使用してレイヤーを設定する必要があります。 追加されたデータ変数は、[標準データ] > [マイ データ][データ ブラウザー] で使用できます。 変数をカスタム レポート テンプレートに追加して、リングや運転時間などがあるサイトに関するレポートを実行できます。

開始するには、プロジェクト パネルを開きます。

  • Web マップは [Web マップおよびレイヤー] セクションに一覧表示されます。 Web マップを展開して、それに含まれるレイヤーを表示します。
  • テリトリーは [テリトリー] セクションに一覧表示されます。 テリトリーを展開して、それに含まれるレイヤーを表示します。
  • 目標物検索の結果から作成されたレイヤーとインポート済みファイルから作成されたレイヤーは [他のレイヤー] セクションで使用できます。
設定するポイント レイヤーまたはポリゴン レイヤーの [展開] 展開 をクリックしてから、[レイヤーの設定] をクリックします。

プロジェクト ビュー

[レイヤーの設定] パネルが開きます。 このパネルで、レイヤーからのフィーチャの選択を確定します。

[レイヤーの設定] ウィンドウ

これらのチェックボックスを使用して、リスト内のアイテムを選択/選択解除できます。 次のコントロールを使用することもできます。

  • [フィールドをアイテム名として使用] ドロップダウン メニューからフィールドを選択して、アイテム名として使用します。
  • [フィルター] [属性でフィルターを設定] オプション をクリックして、属性を基準にレイヤー内のアイテムをフィルター処理します。
  • ポイント レイヤーでは、[選択したポイントの周囲にバッファーを作成] オプションを使用して、選択したポイントの周囲に適用されるようにバッファーを変更することができます。デフォルト値はリングです。 一度に作成できるリング、運転時間、および徒歩時間は 1000 件までです。 レイヤーに含まれているポイントの数が 1000 を超えている場合は、フィルター処理を行うか、一部を選択解除してから、操作を続行する必要があります。
    注意:

    このオプションは、ポリゴン レイヤーには使用できません。

    ポリゴン レイヤーでは、フィーチャの最大数は 5000 です。 ポリゴンまたは標準区画境界の数が 5000 を超えている場合は、フィルター処理を行うか、一部を選択解除してから、操作を続行する必要があります。

操作が終了したら、[レイヤーの設定] をクリックします。

  • ポイント レイヤーを操作している場合は、これで設定が完了です。
  • ポリゴン レイヤーを操作している場合は、[レイヤーの設定] ダイアログ ボックスが開きます。

    ポリゴン タイプの選択

    ここで、設定するレイヤーのタイプを選択します。

    • これがポリゴン レイヤーの場合は、[ポリゴン レイヤー] を選択します。
    • 標準の境界を表すポリゴンを含むレイヤー (国など) の場合は、[標準区画レイヤー] を選択します。 ポリゴンが表す標準の区画境界にそのポリゴンが正しく関連付けられるようにするには、このオプションを選択する必要があります。 また、適切な区画境界と、レイヤーの属性テーブルの中から、区画境界の ID を持つフィールドを指定する必要もあります。 上記の例では、郡を含むポリゴン レイヤーが設定されているため、Counties[地理的境界レベル] ドロップダウン リストで選択されています。 レイヤーの属性テーブル内の FIPS 属性に郡 ID が含まれているため、この ID が [区画 ID フィールド] ドロップダウン リストで選択されています。

    このレイヤー内のすべてのフィーチャを設定する場合 (前の手順で選択したフィーチャだけでなく)、[このレイヤーのすべてのフィーチャを設定] チェックボックスをオンにします。

    [OK] をクリックして設定を完了します。

設定したレイヤーを使用できるワークフローのいずれかをすぐに開始するか、[完了] をクリックして、そのレイヤーを現在のセッションで後から使用することができます。

[完了]

設定したレイヤー内のフィーチャをこれらのワークフローでサイトとして使用することができます。 これらのフィーチャは、[サイトの追加] ダイアログ ボックスの [レイヤーから] タブで利用できます。

[サイトの追加] ウィンドウ
注意:

サイトがプロジェクト内で作成されることも保存されることもなく、設定したレイヤーは現在のセッションでしか使用できません。 以降のセッションで、レイヤーをもう一度設定する必要があります。

レイヤー内のフィーチャをプロジェクトに保存されるサイトに変換する場合は、フィーチャを選択して [サイトの作成] を使用します。