カスタム データの設定

カスタム データの設定ワークフローでは、独自のカスタム データを追加し、Esri Demographics データとともに使用することができます。 データ ソースを選択し、Business Analyst Web App で使用する変数を設定できます。 データ ソースはインポートするファイル、または既存のレイヤーです。 カスタム データは、データ ソースの変数に加え、数値データを統計的に割り当てたり、計算したりする方法を定めたいくつかのメタデータを使用します。 メタデータ ファイルは ArcGIS Online または ArcGIS Enterprise 組織に、[統計データ コレクション] と呼ばれるアイテム タイプとして保存されます。

ワークフローを開くには、[マップ] > [データの追加] > [カスタム データの設定] の順にクリックします。

[カスタム データの設定] をクリックして開始
[カスタム データの設定] ダイアログが左側に表示されます。
[ワークフロー] ダイアログ

概要画面には、ワークフローの 3 つのフェーズが示されます。 今後、この画面を表示しない場合は、[今後、こちらを表示しない] チェックボックスをオンにします。 [初期設定] > [マップ] > [データの追加] > [カスタム データ] の順に選択して、再度オンにできます。

[開始] をクリックします。 ワークフローの最初の画面が開きます。

マイ データ

新しいカスタム データを設定するには [設定を開始] をクリックします。 [データ ソースの選択] ステップが開きます。

過去に設定したカスタム データは [マイ データ] タブにリストされます。 他のユーザーから共有してもらったカスタム データは [共有データ] にリストされます。 カスタム データのオプションを表示するには、リストのカスタム データの横にある [オプションの表示] をクリックします。

データ ソースの選択

データ ソースの選択
次のいずれかの方法でデータ ソースを選択します。

  1. 既存の Web レイヤー

    既存のレイヤーを選択します。

    レイヤー メニューの選択
    [レイヤーの選択] ドロップダウン メニューを展開し、以下のいずれかの方法でレイヤーを追加します。
    • [レイヤーを参照]: ArcGIS Online で使用できるレイヤーの中から選択できます。 [レイヤーの選択] ダイアログ ボックスが開き、使用できるレイヤーとフィーチャ サービスが複数のタブの下で整理されます。 コンテンツを参照、フィルタリング、検索し、レイヤーを選択できます。 これは、「Web マップおよびレイヤー」ワークフローで Web マップやレイヤーを選択する手順に非常によく似ています。
      ソース組織のオプション
    • [マップ上のレイヤー]: 現在マップ上にあるレイヤーを選択できます。 選択できるレイヤーがマップにない場合、このオプションは表示されません。
    • [プロジェクトのレイヤー]: [レイヤーの選択] ダイアログが開き、現在のプロジェクトからレイヤーを選択できます。 現在のプロジェクトに選択できるレイヤーがない場合は、このオプションは表示されません。
    • [URL の入力]: フィールドに URL を直接入力してデータを追加できます。
      URL の入力
      URL が有効な場合、[検索] ボタンが有効になります。 [検索] をクリックします。 レイヤーが選択されます。 追加可能なデータ レイヤーがある、ArcGIS Online 上のフィーチャ サービスの URL も入力できます。この場合、[レイヤーの選択] ダイアログ ボックスが開き、フィーチャ サービスのレイヤーが表示されます。 数値フィールドが 1 つ以上ある、任意のレイヤーを選択できます。
      レイヤーの選択

  2. ファイルのインポート

    Excel ファイルまたはシェープファイルをインポートし、ポイント データ、ポリゴン境界、または区画境界を取り入れることができます。 [参照] をクリックし、デバイス上のファイルを選択します。 [インポート] をクリックします。

    Excel か CSV ファイルをインポートする場合、インポートするデータのタイプを選択するよう求められます: [ポイント位置] または [地理的な境界] データ テーブルの標準的な地理属性 (郵便番号や郡など) がファイルにある場合、[地理的な境界] オプションを選択できます。 地理的な境界の指定に関する情報については次の段落をご参照ください。

    ポイント位置の選択

次のいずれかをインポートします。

  • Excel/CSV ファイル ([地理的な境界] オプションを選択)
  • ポリゴン シェープファイル
  • 既存のポリゴン Web レイヤー
設定するレイヤーのタイプを選択するよう求められます。 上記のいずれでも [ポリゴン レイヤー] を選択できます。 ただし、データが区画単位による商圏とも呼ばれる管理区画 (郡など) を表している場合、[標準区画レイヤー] を選択して、ポリゴンが表す標準の区画境界にそのポリゴンが正しく関連付けられるようにすることをおすすめします。 また、適切な区画境界タイプを区画 ID フィールドとマッチングさせる必要があります。 次の例では、郡を含むカスタム データが設定されているため、Counties[地理的境界レベル] ドロップダウン リストで選択されています。 レイヤーの属性テーブル内の CNTY_FIPS 属性に郡 ID が含まれているため、この ID が [区画 ID フィールド] ドロップダウン リストで選択されています。
[インポートされたレイヤー] オプション

[インポートされたレイヤー] フィールドで、[オプションの表示] をクリックして以下のオプションを表示できます。

  • ArcGIS Online のレイヤーの関連するフィーチャ サービス URL を開くには [ArcGIS で表示] をクリックします。
  • マップ上のレイヤーを開いて表示するには [レイヤーを開く] をクリックします。
選択したレイヤーのフィールドを変数として構成するには [次へ] をクリックします。

データの構成

変数を構成して 1 つ以上のカテゴリに追加することにより、データをセットアップします。 たとえば、米国の countiesagepopulation、など特定の年代またはアプリケーションで使用するために構成する独自ソースの変数が前のセクションで選択したデータ ソースにあるとします。

[カテゴリ ビュー] リンクを選択すると、選択したデータ レイヤーの変数が左側にリストされ、カテゴリが右側にリストされます。 データ ソース名をクリックして、ArcGIS Online のレイヤーのメタデータを表示できます。

カテゴリ ビュー
  • デフォルトではカテゴリは 1 つだけです。 カテゴリを追加するには [カテゴリの追加] をクリックします。 上記の例ではカテゴリ Age が追加されています。
  • カテゴリを編集するには、対象のカテゴリにポインターを移動し、[編集] をクリックします。 [カスタム カテゴリの編集] ダイアログ ボックスが開きます。 Title およびその他のフィールドを編集できます。 上記の例では、デフォルト カテゴリの名前が Population に変更され、そのアイコンが選択され、他のメタデータ フィールドに値が入力されています。
    カスタム カテゴリの保存
  • 変数を検索するには [変数の検索] をクリックします。
  • [変数のフィルタリング] をクリックして [変数のフィルタリング] ダイアログ ボックスを開きます。 ドロップダウン メニューとテキスト フィールドを使用してフィルターを指定します。たとえば、「Display name Starts with AGE」のようにします。 [フィルターの追加] をクリックしてフィルターを追加します。 [一致する変数を表示] ドロップダウン メニューでは、指定したフィルター、またはすべてのフィルターを適用して、変数のリストをフィルタリングできます。
    変数のフィルタリング
    [適用] をクリックします。
  • 左側の変数をクリックして選択します。 変数を選択対象に追加するには Ctrl キーを押しながらクリックします。複数の変数を選択するには Shift キーを押しながらクリックします。 選択した変数をカテゴリに追加するには、カテゴリに変数をドラッグ アンド ドロップします。 または、[オプションの表示] をクリックして [カテゴリに追加] を使用します。

  • カテゴリ内の変数を表示するには、対象のカテゴリにポインターを移動し、[開く] をクリックします。 [サブカテゴリの追加] をクリックしてサブカテゴリを追加できます。 1 つ以上の変数を選択して [その他のオプション] をクリックし、リストを並べ替える [移動] や、カテゴリから変数を削除する [削除] など、その他のオプションを表示することもできます。
    変数
  • 選択した変数を構成するには、[オプションの表示][変数の構成] をクリックします。 すべての変数を構成するには、上部の [オプションの表示][すべて設定] をクリックします。
    郡変数
    [変数の構成] ダイアログ ボックスが開きます。
    変数の構成
    ここでは変数プロパティを編集できます。 終了したら [適用] をクリックします。
    • [表示名]: データ ブラウザーに表示される変数名を設定します。 1 つの変数を構成している場合のみ、これを編集できます。
    • [年代]: データ ブラウザーの情報ボタンに表示される年代を設定します。
    • [サマリー タイプ]: 集約した値を集計する方法を定義します。
      • Sum: ターゲット エリアと交差するポリゴンの集約値を合計します。
      • Average: ターゲット エリアと交差するポリゴンの集約値を平均します。
    • [加重]: [サマリー タイプ]Average である場合に使用される追加パラメーターで、加重合計を得るために使用されるフィールドを定義します。 [サマリー タイプ] として Average が選択されていない場合は、[加重] には None が自動的に選択されます。その逆も同様です。
      ヒント:

      データの中央値や比例値の変数がある場合は、複数のエリアに対してその変数の値を決定するには、加重平均が便利です。 たとえば、ZIP コード別の認知度キャンペーンに関するデータなどです。 占有率とは、キャンペーンのターゲットとなる問題について情報を得ているエリアの人口比です。 また、データセットには人口の変数も必要です。 すべてのエリアに対する全体的な占有率を把握するには、加重平均を計算します。これは、次の数式で計算されます。

      加重の数式

      エリア占有率人口占有率 x 人口

      A1

      0.5

      24,000

      (0.5 * 24,000) = 12,000

      A2

      0.7

      12,000

      (0.7 * 12,000) = 8,400

      A3

      0.4

      30,000

      (0.4 * 30,000) = 12,000

      A4

      0.2

      35,000

      (0.2 * 35,000) = 7,000

      A5

      0

      18,000

      (0 * 18,000) = 0

      Sum(人口) = 119,000

      Sum(占有率 x 人口) = 39,400

      画面上部で [テーブル ビュー] に切り替えて、テーブルで変数を構成することもできます。 構成に必要なステップの数を減らすには、複数の変数に共通するプロパティを最初に編集してから、テーブルの各変数の [表示名] を個別に編集すると便利です。 テーブルでいずれかのセル内をクリックして値を編集するか、ドロップダウン リストから別の値を選択できます。
      テーブル ビュー
完了したら、[保存] をクリックします。 構成した変数は保存されます。作成したすべてのカテゴリがカスタム データとして保存され、[マイ データ] タブにリストされます。 そのデータ タイプ (ポイントまたはポリゴン) をサポートするワークフローにあるカスタム データの変数を使用できます。 これらはデータ ブラウザーで利用できます。

カスタム データのオプション

設定したカスタム データは [マイ データ] タブで利用できます。 データ ソースから作成したすべてのカテゴリがカスタム データとして保存されます。 前のセクションの例で作成した Population カテゴリと Age カテゴリが [マイ データ] タブでカスタム データとして利用できます。 [共有データ] で、組織内の他のユーザーが共有したデータにアクセスできます。 選択したタブのカスタム データを検索するには [レイヤーの検索] をクリックします。 カスタム データ リストを更新するには [カスタム データ リストを更新] をクリックします。

[マイ データ] のオプション
以下のオプションを表示するには、レイヤーの横にある [オプションの表示] をクリックします。
  • [編集]: [カスタム データの設定] ダイアログ ボックスにカスタム データ レイヤーを開きます。 編集するには、サムネイルの上にポインターを移動し、編集ボタンをクリックします。
  • [レイヤー タイプの変更]: レイヤー タイプを変更します。 たとえば、[ポリゴン レイヤー] オプションを使ってデータ ソースを設定したものの、区画境界レベルと区画 ID フィールドを指定することで [標準区画レイヤー] に変更したくなったとします。
  • [共有]: [カスタム データの共有] ダイアログ ボックスを使用して、組織やグループを選択し、組織やグループとこのカスタム データ レイヤーを共有します。
    注意:

    1. インポートしたファイルをデータ ソースとして使用する場合、プロジェクトも共有する必要があります。
    2. 既存のレイヤーをデータ ソースとして使用する場合、レイヤーも共有する必要があります。
    追加の共有ステップが完了していない場合、共有されているカスタム データを使用した際に一部のユーザーでエラーが発生する場合があります。

  • [無効化]: カスタム データ レイヤーを無効化し、データ ブラウザーで使用できないようにします。 このリストにはレイヤーが引き続き表示され、いつでも再度有効にできます。
  • [削除]: カスタム データ レイヤーを完全に削除します。 カスタム データ レイヤーをもう一度使用するには、[カスタム データの設定] ワークフローで追加する必要があります。
  • [メタデータの表示]: レイヤーのメタデータを表示します。 メタデータを編集するには、[編集] オプションを使用します。
注意:

カテゴリ変数を編集するか、レイヤー タイプを変更すると、変数を使って作成したアイテム (カスタム インフォグラフィックス テンプレートやカスタム レポートなど) に問題が発生する場合があります。

[共有データ] では、[無効化] オプションと [メタデータの表示] オプションだけがレイヤーに使用できます。

[共有データ] オプション

カスタム データの使用

データ ブラウザーで変数を選択することで、レイヤーのデータ タイプ (ポイントまたはポリゴン) をサポートするワークフローでカスタム データを使用できます。 [マイ データ] タブには、過去に追加および設定したカスタム データがリストされます。 他のユーザーから共有してもらったカスタム データは [共有データ] で利用できます。

[マイ データ] タブ
たとえば、5 歳未満の人口のカラーコード マップを作成するには、[Age] カスタム データ カテゴリの変数を使用して以下の手順を実行します。

  1. [データからマップを作成] > [カラーコード マップ] > [すべての変数の参照] の順にクリックします。

    データ ブラウザーが開きます。

  2. [マイ データ] タブをクリックします (このタブは、カスタム データを追加した場合にのみ表示されます)。
  3. [Age] カテゴリをクリックします。

    [Age] カスタム データ カテゴリの変数はここで使用できます。

    Age 変数

  4. [Age_Under5] 変数をクリックし、その変数のカラーコード マップを作成します。