Configure Citizen Problem Reporter

Learn how to configure the Citizen Problem Reporter solution to meet specific needs in your organization. The first three sections will guide you through adding a new problem category, modifying existing problem types and agencies, and revise existing survey questions. The last section guides you through extending the app to generate report IDs, moderate reports, send email notifications and enrich reports.

Add a new problem category

The Citizen Problem Reporter app allows the public to submit nonemergency problem reports. Problem reports are grouped into categories that make it easier to submit a report. The problem categories appear when a user signs in to the app and are stored in the CitizenProblems feature layer and visualized in feature layer views.

Citizen Problem Reporter includes nine problem categories: Animal, Blight, Health, Land Use, Park/Tree, Road, Snow/Ice, Trash, and Utility. In some cases, you may want to add a problem category to Citizen Problem Reporter to meet your organization’s needs.

Add problem category

Review the CitizenProblems feature layer categories and identify what categories your organization may want to add or remove from the Citizen Problem Reporter app.

  1. Sign in to your ArcGIS organization and browse to your CitizenProblems feature layer.
  2. Open the item page and click the Data tab.
  3. Click Fields.
  4. Click the Category display name.

    In the List of Values (Domain) section, review existing categories and identify ones that are not applicable and ones that are missing.

  5. Click Edit next to List of Values (Domain).
  6. Optionally, click the Delete button to remove a category from the list.
  7. Optionally, click Add.
  8. Type the new category name into the Displayed Value and Stored Value text boxes.
  9. Repeat steps 7 and 8 to add the remaining missing categories.
  10. Optionally, drag the category to a new location in the list to reorder them.
  11. Click Save.

If you did not add new categories on the CitizenProblem layer but rather deleted them, go to the Add or remove project category indicator section.

Create feature layer view

Create a feature layer view of each new category added to the CitizenProblems feature layer.

  1. In your browser, click the Overview tab.
  2. On the CitizenProblems feature layer item page, click Create View Layer.
  3. Type the name of the category in the Title text box—for example, CitizenProblems_animal.
  4. Type tag terms separated by commas.
  5. Type a summary in the Summary text box—for example, A public view of <insert category name> problems reported by the public through focused citizen engagement apps.
  6. Save the feature layer view in the Citizen Problem Reporter folder.
  7. Click OK.

    Update the editing setting, so the public can submit nonproblem reports with the Citizen Problem Reporter app.

  8. On the item page, click the Settings tab.
  9. Scroll to the Feature Layer (hosted, view) section and check the Enable editing check box.
  10. Uncheck the Delete check box under the What kind of editing is allowed setting.
  11. Click Save.

    Set the view definition so the public sees the new problem report category.

  12. Click the Overview tab.
  13. Click Open in Map Viewer Classic.
  14. On the new category layer, click More Options, and click Set View Definition > Define Features.
  15. Create the following expression: Category is new category.
  16. Click Add another expression and create the following expression: Visible to the public is Yes.

    By default, all problem reports submitted using the Citizen Problem Reporter automatically set the Public View field to Yes, making it visible to the public. You can manually set the visibility to No using the Citizen Problem Manager when triaging the issue.

  17. Click Apply Definition.
  18. On the new category layer, click More Options, and click Show Item Details.
  19. Close the new category map tab.
  20. On the item page, click the Data tab.
  21. Click Fields.
  22. Click the Type of Problem display name.

Install add-in

To add a problem category using the Modify Domain tool, install the ArcGIS Solutions Deployment Tool Add-In. If you already installed the add-in, you do not need to install it again.

Note:
The current version of the ArcGIS Solutions Deployment Add-In is 2020.7.28. Ensure you have the most recent version of the add-in installed before proceeding.

  1. Download the ArcGIS Solutions Deployment Tool .zip file.
  2. Close ArcGIS Pro before installing the add-in.
  3. Browse to the folder to which you downloaded the .zip file and extract its contents.
  4. Double-click SolutionDeployment.esriAddInX to run the installer.
  5. Click Install Add-In.
  6. After installation is complete, click OK.
    Note:
    The current version of the ArcGIS Solutions Deployment Add-In is 2020.7.28. Ensure you have the most recent version of the add-in installed before proceeding.

Add problem type domain

Add a problem type domain for the new problem report category.

  1. Open ArcGIS Pro and create a new project.
  2. Sign in to the ArcGIS organization to which you deployed the Citizen Problem Reporter solution.
  3. On the Share tab, in the Deploy group, click ArcGIS Solutions.
  4. Double-click Configure an ArcGIS Solution task.
  5. On the Configure an ArcGIS Solution step, click Next Step.
  6. On the Add Fields step, click Skip.
  7. On the Modify Domains step, click the browse button next to the Input Layer or Table parameter.

    The Input Layer or Table dialog box appears.

  8. Under Portal, click My Content.
  9. Double-click the Citizen Problem Reporter folder.
  10. Double-click the new category feature layer view.
  11. Click Citizen Problems, and click OK.
  12. In the Field parameter, click the drop-down arrow and choose Type of Problem.
  13. In the Type parameter, click the drop-down arrow and choose Coded Value.
  14. Type the category name in the Name text box—for example, Animal.
  15. In the Domain section, type a new category in the Code text box and in the Description text box. Repeat this step until all the domains that apply to your organization have been added.
  16. Once you have finished adding domains, click Run.
  17. Click Finish.
  18. Close ArcGIS Pro and save your changes.
  19. In your browser, refresh the Type of Problem page.
  20. Click Fields.
  21. Click the Type of Problem display name.

Under the List of Values (Domain), you see the newly added domains. The domains added appear in the Type of Problem drop-down list in the Report a problem form.

Repeat the steps in this section for each new category you want to add to your Citizen Problem Reporter app. Once you have finished adding new categories, you will create a map for each category.

Create a map

Each problem category displayed in the Citizen Problem Reporter app is a single map. Create a map for each category you want to add to your Citizen Problem Reporter app.

  1. Click the Apps button in the header of the site and click Map Viewer Classic.
  2. Click the Add button and choose Search for Layers.
  3. Type the name of a category feature layer view in the search box.
  4. Click the Add button add on the layer result.
  5. Click the Back button.
  6. Click the Content button.
  7. On the new category layer, click More Options, and click Rename.
  8. Type the category name in the Layer Name text box—for example, Animal Problems.
  9. Click OK.

    Create feature templates for each new problem report category.

  10. On the layer, click Change Style.
  11. Click the Choose an attribute to show drop-down arrow and choose Show location only.

    A warning window appears, informing you the changes made to the symbology will affect the symbols displayed. Add and update the symbology once you have created a feature template for your new category.

  12. Click Yes.
  13. Click Done.
  14. Click the Edit button.
  15. Click Manage.
  16. Click the New Feature drop-down arrow and choose Properties.
  17. Type the category name and – Submitted in the Name text box—for example, Animal Problems - Submitted.
  18. Click the Category drop-down arrow and choose the new category.
  19. Click Done.
  20. Click Save Changes.
  21. Click the Close button.

Change style

Update the symbology to reflect your new problem report category.

  1. Click the Details button.
  2. On the layer, click Change Style.
  3. Click the Choose an attribute to show drop-down arrow and choose Status.

    A warning window appears, informing you the changes made will affect the symbols displayed.

  4. Click Yes.
  5. Click Options.
  6. Click the Submitted symbol.
  7. Click Shape.
  8. Click the drop-down arrow and choose a symbol set or Custom Images.
  9. If you chose to add a symbol from a symbol set, click a symbol and set the symbol size, click OK.
    Tip:

    If you chose a symbol from the Government symbol set, set the symbol size to 21 px.

  10. If you chose to add a custom image, click Use an Image, paste a URL in the text box, set a symbol size, and click OK.
  11. Repeat steps 6 through 8 and assign symbols for the remaining category statuses.
  12. Optionally, click the symbol options button to drag and reorder the symbols.
  13. Click OK.
  14. Click Done.

Update the pop-up

Update the pop-up on the new problem report layer.

  1. On the layer, click More Options, and click Configure Pop-up.
  2. Enter a title for your pop-up by clicking the [+] button and choosing the Type of Problem field.
  3. Click Configure.
  4. Click the View HTML Source button in the editor.
  5. Delete the existing HTML code.
  6. Copy and paste the following HTML code:
    {category} problem reported on {CreationDate}.<br /><br />
    <b>Details:</b> {details}<br /><br />
    <b>Status:</b><br />
    <table style="border-collapse: separate; border-spacing: 2px 4px; width: 100%; table-layout: fixed; margin: 0px -2px; max-width: 350px;">
      <tbody><tr height="16">
        <td style="{expression/expr0}; text-align: center; width: 25%"></td>
        <td style="{expression/expr1}; text-align: center; width: 25%"></td>
        <td style="{expression/expr2}; text-align: center; width: 25%"></td>
        <td style="{expression/expr3}; text-align: center; width: 25%"></td>
      </tr>
      <tr height="24" style="text-align: center;">
     	<td style="text-align: center; width: 25%; font-weight: normal; padding-left: 0px; word- wrap: break-word;">Submitted</td>
     	<td style="text-align: center; width: 25%; font-weight: normal; padding-left: 0px; word- wrap: break-word;">Received</td>
     	<td style="text-align: center; width: 25%; font-weight: normal; padding-left: 0px; word- wrap: break-word;">In Progress</td>
     	<td style="text-align: center; width: 25%; font-weight: normal; padding-left: 0px; word- wrap: break-word;">Completed</td>
      </tr>
    </tbody></table>
    <table style=" border-collapse: separate; border-spacing: 0px 0px; width: 100%; table-layout: fixed; margin: 0px -1px;">
      <tbody><tr>
    	<td style="display:{expression/expr4}; text-align: left; width: 100%">
    	  <b><br />Resolved On:</b> {resolutiondt}<br /><br />
    	  <b>Resolution:</b> {resolution}
    	</td>
      </tr></tbody>
    </table>
  7. Click the View HTML Source button in the editor.
  8. Click OK.
  9. Click the Configure Attributes link.
  10. Click the Edit check box, and uncheck the check box.
  11. Click the Display check box and uncheck the check box.
  12. Click the Display check box next to the following fields: {probtype}, {status}, {details}, {expression/expr0}, {expression/expr1}, {expression/expr2}, {expression/expr3}, and {expression/expr4}.

    Display fields are displayed in the Report a problem form.

  13. Check the Edit check box next to the following fields: {probtype}, {details}, {pocfullname},{pocmail}, and {pocphone}. Ensure {pocfullname}, {pocmail}, and {pocphone} display check box is unchecked, so this information isn’t publicly visible.

    Edit fields are editable in the form, so when the public submits a problem report, the information is written to the editable fields.

    Optionally, you can choose to use the {pocfirstname} and {poclastname} fields in your Report a problem form instead of the {pocfullname} field. If you choose to, the First Name and Last Name parameters appear in the form instead of Full Name.

  14. Click the {details} field row.
  15. Click the Textbox Type drop-down arrow and choose Multiple Line.
  16. Rename the {details} field alias to Problem Details.

    The details field (in the Report a problem form) is renamed to Problem Details and the text box has doubled in size, so users can add more information about the problem they are submitting.

  17. Reorder the fields in the following order: {probtype}, {details}, {pocfullname}, {pocphone}, {pocmail}, {status}. To reorder the fields, click the field name and use the Move up and Move down arrows.

    The order of the fields in the Configure Attributes window reflects the order of the questions in the Report a problem form.

  18. Add a colon after the following Field Alias values: Type of Problem, Problem Details, Full Name, Phone Number, Email, and Status.
  19. Click OK.
  20. Check the Show feature attachments as links check box.
  21. Uncheck the Show when last edited check box.
  22. Under Attribute Expression, press the Shift key and click the Resolution Time and Full Name expressions.
  23. Click the Remove expression button.

    The Resolution Time and Full Name Arcade expressions persisted when you created the category feature layer view from the CitizenProblems feature layer. These Arcade expressions are not used in the Citizen Problem Reporter app.

    The first four expressions define the color used in the status bar in the layer pop-up as well as in the problem details in the Citizen Problem Reporter app. The status bar updates as the problem reported status is updated to Submitted, Received, In Progress, and Completed.

    The last Arcade expression is configured to only display the Resolved On date and Resolved fields and information in the pop-up and problem details if the status is set to Completed.

  24. Click OK.

Configure the pop-up

Configure the Comments table pop-up.

  1. On the Comments table, click More Options, and click Rename.
  2. Rename the table to Comments.
  3. Click OK.
  4. On the Comments table, click More Options, and click Configure Pop-up.
  5. Delete the pop-up title.
  6. Click Configure Attributes link.
  7. Click the Edit check box, and uncheck the check box.
  8. Click the Display check box, and uncheck the check box.
  9. Click the Display check box next to the {comments} field.

    Display fields are displayed in the Citizen Problem Reporter comment form.

  10. Check the Edit check box next to the following fields: {comments}, {pocfullname}, {pocphone}, and {pocemail}. Ensure that {pocfullname}, {pocmail}, and {pocphone} display check box is unchecked, so your citizen information isn’t publicly accessible.

    Edit fields are editable in the comment form, so when citizens make comments about a problem report, the information is written to the editable fields.

    Optionally, you can choose to use the {pocfirstname} and {poclastname} fields in your Report a problem form instead of {pocfullname} field. If you choose to, the First Name and Last Name parameters appear in the form instead of Full Name.

  11. Click the {comments} field row.
  12. Click the Textbox Type drop-down arrow and choose Multiple Line.
  13. Rename the {details} field alias to Leave a comment.

    The comment field (in the form) is renamed to Leave a comment and the text box has doubled in size, so users can add more information about their comment.

  14. Change Phone Field Alias to Phone Number.
  15. Add a colon after the following Field Alias values: Leave a comment, Full Name, Phone Number, and Email.
  16. Click OK.
  17. Uncheck the Show when last edited check box.
  18. Click OK.
  19. On the Surveys table, click More Options, and click Remove.
  20. Click Yes, Remove Table.

Save the map

Save the new problem category map.

  1. Click Save > Save As.
  2. Type a title—for example, Animal Problems.
  3. Type tags that describe your map.
  4. Provide a summary that describes the map—for example, A map used to report animal concerns in our community.
  5. Save the map in the Citizen Problem Reporter folder.
  6. Click Save Map.
  7. Click Share.
  8. Check the Citizen Problem Reporter check box.
  9. Click Cancel to update sharing. Do not share the feature layer view to the Citizen Problem Reporter group.
  10. Click Done.
  11. Click the About button.
  12. Click the More Details link.
  13. Close the new category map tab.
  14. On the item page, click Edit Thumbnail, and upload an image for the new category map.

    Repeat the steps in this section for each new category you want to add to your Citizen Problem Reporter app. In addition, you can view your new problem report category, or categories, in the Citizen Problem Reporter app.

  15. At the top of the site, click Content.
  16. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  17. Click the Citizen Problem Reporter folder.
  18. Under Item Type, click Apps.
  19. On the right side of the page, click the Citizen Problem Reporter app.
  20. On the item page, click View Application.
  21. If you haven’t shared the Citizen Problem Reporter app and all the maps referenced in the app publicly, choose Sign in with ArcGIS.

    You see the new category or categories in the app.

  22. Click a new category and click Submit Problem.
  23. Click the Type of Problem drop-down arrow to see the type of problem domains you added in ArcGIS Pro.

Once you finished reviewing the Citizen Problem Reporter app, close the tab.

Add problem category symbology

Add new problem category symbology.

  1. At the top of the site, click Content.
  2. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  3. Click the Citizen Problem Reporter folder.
  4. Under Item Type, click Layers.
  5. On the right side of the page, click the CitizenProblems layer.
  6. On the item page, click Open in Map Viewer Classic.
  7. On the layer, click Change Style.
  8. Click the Choose an attribute to show drop-down arrow and choose Category.

    A warning window appears, informing you the changes made to the symbology will affect the symbols displayed.

  9. Click Yes.
  10. Click Options.
  11. Click the Animal symbol.
  12. Click Shape.
  13. Click the drop-down arrow and choose the Government symbol set.

    All category symbols except for the new category you created are available in the Government symbol set.

  14. Browse to the Animal symbol Animal problem symbol and type 21 in the Symbol Size text box.
  15. Click OK.
  16. Repeat steps 11 through 15 to symbolize the remaining categories.
  17. Optionally, click the symbol options button to drag and reorder the symbols.
  18. Click OK.
  19. Click Done.
  20. On the layer, click More Options, and click Save Layer.

    Repeat the steps in this section to update the CitizenProblems_dashboard feature layer view symbology.

  21. Click the Add button and choose Search for Layers.
  22. Type CitizenProblems_dashboard feature layer view in the search.
  23. Click the Add button on the layer result.
  24. Click the Back button.
  25. Repeat steps 7 through 20 to apply symbols to the CitizenProblems_dashboard feature layer view.
    Tip:

    You can restore the original CitizenProblems symbols, as well as adding new category symbols, by adding a point to the map with every category and status combination.

Add category features

Add new problem features to the map and save them to the problem category and CitizenProblem_dashboard layer view.

  1. Click the Edit button.
  2. In the Add Features pane, click the Animal feature and add a point to the map.
  3. In the pop-up, click the Status drop-down arrow and choose Submitted, and then click Close.
  4. Repeat this step to add a point symbol for Animal Received, Animal In Progress, and Animal Completed because it already exists.
  5. Repeat step 2 and 3 to add the remaining category status to the map.
  6. Once all the category and status point combination have been added to the map, click the Close button.
  7. On the CitizenProblems layer, click Change Style.
  8. Click the Choose an attribute to show drop-down arrow and choose New Expression.
  9. Copy the following expression and paste it in the text box:
    return $feature.category + " " + $feature.status
  10. Click OK.
  11. Click Options.
  12. Click Ungroup to ungroup the remaining categories.
  13. Click the Animal Completed symbol.
  14. Click Shape.
  15. Click the drop-down arrow and choose the Government symbol set.
  16. Choose the Animal Problems - Completed symbol and type 21 in the Symbol Size text box. Click OK.
  17. Repeat step 13 through 16 for the remaining symbols.

    All category symbols except for the new category you created are available in the Government symbol set.

  18. Optionally, click the symbol options button to drag and reorder the symbols.
  19. Click OK.
  20. Click Done.
  21. On the CitizenProblems layer, click More Options, and click Save Layer.
  22. Repeat steps 7 through 21 to apply the original and new category symbology to the CitizenProblems_dashboard feature layer view.
  23. Click the Edit button.
  24. In the map, click one of the points and scroll to the bottom of the pop-up and click Delete. Repeat this step to delete the remaining points.
  25. Click the Close button.

View new category

View new categories in the Citizen Problem Manager and Citizen Problem Dashboard map.

  1. At the top of the site, click the Home drop-down arrow and choose Content.
  2. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  3. Click the Citizen Problem Reporter folder.
  4. Under Item Type, click Maps.
  5. On the right side of the page, click the Citizen Problem Manager map.
  6. On the item page, click Open in Map Viewer Classic.
  7. Click Yes, open the map.
  8. Click the Legend button and review the symbology.

Repeat steps 1 through 7 to review the symbology in the Citizen Problem Dashboard map.

Add or remove problem category indicator

Add or remove a category indicator in the Citizen Problem Dashboard app.

  1. At the top of the site, click the Home drop-down arrow and choose Content.
  2. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  3. Click the Citizen Problem Reporter folder.
  4. Under Item Type, click Apps.
  5. On the right side of the page, click the Citizen Problem Dashboard app.
  6. On the item page, click Edit Dashboard.

    On the Overview tab, not all the problem categories may apply to your community; you can add new category indicator or indicators to your dashboard.

  7. To add a new indicator, hover over the upper corner of the Animal Control indicator and choose Duplicate Element duplicate element.
  8. Hover over the new indicator upper corner and choose Configure Configure.
  9. In the Value area, under Filter, click the Value drop-down arrow and choose a new category.
  10. Scroll down to the Reference area, under Filter, click the Value drop-down arrow and choose a new category.
  11. Click the Indicator tab, in the Style for value at or above reference area, type a new category in the Top Text text box.
  12. In the Style for value below reference area, type a new category in the Top Text text box.
  13. Click the General tab and type a new indicator name in the Name text box.
  14. Click Done.
  15. Hover over the new indicator in the upper corner and choose Drag item drag item.
  16. Press the Shift key on your keyboard while dragging the item to group as a column. Dock the indicator next to an existing indicator.
  17. Optionally, to delete an indicator, hover over the upper corner of the indicator you want to delete and choose Delete delete element.
  18. Click Save to save changes made to the dashboard and close the dashboard.

Modify problem types and responsible agencies

Citizen Problem Reporter includes problem types and responsible agencies for each problem category. In some cases, you may want to add a problem type to an existing category or add a new problem type for any new problem category you created. In addition, you may want to modify the responsible agencies provided to more accurately reflect the name of the agency, department, or team that is responsible for responding to problem reports.

  1. At the top of the site, click Content.
  2. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  3. Click the Citizen Problem Reporter folder.
  4. Under Item Type, click Layers.
  5. On the right side of the page, click the feature layer view you want to modify—for example, CitizenProblems_Animal.
  6. On the item page, click the Data tab.
  7. Click Fields.
  8. Click the Type of Problem display name. Review List of Values (Domain). Identify domains that are missing or need to be removed from the list.
    Tip:

    To modify problem types and responsible agencies using the Modify Domain tool, you must install the Solution Deployment Tool Add-In. If you already installed the add-in, you do not need to install it again.

  9. Open ArcGIS Pro.
  10. Sign in to the ArcGIS organization to which you deployed the Citizen Problem Reporter solution template.
  11. On the Share tab, in the Deploy group, click ArcGIS Solutions.
  12. Double-click the Configure an ArcGIS Solution task.
  13. On the Configure an ArcGIS Solution step, click Next Step.
  14. On the Add Fields step, click Skip.
  15. On the Modify Domains step, click browse next to Input Layer or Table parameter.

    The Input Layer or Table dialog box appears.

  16. Under Portal, click My Content.
  17. Double-click the Citizen Problem Reporter folder.
  18. Double-click the new feature layer view.
  19. Click Citizen Problems, and click OK.
  20. In the Field parameter, click the drop-down arrow and choose Type of Problem.
  21. In the Domain section, optionally, to delete a domain, hover to the left of the domain you want to delete and click remove. Repeat this step until all the domains that do not apply to your organization have been removed.
  22. Optionally, to add a new domain, type a new category in the Code text box, and then type it in the Description text box. Repeat this step until all the domains that apply to your organization have been added.
  23. Optionally, to modify an existing domain or domains, click in the Code text box and type a new problem type, and click in the Description text box and type a new problem type.
  24. Once you have finished modifying domains, click Run.
  25. Click Finish.
  26. Close ArcGIS Pro and save your changes.

View new problem type

View new problem type in the Citizen Problem Reporter app.

  1. In your browser, refresh the Type of Problem page.
  2. Click Fields.
  3. Click the Type of Problem display name.

    Under List of Values (Domain), you see the newly added or removed domain or domains.

    Repeat the steps in this section for each problem type you want to add or modify in your Citizen Problem Reporter app.

  4. At the top of the site, click Content.
  5. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  6. Click the Citizen Problem Reporter folder.
  7. Under Item Type, click Apps.
  8. On the right side of the page, click the Citizen Problem Reporter app.
  9. On the item page, click View Application.
  10. Sign in to the app using Sign in with ArcGIS.
  11. Click the category for which you modified the problem types, and then click Submit Problem.
  12. In the Report a problem form, click the Type of Problem drop-down arrow and you see the updated type of problem domains.

    Once you finished reviewing the Citizen Problem Reporter app, close the tab.

    Now, review the list of responsible agencies and modify them to meet the needs of your organization.

  13. At the top of the site, click Content.
  14. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  15. Click the Citizen Problem Reporter folder.
  16. Under Item Type, click Layers.
  17. On the right side of the page, click the CitizenProblems feature layer.
  18. On the item page, click the Data tab.
  19. Click Fields.
  20. Click the Assigned To display name.

    Review existing agencies and identify missing ones in the List of Values (Domain) section.

  21. Click Edit next to List of Values (Domain).
  22. Optionally, click Add.
  23. Type the new agency name in the Displayed Value and Stored Value text boxes.
  24. Repeat steps 22 and 23 to add the remaining missing agencies.
  25. Optionally, click Delete to remove an agency.
  26. Optionally, click in the Label text box with an existing agency labeled and change the agency name. Repeat this step to change the Code as well.
  27. Optionally, drag the category to a new location in the list to reorder them.
  28. Click Save.

Share Citizen Problem Reporter maps and app

For the Citizen Problem Reporter app to be publicly accessible through guest and social media access, the maps and layers must be shared with everyone. Follow the steps below to share your maps and layers with everyone.

  1. Click Groups at the top of the site.
  2. Open the Citizen Problem Reporter group page and click View all group content.
    Note:

    Review the maps shared to the group. The maps shared to this group will be displayed in the Citizen Problem Reporter app.

  3. Optionally, add a map or maps to the group by clicking the Add items to group and browse to the map or maps. Check the check box next to the map or maps you want to add to the group and click Add items.
  4. Optionally, remove a map or maps from the group by checking the check box next to the map and click Remove from group.
  5. Click the Settings tab.
  6. Under Who can view this group, click Everyone (public), and click Save.
  7. Click Content at the top of the site.
  8. On the My Content tab, under Folders, type Citizen Problem Reporter in the search box.
  9. Click the Citizen Problem Reporter folder.
  10. Under Item Type, click Maps.
  11. On the right side of the page, check the check box next to the maps you want to appear in the Citizen Problem Reporter app, and click Share.
    Tip:

    Share maps with the word problems in the map name.

  12. In the Share window, click Everyone (public) and click Save.
  13. In the Update sharing window, click OK.
    Note:

    The layers associated with the maps should also be shared publicly.

  14. Next to Item Type, click Clear.
  15. Under Item Type, click Apps.
  16. On the right side of the page, click the Citizen Problem Reporter app.
  17. On the item page and click Share.
  18. In the Share window, click Everyone (public) and click Save.
  19. Click View Application.
  20. Sign in to the app using one of the sign in options and review the app.
  21. Once you finished reviewing the Citizen Problem Reporter app, close the tab.

Revise satisfaction survey questions

The Citizen Problem Satisfaction Survey allows you to solicit feedback from the public that helps you improve your community’s customer service. The survey includes six questions. In some cases, you may want to add, or remove, questions from the survey.

  1. Install ArcGIS Survey123 Connect.
  2. Start ArcGIS Survey123 Connect and sign in to your ArcGIS organization.
  3. Click Citizen Problem Satisfaction Survey to download the survey.
  4. In the Download window, click Download and click OK.
  5. Click Citizen Problem Satisfaction Survey again to open the survey.
  6. On the side toolbar, click the Open XLSForm Spreadsheet button.
  7. In the Microsoft Excel spreadsheet, click the choices tab.

    This tab comprises all the selectable options for survey questions.

  8. Click the survey tab.

    This tab comprises all the questions in the survey.

  9. Revise the survey to reflect your needs.
  10. Save and close the Microsoft Excel spreadsheet and preview your changes in ArcGIS Survey123 Connect.
  11. In ArcGIS Survey123 Connect, click Publish on the side toolbar to publish your changes.
  12. Click Publish survey to publish your changes and click OK.

Extend Citizen Problem Reporter

You can extend the Citizen Problem Reporter solution with a set of Python tools that can be used to generate report IDs, moderate reports, send email notifications, and enrich reports. These tools can be executed automatically via Task Scheduler and as new problem reports are submitted or updated the corresponding action occurs.

Add the ServiceFunctions toolbox

The ServiceFunctions toolbox contains tools for generating report IDs, moderating reports, sending email notifications, and enriching reports. Download and add the ServiceFunctions toolbox to your ArcGIS Pro project before configuring the appropriate tools.

  1. Download the ServiceFunctions toolbox.
  2. Browse to the ServiceSupport.zip file and unzip the file to the location from which you want to the tools to execute.
  3. Open ArcGIS Pro and create a new project.
  4. Sign in to the ArcGIS organization to which you deployed the Citizen Problem Reporter solution, if necessary.
  5. On the View tab, in the Windows group, click the Catalog pane, if necessary.
  6. In the Catalog pane, right-click Toolboxes and choose Add Toolbox.

    The Add Toolbox dialog box appears.

  7. Browse to the ServiceSupport folder.
  8. Click the ServiceSupport.pyt Python toolbox, and click OK.
  9. In the Catalog pane, expand Toolboxes and ServiceSupport.pyt.

    If you've never used the ServiceSupport toolbox before, run the Define Connection Settings tool to establish a connection between the toolbox and the CitizenProblem feature layer.

  10. In the Catalog pane, in the ServiceSupport.pyt Python toolbox, double-click the Define Connection Settings tool.
  11. In the ArcGIS Online organization or ArcGIS Enterprise portal URL parameter, click the drop-down arrow and choose a URL.
  12. In the Username parameter, type your user name for the organization you chose in step 11.
  13. In the Password parameter, type your password for the user name provided in the Username.
  14. Click Run.

Generate report IDs

Many workflows require you to generate a unique identifier when a feature or record is created so it can be referenced and tracked in other workflows. You can use the Generate IDs tool to configure custom unique identifiers that will be applied to features at a regularly scheduled interval of your choosing. The tool only generates the configuration; you must run an additional script (provided) to update the features with incrementing identifier values.

  1. In the Catalog pane, expand Toolboxes and ServiceSupport.pyt, if necessary.
  2. Double-click the Generate IDs tool.
  3. In the Layer parameter, click Browse.

    The Layer dialog box appears.

  4. Under Portal, click My Content.
  5. Double-click the Citizen Problem Reporter folder.
  6. Double-click the CitizenProblems feature layer.
  7. Click Citizen Problems, and click OK.

    Expand General Identifier Settings. If the tool has not been run previously, start by specifying at least one identifier sequence.

  8. In the Sequence Name parameter, type a name for the sequence.

    This value appears in the drop-down menu for selecting the sequence to assign to each layer.

  9. In the Pattern parameter, type a pattern to use for the sequence.

    This can be a combination of letters, numbers, and symbols. Mark the location for the incrementing value with a pair of curly braces {}. Python formatting is applied to the pattern text, so string formatting syntax such as {0:03d} pads the incrementing number section with zeros to a length of 3. For example, the expression seq-{0:05d} creates the following pattern of values: seq-00001, seq-00002, seq-00003, and so on.

  10. In the Next Value parameter, type a value.

    When initially creating the sequence, this must be the first value in the identifiers. After this point, this value shows the value to be used for the next identifier generated.

  11. In the Interval parameter, type a value.

    The interval by which the identifier values increase between features. For example, an initial Next Value of 1 and an Interval of 10 creates identifiers with the incrementing values of 1, 11, 21, and so on.

    Deleting or changing these sequences impacts all the layers that are configured to use the edited sequences.

  12. Optionally, edit the identifier configuration and run the tool to overwrite the existing identifier configuration for the selected layer.
    Note:

    If an identifier configuration already exists, a check box appears that, when checked, deletes the existing identifier configuration for the selected layer.

  13. Choose the moderation list to use to process the features in the selected layer.
  14. Choose the sequence to use to generate the identifiers for each feature in the layer.
  15. Choose a text field to store the generated identifier.
  16. Click Run to write out the identifier configuration for the layer and any changes to the identifier sequences.
  17. To configure identifiers for another layer, rerun the tool with the settings for the next layer.

General Identifier Settings are not specific to any one layer—they apply to all layers configured using this tool.

Moderate reports

Public comment apps can occasionally generate feedback that should not be made publicly visible. Data entered into specific fields, such as personal information, can be hidden and protected using the pop-up configuration and layer security, but sometimes entire comments need to be hidden to avoid displaying sensitive or explicit content to other users.

You can hide features by updating the value of a field so that it no longer meets the requirements of a filter applied to that layer in the map. You can use the Moderate Reports tool to configure which layers and fields to scan for explicit or sensitive words and phrases and how to update the feature so that it can be filtered from the map. You can choose how often to scan features and records. The tool only generates the configuration; an additional script (provided) must be run to scan the features.

  1. In the Catalog pane, expand Toolboxes and ServiceSupport.pyt.
  2. Double-click the Moderate Reports tool.
  3. In the Layer parameter, click Browse.

    The Layer dialog box appears.

  4. Under Portal, click My Content.
  5. Double-click the Citizen Problem Reporter folder.
  6. Double-click the CitizenProblems feature layer.
  7. Click Citizen Problems, and click OK.

    Expand General Moderation Settings. If the tool has not been run previously, start by specifying at least one moderation list.

  8. In the List Name parameter, type a name.

    This value appears in the drop-down menu for selecting the moderation list use when scanning each layer.

  9. In the Filter Type parameter, click the drop-down arrow and choose to scan feature for words and phrases that exactly match the provided list of words and phrases.

    For example, when the filter type is EXACT, if the list contains the word duck, the script updates the specified field when the feature contains the word duck, but not when it contains the word duckling. When the filter type is FUZZY, the script updates the feature when either duck or duckling are found.

  10. In the Words and Phrases parameter, type a word or phrase. Provide a comma-separated list of words or phrases to scan for.

    Keep in mind that deleting or changing these lists will impacts all the layers that are configured to use the edited sequences.

  11. If a moderation configuration already exists for the selected layer, choose to edit an existing configuration by selecting the name of the moderation list used in the configuration, or choose the option to add a new moderation configuration.

    If you choose to edit an existing configuration, a check box appears that, when checked, deletes the existing moderation configuration for the selected layer. Alternatively, edit the moderation configuration and run the tool to overwrite the existing moderation configuration for the selected layer and moderation list.

    To add a new moderation configuration, click the Add New button and continue with the following steps.

  12. Choose the moderation list to use to process the features in the selected layer.
  13. Choose the fields that will be scanned for content that matches the words and phrases in the selected moderation list.
  14. Optionally, provide an SQL query to only apply moderation to some features.

    If no query is provided, all features are processed.

  15. Use the Field to Update parameter when a match is found between the value of a field and the content of a moderation list. Use the Found Value parameter to specify the value that should be written to this field indicating a match.
  16. Click Run.

Send email notifications

Many workflows require that an email be sent when a feature or record is created and updated. You can use the Send Emails tool to configure emails that can be sent based on attribute values and a schedule of your choosing. The tool only generates the configuration; you must run an additional script (provided) to actually generate and send the emails.

  1. In the Catalog pane, expand Toolboxes and ServiceSupport.pyt.
  2. Double-click the Send Emails tool.
  3. In the Layer parameter, click Browse.

    The Layer dialog box appears.

  4. Under Portal, click My Content.
  5. Double-click the Citizen Problem Reporter folder.
  6. Double-click the CitizenProblems feature layer.
  7. Click Citizen Problems, and click OK.

    All existing email settings for the layer load and can be edited by updating the parameter values for each configuration. To delete a single email configuration, click the Remove button remove next to the configuration. To delete all the email configurations for the layer, check the Delete all existing email configurations for this layer check box. Run the tool to save your changes.

  8. In the Email Template parameter, click Browse to access the ServiceSupport folder.
  9. Click one of the HTML templates for the body of the email, and click OK.

    To add attributes from the triggering feature to the email, use unique string keys in the places where the values should appear in the HTML and reference these strings in the Find parameter of the Email Substitutions section of the General Email Settings along with the name of the field that contains the value to be substituted for the string key in the Replace parameter.

  10. Optionally, in the SQL Query parameter, provide an SQL query to only trigger an email from specific features.

    If no query is provided, all features trigger emails every time the script is run, so you most likely want to use this query along with the Field to Update and Sent Value parameters to ensure that the same email isn't sent repeatedly for the same feature.

  11. In the Recipient Email Address parameter, type an email address of the recipient or the name of a field in the layer that contains the address of the recipient.
  12. In the Email Subject parameter, type the subject for the email.

    Similar to the email body provided in the HTML document, this text can contain string keys that will be swapped out for attribute values based on the Find and Replace values defined in the Email Substitutions list in the General Email Settings section.

  13. In the Field to Update parameter, type Email. When the email has been sent for each feature, use the Sent Value parameter to specify the value that should be written to this field indicating that the email has been sent.

    This field and value can be used in the previously described SQL query to prevent duplicate emails from being sent.

  14. Configure additional emails to be sent for the currently selected layer by clicking the Add New button.

    Emails will be sent in the order they are configured. Expand General Email Settings. If the tool has not been run previously, start by specifying the connection information for your SMTP server in the tool.

  15. In the SMTP Server parameter, type the URL of the SMTP server used for sending emails.
  16. In the SMTP Username parameter, type the user name required to authenticate to the SMTP server. This is not required if authenticating through a port.
  17. In the SMTP Password parameter, type the password required to authenticate to the SMTP server. This is not required if authenticating through a port.
  18. In the From Address parameter, type the address from which the emails should be sent.
  19. In the Reply Address parameter, type the address that should be used for any replies to the email message.
  20. Check or uncheck the Use TLS check box to turn on or off TLS.
  21. In the Email Substitutions section, type Find and Replace values. Swap out one piece of text for another in the outgoing email subject or body.

    Anywhere a value in the Find parameter is found in the email subject or body, it will be replaced with the corresponding value from the Replace parameter. If the value in the Replace parameter is a field in the layer, the Find value will be replaced with the value in that field in the triggering feature. For example, to add the ID of a feature from the REQUESTID field to the email subject, include a piece of text such as {ID} in the configured Email Subject, and add {ID} to the Find parameter and REQUESTID to the Replace parameter. All specified substitutions are applied to all emails configured for all layers so, while the Find values can be any piece of text, it's suggested that you use something that is clearly variable-like and unlikely to appear elsewhere in the messages in a literal form.

    Deleting or changing these settings impacts all the emails for all the layers configured with this tool.

  22. Click Run.

Enrich reports

Reports made in public comment apps can be enriched with information about the report location. You can then use this information to efficiently direct the report to the correct person or agency responsible for its resolution.

You can then use the Enrich Reports tool to configure which attribute values to calculate from a coincident or intersecting set of features at a regularly scheduled interval of your choosing. Note that the tool only generates the configuration; you must run an additional script (provided) to update the features based on intersecting features.

  1. In the Catalog pane, expand Toolboxes and ServiceSupport.pyt.
  2. Double-click the Enrich Reports tool.
  3. In the Layer parameter, click the browse button.

    The Layer dialog box appears.

  4. Under Portal, click My Content.
  5. Double-click the Citizen Problem Reporter folder.
  6. Double-click the CitizenProblems feature layer.
  7. Click Citizen Problems, and click OK.
  8. In the Enrichment parameter, if an enrichment configuration already exists for the selected layer, choose to either edit an existing configuration by selecting the configuration from the drop-down list, or choose the option to add a new enrichment configuration.

    If you choose to edit an existing configuration, a check box appears that, when checked, deletes the existing enrichment configuration for the selected layer. Alternatively, edit the configuration and run the tool to save the changes. To add a new enrichment configuration, click the Add New button and continue with the following steps.

  9. Choose the polygon feature layer that will provide the enriching attribute values by either choosing a layer from the active map or by browsing to your hosted content and choosing a polygon feature layer.
  10. In the Source Field parameter, click the drop-down arrow and choose a field from the enrichment layer.
  11. In the Target Field parameter, click the drop-down arrow and choose a field from the CitizenProblem feature layer.

    The script does not process features that already have a value in the target field.

  12. In the Priority parameter, type a value. Specify the priority for this enrichment configuration relative to the other configurations for the CitizenProblem feature layer.

    Enrichment configurations for a layer that have a lower priority value will override enrichment configurations with a higher value. For example, a layer has two enrichment configurations that use the same target field, but one has a priority value of 1 and the other has a priority of 2. If the configuration with priority 1 does not produce a valid value for the field, the field is populated with the value produced from the configuration with priority 2.

  13. Click Run.

Set up Task Scheduler

Use Windows Task Scheduler to schedule the script to generate report IDs when a feature or record is created, moderate reports when feedback contains inappropriate language, send email notifications when a feature or record is created or updated, or enrich reports. All the tools in this toolbox share a common configuration file and execution script, so only one scheduled task is required to automate running all the associated processes.

  1. Open the Task Scheduler on the computer that is hosting the scripts.
  2. Click Action > Create Task and name your task.
  3. Click the Action tab and click New.
  4. Set Action to Start a Program.
  5. Browse to the location of your Python 3 installation (for example, <default directory>\C:\Program Files\ArcGIS\Pro\bin\Python\envs\arcgispro-py3\python.exe).
  6. In the Add arguments text box, type the name of the script (servicefunctions.py).
  7. In the Start in text box, type the path to the folder where your script is and click OK.
  8. Click the Trigger tab, click New, and set a schedule for your task.
  9. Click OK.

When the trigger occurs, the scripts begin scanning the configured layers and, for each one, processing (in order) configurations for generating identifiers, enriching reports, moderating reports, and sending emails.