Publication de couches de tuiles hébergées à partir de fichiers

Les couches de tuiles publiées et hébergées dans ArcGIS Online prennent en charge la visualisation rapide des jeux de données volumineux utilisant un ensemble de tuiles ou d’images de carte prédessinées. Les tuiles hébergées fournissent un contexte géographique pour vos couches opérationnelles. Par exemple, vous pouvez inclure des tuiles de rues de votre voisinage pour offrir une référence visuelle pour les panneaux de votre couche d’entités.

Les couches de tuiles hébergées dans ArcGIS Online sont utiles lorsque vous avez besoin d’exposer une carte sur le Web à des fins de visualisation, mais que vous ne disposez pas de votre propre serveur ArcGIS Server. Elles permettent également de partager facilement certaines cartes avec un public Internet si votre propre serveur ArcGIS Server ne peut pas être rendu public. WMTS est disponible pour les couches de tuiles hébergées dans ArcGIS Online qui sont partagées avec le public.

Vous pouvez publier une couche de tuiles à partir d’une couche d’entités hébergée existante ou employer l’une des méthodes suivantes pour créer un fichier dans ArcGIS Pro ou ArcMap et utiliser ce fichier pour publier une couche de tuiles hébergée dans ArcGIS Online:

Pour publier une couche de tuiles hébergée, vous devez être membre de l’un des éléments suivants dans votre organisation :

Lorsque vous publiez à partir de ArcGIS Pro, de ArcMap ou d’un paquetage de tuiles, un fichier de paquetage de tuiles est ajouté en tant qu’élément dans votre contenu. Après avoir vérifié le bon fonctionnement de la couche de tuiles, vous pouvez supprimer le paquetage de couche de tuiles de ArcGIS Online pour libérer de l’espace de stockage, mais uniquement si vous êtes certain de ne plus en avoir besoin.

Définition et publication d’une carte dans ArcGIS Pro

À partir d’une carte dans ArcGIS Pro, vous pouvez publier une couche de tuiles à héberger dans ArcGIS Online. Une connexion Internet est nécessaire pour appliquer cette procédure.

Remarque :

Si des ensembles de définition sont appliqués aux couches dans ArcGIS Pro, ArcGIS les applique à la couche de tuiles hébergée publiée. Cependant, toutes les données sont chargées dans ArcGIS Online. Si vous ne souhaitez publier qu’un sous-ensemble des données et le stocker dans ArcGIS Online, vous devez l’exporter vers une autre classe d’entité et le publier.

La vitesse et la bande passante de votre connexion déterminent la rapidité de publication de la couche de tuiles.

Notez également que les navigateurs web ne peuvent pas afficher certains des symboles cartographiques les plus complexes que vous pouvez avoir utilisés à l’origine pour créer la carte. La plupart des types de symbole sont disponibles, mais dans certains cas, les symboles peuvent être rétrogradés lorsque vous les publiez. Pour en savoir plus sur les symboles pris en charge et apporter les modifications nécessaires à la symbologie de la carte avant la publication, reportez-vous à la rubrique Créer des cartes pour publier les services d’entités dans l’aide de ArcGIS Server.

  1. Démarrez ArcGIS Pro et ouvrez le projet qui contient la carte à publier.
  2. Connectez-vous à votre organisation à partir de ArcGIS Pro en utilisant un compte doté de privilèges permettant de créer du contenu et de publier des couches de tuiles hébergées.
  3. Cliquez sur Couche Web dans le groupe Partager en tant que de l'onglet Partager.
  4. Tapez le nom de la couche de tuiles.
  5. Fournissez un résumé et des balises pour la couche de tuiles.
  6. Sélectionnez Tuile dans le champ Type de couche.
    Par défaut, la couche est enregistrée dans Mon contenu. Vous pouvez l'enregistrer dans un sous-dossier de Mon contenu en saisissant le nom du dossier ou en accédant à un dossier existant.
  7. Spécifiez qui doit avoir accès à la couche de tuiles hébergée.

    Toutes les couches que vous publiez sont automatiquement partagées sur votre espace de travail personnel dans votre organisation (Mon contenu). Votre contenu est inaccessible aux autres tant que vous ne le partagez pas à l'aide d'une des options suivantes :

    • Tout le monde : sélectionnez cette option pour rendre la couche accessible au public.
    • Nom de votre organisation : cette option est disponible si vous êtes connecté avec un compte d'organisation. Sélectionnez cette option pour partager la couche avec tous les utilisateurs authentifiés de l'organisation.
    • Groups (Groupes) - Vous pouvez partager la couche avec les membres des groupes auxquels vous appartenez en choisissant les groupes dans la liste déroulante.
  8. Cliquez sur l'onglet Configuration pour spécifier les paramètres du cache.
  9. Choisissez une option Tiling Scheme (Structure de tuilage).
  10. Redimensionnez et déplacez la barre Niveaux de détail pour indiquer l'échelle minimum et maximum de votre couche de tuiles.

    La taille estimée du cache obtenu change au fur et à mesure que vous modifiez l'échelle minimum et maximum.

  11. Sous Options, indiquez où et quand créer le cache de tuiles.
    • Sélectionnez Cache automatically on the server (Mettre automatiquement en cache sur le serveur) si vous souhaitez que les tuiles soient créées dans ArcGIS Online au moment de publier la couche.
    • Si vous voulez que le cache soit créé et stocké dans ArcGIS Online, mais que vous voulez le créer vous-même après publication, sélectionnez Cache manually on the server (Mettre manuellement en cache sur le serveur), ouvrez la couche de tuiles sur le site Web ArcGIS Online une fois la couche publiée, puis créez le cache manuellement.
    • Si vous souhaitez limiter le nombre de crédits utilisés lors de la publication d’une couche de tuiles dans ArcGIS Online, sélectionnez Cache locally (Mettre en cache localement), puis indiquez l’emplacement de stockage pour un paquetage de tuiles temporaire sur la machine ArcGIS Pro. Le cache est créé et empaqueté sur la machine ArcGIS Pro, le paquetage de tuiles est chargé automatiquement dans ArcGIS Online pour y être décompressé, puis le cache est stocké dans ArcGIS Online.
  12. Pour permettre aux utilisateurs de télécharger des tuiles de carte à utiliser en mode hors connexion, activer la case à cocher Autoriser les clients à exporter les tuiles du cache.
  13. Si vous avez activé la case à cocher Autoriser les clients à exporter les tuiles du cache, utilisez le champ Limiter l'exportation à pour préciser un nombre maximal de tuiles que les clients peuvent utiliser en mode hors connexion en une seule fois.
  14. Pour calculer le nombre de tuiles et l’espace de stockage qui seront utilisés par vos options de mise en cache, ouvrez la section Estimate (Estimation), puis cliquez sur Calculate (Calculer).

    Vous pouvez modifier les paramètres du cache et effectuer un nouveau calcul pour voir comment les paramètres affectent le cache.

  15. Cliquez sur l'onglet Contenu pour confirmer l'intégration dans la couche de tuiles des couches de données que vous souhaitez.
  16. Cliquez sur Analyze (Analyser) pour rechercher d’éventuels erreurs ou problèmes.

    L’onglet Messages répertorie les problèmes découverts par les analystes. Cliquez avec le bouton droit sur chaque message pour obtenir plus d'informations, lire l'aide relative à l'erreur ou l'avertissement et accéder aux solutions suggérées. Vous devez résoudre les erreurs avant de procéder à la publication. Résolvez les éventuels avertissements afin d’améliorer davantage les performances et l’apparence de votre couche de tuiles hébergée.

  17. Une fois que vous avez corrigé les erreurs et les avertissements éventuels, cliquez sur Publish (Publier).
    Remarque :

    C’est à ce stade que vos données sont copiées dans ArcGIS Online. La taille des données, le débit et la bande passante de votre connexion Internet déterminent le temps nécessaire à la publication.

Une fois la publication terminée, vous pouvez cliquer sur Manage the web layer (Gérer la couche Web) pour ouvrir ArcGIS Online.

Création d’un paquetage de tuiles dans ArcGIS Pro et chargement de celui-ci dans votre organisation

Utilisez l’outil de géotraitement Create Map Tile Package (Créer un paquetage de tuiles de carte)pour créer un paquetage de tuiles, l’ajouter à votre organisation et publier une couche de tuiles.

ArcGIS Pro version 2.3 et ultérieures vous permet de préciser le format de la sortie de cet outil de géotraitement : fichier .tpk ou fichier .tpkx. Le nouveau format .tpkx utilise une structure de fichier simplifiée, ce qui a pour effet d’améliorer les performances d’exécution dans le cloud et aux emplacements réseau partagés. Par ailleurs, il s’agit d’un format à spécification ouverte. Vous pouvez utiliser l’un ou l’autre format dans ce processus.

  1. Ouvrez le projet qui contient les données à empaqueter.
  2. Ouvrez et exécutez l'outil de géotraitement Créer un paquetage de tuiles de carte.
  3. Après avoir créé le paquetage de tuiles, connectez-vous à votre organisation en utilisant un compte doté de privilèges permettant de créer du contenu et de publier des couches de tuiles hébergées, puis cliquez sur Content (Contenu) > My Content (Mon contenu) > New item (Nouvel élément).
  4. Cliquez sur Your device (Votre appareil) pour ajouter le paquetage de tuiles.
  5. Sélectionnez Add tile package and create a hosted tile layer (Ajouter un paquetage de tuiles et créer une couche tuilée hébergée).
  6. Cliquez sur Next (Suivant).
  7. Spécifiez un titre.
  8. Choisissez un dossier pour y enregistrer votre élément.
  9. Si votre organisation a configuré des catégories de contenu, cliquez sur Assign categories (Attribuer des catégories) et sélectionnez jusqu'à 20 catégories pour aider les utilisateurs à trouver votre élément.

    Vous pouvez également commencer à saisir un nom de catégorie pour affiner la liste des catégories.

  10. Saisissez éventuellement des termes de balises en les séparant par des virgules.

    Les balises sont des mots ou de brèves expressions qui décrivent votre élément et aident les utilisateurs à trouver votre élément. Terres fédérales correspond à une balise, alors que Terres,fédérales correspond à deux balises.

  11. Cliquez sur Save (Enregistrer).

Les tuiles sont décompressées et une couche de tuiles hébergée est créée. Les tuiles de carte et le paquetage de tuiles apparaissent dans My Content (Mon contenu).

Après avoir vérifié que la couche de tuiles est présente et qu’elle fonctionne, vous pouvez éventuellement supprimer le paquetage de tuiles d’origine afin d’éviter de dépenser des crédits pour son stockage.

Publier de grands paquetages de tuiles

Pour créer et partager de grandes quantités de données, Esri recommande d’utiliser le jeu d’outils Tile Cache (Cache de tuiles) plutôt que le processus précédent. Ces outils peuvent tirer parti de plusieurs cœurs de traitement pour améliorer les performances de génération et de publication des tuiles.

Dans ArcGIS Pro, exécutez les outils de géotraitement.

  1. Exécutez l’outil de géotraitement Créer un paquetage de tuiles de carte pour créer un paquetage de tuiles en une seule étape ou exécutez les outils de géotraitement suivants dans l’ordre indiqué ci-dessous :
    1. Exécutez l’outil Générer la structure de tuilage du cache de tuiles pour définir la grille de tuilage et le format d’image.
    2. Exécutez l’outil Gérer le cache de tuiles pour créer les tuiles.
    3. Exécutez l’outil Exporter le cache de tuiles pour créer le paquetage de tuiles.

    Pour générer le cache à des étendues ou des niveaux de détail spécifiques, utilisez les trois outils indiqués ci-dessus.

  2. Exécutez l’outil Share Package (Partager un paquetage) [dans le jeu d’outils Package (Paquetage)] pour charger les tuiles dans ArcGIS Online.
  3. Une fois votre paquetage de tuiles généré, connectez-vous à votre organisation avec le compte que vous avez utilisé pour créer le paquetage de tuiles dans ArcGIS Pro, puis cliquez sur Content (Contenu) > My Content (Mon contenu).
  4. Cliquez sur le paquetage de tuiles pour afficher sa page Détails des éléments.
  5. Cliquez sur Publish (Publier).
  6. Saisissez un titre et des balises.
  7. Si l’administrateur de votre portail a configuré des catégories de contenu, cliquez sur Assign Category (Attribuer une catégorie), et sélectionnez un maximum de 20 catégories pour aider les utilisateurs à trouver votre élément.

    Vous pouvez également utiliser la zone Filter categories (Filtrer les catégories) pour affiner la liste des catégories.

  8. Cliquez sur Publish (Publier).

Les tuiles sont décompressées et une couche de tuiles hébergée est créée. La couche apparaît dans My Content (Mon contenu).

Après avoir vérifié que la couche de tuiles est présente et qu’elle fonctionne, vous pouvez éventuellement supprimer le paquetage de tuiles d’origine afin d’éviter de dépenser des crédits pour son stockage.

Définition et publication d’une carte dans ArcMap

Dans ArcMap, vous pouvez publier une couche de tuiles à héberger dans ArcGIS Online. Une connexion Internet est nécessaire pour appliquer cette procédure.

Remarque :

Si des ensembles de définition sont appliqués aux couches dans ArcMap, ArcGIS les applique à la couche de tuiles hébergée publiée. Cependant, toutes les données sont chargées dans ArcGIS Online. Si vous ne souhaitez publier qu’un sous-ensemble des données et le stocker dans ArcGIS Online, vous devez l’exporter vers une autre classe d’entité et le publier.

La vitesse et la bande passante de votre connexion déterminent la rapidité de publication du service.

  1. Démarrez ArcMap et ouvrez la carte à publier.
  2. Connectez-vous à ArcGIS Online avec un compte d’organisation détenteur des privilèges requis pour créer du contenu et publier des couches de tuiles hébergées.
    1. Cliquez sur Fichier > Se connecter.
    2. Saisissez votre nom d’utilisateur et votre mot de passe pour ArcGIS Online, puis cliquez sur Sign In (Se connecter).
  3. Publiez maintenant la carte.
  4. Cliquez sur Fichier > Partager en tant que > Service.
  5. Sélectionnez Publier un service et cliquez sur Suivant.
    Attention :

    Si vous choisissez de remplacer le service à la place, l’élément de tuile de carte existant est supprimé de ArcGIS Online et un nouvel élément de même nom est créé. Le nouvel élément est créé dans le dossier racine et un nouvel ID lui est attribué. Vous devez reconfigurer le partage et, le cas échéant, redéplacer l'élément dans le dossier dans lequel il se trouvait avant la republication.

  6. Dans la liste déroulante des types de connexion, sélectionnez Mes services hébergés. Saisissez ensuite un nom pour vos tuiles et cliquez sur Continuer.
  7. Définissez les propriétés voulues dans l'Editeur de services.

    Ici, vous pouvez choisir ce que les utilisateurs peuvent faire avec vos tuiles et contrôler précisément comment vos tuiles sont exposées aux utilisateurs finaux. Pour plus d’informations la configuration des tuiles pour le déploiement, reportez-vous à la rubrique Optimiser et configurer les services dans l’aide de ArcGIS Server. Certaines des propriétés mentionnées dans cette rubrique s’appliquent uniquement à ArcGIS Server et ne sont pas disponibles pour les couches de tuiles hébergées. Par exemple, pour les couches de tuiles hébergées dans ArcGIS Online, il n’existe aucune option permettant de définir le nombre minimal et maximal d’instances du service, car Esri se charge automatiquement de la mise à l’échelle du service.

    Conseil :

    Si vous fermez Service Editor (Éditeur de services) pendant cette session, vous serez invité à enregistrer votre travail en tant que service de brouillon. Les services de brouillon vous permettent de reprendre ultérieurement votre travail de configuration d'un service. Les brouillons sont enregistrés par défaut dans le dossier Brouillons de votre connexion à Mes cartes hébergées. Pour plus d’informations, consultez la rubrique À propos des services de brouillon dans l’aide ArcGIS Server.

  8. Vous devez toutefois définir un certain nombre de propriétés propres aux couches de tuiles hébergées. Elles sont détaillées dans la procédure qui suit.
  9. Dans la fenêtre Service Editor (Éditeur de services), cliquez sur Capabilities (Fonctionnalités) et cochez l’option Tiled Mapping (Carte tuilée) pour exposer votre carte en tant que couche de tuiles. Cochez Feature Access (Accès aux entités) pour publier une couche d’entités avec vos tuiles si vous souhaitez configurer des fenêtres contextuelles pour la couche lorsque vous l’ajoutez à Map Viewer.

    Vous pouvez cliquer sur le sous-élément Tiled Mapping (Carte tuilée) dans la fenêtre Service Editor (Éditeur de services) pour définir des propriétés avancées liées aux fonctions que les clients peuvent mettre en œuvre avec la couche de tuiles publiée.

  10. Cliquez sur l'élément Mise en cache pour définir les propriétés du cache de tuiles.

    Pour des étapes plus détaillées, reportez-vous à la rubrique Créer un cache de carte dans l’aide ArcGIS Server en gardant à l’esprit que certains des paramètres avancés de mise en cache sont uniquement disponibles en cas de publication directe dans ArcGIS Server.

  11. Dans Service Editor (Éditeur de services), cliquez sur Item Description (Description de l’élément) et fournissez un résumé et des balises pour votre couche de tuiles.

    Vous devez fournir ces informations avant de procéder à la publication.

    Pour plus d’informations, reportez-vous à la section de description de l’élément dans la rubrique Définition des propriétés d’un service de carte de l’aide ArcGIS Server.

  12. Dans Service Editor (Éditeur de services), cliquez sur ArcGIS Online, puis sélectionnez les personnes avec lesquelles la couche de tuiles hébergée doit être partagée.

    Par défaut, votre couche de tuiles hébergée est privée et vous seul pouvez y accéder. Vous pouvez la partager avec tout le monde, tous les membres de votre organisation ou les membres de certains groupes ArcGIS Online.

  13. Dans Service Editor (Éditeur de services), cliquez sur Analyze (Analyser)Analyser.

    Cette fonction examine la carte pour voir si elle peut être publiée. Vous devez corriger les erreurs sous Errors (Erreurs) Erreur dans la fenêtre Prepare (Préparation) avant de pouvoir publier. Vous pouvez éventuellement traiter les avertissements et les messages informatifs pour optimiser les performances et l'apparence de vos tuiles publiées.

  14. Vous pouvez également cliquer sur Preview (Aperçu) Aperçu dans Service Editor (Éditeur de services).

    Cela peut vous donner une idée de l'apparence de votre couche de tuiles sur le web.

  15. Une fois que vous avez corrigé les erreurs et éventuellement les avertissements et les messages, cliquez sur Publish (Publier) Publier.
    Remarque :

    C’est à ce stade que vos données sont copiées dans ArcGIS Online. La taille des données, le débit et la bande passante de votre connexion Internet déterminent le temps nécessaire à la publication. Vous devez également anticiper le délai de génération de vos tuiles.

Une fois vos tuiles publiées sur ArcGIS Online, elles s’affichent lorsque vous développez le nœud My Hosted Services (Mes services hébergés) dans la fenêtre Catalog (Catalogue).

Votre couche de tuiles hébergée est répertoriée sous la forme de deux éléments indépendants dans l’onglet My Content (Mon contenu) du site Web ArcGIS Online : Tiles (Tuiles) et Service Definition (Définition de service). Une définition de service est un fichier compressé contenant la carte, ses données et les informations concernant la façon dont les tuiles doivent être publiées. Une définition de service peut être transférée et publiée sur une machine exécutant ArcGIS Server 10.1 ou une version ultérieure.

Créez et partagez un paquetage de tuiles dans ArcMap et publiez-le

ArcMap vous permet de créer des tuiles pour une carte et de les stocker dans un fichier de paquetage de tuiles transférable. Vous pouvez créer un paquetage de tuiles dans ArcMap, le partager dans ArcGIS Online et le publier en tant que couche de tuiles hébergée. Ce processus vous permet de créer les tuiles en faisant appel à votre propre puissance de calcul au lieu d’utiliser vos crédits ArcGIS Online.

Conseil :

Vous devez publier une couche d’entités avec la couche de tuiles hébergée si vous souhaitez configurer des fenêtres contextuelles.

Il y a deux façons de créer et de partager un paquetage de tuiles à partir de ArcMap.

  • Pour empaqueter et partager une petite quantité de données (moins de 1 Go), créez et partagez le paquetage de tuiles directement depuis votre carte. Lorsque vous publiez le paquetage dans ArcGIS Online, des éléments du document, tels que la légende et des éléments de texte, sont préservés.
  • Si vous avez plus de 1 Go de données, utilisez des outils de géotraitement pour empaqueter et partager les tuiles. Cette méthode maintient uniquement les données lorsque des tuiles sont publiées à partir du paquetage de tuiles, ce qui améliore les performances de création des tuiles.

À partir de ArcMap 10.7, vous pouvez désigner les résultats de chaque processus comme étant un fichier .tpk ou un fichier .tpkx. Le nouveau format .tpkx utilise une structure de fichier simplifiée, ce qui a pour effet d’améliorer les performances d’exécution dans le cloud et aux emplacements réseau partagés. Par ailleurs, il s’agit d’un format à spécification ouverte. Vous pouvez utiliser l’un ou l’autre format dans les deux processus suivants.

Publier de petits paquetages de tuiles

Si le paquetage de tuiles que vous créez dans ArcMap est plus petit que 1 Go, utilisez le processus suivant pour publier :

  1. Ouvrez votre carte dans ArcMap.
  2. Connectez-vous avec un compte d'organisation détenteur des privilèges requis pour créer du contenu et publier des couches de tuiles hébergées.
  3. Cliquez sur Personnaliser > Options ArcMap > Partage et vérifiez que l'option Activer les outils ArcGIS Runtime est sélectionnée.

    Cette opération active l'option de menu que vous utiliserez dans la prochaine étape.

  4. Dans ArcMap, cliquez sur File (Fichier) > Share As (Partager en tant que) > Tile Package (Paquetage de tuiles).
  5. Configurez tous les paramètres dans les sous-étapes suivantes. Vous pouvez choisir les autres paramètres comme il vous convient.
    1. Sous l'onglet Paquetage de tuiles, sélectionnez Télécharger le paquetage vers mon compte ArcGIS Online.
    2. Sous l'onglet Format des tuiles, choisissez ArcGIS Online / Bing Maps / Google Maps comme structure de tuile.
    3. Sous l'onglet Description de l'élément, indiquez les éléments marqués comme obligatoires.
    4. Sous l’onglet Sharing (Partage), indiquez si vous voulez partager le paquetage avec le public ou avec des groupes spécifiques.
  6. Cliquez sur Share (Partager).

    Vous pouvez être invité à enregistrer votre carte avant que ArcMap ne crée le paquetage de tuiles.

    La génération d'un paquetage de tuiles peut prendre du temps, en particulier si vous avez compris de grandes échelles.

  7. Une fois votre paquetage de tuiles généré, connectez-vous à ArcGIS Online en utilisant votre compte d’organisation, puis cliquez sur Content (Contenu) > My Content (Mon contenu).
  8. Cliquez sur le paquetage de tuiles pour afficher sa page Détails des éléments.
  9. Cliquez sur Publish (Publier).
  10. Saisissez un titre et des balises, puis cliquez sur Publier.

Les tuiles sont décompressées et hébergées sous la forme d’une couche de tuiles dans ArcGIS Online. La couche de tuiles hébergée apparaît dans My Content (Mon contenu).

Après avoir vérifié que la couche de tuiles est présente et en cours d'exécution, vous pouvez supprimer le paquetage de tuiles d'origine afin de ne pas dépenser de crédits pour son stockage.

Publier de grands paquetages de tuiles

Pour créer et partager de grandes quantités de données, Esri recommande d’utiliser le jeu d’outils Tile Cache (Cache de tuiles) plutôt que le processus précédent. Ces outils peuvent tirer parti de plusieurs cœurs de traitement pour améliorer les performances de génération et de publication des tuiles.

Exécutez ces outils dans l'ordre suivant :

  1. Exécutez Générer la structure de tuilage du cache de tuiles pour définir la grille de tuilage et le format d’image.
  2. Exécutez Gérer le cache de tuiles pour créer les tuiles.
  3. Exécutez Exporter le cache de tuiles pour créer le paquetage de tuiles.
  4. Exécutez Share Package (Partager un paquetage) [dans le jeu d’outils Package (Paquetage)] pour charger les tuiles dans ArcGIS Online.
  5. Une fois votre paquetage de tuiles généré, connectez-vous à ArcGIS Online en utilisant votre compte d’organisation, puis cliquez sur Content (Contenu) > My Content (Mon contenu).
  6. Cliquez sur le paquetage de tuiles pour afficher sa page Détails des éléments.
  7. Cliquez sur Publish (Publier).
  8. Saisissez un titre et des balises.
  9. Si l’administrateur de votre portail a configuré des catégories de contenu, cliquez sur Assign Category (Attribuer une catégorie), et sélectionnez un maximum de 20 catégories pour aider les utilisateurs à trouver votre élément.

    Vous pouvez également utiliser la zone Filter categories (Filtrer les catégories) pour affiner la liste des catégories.

  10. Cliquez sur Publish (Publier).

Les tuiles sont décompressées et hébergées sous la forme d’une couche de tuiles dans ArcGIS Online. La couche de tuiles hébergée apparaît dans My Content (Mon contenu).

Après avoir vérifié que la couche de tuiles est présente et en cours d'exécution, vous pouvez supprimer le paquetage de tuiles d'origine afin de ne pas dépenser de crédits pour son stockage.

Publier à partir d'un fichier de définition de service

Vous pouvez également partager des données et des couches de tuiles avec d’autres utilisateurs en créant un fichier de définition de service et en le chargeant sur ArcGIS Online. L’auteur de la carte définit les données et la symbologie requises pour la couche de tuiles hébergée et les inclut dans le fichier de définition de service.

Créer un fichier de définition de service

Reportez-vous à la rubrique Enregistrer un fichier de définition de service pour savoir comment créer un fichier de définition de service dans ArcGIS Pro.

Procédez comme suit pour créer un fichier de définition de service dans ArcMap.

  1. Démarrez ArcMap et connectez-vous avec un compte d’organisation.
  2. Créez et enregistrez une carte.

    Pour plus d’informations sur la création et la publication d’une carte, reportez-vous aux rubriques relatives au service de carte dans l’aide ArcGIS Server.

  3. Créez maintenant un fichier de définition de service.
  4. Cliquez sur Fichier > Partager en tant que > Service.
  5. Sélectionnez Save a service definition file (Enregistrer un fichier de définition de service) et cliquez sur Next (Suivant).
  6. Cliquez sur Choisir une connexion et choisissez Mes services hébergés dans la liste déroulante.
  7. Saisissez un nom pour le fichier, puis cliquez sur Suivant.
  8. Précisez dans quel répertoire sur l'ordinateur client créer le fichier de définition de service, puis cliquez sur Continuer.

    La fenêtre Service Editor (Éditeur de services) s’ouvre.

  9. Dans la fenêtre gauche de Service Editor (Éditeur de services), cliquez sur Caching (Mise en cache).
  10. Choisissez une Structure de tuilage.
  11. Choisissez les échelles minimum et maximum pour les tuiles puis exécutez l'option Calculer la taille du cache.
  12. Cliquez sur Créer un cache manuellement une fois le service publié.
  13. Vous pouvez également cliquer sur Paramètres avancés et définir des paramètres de cache supplémentaires pour le cache de tuiles.
  14. Dans la fenêtre gauche de Service Editor (Éditeur de services), cliquez sur Item Description (Description de l’élément) et indiquez les informations correspondant à votre couche de tuiles.

    Vous devez indiquer au moins un résumé et des balises afin de créer le fichier de définition de service.

  15. Cliquez sur Analyser Analyser pour vous assurer qu'il ne contient aucune erreur.

    Vous devez résoudre toutes les erreurs avant d'organiser le fichier de définition de service. Vous pouvez également apporter les corrections nécessaires concernant les avertissements et messages renvoyés.

  16. Une fois les erreurs et éventuellement les avertissements et messages corrigés, cliquez sur Intermédiaire Etape.

Le fichier de définition de service est enregistré à l'emplacement que vous avez spécifié.

Charger la définition du service et publier

Une fois que l’auteur vous a envoyé le fichier définition de service, vous pouvez le charger dans ArcGIS Online et publier une couche de tuiles.

  1. Connectez-vous avec un compte d'organisation détenteur des privilèges requis pour créer du contenu et publier des couches de tuiles hébergées, puis cliquez sur Contenu > Mon contenu..
  2. Cliquez sur New item (Nouvel élément).
  3. Sélectionnez Your device (Votre appareil).
  4. Sélectionnez le fichier de définition de service.
  5. Sélectionnez Add service definition and create a hosted feature layer (Ajouter une définition de service et créer une couche d'entités hébergée).
  6. Cliquez sur Next (Suivant).
  7. Si votre organisation a configuré des catégories de contenu, cliquez sur Assign categories (Attribuer des catégories) et sélectionnez jusqu'à 20 catégories pour aider les utilisateurs à trouver votre élément.

    Vous pouvez également commencer à saisir un nom de catégorie pour affiner la liste des catégories.

  8. Saisissez éventuellement des termes de balises en les séparant par des virgules.

    Les balises sont des mots ou de brèves expressions qui décrivent votre élément et facilitent sa localisation. Terres fédérales correspond à une balise, alors que Terres,fédérales correspond à deux balises.

  9. Cliquez sur Save (Enregistrer) pour ajouter le fichier de définition de service et publier la couche de tuiles.

    La couche de tuiles est publiée et la définition de service, ainsi que les tuiles, sont ajoutées à Mon contenu.

  10. Une fois la couche de tuiles publiée, cliquez sur l’option Start building tiles (Commencer à créer des tuiles) pour créer les tuiles.

Par défaut, vous seul avez accès au fichier de définition de service et à la couche de tuiles hébergée. Vous pouvez partager le fichier et les tuiles avec le public, d'autres personnes dans votre organisation ou des groupes spécifiques.