ノートブックの基本操作

ノートブックは、ArcGIS Onlineで開かれるノートブック エディターで作成されます。 このトピックでは、ノートブック エディターのコンポーネントとメニューについて説明します。

インターフェイスの基本

ノートブック エディターには、次の 5 つの基本コンポーネントがあります。

ノートブック エディターのコンポーネント
  1. ナビゲーション バー: Web サイトを参照したり、アプリ ランチャーから他のアプリを開いたり、ヘルプ リソースを表示したり、プロファイルにサイン インまたはサイン アウトしたりできます。 ナビゲーション バーには、ノートブックのタイトルや、ノートブックに未保存の変更がないかどうかも表示されます。
  2. 上部のリボン: ノートブックに関連するさまざまなタスクを実行します。 このリボンには、次のボタンがあります。
  3. ノートブック メニュー リボン: このリボンのアクションは、ノートブックの作業ディレクトリ用です。 ここでは、セルの追加と削除、ノートブックの外観の変更、ノートブックを以前のチェックポイントに戻すなどの操作を行えます。 このリボンには、ノートブックが信頼されているかどうかと、実行されている Python のバージョンも表示されます。
  4. ツールバー: ノートブックの一般的なタスクを行うためのツールを使用します。
  5. ワークスペース: ノートブックのコンテンツはここに表示されます。また、コンテンツの修正もここで行えます。

ノートブック メニュー リボン

ノートブック メニュー リボンのドロップダウン リストでは、次の操作を行えます。

ファイル

[ファイル] メニューで、ノートブックをダウンロードする形式を次の中から選択できます。

  • Python コード (*.py)
  • Python ノートブック (*.ipynb)
  • Reveal.js スライド (*.html)
  • Markdown (*.md)

ノートブックのアイテム詳細ページに、*.ipynb 形式のノートブックをダウンロードすることもできます。

編集

[編集] メニューでは、次のアイテムが利用できます。

  • [セルの切り取り]: 選択中のセルをノートブックのワークスペースから切り取ります。
  • [セルのコピー]: ノートブック ワークスペースで選択中のセルをコピーします。
  • [セルを上に貼り付け]: コピーしたセルを、選択中のセルの上に貼り付けます。
  • [セルを下に貼り付け]: コピーしたセルを、選択中のセルの下に貼り付けます。
  • [セルの貼り付けと置換]: コピーしたセルを、選択中のセルに貼り付けて置換します。
  • [セルの削除]: 選択中のセルを削除します。
  • [削除したセルを元に戻す]: セルの削除操作を元に戻します。最後に行われた削除操作から順番に元に戻されます。
  • [セルの分割]: セル内のコンテンツを、カーソルが置かれている場所から 2 つに分けてセルを分割します。
  • [上のセルとマージ]: 選択中のセルを、その上のセルとマージします。
  • [下のセルとマージ]: 選択中のセルを、その下のセルとマージします。
  • [セルを上に移動]: 選択中のセルを、ノートブックのワークスペース内で 1 つ上の位置に移動します。
  • [セルを下に移動]: 選択中のセルを、ノートブックのワークスペース内で 1 つ下の位置に移動します。
  • [検索と置換]: 検索語句を入力するポップアップ ウィンドウが開きます。 ノートブック内の特定の値や文字列を検索したり、置換したりできます。
  • [セルの添付ファイルのコピー]: 選択されたセルに含まれる添付ファイルをコピーします。
  • [セルの添付ファイルの切り取り]: 選択されたセルに含まれる添付ファイルを切り取り、コピーします。
  • [セルの添付ファイルの貼り付け]: コピーした添付ファイルを、選択されたセルに貼り付けます。
  • [画像の挿入]: GIF などの画像を参照して追加するポップアップ ウィンドウが開きます。画像は Markdown セルにのみ追加されます。

表示

[表示] メニューでは、次のアイテムが利用できます。

  • [ツールバーの切り替え]: ツールバーの表示と非表示を切り替えます。
  • [行番号の切り替え]: ノートブックのワークスペースの各セルで行番号の表示と非表示を切り替えます。
  • [セル ツールバー]: ノートブックのワークスペースの各セルで、選択したスライド ツールバー オプションの表示と非表示を切り替えます。 次のようなオプションがあります。
    • [なし]: セル ツールバーを表示しません。
    • [メタデータの編集] - JSON を使用して各セルのメタデータを入力します。
    • [未加工のセル形式]: 未加工のセルは、出力を直接書き込むことができます。ノートブックは、これらのセルのコンテンツを評価しません。
    • [スライドショー] - 各セルがスライド ショーに表示される方法を指定します。 このオプションは、コードを表示する際に便利です。
    • [添付ファイル] - ノートブックのワークスペースの各セルに含まれる、関連添付ファイルを管理します。
    • [タグ] - ノートブックのワークスペースに含まれる各セルのタグを作成し、管理します。

挿入 (Insert)

[挿入] メニューでは、次のアイテムが利用できます。

  • [セルを上に挿入] - 選択中のセルの上に、空白のセルを挿入します。
  • [下にセルを挿入] - 選択中のセルの下に、空白のセルを挿入します。

セル

[セル] メニューでは、次のアイテムが利用できます。

  • [セルの実行] - 選択中のセルを実行し、ポインターを次のセルに移動します。
  • [セルを実行して下のセルを選択] - 選択中のセルを実行し、その下のセルを選択します。
  • [セルを実行してセルを下に挿入] - 選択中のセルを実行し、その下に空白のセルを挿入します。
  • [すべて実行] - ノートブック内のすべてのセルを順番に実行します。
  • [上のセルをすべて実行] - 選択中のセルは実行せず、その上にあるすべてのセルを実行します。
  • [下のセルをすべて実行] - 選択中のセルと、その下のすべてのセルを実行します。
  • [セル タイプ] - 選択中のセルのタイプを変更します。 オプションは [コード][Markdown][Raw NBConvert] です。 なお、[見出し] タイプは [Markdown] に切り替わります。
  • [現在の出力]: 選択中のセルの出力を制御できます。 オプションには次のものがあります。
    • [出力の切り替え] - 選択中のセルの出力の表示と非表示を切り替えます。
    • [スクロールの切り替え] - 選択中のセルのスクロールを有効または無効にします。
    • [出力のクリア] - 選択中のセルの出力をクリアします。
  • [すべての出力] - ノートブックのワークスペース内のすべてのセルの出力を制御します。 オプションには次のものがあります。
    • [出力の切り替え] - すべてのセルの出力の表示と非表示を切り替えます。
    • [スクロールの切り替え] - すべてのセルのスクロールを有効または無効にします。
    • [出力のクリア] - すべてのセルの出力をクリアします。

カーネル

[カーネル] メニューでは、次のアイテムが利用できます。

  • [中断] - 計算または解析に時間がかかりすぎている場合、実行中のカーネルを一時停止します。
  • [再開] - カーネルを再開し、計算処理を最初からやり直します。
  • [再開して出力をクリア] - 計算処理を再開し、ノートブックに表示された出力をクリアします。
  • [再開してすべて実行] - 計算処理を再開し、すべてのセルを順番に実行します。
  • [再接続] - カーネルがアイドル状態になったときに、カーネルに再接続します。
  • [シャットダウン] - ノートブック内のすべての計算処理をシャットダウンします。
  • [カーネルの変更] - カーネル タイプを変更します。 ArcGIS Notebooks でサポートされているのは、Python 3 カーネル タイプのみです。

ヘルプ

このリストでは、キーボード ショートカット、ユーザー インターフェイス、ArcGIS Notebooks および主な Python モジュールに関するさまざまなヘルプ ドキュメントにアクセスできます。

ノートブック環境を初めて使用するユーザーには、特に [ユーザー インターフェイス ツアー] が便利です。

ノートブックのツールバーのボタン

ノートブック ツールバーは、ノートブック メニュー リボンで特によく使用される操作へのクイック アクセスを提供しています。 使用できるボタンは次のとおりです (左から右)。

  • 追加 - 選択中のセルの下にセルを挿入します。
  • 切り取り - 選択中のセルを切り取ります。
  • コピー - 選択中のセルをコピーします。
  • 貼り付け - コピーしたセルを、選択中のセルの下に貼り付けます。
  • 上矢印 - 選択したセルを、ノートブックのシーケンス内で上方向に移動します。
  • 下矢印 - 選択したセルを、ノートブックのシーケンス内で下方向に移動します。
  • 実行 - 現在選択中のセルを実行します。
  • 停止 - カーネルを中断します。
  • 再開 - カーネルを再開します。
  • 早送り - カーネルを再開し、すべてのセルを実行します。
  • セル タイプ - 選択中のセルのタイプを選択または変更します。
  • キーボード - コマンド パレットを開きます。
  • チャート - スライド ショー モードに入るか、終了します。