Introduzione agli appunti

Gli appunti vengono creati nell'editor degli appunti, che si apre ArcGIS Online. Questa sezione tratta i componenti e i menu nell'editor degli appunti.

Nozioni di base sull'interfaccia

L'editor degli appunti contiene cinque componenti fondamentali:

Componenti dell'editor degli appunti

  1. Barra di navigazione: consente di esplorare il sito Web, di aprire altre app dal launcher, di visualizzare la guida e di accedere al proprio profilo o di o uscirne. La barra di navigazione mostra anche il titolo degli appunti e indica la presenza di eventuali modifiche non salvate.
  2. Barra superiore: consente di eseguire diverse operazioni riguardanti gli appunti. Questa barra contiene i seguenti pulsanti:
  3. Barra del menu degli appunti: le operazioni disponibili in questa barra consentono di lavorare direttamente sugli appunti. È possibile aggiungere ed eliminare celle, modificare l'aspetto degli appunti, riportare gli appunti a un punto di ripristino e tanto altro. Questa barra indica anche se gli appunti sono affidabile e mostra la versione di Python in esecuzione.
  4. Barra degli strumenti: contiene gli strumenti per le attività più comuni con gli appunti.
  5. Workspace: qui viene visualizzato il contenuto degli appunti ed è possibile modificarlo.

Barra multifunzione del menu degli appunti

Nella barra del menu degli appunti sono disponibili le seguenti azioni negli elenchi a discesa.

File

Dal menu File è possibile scaricare i propri appunti in uno dei seguenti formati:

  • Codice Python (.py)
  • Appunti Python (.ipynb)
  • Slide Reveal.js (.slides.html)
  • Markdown (.md)

È anche possibile scaricare gli appunti in formato .ipynb nella pagina dei dettagli dell'elemento degli appunti.

Modifica

Nel menu Modifica sono disponibili i seguenti elementi:

  • Taglia celle: consente di tagliare le celle selezionate nel workspace degli appunti.
  • Copia celle: consente di copiare le celle selezionate nel workspace degli appunti.
  • Incolla celle sopra: consente di incollare le celle copiate sopra la cella attualmente selezionata.
  • Incolla celle sotto: consente di incollare le celle copiate sotto la cella attualmente selezionata.
  • Incolla celle e sostituisci: consente di incollare le celle copiate sostituendo le celle attualmente selezionate con le celle copiate.
  • Elimina celle: consente di eliminare le celle attualmente selezionate.
  • Annulla eliminazione celle: consente di annullare le operazioni di eliminazione delle celle eseguite, in ordine inverso. L'eliminazione più recente viene annullata per prima.
  • Dividi cella: consente di dividere una cella in due separandone il contenuto nella posizione attuale del cursore.
  • Unisci cella sopra consente di unire la cella attualmente selezionata con quella sovrastante.
  • Unisci cella sotto consente di unire la cella attualmente selezionata con quella sottostante.
  • Sposta cella su: consente di spostare la cella attualmente selezionata in alto di una posizione nel workspace degli appunti.
  • Sposta cella giù: consente di spostare la cella attualmente selezionata in basso di una posizione nel workspace degli appunti.
  • Trova e sostituisci: determina l'apertura di una finestra in cui si può digitare una query di ricerca. Consente quindi di trovare e sostituire valori o stringhe specifici all'interno degli appunti.
  • Copia allegati cella: consente di copiare gli allegati presenti nella cella selezionata.
  • Taglia allegati cella: consente di tagliare e poi copiare gli allegati presenti nella cella selezionata.
  • Incolla allegati cella: consente di copiare gli allegati nella cella selezionata.
  • Inserisci immagine: determina l'apertura di una finestra in cui si possono sfogliare e aggiungere immagini, comprese quelle in formato GIF, solo nelle celle di tipo Markdown.

Vista

Nel menu Visualizza sono disponibili i seguenti elementi:

  • Attiva/disattiva barra degli strumenti: consente di nascondere o visualizzare la barra degli strumenti.
  • Attiva/disattiva numeri di riga: consente di nascondere o visualizzare i numeri di riga all'interno di ciascuna cella nel workspace degli appunti.
  • Barra degli strumenti celle: consente di nascondere o visualizzare l'opzione della barra degli strumenti della slide selezionata per ogni cella nel workspace degli appunti. Le opzioni sono le seguenti:
    • Nessuna: non mostrare le barre degli strumenti delle celle.
    • Modifica metadati: inserire i metadati di ogni cella con JSON.
    • Formato cella non elaborata: le celle non elaborate consentono di scrivere direttamente l'output; il contenuto di queste celle non viene valutato dagli appunti.
    • Presentazione: specificare come sarà visualizzata ogni cella in una presentazione. Questa opzione è utile durante per la presentazione del codice.
    • Allegati: gestire gli allegati di ciascuna cella nel workspace degli appunti.
    • Tag: creare e gestire dei tag per ogni cella nel workspace degli appunti.

Inserisci

Nel menu Inserisci sono disponibili i seguenti elementi:

  • Inserisci cella sopra: inserire una cella vuota sopra la cella attualmente selezionata.
  • Inserisci cella sotto: inserire una cella vuota sotto la cella attualmente selezionata.

Cella

Nel menu Cella sono disponibili i seguenti elementi:

  • Esegui celle: eseguire la cella attualmente selezionata e spostare il cursore sulla cella successiva.
  • Esegui celle e seleziona sotto: eseguire la cella attualmente selezionata e quindi selezionare la cella sottostante.
  • Esegui celle e inserisci sotto: eseguire la cella attualmente selezionata e quindi inserire una cella vuota sotto la cella selezionata.
  • Esegui tutto: eseguire tutte le celle degli appunti in sequenza.
  • Esegui tutto sopra: eseguire tutte le celle sopra la cella attualmente selezionata, senza eseguire la cella selezionata.
  • Esegui tutto sotto: eseguire la cella attualmente selezionata e tutte le celle sottostanti.
  • Tipo di cella: modificare il tipo di cella attualmente selezionata. Le opzioni disponibili sono Codice, Markdown e Conversione appunti grezzi. Nota: il tipo di Intestazione passerà a Markdown.
  • Output attuali: consente di controllare l'output della cella attualmente selezionata. Le opzioni includono quanto segue:
    • Attiva/disattiva output: nascondere o visualizzare l'output della cella attualmente selezionata.
    • Attiva/disattiva scorrimento: abilitare o disabilitare lo scorrimento nella cella attualmente selezionata.
    • Cancella output: cancellare l'output della cella attualmente selezionata.
  • Tutti gli output: controllare l'output di tutte le celle nel workspace degli appunti. Le opzioni includono quanto segue:
    • Attiva output: nascondere o visualizzare l'output per tutte le celle.
    • Attiva/disattiva scorrimento: abilitare o disabilitare lo scorrimento per tutte le celle.
    • Cancella output: cancellare l'output per tutte le celle.

Kernel

Nel menu Kernel sono disponibili i seguenti elementi:

  • Interrompi: mettere in pausa il kernel in esecuzione se un calcolo o un'analisi richiede troppo tempo.
  • Riavvia: riavviare l'intera procedura di calcolo riavviando il kernel.
  • Riavvia e cancella l'output: riavviare la procedura di calcolo e cancellare gli eventuali output visualizzati negli appunti.
  • Riavvia ed esegui tutto: riavviare la procedura di calcolo ed eseguire tutte le celle in sequenza.
  • Riconnetti: riconnettersi a un kernel se è inattivo.
  • Arresta: arrestare tutte le procedure di calcolo negli appunti.
  • Cambia kernel: cambiare il tipo di kernel. In ArcGIS Notebooks è supportato solo il kernel di tipo Python 3.

?

Questo elenco contiene informazioni sulle scorciatoie da tastiera, sull'interfaccia utente e sui vari documenti della guida riguardanti ArcGIS Notebooks e i moduli Python fondamentali.

Il tour dell'interfaccia utente è particolarmente utile agli utenti che non hanno dimestichezza con l'ambiente degli appunti.

Pulsanti della barra degli strumenti degli appunti

La barra degli strumenti degli appunti consente di accedere rapidamente alle azioni utilizzate più spesso nella barra del menu degli appunti. I pulsanti disponibili, da sinistra verso destra, sono i seguenti:

  • Aggiungi: inserire una cella sotto la cella attualmente selezionata.
  • Taglia: tagliare la cella attualmente selezionata.
  • Copia: copiare la cella attualmente selezionata.
  • Incolla: incollare le celle copiate sotto la cella attualmente selezionata.
  • Freccia su: spostare verso l'alto la cella selezionata nella sequenza degli appunti.
  • Freccia giù: spostare verso il basso la cella selezionata nella sequenza degli appunti.
  • Esegui: eseguire la cella attualmente selezionata.
  • Arresta: arrestare il kernel.
  • Riavvia: riavviare il kernel.
  • Avanzamento rapido: riavviare il kernel ed eseguire tutte le celle.
  • Tipo di cella: selezionare o modificare il tipo di cella attualmente selezionata.
  • Tastiera: aprire il riquadro dei comandi.
  • Grafico: accedere alla modalità di presentazione o uscirne.