Skip To Content

System requirements

There are certain device requirements to run AppStudio for ArcGIS and AppStudio Player, as well as requirements on the data used in the app.

ArcGIS requirements

To use your maps in AppStudio, you must have an ArcGIS organizational account. Your maps can include data from ArcGIS Online, Portal for ArcGIS, and ArcGIS Server.

A user can sign in to AppStudio Player with an ArcGIS Online account of any user type. If an app item is shared publicly, it can be downloaded to Player without signing in.

To use the AppStudio website with an ArcGIS Online account, a user needs to be either the Creator or GIS Professional user type. For details of user types and permissions, see User types, roles, and privileges.

To use AppStudio for ArcGIS Desktop Edition with an ArcGIS Online account, a user needs to be either the Creator or GIS Professional user type, with the AppStudio for ArcGIS Standard add-on license.

To connect your app to ArcGIS Server data or services, use ArcGIS Server 10.0 or later. To use ArcGIS Server data when your app is offline, use ArcGIS Server 10.2.2 or later.

AppStudio supports ArcGIS Runtime 100.4.

AppStudio app items can be saved in ArcGIS Online and ArcGIS Enterprise. Portal for ArcGIS 10.4 and higher are also supported for signing in, creating and uploading apps, and data stored in Portal for ArcGIS 10.2 or later can be used in your apps.

Supported browsers for the AppStudio website

The following browsers are supported. For best performance, use the latest version.

  • Chrome
  • Firefox
  • Safari
  • Edge
  • Internet Explorer 11

Supported operating systems

The following operating systems (with minimum versions) are supported for AppStudio on the desktop:

Operating systemOS version

Windows

  • Windows 10 Pro and Windows 10 Enterprise (32 bit and 64 bit [EM64T])
  • Windows 8.1, Windows 8.1 Pro, and Windows 8.1 Enterprise (32 bit and 64 bit [EM64T])
  • Windows 7 Ultimate, Enterprise, Professional, and Home Premium (32 bit and 64 bit [EM64T]) SP1
  • Windows Server 2016 (64 bit)

Ubuntu

16.04 LTS or later (64 bit)

macOS

10.12.6 Sierra or later

The following operating systems (with minimum versions) are supported for AppStudio Player:

Operating systemOS version

Windows

  • Windows 10 Pro and Windows 10 Enterprise (32 bit and 64 bit [EM64T])
  • Windows 8.1, Windows 8.1 Pro, and Windows 8.1 Enterprise (32 bit and 64 bit [EM64T])
  • Windows 7 Ultimate, Enterprise, Professional, and Home Premium (32 bit and 64 bit [EM64T]) SP1
  • Windows Server 2012 Standard and Datacenter (64 bit [EM64T])
  • Windows Server 2016 (64 bit)

Ubuntu

16.04 LTS or later (64 bit)

macOS

10.12.6 Sierra or later

Android

4.4 KitKat or later

iOS

10 or later (64 bit)

iOS compatibility was limited to 64-bit devices with AppStudio Player 3.0. For information on what iOS devices are supported, see the arm64 support in Apple's developer documentation on device compatibility.

An operating system can only be supported if it is also supported by the Qt SDK from The Qt Company.

DirectX

ArcGIS Runtime uses ANGLE, which renders using DirectX, to provide high-performance map rendering. DirectX provides support for hardware and software rendering of graphics and is provided by the supported Windows platforms. DirectX software rendering is used if DirectX hardware support is not available (including on virtual machines).

Hardware requirements

CPU Speed

2.2 GHz minimum or higher; Hyper-threading (HHT) or Multi-core recommended

Processor

Platform

Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 minimum

Windows: Run this Microsoft utility from your Windows command prompt to check your processor.

Memory/RAM

2 GB or higher

Display properties

24-bit color depth

Screen resolution

1024x768 recommended or higher at normal size (96 dpi)

Swap space

Determined by the operating system; 500 MB minimum

ArcGIS Runtime will create cache files when used; additional disk space may be required.

Video/Graphics adapter

64 MB RAM minimum; 256 MB RAM minimum recommended. NVIDIA, ATI, and INTEL chipsets supported.

Accelerated graphics card driver

OpenGL version 2.1 minimum runtime is required for 2D map views, OpenGL version 3.2 is required for 3D scene views. Shader Model 3.0 minimum is recommended. Be sure to use the latest available driver.

User interface

Linux: X Windows with Gnome or KDE Desktop Environment

Supported languages

The following languages are supported by AppStudio:

Arabic, Bosnian, Catalan, Croatian, Czech, Danish, Dutch, English, Estonian, Finnish, French, German, Greek, Hebrew, Hungarian, Indonesian, Italian, Japanese, Korean, Latvian, Lithuanian, Norwegian, Polish, Portuguese (Brazil), Portuguese (Portugal), Romanian, Russian, Serbian, Simplified Chinese, Slovenian, Spanish, Swedish, Thai, Traditional Chinese (Hong Kong), Traditional Chinese (Taiwan), Turkish, Ukrainian, and Vietnamese.

The language used is determined by your device's language setting.