Управление размещёнными векторными слоями

Вы можете изменить некоторые настройки в размещенном векторном слое (или в таблице), в то время как другие параметры заданы в отдельных слоях, входящих в состав размещенного векторного слоя. В следующих разделах описывается, как владелец слоя или администратор может управлять следующими настройками для размещенного векторного слоя и слоев, которые он содержит.

Подсказка:

Следующие параметры применяются ко всем, кто имеет доступ к размещенному векторному слою. Примите следующее во внимание при публикации слоя:

  • Включить синхронизацию (требуется для автономного использования и совместной работы) — используйте размещенный векторный слой в автономном режиме или при совместной работе.
  • Разрешить другим экспорт в разных форматах — экспорт данных из размещенного векторного слоя.
  • Включить вложения — добавьте вложения к объектам в размещенных векторных слоях.

Когда вы публикуете размещённый векторный слой в группе общего обновления, члены группы могут управлять многими параметрами этого слоя.

Переименование слоев

Вы можете поменять имя элементов размещённых векторных слоев и слоев внутри них.

Изменение имени элемента или слоев внутри размещенного векторного слоя не повлияет на имена в любых связанных размещенных слоях или представлениях. Верно и обратное: при изменении имени элемента слоя или имен слоев в связанных слоях не повлияет на имена в источнике размещенного векторного слоя.

  1. Войдите в вашу организацию и откройте страницу элемента размещенного векторного слоя. Чтобы переименовать подслой, откройте его страницу элементов, щелкнув имя слоя под списком Слои на вкладке Обзор.
  2. На вкладке Обзор щелкните кнопку Редактировать рядом с именем элемента или слоя, которое вы хотите изменить.
  3. Введите новое имя слоя или элемента и щелкните Сохранить.

Управление настройками редактирования

Как владелец или администратор размещенного векторного слоя вы можете изменить настройки векторного слоя, которые влияют на то, кто может редактировать и какие изменения они могут вносить. Другие факторы также влияют на то, кто может редактировать. См. Управление редактированием размещенных векторных слоев для получения информации обо всех настройках и факторах, влияющих на редактирование размещенного векторного слоя.

Есть две настройки редактирования, использующие журнал изменений, которыми можно управлять, обрезая старые записи, как описано ниже.

Управление размером журнала изменений

Когда вы включаете параметры Включить синхронизацию (требуется для автономного использования и совместной работы) или Сохранить отслеживание изменений в данных (добавлять, обновлять, удалять объекты) в размещенном векторном слое, ArcGIS Online сохраняет информацию об изменениях данных и автономных версиях в журнале изменений. Этот журнал изменений растет по мере накопления изменений. Чтобы избежать расхода кредитов, связанных с большим журналом изменений, вы можете его обрезать.

Для каждого векторного слоя, для которого включена одна из этих опций, вы можете указать количество дней, в течение которых должны сохраняться изменения. Любые внесенные изменения или версии, переведенные в автономный режим или опубликованные в совместной работе, старше указанного вами количества дней, будут удалены.

Внимание:

Не обрезайте журнал изменений, если у вас есть несинхронизированные совместные работы или автономные правки, которые были опубликованы в совместной работе или переведены в автономный режим в течение периода времени, который будет вырезан из таблицы. Например, если вы опубликовали редактируемый векторный слой в совместной работе 100 дней назад, и правки из этой совместной работы не были синхронизированы, вы можете обрезать записи старше 180 дней, но не надо обрезать записи старше 30 или 90 дней. Точно так же, если векторный слой был отключен для редактирования 40 дней назад и не синхронизирован, вы можете обрезать записи старше 90 или 180 дней, но не обрезать записи старше 30 дней.

Кроме того, если слой входит в автономную область или области карты, подумайте, когда в последний раз обновлялся связанный со слоем пакет загрузки. Чтобы избежать повторного создания областей карты, выберите период хранения, включающий дату последнего обновления пакета загрузки. Например, если пакет загрузки был обновлен 38 дней назад, не обрезайте записи старше 30 дней, потому что это предотвратит обновление и синхронизацию области карты при ее загрузке.

Если все параметры, использующие файл журнала, отключены, например, включены параметры Включить синхронизацию (требуется для автономного использования и совместной работы) или Сохранить отслеживание изменений в данных (добавлять, обновлять, удалять объекты), а вы отключите оба параметра или есть только Включить синхронизацию (требуется для автономного использования и совместной работы), и вы отключите его — все записи будут удалены из файла журнала.

  1. Откройте страницу информации для размещенного векторного слоя, для которого вы хотите управлять журналом изменений.
  2. Перейдите на вкладку Настройки.
  3. Прокрутите до раздела Настройки векторного слоя (размещенный) и щелкните Управлять журналом изменений.

    Открывается окно Управлять журналом изменений.

  4. Используйте ниспадающий список, чтобы указать количество дней хранения журналов.

    Записи журнала старше указанного вами числа дней будут удалены из журнала.

  5. Щелкните Сократить журнал изменений.

Разрешение на экспорт данных

Будучи владельцем или администратором размещенного векторного слоя, вы можете экспортировать данные из любого слоя в файл со значениями, разделенными запятой (.csv), файлMicrosoft Excel, шейп-файл, класс объектов файловой базы геоданных, файл GeoJSON, набор пространственных объектов, файл .kml или файл Open Geospatial Consortium (OGC) GeoPackage. Вы также можете настроить размещенный векторный слой, чтобы позволить другим пользователям экспортировать данные из него при обращении к слою ArcGIS Online.

Когда пользователи, кроме владельца или администратора, выполняют экспорт из представления размещённого векторного слоя, к которому были применены определения полей или объектов, экспортированный файл будет содержать только поля или объекты, которые допускаются этими определениями. Когда экспорт выполняется владельцем или администратором, определения не применяются, и экспортируемый файл содержит все поля и объекты.

Выполните следующие шаги, чтобы разрешить другим экспортировать данные из размещенного векторного слоя или из представления размещенного векторного слоя при доступе к слою в ArcGIS Online:

  1. Выполните вход под учетной записью владельца размещенного векторного слоя или представления размещенного векторного слоя или администратора организации.
  2. Откройте страницу элемента для слоя, который вы хотели бы разрешить экспортировать другим пользователям.
  3. Щелкните вкладку Настройки и прокрутите список вниз до раздела Настройки векторного слоя.
  4. Щёлкните Разрешить пользователям экспорт в другие форматы и Сохранить.

Теперь другие участники организации могут экспортировать из размещённого векторного слоя.

Примечание:

Этот параметр не влияет на возможности людей экспортировать данные из базового сервиса. Даже если вы не включите этот параметр экспорта в своем векторном слое, любой, кто получит доступ к этому слою в других клиентах, таких как ArcGIS Pro или пользовательских приложениях, сможет экспортировать данные из него.

Разрешение на добавление вложений

Вы можете разрешить пользователям прикреплять изображения или другие файлы к отдельным объектам слоя, входящего в состав размещенного векторного слоя. Это позволяет прикреплять документацию или фото, относящиеся к отдельным объектам. Например, инспектор может добавить фото о несоответствии адреса объекта его фактическому местоположению, а сотрудник управления землеустройства может прикрепить PDF-документ разрешения на застройку.

Каждое представление размещенного векторного слоя наследует параметры вложений исходного векторного слоя, из которого это представление было создано. По умолчанию вложения, перешедшие с размещенного векторного слоя, смогут увидеть все пользователи представлений. Для контроля доступа к этим вложениям вы можете скрыть эти вложения в представлении размещенного векторного слоя.

Размер прикрепляемых к объектам файлов не должен превышать 10 МБ каждый. Что прикрепить файлы размером свыше 10ГБ, можно использовать операции Частичная загрузка и Добавить вложение из ArcGIS REST API для загрузки по частям.

Список поддерживаемых типов файлов, которые могут быть прикреплены, см. в разделе Редактирование таблиц.

Выполните следующие шаги, чтобы разрешить добавление файлов в объекты слоя, входящего в состав размещённого векторного слоя:

  1. Включите редактирование для размещённого векторного слоя.

    Если вы не разрешите редактирование, пользователи не смогут добавлять в этот слой вложения.

  2. Выполнив вход под своей учетной записью ArcGIS Online, щелкните слой на вкладке Мои ресурсы и откройте страницу подробной информации об этом векторном слое.
  3. Щелкните имя слоя в списке Слои на вкладке Обзор, чтобы открыть страницу информации о слое.
  4. Щелкните переключатель Разрешить вложения.

Теперь пользователи, редактирующие слой, смогут добавлять файлы к отдельным объектам.

Если вы решите, что больше не хотите, чтобы какие-либо файлы были добавлены к вашему слою, откройте страницу информации о подслое и выключите переключатель рядом с пунктом Разрешить вложения. Примите во внимание, что в этом случае из слоя будут удалены все существующие вложения, а другие пользователи больше не смогут добавлять новые вложения.

Скрытие вложений в представлениях

Скройте вложения в представлениях размещенных векторных слоев, если определенным пользователям нужен доступ к атрибутам объектов, но они не должны видеть эти вложения или им не требуется доступ к этим вложениям.

Например, если вложение содержит конфиденциальную информацию, которую должны видеть только несколько определенных участников организации, опубликуйте этот размещенный векторный слой в группе, в которую входили бы эти несколько участников. Создайте из слоя представление размещенного векторного слоя, скройте вложения и опубликуйте представление для более широкой аудитории.

Выполните следующие шаги, чтобы скрыть вложения отдельных слоев представления размещённого векторного слоя:

  1. Откройте страницу подробных сведений для представления размещенного векторного слоя.
  2. Перейдите к списку Слои на вкладке Обзор и щелкните слой с вложениями, которые вы хотите скрыть.
  3. Щелкните переключатель Скрыть вложения, чтобы пользователи данного представления размещенного векторного слоя не могли получить доступ к вложениям на этом слое.
  4. Повторите шаги 2 и 3 для каждого слоя, в котором есть вложения, для которых вы хотите закрыть доступ пользователям.

Если вы решите, что пользователям представления нужен доступ к одному или к нескольким слоям в данном представлении, щелкните ссылку Показать вложения; такие ссылки находятся под соответствующими слоями на вкладке Обзор страницы подробных сведений представления размещенного векторного слоя.

Оптимизация отрисовки сложных линий и полигонов

Если ваш размещённый векторный слой включает линейный или полигональный слои, которые содержат большое число вершин и обычно просматриваются в мелких и средних масштабах, то вы можете оптимизировать эти слои, чтобы ускорить их отображение в веб-клиентах. Например, хорошим кандидатом на оптимизацию является слой с границами полигонов почтовых индексов для штата или большого региона. Вы можете просмотреть почтовые индексы в мелких или средних масштабах, чтобы все индексы отображались одновременно, а также вы можете приблизиться и рассмотреть подробно границы в крупных масштабах. Оптимизация слоя повысит быстродействие в мелких и средних масштабах, поддерживая при этом уровень детализации в крупных масштабах.

Оптимизация слоёв использует дополнительное место на диске, и слои нельзя редактировать до завершения процесса оптимизации. Требуемое для оптимизированных слоёв хранилище данных увеличится, однако улучшение быстродействия иногда может быть важнее для веб-клиентов. Если вы решили, что вам не требуется увеличить скорость отрисовки, то отключите оптимизацию. У вас сразу же уменьшатся объём хранимых данных (сократится размер размещенного векторного слоя), и дальнейшие затраты на хранение. Вы можете увидеть размер размещенного векторного слоя на вкладке Обзор на странице элемента этого слоя.

Примечание:

Представления размещенного векторного слоя наследуют настройки оптимизации исходного слоя, из которого они были созданы; невозможно независимо настраивать оптимизацию для представления. Чтобы включить оптимизацию для представлений, которые содержат линии или полигоны, измените настройки вложений того слоя, из которого представление было создано.

Если слой в размещенном векторном слое содержит полигональный или линейный объект, включающий более 500 000 вершин, оптимизация отрисовки будет включена по умолчанию.

Чтобы увидеть и сравнить, как улучшается производительность на примере одного слоя границ округов США, перейдите по ссылкам. Откройте эти слои в двух окнах, используя один браузер, добавьте их в Map Viewer или Map Viewer Classic, приблизьтесь к этим слоям и выполните перемещения. Несмотря на то, что быстродействие зависит от скорости работы сети, вы увидите значительную разницу в скорости работы оптимизированного слоя.

Без оптимизации отрисовки слоя размер размещенного векторного слоя – 136 Мб. После оптимизации размер размещенного векторного слоя – 205 Мб.

Оптимизация особенно полезна для линейных или полигональных слов, которые включают объекты с множеством вершин.

Примите во внимание следующие аспекты редактирования и перезаписи оптимизированных слоёв:

  • Если вы редактируете или синхронизируете изменения слоя при выполнении оптимизации, все изменения автоматически оптимизируются.
  • Если векторный слой является редактируемым слоем карты, то слой загружается без оптимизации для гарантии того, что при редактировании будет доступен полный уровень детализации.
  • Если вам не требуется редактировать данные в отдельной карте, отключите редактирование для слоёв во вьюере карт. Это позволяет вам получить преимущества от оптимизации на вашей карте, доступной только для чтения, но слой можно будет редактировать в других картах и приложениях.
  • Перезапись слоя отключает оптимизацию. Для оптимизации времени отрисовки выполните заново следующие шаги для слоя.

Примечание:

Базовая карта, на которой отображается векторный слой, должна быть выполнена в проекции Web Mercator Auxiliary Sphere (как базовые карты Esri по умолчанию), что улучшает время прорисовки. Если слой, имеющий проекцию не Web Mercator Auxiliary Sphere, добавляется к базовым картам, слой загружается без оптимизации.

Выполните следующие шаги для оптимизации времени отрисовки для линейного или полигонального слоя:

  1. Откройте страницу подробной информации размещенного векторного слоя.
  2. Перейдите на вкладку Настройки и найдите раздел Оптимизировать отрисовку слоя.

    Перечислены слои в размещенном векторном слое, для которых в настоящее время включена оптимизация отрисовки.

  3. Щёлкните Оптимизировать слои.

    Появится диалоговое окно Оптимизировать отрисовку слоя.

  4. Поставьте отметку в окошке рядом со слоем, отрисовку которого надо оптимизировать, и щелкните Обновить.

    Диалоговое окно Оптимизировать отрисовку слоя закроется, и на вкладке Настройки будет отображаться статус обновления.

    Процесс оптимизации может занять несколько минут. До завершения оптимизации редактирование слоя временно недоступно.

Если позже вы решите, что слой используется мало и не требует оптимизации отрисовки, вы можете отключить ее. Чтобы отключить оптимизацию отрисовки, повторите шаги с 1 по 3. На шаге 4 снимите флажок у слоя, для которого вы хотите отключить оптимизацию отрисовки, и щелкните Обновить.

Включение настроек времени

Если размещенный векторный слой записывает разную информацию для одного и того же местоположения, используя дату и время, то вы можете включить и настроить параметры времени для слоев размещенного векторного слоя. Когда параметры времени будут заданы и вы добавите размещенный векторный слой на карту, вы можете настроить параметры времени на карте и наблюдать, что произойдет в определенное время, или визуализировать модели и тенденции, проявляющиеся по мере изменения данных во времени.

Перезапись размещённых векторных слоёв

Чтобы обновить данные в размещенных векторных слоях, опубликованных из файловой базы геоданных, шейп-файла, файла GeoJSON, файла Microsoft Excel или файла .csv, замените эти данные данными из обновленного исходного файла с помощью опции Обновить данные > Перезаписать весь слой на странице элемента слоя. Например, если ваш размещенный векторный слой находится в общем доступе для всех Интернет-пользователей, и вы не хотите, чтобы его редактировали, или если вы регулярно получаете обновление данных в представлении шейп-файла, то вы можете перезаписать данные размещенного векторного слоя. Это позволяет сохранить его URL, свойства слоя, которые вы указали на странице элемента размещенного векторного слоя, символы и настройки всплывающих окон.

Когда вы перезаписываете данные из локального файлового источника, то и файл источника, и данные размещенного векторного слоя в ArcGIS Online будут перезаписаны с использованием данных из обновленного исходного файла. Если источником является шейп-файл с метаданными либо файловая база геоданных, содержащая классы объектов с метаданными, ArcGIS Online добавляет или заменяет метаданные уровня слоя слоя в размещенном векторном слое. Если вы опубликовали размещенный векторный слой из облачного хранилища, данные остаются на диске облака, но данные в размещенном векторном слое заменяются.

При перезаписи размещенного векторного слоя необходимо использовать такой же тип файла-источника и схему.

Если опция Перезаписать весь слой не доступна, то это значит, что размещенный слой не может быть перезаписан по одной из следующих причин:

  • Он был опубликован с клиента, а не с сайта ArcGIS Online. Например, если векторный слой был опубликова из ArcGIS Pro, сервисо можно перезаписать с ArcGIS Pro.
    Примечание:

    При перезаписи размещенных векторных слоев из ArcMap, определение сервиса, изначально созданное с веб-слоем, должно находиться в вашей организации ArcGIS Online.

  • Он был опубликован на основе файла .csv до марта 2014 года.
  • Синхронизация включена для размещенного векторного слоя.
  • Это представление размещенного векторного слоя, а не сам слой. Чтобы обновить данные и в представлении размещенного векторного слоя, и в основном слое, из которого это представление было создано, перезапишите размещенный векторный слой – и обновления отразятся и в представлении.
  • Вы включили отслеживание изменения данных на слое.
  • Вы удалили связанный исходный файл.

Внимание:

  • Если для размещенного векторного слоя включено редактирование, любые изменения, внесенные в данные слоя заменяются данными из обновленного файла источника.
  • Если вы перезаписываете данные из локального файла, имена файла, полей и имени класса объектов должны быть такими же, как в исходном файле, который вы загрузили.
  • В обновленном файле должны присутствовать все те же поля и классы объектов (в случае файловых баз геоданных), которые есть в исходном файле. Например, если вы удалите класс объектов из файловой базы геоданных или добавите поле в шейп-файл или класс объектов, но не перезаписывайте данные.
  • Если вы все же перезапишите данные, и поля и имена классов объектов и схемы не будут одинаковыми, то векторный слой и веб-карты, которые используют этот векторный слой, могут работать некорректно. Если схема исходных данных изменилась, или если вы хотите сохранить изменения, которые вы сделали в размещенном слое, загрузите шейп-файл, файловую базу геоданных, файл Excel или файл .csv как новый элемент и опубликуйте новый слой.
  • Источник данных и слой должны принадлежать одному владельцу. Если для одного из них владелец изменен, то же следует сделать и для второго. В противном случае перезаписать слой не получится.
  • Если вы использовали адреса или местоположения для размещения объектов при первой публикации слоя, перезапись слоя геокодирует все адреса или местоположения обновляемого файла. В этом случае могут использоваться кредиты – в зависимости от конфигурации вашей организации. Обратитесь к своему администратору ArcGIS Online, если у вас появятся вопросы о том, какой сервис используется в вашей организации для геокодирования местоположений. Выбранный при первой публикации слоя локатор будет автоматически использоваться при перезаписи.
  • Если вы изменили детали отдельных подслоев, то эти правки пропадут, если вы перезапишете размещенный векторный слой из файла ArcMap или ArcGIS Pro
  • Векторный слой будет недоступен для других пользователей в течение короткого периода времени, пока он будет перезаписываться.

Выполните следующие шаги, чтобы перезаписать размещенный векторный слой:

  1. Выполните вход от имени владельца размещенного векторного слоя или администратора.
  2. Откройте страницу размещенного векторного слоя.
    • Если вы вошли под учетной записью владельца слоя, откройте страницу Мои ресурсы через страницу ресурсов и щелкните размещенный векторный слоя, чтобы открыть страницу с подробной информацией об элементе.
    • Если вы вошли под учетной записью администратора, откройте страницу Ресурсы моей организации через страницу ресурсов и щелкните имя слоя, чтобы открыть страницу с подробной информацией об элементе.
  3. Нажмите Обновить данные > Переписать весь слой.
  4. Загрузите отредактированные данные.
    • Если размещенный векторный слой был опубликован из локального файла, щелкните Обзор или Выбрать файл (зависит от браузера), перейдите к местоположению файла источника на диске и нажмите Переписать.
    • Если размещенный векторный слой был опубликован из файла на облачном диске, выполните вход на этот диск. ArcGIS Online автоматически обновляет размещенный векторный слой ресурсами из исходного файла на облачном диске.

Присоединение данных к слоям

Как владелец размещенного векторного слоя или администратор организации вы можете присоединять объекты к слою для размещенного векторного слоя. Это позволит вам публиковать исходные данные или даже пустой размещенный векторный слой, и затем добавлять данные по мере поставления, без необходимости перезаписывать весь размещенный векторный слой. Например, если у вас есть список сотрудников, которые выполняют полевые проверки и они собирают информацию в файл .csv или пользовательское приложение, которое записывает данные в шейп-файл, то вы можете брать файл от каждого инспектора в конце дня и обновлять размещенный векторный слой новыми данными.

Если обновленный файл содержит изменения для уже опубликованных объектов, то вы можете также использовать входной файл для обновления существующих объектов. Для этого требуется, чтобы слой и файл, который вы хотите использовать для загрузки обновлений, содержали поле с уникальными значениями, которые ArcGIS Online может использовать для идентификации объекта для обновления. Вы можете задать поле в подслое размещенного векторного слоя, как уникальное на вкладке Данные страницы подробной информации о слое. Затем, когда вы обновите слой, ArcGIS Online сможет использовать это поле в качестве идентификатора.

Внимание:

Вы должны убедиться, что значения полей в файле обновления и в слое корректно и уникально идентифицируют изменяемый объект. Если этого не происходит, вы можете потерять данные при перезаписи атрибутов существующих объектов. Обновление и присоединение закончится неудачей, если вы обновляете результаты с неуникальными значениями в поле, которое было задано, как уникальное.

При публикации из .csv или файла Microsoft Excel, имена полей которого содержат пробелы, в размещенном векторном слое пробелы будут заменены подчеркиванием. При присоединении данных необходимо вставить подчеркивания в имена полей файла; иначе имена полей не будут идентичными.

Вы можете использовать следующие файловые форматы, чтобы присоединить или обновить данные:

  • Шейп-файл (архивный)
  • Файловая база геоданных (архивный)
  • Файл CSV (.csv) – пространственное поле должно быть представлено в координатах широты и долготы.
  • Файл Microsoft Excel — должен содержать поле с пространственной информацией: координатами широты и долготы.
  • Файл GeoJSON (.geojson)

Если ваш размещенный векторный слой включен для автономного редактирования, можно только присоединить объекты, а обновить их - нельзя.

Выполните следующие шаги, чтобы присоединить и обновить объекты в слое внутри размещённого векторного слоя

  1. Выполните вход от имени владельца размещенного векторного слоя или администратора.
  2. Откройте страницу размещенного векторного слоя.
    • Если вы выполните вход в качестве владельца векторного слоя, щелкните вкладку Мои ресурсы страницы ресурсов и щелкните размещенный векторный слой, чтобы открыть страницу элемента. Чтобы открыть сведения о подслое в размещенном векторном слое, щелкните его имя в разделе Слои на вкладке Обзор.
    • Если вы вошли под учетной записью администратора, откройте страницу Ресурсы моей организации через страницу ресурсов и щелкните имя слоя, чтобы открыть страницу с подробной информацией об элементе. Чтобы открыть сведения о подслое в размещенном векторном слое, щелкните его имя в разделе Слои на вкладке Обзор.
  3. Щелкните Обновить данные > Присоединить данные к слою.
    Примечание:

    Вы сможете только добавить новые данные к размещенному векторному слою, для которого активирована синхронизация или отслеживание изменений (Сохранить отслеживание изменений в данных (Добавить, обновить, удалить объекты)).

  4. Щелкните Обзор или Выбрать файл (зависит от браузера) и перейдите к местоположению файла источника на диске.
  5. Если файл архивный, используйте формат файла из ниспадающего списка Ресурсы.
  6. Щелкните Загрузить и сохранить.

    Когда ArcGIS Online закончит анализ входного файла, откроется диалоговое окноПрисоединить данные.

  7. Если размещенный векторный слой содержит несколько слоев, укажите слой, к которому данные будут присоединены или в котором они будут обновлены.
  8. Если имена полей во входном файле не точно совпадают с полями слоя, щелкните Показать сопоставление полей, чтобы сопоставить поля файла и слоя.

    При операции присоединения несовпадающие поля будут удалены.

  9. Если вы только добавляете новые объекты в слой, нажмите Применить изменения.

    ArcGIS Online добавляет новые объекты в слой. Они доступны на картах, в сценах и в зависимых слоях WFS и представлениях размещенного векторного слоя сразу после применения обновлений.

  10. Если входной файл содержит обновления, которые вы желаете применить к существующим объектам в слое, выполните эти шаги:
    1. Установите отметку Обновить существующие объекты.
    2. Укажите поля во входной таблице и в слое, которые ArcGIS Online может использовать как уникальные идентификаторы объектов для обновления.
    3. Чтобы обновить местоположения существующих объектов и непространственные атрибуты, установите отметку Обновить геометрию существующих объектов. Если вы не отметили эту опцию, ArcGIS Online будет обновлять только непространственные атрибуты каждого объекта.

      Примечание:

      Если тип геометрии входного файла (например, точечного и линейного) е соответствует опубликованному векторному слою, доступна только опция обновления атрибутов имеющихся объектов.

    4. Если вы хотите, чтобы обновление произошло, даже если входной файл содержит строки, которые не содержатся в слое, включите опцию Игнорировать объекты без совпадений.
    5. Щелкните Применить изменения.

    ArcGIS Online добавляет новые объекты и обновляет существующие на основе входных данных. Измененные объекты и новые доступны на картах, в сценах и в зависимых слоях WFS и представлениях размещенного векторного слоя сразу после применения обновлений.

Перестроение пространственного индекса

Пространственные индексы увеличивают скорость выполнения пространственных запросов, например, прорисовку объектов на карте и выполнение поиска объектов. Если вы либо другие редакторы добавили объекты слоя, расположенные за пределами его начального экстента, пространственный индекс будет обновлен и его нужно перестроить. К примеру, если ваш размещенный векторный слой содержал объекты только в одном городе, и вы после этого присоединили объекты по всей стране, вам нужно перестроить пространственный индекс для этого слоя.

Если вы почувствуете, что слой отрисовывается медленнее, чем должен, и вы знаете, что было добавлено много объектов, находящихся за пределами исходного экстента, перестройте пространственный индекс.

Чтобы перестроить пространственный индекс слоя, выполните следующие действия:

  1. Выполните вход от имени владельца размещенного векторного слоя или администратора.
  2. Откройте страницу подробной информации о слое и щелкните вкладку Настройки.
  3. Прокрутите до раздела Управление пространственными индексами и щелкните Перестроить индексы.
  4. Установите отметку рядом с подслоем, для которого необходимо создать пространственный индекс, и щелкните Перестроить.

    Примечание:

    Хотя ArcGIS Online создает пространственный индекс заново, пользователи слоя могут заметить, что скорость работы с ним уменьшилась. По возможности перестраивайте пространственные индексы, когда слой не используется.

Связанные разделы