Introducción a los notebooks

Los ArcGIS Notebooks ofrecen una versátil interfaz web para el análisis de datos. Con los notebooks, puede realizar análisis, automatizar flujos de trabajo y ver al momento los resultados de los datos y los análisis en un contexto geográfico. Los notebooks combinan código, visualizaciones y mapas al vuelo y herramientas de datos. En el editor de notebooks, puede escribir, documentar y ejecutar código de Python en un único lugar.

Los notebooks se crean en el editor de notebooks, que se abre desde el ArcGIS Online. Este tema presenta los componentes y menús del editor de notebooks.

Fundamentos de la interfaz

El editor de notebooks presenta los siguientes componentes básicos:

Componentes del editor de notebooks

  1. Barra de navegación: navegue por el sitio web, abra otras aplicaciones desde el selector de aplicaciones, consulte recursos de ayuda e inicie o cierre sesión de su perfil. La barra de navegación también muestra el título de su notebook y le indica si tiene cambios en el notebook que aún no se han guardado.
  2. Cinta superior: realice diferentes tareas relacionadas con su notebook. Esta cinta incluye los siguientes botones:
  3. Cinta de menú del notebook: las acciones de esta cinta sirven para trabajar directamente en su notebook. Puede agregar y eliminar celdas, cambiar la apariencia del notebook, devolver el notebook a un punto de control anterior, etc. Esta cinta también muestra si el notebook es de confianza y la versión de Python que se está ejecutando.
  4. Barra de herramientas: utilice herramientas para tareas comunes de su notebook.
  5. Espacio de trabajo: aquí se muestra y se puede modificar el contenido de su notebook.

Cinta de menú del notebook

En las listas desplegables de la cinta de menú del notebook están disponibles las siguientes acciones.

Archivo

En el menú Archivo, puede optar por descargar su notebook en uno de los siguientes formatos:

  • Código de Python (.py)
  • Notebook de Python (.ipynb)
  • Diapositivas de Reveal.js (.slides.html)
  • Markdown (.md)

También puede descargar el notebook en formato .ipynb desde la página de detalles de elemento del notebook.

Editar

Los siguientes elementos están disponibles en el menú Editar:

  • Cortar celdas: corta las celdas actualmente seleccionadas en el espacio de trabajo del notebook.
  • Copiar celdas: copia las celdas actualmente seleccionadas en el espacio de trabajo del notebook.
  • Pegar celdas encima: pega las celdas copiadas encima de la celda actualmente seleccionada.
  • Pegar celdas debajo: pega las celdas copiadas debajo de la celda actualmente seleccionada.
  • Pegar celdas y reemplazar: pega las celdas copiadas y sustituye la celda actualmente seleccionada por las celdas copiadas.
  • Eliminar celdas: elimina las celdas actualmente seleccionadas.
  • Deshacer eliminación de celdas: revierte las acciones de eliminación de celdas realizadas en orden inverso; la eliminación más reciente se deshace primero.
  • Dividir celda: divide una celda en dos, dividiendo el contenido de la celda en la ubicación actual del puntero.
  • Combinar celda encima: combina la celda actualmente seleccionada con la que hay encima.
  • Combinar celda debajo: combina la celda actualmente seleccionada con la que hay debajo.
  • Mover celda encima: desplaza la celda actualmente seleccionada una posición hacia arriba en el espacio de trabajo del notebook.
  • Mover celda debajo: desplaza la celda actualmente seleccionada una posición hacia abajo en el espacio de trabajo del notebook.
  • Buscar y reemplazar: abre una ventana emergente para introducir una consulta de búsqueda. Esto le permite buscar y reemplazar valores o cadenas concretos en su notebook.
  • Copiar archivos adjuntos de la celda: copia los archivos adjuntos que incluye la celda seleccionada.
  • Cortar archivos adjuntos de la celda: corta y copia los archivos adjuntos que incluye la celda seleccionada.
  • Pegar archivos adjuntos de la celda: pega los archivos adjuntos copiados en la celda seleccionada.
  • Insertar imagen: abre una ventana emergente para examinar y agregar imágenes, incluidos archivos GIF, solamente en las celdas markdown.

Vista

Los siguientes elementos están disponibles en el menú Vista:

  • Alternar barra de herramientas: oculta o muestra la barra de herramientas.
  • Alternar números de línea: oculta o muestra los números de línea dentro de cada celda del espacio de trabajo del notebook.
  • Barra de herramientas de la celda: oculta o muestra la opción de la barra de herramientas de la diapositiva seleccionada para cada celda del espacio de trabajo del notebook. Las opciones son las siguientes:
    • Ninguna: no se muestra ninguna barra de herramientas de celda.
    • Editar metadatos: introduzca metadatos para cada celda mediante JSON.
    • Celda sin formato: las celdas sin formato permiten escribir directamente la salida; el notebook no evalúa el contenido de estas celdas.
    • Presentación de diapositivas: especifique cómo se mostrará cada celda en una presentación de diapositivas. Esta opción es útil para presentar el código.
    • Archivos adjuntos: administre los archivos adjuntos asociados dentro de cada celda en el espacio de trabajo del notebook.
    • Etiquetas: cree y administre etiquetas para cada celda dentro del espacio de trabajo del notebook.

Insertar

Los siguientes elementos están disponibles en el menú Insertar:

  • Insertar celda encima: inserta una celda vacía encima de la celda actualmente seleccionada.
  • Insertar celda debajo: inserta una celda vacía debajo de la celda actualmente seleccionada.

Celda

Los siguientes elementos están disponibles en el menú Celda:

  • Ejecutar celdas: ejecuta la celda actualmente seleccionada y desplaza el puntero a la siguiente celda.
  • Ejecutar celdas y seleccionar la de debajo: ejecuta la celda actualmente seleccionada y luego selecciona la celda de debajo.
  • Ejecutar celdas e insertar debajo: ejecuta la celda actualmente seleccionada y luego inserta una celda vacía debajo de la celda seleccionada.
  • Ejecutar todas: ejecuta todas las celdas del notebook en orden secuencial.
  • Ejecutar todas las de arriba: ejecuta todas las celdas que hay encima de la celda actualmente seleccionada, pero no ejecuta la celda seleccionada.
  • Ejecutar todas las de abajo: ejecuta la celda actualmente seleccionada y todas las celdas que hay debajo de ella.
  • Tipo de celda: permite cambiar el tipo de la celda actualmente seleccionada. Las opciones son Código, Markdown y NBConvert sin formato. Tenga en cuenta que el tipo Encabezado cambiará a Markdown.
  • Salidas actuales: le permite controlar la salida de la celda actualmente seleccionada. Entre las opciones se incluyen las siguientes:
    • Alternar salida: oculta o muestra la salida de la celda actualmente seleccionada.
    • Alternar desplazamiento: habilita o deshabilita el desplazamiento en la celda actualmente seleccionada.
    • Borrar salida: borra la salida de la celda actualmente seleccionada.
  • Salida de todas: controlar la salida de todas las celdas dentro del espacio de trabajo del notebook. Entre las opciones se incluyen las siguientes:
    • Alternar salida: oculta o muestra la salida de todas las celdas.
    • Alternar desplazamiento: habilita o deshabilita el desplazamiento en todas las celdas.
    • Borrar salida: borra la salida de todas las celdas.

Kernel

Los siguientes elementos están disponibles en el menú Kernel:

  • Interrumpir: pone en pausa el kernel en ejecución si un cálculo o un análisis están tardando demasiado.
  • Reiniciar: reinicia todo el proceso computacional al reiniciar el kernel.
  • Reiniciar y borrar salida: reinicia el proceso computacional y borra todas las salidas mostradas dentro de los notebooks.
  • Reiniciar y ejecutar todas: reinicia el proceso computacional y acto seguido ejecuta todas las celdas en orden secuencial.
  • Reconectar: permite volver a conectarse a un kernel si pasa a estar inactivo.
  • Cerrar: cierra todos los procesos computacionales dentro del notebook.
  • Cambiar kernel: cambia el tipo de kernel. En ArcGIS Notebooks, solo se admite el tipo de kernel de Python 3.

Ayuda

Esta lista permite acceder a la información acerca de los accesos directos del teclado, la interfaz de usuario y los diferentes documentos de ayuda asociados a ArcGIS Notebooks y a los módulos clave de Python.

Recorrido por la interfaz de usuario es especialmente útil para los usuarios nuevos en el entorno de notebook.

Botones de la barra de herramientas de Notebook

La barra de herramientas del notebook permite acceder rápidamente a las acciones más utilizadas desde la cinta de menú del notebook. Los botones disponibles, de izquierda a derecha, son los siguientes:

  • Agregar: inserta una celda debajo de la celda actualmente seleccionada.
  • Cortar: corta la celda actualmente seleccionada.
  • Copiar: copia la celda actualmente seleccionada.
  • Pegar: pega las celdas copiadas debajo de la celda actualmente seleccionada.
  • Flecha hacia arriba: desplaza la celda seleccionada hacia arriba en la secuencia del notebook.
  • Flecha hacia abajo: desplaza la celda seleccionada hacia abajo en la secuencia del notebook.
  • Ejecutar: ejecuta la celda actualmente seleccionada.
  • Detener: interrumpe el kernel.
  • Reiniciar: reinicia el kernel.
  • Avance rápido: reinicia el kernel y ejecuta todas las celdas.
  • Tipo de celda: permite seleccionar o cambiar el tipo de la celda actualmente seleccionada.
  • Teclado: abre la paleta de comandos.
  • Gráfico: entra o sale del modo de presentación de diapositivas.