Начало работы с блокнотами

ArcGIS Notebooks содержит удобный веб-интерфейс для анализа данных. С помощью блокнотов можно выполнять анализ, автоматизировать рабочие процессы и быстро визуализировать данные и результаты анализа в географическом контексте. Блокноты сочетают код, визуализацию "на лету", карты и инструменты обработки данных. В редакторе блокнотов можно создавать, документировать и запускать код Python, все в одном месте.

Блокноты создаются в редакторе блокнотов, который открывается из портала ArcGIS Online. В этом разделе описаны компоненты и меню редактора блокнотов.

Основы интерфейса

Редактор блокнотов включает следующие базовые компоненты:

Компоненты редактора блокнотов

  1. Панель навигации – выполняйте обзор веб-сайта, открывайте другие приложения из окна вызова, просматривайте справку и выполняйте вход/выход из своей учетной записи. На панели навигации также показан заголовок блокнота и статус того, если ли не сохраненные изменения в блокноте.
  2. Верхняя лента – выполняет различные задачи в блокноте. На ленте есть следующие кнопки:
  3. Лента меню блокнота – действия, расположенные на этой ленте, предназначены непосредственно для работы с блокнотом. Вы можете добавлять и удалять ячейки, менять внешний вид блокнота, откатывать блокнот до предыдущей контрольной точки и пр. На этой ленте также отображается, является ли блокнот доверенным и какая запущена версия Python.
  4. Панель инструментов – инструменты, которые используются для наиболее частых задач в блокноте.
  5. Рабочая область – здесь отображаются ресурсы блокнота, здесь же вы можете их изменить.

Лента меню блокнота

Из ниспадающих списков ленты меню блокнота доступны следующие возможности.

Файл

В меню Файл вы можете загрузить блокнот в одном из следующих форматов:

  • Код Python (.py)
  • Блокнот Python (.ipynb)
  • Слайды Reveal.js (.slides.html)
  • Markdown (.md)

Вы также можете скачать блокнот в формате .ipynb со страницы сведений об элементе блокнота.

Редактирование

В меню Редактировать доступны следующие пункты:

  • Вырезать ячейки – вырезает выбранные в данный момент ячейки из рабочей области блокнота.
  • Копировать ячейки – копирует выбранные в данный момент ячейки в рабочую область блокнота.
  • Вставить ячейки над – вставляет скопированные ячейки над ячейкой, выбранной в настоящий момент.
  • Вставить ячейки под – вставляет скопированные ячейки под ячейкой, выбранной в настоящий момент.
  • Вставить ячейки и Заменить – вставляет скопированные ячейки и заменяет ячейки, выбранные в настоящий момент, скопированными.
  • Удалить ячейки – удаляет ячейки, выбранные в настоящий момент.
  • Отменить удаление ячеек – отменяет действие удаления ячеек, в первую очередь отменяется последнее действие.
  • Разбить ячейку – разбивает одну ячейку на две, разделяя ресурсы в ячейке по текущему расположению курсора.
  • Слить ячейки над – сливает ячейку, выбранную в настоящий момент, с ячейкой, которая находится над ней.
  • Слить ячейки под – сливает ячейку, выбранную в настоящий момент, с ячейкой, которая находится под ней.
  • Переместить ячейку выше – перемещает выбранную в данный момент ячейку на одну позицию выше в рабочей области блокнота.
  • Переместить ячейку ниже – перемещает выбранную в данный момент ячейку на одну позицию ниже в рабочей области блокнота.
  • Найти и заменить – открывает всплывающее окно, которое позволяет задать запрос поиска. Таким образом вы сможете найти и заменить указанные значения или строки в блокноте.
  • Копировать вложения ячейки – копирует вложения, которые содержатся в выбранной ячейке.
  • Вырезать вложения ячейки – вырезает и вставляет вложения, которые содержатся в выбранной ячейке.
  • Вставить вложения ячейки – вставляет скопированные вложения в выбранную ячейку.
  • Вставить изображение – открывает всплывающее окно, которое позволяет искать и добавлять вложения, в т.ч. GIF, доступно только для ячеек Markdown.

Просмотр

В меню Вид доступны следующие пункты:

  • Переключить панель инструментов – скрывает или показывает панель инструментов.
  • Переключить номера линий – скрывает или показывает номера линий в каждой ячейке в рабочей области блокнота.
  • Панель инструментов ячеек – скрывает или показывает выбранную опцию скрываемой панели инструментов для каждой ячейки в рабочей области блокнота. Можно выбрать следующие опции:
    • Нет – не показывать панели инструментов ячеек.
    • Редактировать метаданные—Введите метаданные для каждой ячейки с помощью JSON.
    • Необработанный формат ячеек – необработанные ячейки позволяют напрямую записывать результат; содержимое этих ячеек блокнотом не оценивается.
    • Слайд-шоу—Определяет, как каждая ячейка будет отображаться в слайд-шоу. Эта опция полезна при представлении кода.
    • Вложения—Управляет связанными сложениями в каждой ячейке в рабочей области блокнота.
    • Теги—Создавать и управлять тегами для каждой ячейки в рабочей области блокнота.

Вставка

В меню Вставка доступны следующие пункты:

  • Вставить ячейку над—Вставляет пустую ячейку над ячейкой, выбранной в данный момент.
  • Вставить ячейку под—Вставляет пустую ячейку под ячейкой, выбранной в настоящий момент.

Ячейка

В меню Ячейка доступны следующие пункты:

  • Запустить ячейки—Запускает выбранную в данный момент ячейку и переносит курсор на следующую ячейку.
  • Запустить ячейки и выбрать ниже—Запускает выбранную в данный момент ячейку, а затем выбирает ячейку ниже.
  • Запустить ячейки и вставить ниже— Запускает выбранную в данный момент ячейку, а затем вставляет пустую ячейку ниже выбранной.
  • Запустить все—Запускает все ячейки в блокноте в последовательном порядке.
  • Запустить все над—Запускает все ячейки над ячейкой, выбранной в настоящий момент, но не запускает выбранную ячейку.
  • Запустить все под— Запускает выбранную в настоящий момент ячейку и все ячейки под ней.
  • Тип ячейки—Изменяет тип выбранной ячейки. Доступны варианты: Код, Markdown и Raw NBConvert. Обратите внимание, что тип Heading будет переключен на Markdown.
  • Текущие выходные данные – позволяет настроить выходные параметры ячейки, выбранной в настоящий момент. Вы можете упорядочить слои следующим образом:
    • Переключить выходные данные—Скрывает или показывает выходные данные ячейки, выбранной в настоящий момент.
    • Переключить пролистывание— Включает или отключает пролистывание ячейки, выбранной в настоящий момент.
    • Очистить выходные данные— Очищает выходные данные ячейки, выбранной в настоящий момент.
  • Все выходные данные— Управляет выходными данными всех ячеек в рабочей области блокнота. Вы можете упорядочить слои следующим образом:
    • Переключить выходные данные—Скрывает или показывает выходные данные всех ячеек.
    • Переключить пролистывание— Включает или отключает пролистывание всех ячеек.
    • Очистить выходные данные—Очищает выходные данные всех ячеек.

Ядро

В меню Ядро доступны следующие пункты:

  • Приостановить—Приостанавливает запуск ядра, если вычисление или анализ длится слишком много времени.
  • Перезапустить—перезапускает процесс вычисления полностью путем перезапуска ядра.
  • Перезапустить и Очистить выходные данные—Перезапускает процесс вычисления и очищает все выходные данные, которые отображаются в блокноте.
  • Перезапустить и Запустить все—Перезапускает процесс вычислений, а затем запускает все ячейки в последовательном порядке.
  • Переподключить—Заново подключается к ядру, если оно уходит в режим простоя.
  • Выключить—Выключает все вычислительные процессы в блокноте.
  • Изменить ядро—Изменяет тип ядра. В ArcGIS Notebooks поддерживается только тип ядра Python 3.

Справка

В этом списке содержится информация о горячих клавишах, пользовательском интерфейсе и различной справочной документации, связанной с ArcGIS Notebooks и ключевыми модулями Python.

Тур по пользовательскому интерфейсу довольно полезен для тех, кто незнаком со средой блокнотов.

Кнопки панели инструментов блокнота

На панели инструментов блокнота предоставлена возможность быстрого доступа к наиболее часто используемым функциям из ленты меню блокнота. Доступны следующие кнопки, слева направо:

  • Добавить – Вставляет ячейку под ячейкой, выбранной в настоящий момент.
  • Вырезать — Вырезает выбранную ячейку.
  • Копировать – Копирует ячейку, выбранную в настоящий момент.
  • Вставить – Вставляет скопированные ячейки под ячейкой, выбранной в настоящий момент.
  • Вверх – Перемещает выбранную ячейку вверх в последовательности блокнота.
  • Вниз – Перемещает выбранную ячейку вниз в последовательности блокнота.
  • Запустить – Запускает ячейку, выбранную в настоящий момент.
  • Остановить – Приостанавливает ядро.
  • Перезапустить – Перезапускает ядро.
  • Значок Вперед-назад – Перезапускает ядро и запускает все ячейки.
  • Тип ячейки — Выбирает или изменяет тип выбранной ячейки.
  • Клавиатура – Открывает панель выбора команд.
  • Диаграмма – Входит или выходит из режима слайд-шоу.