Iniciar com notebooks

O ArcGIS Notebooks fornece uma interface baseada na web versátil para análise de dados. Com os notebooks, você pode realizar análises, automatizar fluxos de trabalho e visualizar imediatamente os resultados de dados e análises em um contexto geográfico. Notebooks combinam código, visualizações e mapas dinâmicos e ferramentas de dados. No editor do notebook, você pode escrever, documentar e executar o código de Python em um só lugar.

Notebooks são criados no editor do notebook, que é aberto a partir do portal ArcGIS Online. Este tópico apresenta os componentes e menus no editor do notebook.

Fundamentos da interface

O editor de notebook possui os seguintes componentes básicos:

Componentes de editor do notebook

  1. Barra de navegação—Procure no site da web, abra outros aplicativos a partir do iniciador de aplicativos, visualize recursos de ajuda e entre e saia do seu perfil. A barra de navegação também exibe o título do seu notebook e indica se você tem alterações não salvas no notebook..
  2. Barra de formatação superior—Execute várias tarefas envolvendo seu notebook. Esta barra de formatação tem os seguintes botões:
  3. Barra de formatação do menu do notebook—As ações nesta barra de formatação são para trabalhar diretamente em seu notebook. Você pode adicionar e excluir células, alterar a aparência do notebook, retornar ao notebook para um ponto de verificação anterior e mais. Esta barra de formatação exibe se o notebook é confiável e a versão do Python sendo executada.
  4. Barra de ferramentas—Utilize as ferramentas das tarefas comuns em seu notebook.
  5. Área de trabalho—Seu conteúdo do notebook é exibido aqui, e você também pode modificar o conteúdo aqui.

Barra de formatação do menu de notebook

As seguintes ações estão disponíveis a partir da lista suspensa na barra de formatação do menu do notebook.

Arquivo

No menu Arquivo , você pode escolher para baixar o seu notebook em um dos seguintes formatos:

  • Código Python (.py)
  • Notebook Python (.ipynb)
  • Slides Reveal.js (.slides.html)
  • Remarcação (.md)

Você também pode baixar o notebook no formato .ipynb a partir da página de detalhes do item do notebook.

Editar

Os seguintes itens estão disponíveis no menu Editar:

  • Recortar Células—Recorta as células atualmente selecionadas a partir da área de trabalho do notebook.
  • Copiar Células—Copia as células atualmente selecionadas na área de trabalho do notebook.
  • Colar Células Acima—Cola as células copiadas acima da célula atualmente selecionada.
  • Colar Células Abaixo—Cola as células copiadas abaixo da célula atualmente selecionada.
  • Colar Células & Substituir—Cola as células copiadas e substitui a célula atualmente selecionada por células copiadas.
  • Excluir Células—Exclui as células atualmente selecionadas.
  • Desfazer Excluir Células—Reverte as ações de exclusão da célula que você executou na ordem reversa; a exclusão mais recente é desfeita primeiro.
  • Dividir Célula—Divide uma célula em dois ao dividir o conteúdo dentro da célula na localização atual do cursor.
  • Juntar Célula Acima—Junta a célula atualmente selecionada com a acima dela.
  • Juntar Célula Abaixo—Junta a célula atualmente selecionada com a abaixo dela.
  • Mover Célula para Cima—Move a célula atualmente selecionada uma posição para cima na área de trabalho do notebook.
  • Mover Célula para Baixo—Move a célula atualmente selecionada uma posição para baixo na área de trabalho do notebook.
  • Localizar e Substituir—Abre uma janela pop-up que permite a você inserir uma consulta de pesquisa. Isto permite que você localize e substitua valores específicos ou strings no seu notebook.
  • Copiar Anexos de Célula—Copia os anexos contidos na célula selecionada.
  • Recortar Anexos de Célula—Recorta os anexos contidos na célula selecionada.
  • Colar Anexos da Célula—Cola os anexos copiados na célula selecionada.
  • Inserir Imagem—Abre uma janela pop-up que permite a você procurar e adicionar imagens, incluindo GIFs, em células de marcação somente.

Visualizar

Os seguintes itens estão disponíveis no menu Exibir:

  • Alternar Barra de Ferramentas—Oculta ou mostra a barra de ferramentas.
  • Alternar Números das Linhas—Oculta ou mostra os números das linhas dentro de cada célula na área de trabalho do notebook.
  • Barra de Ferramentas da Célula—Oculta ou mostra a opção da barra de ferramentas de slide selecionada para cada célula na área de trabalho do notebook. Estas opções são as seguintes:
    • Nenhum—Não mostra a barras de ferramentas da célula.
    • Editar Metadados—Insira metadados para cada célula utilizando JSON.
    • Formato de Célula Bruta—Células brutas permitem a você gavar a saída diretamente; o conteúdo destas células não é avaliado pelo notebook.
    • Slideshow—Especifique como cada célula exibirá em um slideshow Esta opção é útil ao apresentar o código.
    • Anexos—Gerencie os anexos associados dentro de cada célula na área de trabalho do notebook.
    • Tags—Crie e gerencie tags para cada célula dentro da área de trabalho do notebook.

Inserir

Os seguintes itens estão disponíveis no menu Inserir:

  • Inserir Célula Acima—Insere uma célula vazia acima da célula atualmente selecionada.
  • Inserir Célula Abaixo—Insere uma célula vazia abaixo da célula atualmente selecionada.

Célula

Os seguintes itens estão disponíveis no menu Célula:

  • Executar Células—Executa a célula atualmente selecionada e move o cursor para a próxima célula.
  • Executar Células e Selecionar Abaixo—Executa a célula atualmente selecionada e então seleciona a célula abaixo.
  • Executar Células e Inserir Abaixo—Executa a célula atualmente selecionada e então insere uma célula vazia abaixo de sua célula selecionada.
  • Executar Tudo—Executa todas as células no notebook em ordem sequencial.
  • Executar Todos Acima—Executa todas as células acima da célula atualmente selecionada, mas não sua célula selecionada.
  • Executar Tudo Abaixo—Executa a célula atualmente selecionada e todas as células abaixo dela.
  • Tipo de Célula—Altera o tipo de célula atualmente selecionada. As opções são Código, Remarcação, e NBConvert Bruto. Note que o tipo Cabeçalho trocará para Remarcação.
  • Saídas Atuais—Permite a você controlar a saída da célula selecionada atualmente. As opções incluem o seguinte:
    • Alternar Saídas—Oculta ou mostra a saída da célula atualmente selecionada.
    • Alternar Rolagem—Habilita ou desabilita a rolagem na célula atualmente selecionada.
    • Limpar Saída—Limpa a saída da célula atualmente selecionada.
  • Todas as Saída—Controla a saída de todas as células dentro da área de trabalho do notebook. As opções incluem o seguinte:
    • Alternar Saída—Oculta ou mostra a saída de todas as células.
    • Alternar Rolagem—Habilita ou desabilita a rolagem em todas as células.
    • Limpar Saída—Limpa a saída de todas as células.

Kernel

Os seguintes itens estão disponíveis no menu Kernel:

  • Interromper—Pausa a execução do kernel se um cálculo ou análise estiver demorando muito tempo.
  • Reiniciar—Reinicia o processo computacional inteiro reiniciando o kernel.
  • Reiniciar e Limpar Saída—Reinicia o processo computacional e limpa qualquer saída que seja exibida dentro dos notebooks.
  • Reiniciar e Executar Todos—Reinicia o processo computacional e então executa todas as células em ordem sequencial.
  • Reconectar—Reconecta a um kernel se ele estiver inativo.
  • Fechar—Fecha todos os processos computacionais dentro do notebook.
  • Alterar Kernel—Altera o tipo de kernel. Somente o tipo Kernel de Python 3 é suportado no ArcGIS Notebooks.

Ajuda

Esta lista fornece acesso a informações nos atalhos do teclado, a interface do usuário e os vários documentos de ajuda associados com ArcGIS Notebooks e principais módulos do Python.

A Apresentação da Interface do Usuário é particularmente útil para usuários que são novos no ambiente do notebook.

Botões da barra de ferramentas do Notebook

A barra de ferramentas do notebook fornece acesso rápido às ações utilizadas comumente a partir da barra de formatação do menu o notebook. Os botões disponíveis, da esquerda para direita, são os seguintes:

  • Adicionar—Insere uma célula abaixo da célula atualmente selecionada.
  • Recortar—Recorta a célula atualmente selecionada.
  • Copiar—Copia a célula atualmente selecionada.
  • Colar—Cola suas células copiadas abaixo da célula atualmente selecionada.
  • Seta para Cima—Move a célula selecionada para cima na sequência do notebook.
  • Seta para Baixo—Move a célula selecionada para baixo na sequência do notebook.
  • Executar—Executa a célula atualmente selecionada.
  • Parar—Interrompe o kernel.
  • Reiniciar—Reinicia o kernel.
  • Avanço Rápido—Reinicia o kernel e executa todas as células.
  • Tipo de Célula—Seleciona ou altera o tipo de célula atualmente selecionada.
  • Teclado—Abre a palheta de comandos.
  • Gráfico—Entra ou sai do modo de slideshow.