Skip To Content

Créer une carte avec uniquement vos propres données

Dans cet exercice, vous travaillez comme administrateur SIG pour le département en faveur du développement des petites entreprises de la ville de Paris. Vos collègues doivent inspecter les magasins auxquels votre département a accordé des prêts l'année précédente afin de voir si cet argent a été bien utilisé et si le département a rempli sa mission d'aide au développement des petites entreprises. Les inspecteurs doivent afficher, rechercher et calculer des itinéraires vers ces magasins en empruntant les routes du jeu de données réseau de transport que votre organisation gère quotidiennement. La distance qui sépare certains de ces magasins peut être couverte à pied. Pour activer les inspections, vous devez créer une carte que les inspecteurs de cartes peuvent utiliser dans Navigator contenant les points de vente, les routes et un mode de déplacement personnalisé qui génère une feuille de route pour piétons menant aux points de vente.

Pour fournir la carte dont les inspecteurs ont besoin, vous allez utiliser ArcGIS Pro. Vous allez ajouter les données inhérentes aux magasins dans le jeu de données réseau de transport géré par votre organisation. Vous allez ensuite activer la recherche des magasins, créer un mode de déplacement personnalisé qui permet de calculer un itinéraire pour piétons menant aux magasins, empaqueter les données en tant que paquetage de cartes mobiles et les partager avec votre organisation ArcGIS. Les inspecteurs pourront télécharger la carte dans Navigator et l'utiliser pour accéder aux magasins dans Paris.

Remarque :

Si vous souhaitez modifier une carte de navigation fournie par Esri au lieu de créer votre propre carte avec uniquement vos propres données, consultez un des autres exercices Navigator for ArcGIS. Pour savoir quel exercice suivre, reportez-vous à la rubrique Choisir l'exercice à suivre.

Pré-requis

Pour réaliser l’intégralité de cet exercice, vous avez besoin des licences et produits suivants :

  • ArcGIS Pro 2.3 ou version ultérieure
    Remarque :

    Vous pouvez créer des cartes de navigation personnalisées avec les ressources, les localisateurs et les routes de votre organisation dans ArcGIS Pro 1.2 ou version ultérieure. Vous avez besoin de ArcGIS Pro 1.4 ou version ultérieure pour créer vos propres modes de déplacement et utiliser des modèles de mise à jour des entités. Vous pouvez créer des paquetages de cartes mobiles et les partager à l’aide des outils Créer un paquetage de cartes mobiles et Partager un paquetage. ArcGIS Pro 2.2 ou version ultérieure est nécessaire pour utiliser l’onglet Share (Partager) et créer un paquetage de cartes mobiles. ArcGIS Pro 2.3 est requis pour voir l’interface utilisateur à laquelle cet exercice fait référence.

  • Un appareil mobile sur lequel Navigator for ArcGIS est installé
  • Un compte d'organisation ArcGIS avec des licences pour les éléments suivants :

L'administrateur de votre organisation ArcGIS est chargé de configurer ces licences. Si vous détenez un compte d'organisation ArcGIS, mais que vous avez besoin d'un de ces produits ou licences, demandez à l'administrateur de votre organisation ArcGIS d'envoyer un message électronique à services@esri.com. Si vous ne possédez pas de compte d'organisation ArcGIS, inscrivez-vous pour bénéficier d'une version d'évaluation gratuite.

Remarque :

Si vous êtes membre d’une organisation sur ArcGIS Online et que vous avez besoin d’y ajouter une licence d’évaluation Navigator for ArcGIS,demandez une version d’évaluation gratuite sur la liste ArcGIS Marketplace de Navigator.

Les produits et licences supplémentaires nécessaires pour réaliser certaines sections de l’exercice sont indiqués au début de ces sections.

Un jeu de données d'exemple vous est fourni avec cet exercice, mais si vous souhaitez le suivre avec vos propres données, vérifiez que toutes vos données de fond de carte se trouvent dans une seule géodatabase qui ne comprend pas vos données opérationnelles.

Créer un projet

Ouvrez ArcGIS Pro et créez un nouveau projet pour travailler sur la carte de navigation destinée à l’inspection des points de vente de Paris.

  1. Démarrez ArcGIS Pro.
    Remarque :

    Si vous ne l’avez pas, installez ArcGIS Pro.

  2. Sur la page de démarrage, sous la section New (Nouveau), cliquez sur Start without a template (Démarrer sans modèle).

    Un projet vierge s'ouvre et vous êtes prêt à créer un fond de carte avec le jeu de données réseau de transport de votre organisation.

Créer un fond de carte

Créez un fond de carte contenant le jeu de données réseau de votre organisation, sur lequel vous allez superposer les données des points de vente.

  1. Sous l’onglet Insert (Insertion), dans le groupe Project (Projet), cliquez sur la flèche de liste déroulante à côté de New Map (Nouvelle carte) et cliquez sur New Basemap (Nouveau fond de carte) Nouveau fond de carte.

    Une nouvelle vue de carte vierge s'ouvre. Vous pouvez maintenant enregistrer votre projet, puis ajoutez des couches au fond de carte.

  2. Cliquez sur Save (Enregistrer) Enregistrer.

    La fenêtre Save Project As (Enregistrer le projet en tant que) s’ouvre.

  3. Accédez au dossier dans lequel vous voulez enregistrer le projet. Dans le champ Nom, entrez un titre de projet explicite, par exemple Inspection des magasins de Paris.
  4. Cliquez sur le bouton Enregistrer.
  5. Dans l'onglet Carte, groupe Couche, cliquez sur Ajouter des données Ajouter des données.
  6. Accédez aux couches de fond de carte à inclure dans la carte. La ville de Paris conserve ces données dans un paquetage de couche qui est disponible sur un portail. Sous Portail, cliquez sur L’intégralité du portail Tout le portail.
  7. Sur la barre Rechercher, saisissez Navigator tutorial basemap et appuyez sur Entrée.

    Le paquetage de couche Navigator for ArcGIS Tutorial - Basemap Layers apparaît.

  8. Cliquez sur le paquetage de couche et sur OK.

    Une couche nommée New Group Layer (Nouveau groupe de couches) apparaît dans la fenêtre Contents (Contenu).

  9. Cliquez sur la flèche à gauche de New Group Layer (Nouveau groupe de couches) pour afficher les couches du groupe.

    Quatre couches s'affichent dans la fenêtre Contenu : Paris Streets, Water, Parks et ParisMultimodal_ND. La couche Paris Streets contient vos données routières. Les couches Parks et Water contiennent les parcs et plans d’eau locaux, respectivement. Ces données permettront aux inspecteurs de se réorienter par rapport à un parc ou à un plan d'eau connu. La couche ParisMultimodal_ND contient votre jeu de données réseau de transport complet, avec vos données routières, ainsi que la logique sous-jacente à la génération d'itinéraires. Toutes les données de fond de carte se trouvent dans une seule géodatabase, ce qui est requis lors de la création de fonds de carte pour Navigator.

  10. Dans la fenêtre Contenu, cliquez sur Répertorier par source de données Répertorier par source de donnéespour vous assurer que toutes les couches de votre fond de carte proviennent de la même géodatabase.

    Les couches sont répertoriées en fonction de leurs sources de données et vous voyez que toutes les couches proviennent de la même géodatabase.

  11. Dans la fenêtre Contenu, double-cliquez sur le nom par défaut du fond de carte, modifiez-le en Paris Store Inspections_BM, puis cliquez sur OK.
  12. Cliquez sur Enregistrer le projet Enregistrer.
  13. Sur l’onglet Insert (Insertion), dans le groupe Project (Projet), cliquez sur la flèche de la liste déroulante New Map (Nouvelle carte) et sélectionnez New Map (Nouvelle carte) Nouvelle carte.

    Une nouvelle carte est créée avec le fond de carte World Topographic Map (Carte topographique mondiale).

  14. Dans le ruban, cliquez sur l’onglet Map (Carte), cliquez sur Basemap (Fond de carte) Fond de carte, accédez au bas de la fenêtre, puis cliquez sur le fond de carte que vous venez de créer, Paris Store Inspections_BM.

    Le fond de carte World Topographic Map devient le fond de carte Paris Store Inspections_BM.

  15. Cliquez avec le bouton droit sur la couche Paris Store Inspections_BM et sélectionnez Zoom To Layer (Zoom sur la couche) Zoom sur la couche.

    Les couches du fond de carte apparaissent sur la carte.

  16. Cliquez sur Enregistrer le projet Enregistrer.

Ajouter une couche de ressources

Maintenant que vous avez créé un fond de carte avec le jeu de données réseau de votre organisation, ajoutez les données des magasins à la carte afin que les inspecteurs puissent afficher, rechercher et calculer un itinéraire vers certains magasins dans Paris.

  1. Dans l'onglet Carte, groupe Couche, cliquez sur Ajouter des données Ajouter des données.
    Remarque :

    Si vous suivez cet exercice avec vos propres données et que vous ajoutez une couche opérationnelle avec un système de coordonnées différent de celui de la carte, le système de coordonnées de la carte se transformera par défaut en celui de la première couche opérationnelle que vous ajoutez. Si vous préférez choisir le système de coordonnées de la carte, cliquez sur l'onglet Projet et sur Options. Sous Application, cliquez sur Carte et scène et sur Référence spatiale. Cliquez sur l'option Choisir une référence spatiale et choisissez le système de coordonnées qui convient à votre carte.

  2. Accédez aux données des magasins à inclure dans la carte. Comme avec les données de fond de carte, la ville de Paris conserve ces données dans un paquetage de couche qui est disponible sur un portail. Sous Portail, cliquez sur L’intégralité du portail Tout le portail.
  3. Dans la barre Rechercher, saisissez Navigator tutorial stores et appuyez sur Entrée.

    Le paquetage de couche Navigator for ArcGIS Tutorial - Stores apparaît.

  4. Cliquez sur le paquetage de couche et sur OK.

    Les magasins s'affichent sur la carte et la couche apparaît dans la fenêtre Contenu.

    Couche Stores
  5. Dans la fenêtre Contenu, cliquez sur Répertorier par source de données Répertorier par source de donnéespour vous assurer que la couche Stores provient de la même géodatabase.

    Votre couche opérationnelle doit se trouver dans une géodatabase différente de celle de vos couches de fond de carte. La géodatabase qui contient les couches de fond de carte est compressée lorsque vous empaquetez toutes vos données dans un paquetage de cartes mobiles, et vous ne voulez pas que vos données opérationnelles soient compressées avec les données du fond de carte.

    Vous voyez que la couche des magasins et les couches de fond de carte proviennent de différentes géodatabases.

    Attention :

    Votre carte et le jeu de données réseau doivent posséder le même système de coordonnées. Sinon, un avertissement apparaît lorsque vous essayez d’empaqueter toutes les données dans un paquetage de cartes mobiles. Pour ce faire, cliquez avec le bouton droit de la souris sur la couche du jeu de données réseau dans la fenêtre Contenu, puis sélectionnez Propriétés Propriétés. Dans la fenêtre Propriétés de la couche, cliquez sur Source et développez la section Référence spatiale. De même, vous pouvez cliquer avec le bouton droit sur la carte dans la fenêtre Contents (Contenu) et sélectionner Properties (Propriétés) Propriétés. Dans la fenêtre Map Properties (Propriétés de la carte), cliquez sur Coordinate Systems (Systèmes de coordonnées).

    A ce stade, vous avez créé une carte pour les inspecteurs, qui contient des routes et des magasins. Vous n'avez toutefois pas encore rendu les magasins détectables ou permis aux inspecteurs de générer des feuilles de route pour piétons.

Activer la recherche de ressources

Les inspecteurs identifient les points de vente vers lesquels ils doivent s’acheminer en fonction de leur nom. Activez la recherche de points de vente par nom dans Navigator en configurant la recherche sur un champ en particulier dans une couche de ressources. L’activation de la recherche par nom à l’aide de la fenêtre Locate (Localiser) permet aux inspecteurs de points de vente de trouver rapidement leurs destinations.

  1. Si la couche Stores n'est pas encore sélectionnée dans la fenêtre Contenu, cliquez dessus.
  2. Sur l'onglet Carte, dans le groupe Requête, cliquez sur Localiser Localiser.
    Bouton Localiser

    La fenêtre Locate (Localiser) s’ouvre.

  3. Cliquez sur Settings (Paramètres).

    La fenêtre Locate (Localiser) présente la liste des fournisseurs de localisation disponibles.

  4. Cliquez sur Add (Ajouter) Ajouteret sur Add Layer (Ajouter une couche) pour ajouter une couche depuis votre carte dans la fenêtre Locate (Localiser).
    Ajouter un fournisseur de localisation
  5. Sélectionnez la couche Stores (Points de vente) et cliquez sur OK.

    La fenêtre Locate (Localiser) affiche la vue Configure Layer for Locate (Configurer la couche pour la localisation) pour la couche Stores (Points de vente).

  6. Comme vous voulez activer la recherche en fonction du nom des points de vente, cliquez sur la flèche de la liste déroulante en regard de NOM dans la colonne Search Mode (Mode de recherche) et sélectionnez Contains (Contient).
    Fenêtre Configurer la couche pour la localisation

    NOM est le champ que le localisateur utilise pour rechercher une entité. Dans ce cas, vous ajoutez un fournisseur de localisation qui recherchera les points de vente en fonction de leur nom.

  7. Cliquez sur le bouton Save and return to Settings (Enregistrer et revenir aux Paramètres) Enregistrer et revenir aux Paramètres pour quitter la vue Configure Layer for Locate (Configurer la couche pour la localisation).

    La couche Stores (Points de vente) est ajoutée à la liste des fournisseurs de localisation dans la fenêtre Locate (Localiser).

  8. Cliquez sur la couche Stores (Points de vente) dans la liste des fournisseurs de localisation et faites-la glisser en haut de la liste.

    Les points de vente seront répertoriés en premier dans les résultats de recherche Locate (Localiser).

Astuce:

Contrairement à la création d’un localisateur d’adresses personnalisé, l’ajout d’une couche de ressources en tant que fournisseur de localisation n’augmente pas la taille de votre fichier .mmpk. Toutefois, les suggestions ne s’affichent pas dans Navigator lorsqu’une couche de ressources est ajoutée en tant que fournisseur de localisation. Si vous voulez activer les suggestions pour la recherche de ressources dans Navigator, vous devez créer un localisateur d’adresses personnalisé à l’aide de l’outil Créer un localisateur d’adresses. Pour cet exercice, la fenêtre Créer un localisateur d’adresses doit correspondre à l’image ci-dessous.

Fenêtre Créer un localisateur d'adresses renseignée

Tester la recherche des ressources

Avant de partager la carte avec les inspecteurs, vérifiez que la recherche fonctionne correctement en recherchant un magasin en particulier.

  1. Dans ArcGIS Pro, vous pouvez exécuter une recherche à l’aide de l’outil Locate (Localiser). Si la fenêtre Locate (Localiser) est fermée, sous l’onglet Map (Carte), dans le groupe Inquiry (Requête), cliquez sur Locate (Localiser) Localiser.
  2. Cliquez sur l’onglet Locate (Localiser). Sur la barre Rechercher, saisissez le nom d'un magasin sur la carte que vous souhaitez localiser. Saisissez par exemple le nom ELYSEE 26 et appuyez sur Entrée.

    Les résultats de recherche des deux localisateurs d’adresses apparaissent dans la fenêtre Locate (Localiser).

  3. Double-cliquez sur le résultat de recherche situé sous Stores (Points de vente).

    La carte applique un zoom avant sur le magasin recherché et celui-ci apparaît dans les résultats de recherche de la fenêtre Localiser. Vous avez activé la recherche de ressources.

Créer votre propre mode de déplacement

Comme vos inspecteurs vont marcher entre certains magasins, ils ont besoin de feuilles de route pour piétons. Créez un mode de déplacement que les inspecteurs choisiront dans Navigator et procurez-leur des feuilles de route pour piétons vers les magasins afin que votre organisation fasse des économies de carburant.

Remarque :

Extension ArcGIS Network Analyst est requis pour réaliser cette section de l’exercice.

  1. Dans la fenêtre Contenu, cliquez avec le bouton droit sur la couche ParisMultimodal_ND, puis choisissez Propriétés Propriétés.
  2. Dans l'angle inférieur gauche de la boîte de dialogue, cliquez sur Modes de déplacement.

    Les détails concernant le mode de déplacement Temps de trajet, qui est déjà inclus dans le jeu de données réseau de votre organisation, apparaissent.

  3. Cliquez sur le menu Menu dans l'angle supérieur droit , puis sur Nouveau Nouveau.

    Les champs associés à votre nouveau mode de déplacement apparaissent dans la boîte de dialogue.

  4. Le premier champ concerne le nom de votre nouveau mode de déplacement. Remplacez le nom par défaut New Travel Mode (Nouveau mode de déplacement) par Walking Time (Durée du trajet à pied) afin les inspecteurs connaissent l’objectif de ce mode de déplacement : générer des feuilles de route pour piétons vers les points de vente, qui réduisent le temps de trajet.
    Astuce:

    Si vous devez renommer votre mode de déplacement, cliquez sur le menu Menu et choisissez Rename (Renommer) ou appuyez sur F2.

  5. Dans le champ Description, saisissez Use this travel mode to produce walking directions to stores, which minimizes the time it takes to travel between stores (Utilisez ce mode de déplacement pour générer des feuilles de route vers les points de vente, ce qui réduit le temps de trajet).

    La description offre aux inspecteurs davantage de détails sur ce mode de déplacement.

  6. Définissez le champ Type sur A pied.
  7. Sous Costs (Coûts), définissez le champ Impedance (Impédance) sur PedestrianTime.

    L'impédance spécifie l'attribut de coût sur lequel optimiser l'analyse. En définissant l'impédance sur PedestrianTime, vous indiquez que l'attribut de coût sur lequel optimiser l'analyse pour le mode de déplacement Durée du trajet à pied doit stocker le temps requis pour marcher le long des tronçons ou des rues.

  8. Cliquez sur Restrictions pour développer cette section.

    La liste des attributs et des valeurs de paramètres du mode de déplacement apparaît. Les attributs qui s’affichent dépendent des attributs de votre jeu de données réseau.

  9. Faites défiler vers le bas jusqu'à l'attribut Oneway et cliquez dessus.

    Le paramètre Utilisation de restriction apparaît sous l'attribut.

  10. Définissez la valeur Restriction Usage (Utilisation de restriction) Prohibited (Interdit) sur Prefer (low) (Préférer (Faible)), car vous voulez que les inspecteurs puissent générer des feuilles de route pour piétons qui intègrent des rues à sens unique, mais vous ne souhaitez pas que les rues à sens unique soient prioritaires sur les rues à double sens.
  11. Définissez votre nouveau mode de déplacement comme mode de déplacement par défaut pour la carte. Cliquez sur le menu Menu et sur Set as Default (Par défaut) Par défaut.

    En définissant votre nouveau mode de déplacement comme mode de déplacement par défaut, vous garantissez que tous les inspecteurs qui font appel à votre paquetage de cartes dans Navigator utiliseront le mode de déplacement Durée du trajet à pied par défaut.

  12. Cliquez sur OK.

    Vous avez créé un mode de déplacement personnalisé qui permet aux inspecteurs de recevoir des feuilles de route pour piétons vers les magasins.

Tester votre mode de déplacement

Avant d’empaqueter la carte, vérifiez que votre mode de déplacement fonctionne correctement en créant deux arrêts à proximité des points de vente, qui sont accessibles à pied ou en voiture, où les feuilles de route pour piétons et voitures sont différentes. Si le mode de déplacement Temps de trajet et votre mode de déplacement Durée du trajet à pied produisent des itinéraires différents vers les points de vente, votre mode de déplacement fonctionne.

Remarque :

Extension ArcGIS Network Analyst est requis pour réaliser cette section de l’exercice.

  1. Dans la fenêtre Localiser, recherchez le magasin nommé SAMARITAINE.

    La carte applique un zoom sur le magasin que vous recherchiez.

  2. Effectuez un léger zoom arrière pour voir le point de vente nommé GALERIE CARROUSEL DU LOUVRE à l’ouest de la SAMARITAINE. Double-cliquez dessus dans les résultats de recherche.

    Les inspecteurs peuvent se déplacer entre ces deux magasins à pied ou en voiture. L'itinéraire pour piétons est plus direct. Dans les étapes suivantes, vous allez créer des arrêts à chacun de ces points de vente et exécuter une analyse de réseau à l’aide du mode de déplacement Temps de trajet et du mode de déplacement Durée du trajet à pied que vous avez créé. Si votre mode de déplacement génère un itinéraire plus direct que le mode de déplacement Temps de trajet, votre mode de déplacement fonctionne.

  3. Sur l'onglet Analyse, cliquez sur Analyse du réseau et sur Itinéraire Itinéraire.
    Astuce:

    Dans le menu déroulant Analyse du réseau, sous Source de données réseau, vérifiez que ParisMultimodal_ND apparaît. Il s'agit du jeu de données réseau que vous souhaitez tester. S’il n’apparaît pas, cliquez sur Change Network Data Source (Modifier la source de données réseau), sur ParisMultimodal_ND, puis sur OK.

    Dans la fenêtre Contenu, une couche Route (Itinéraire) apparaît. Il s’agit de la couche que vous allez utiliser pour ajouter des arrêts à l’itinéraire.

  4. Sous l'onglet Modifier du groupe Entités, cliquez sur Créer Créer des entités.
  5. Dans la fenêtre Créer des entités, recherchez stops (arrêts) et cliquez dessus dans les résultats.
  6. Capturez un arrêt en haut du magasin SAMARITAINE et un magasin en haut du magasin GALERIE CARROUSEL DU LOUVRE.
  7. Sur l'onglet Itinéraire, dans le groupe Paramètres de déplacement, vérifiez que le champ Mode est défini sur Temps de trajet.
  8. Dans le groupe Analyse, cliquez sur ExécuterExécuter.

    L’itinéraire ci-dessous est généré entre les deux arrêts.

    Itinéraire généré avec le mode de déplacement Temps de trajet
  9. Dans le groupe Paramètres de déplacement, définissez le champ Mode sur Durée du trajet à pied et recliquez sur Exécuter Exécuter.

    Un autre itinéraire plus direct est généré.

    Itinéraire généré avec le mode de déplacement Durée du trajet à pied

    Vous avez créé un mode de déplacement personnalisé qui génère des feuilles de route pour piétons vers les magasins. Lorsque vous empaquetez votre carte de navigation en tant que paquetage de cartes mobiles dans la section suivante, votre mode de déplacement personnalisé est inclus, de sorte que les opérateurs de terrain peuvent y accéder dans Navigator.

  10. Comme ces arrêts n'ont été créés qu'à des fins de test, dans la fenêtre Contenu, cliquez avec le bouton droit sur la couche Route (Itinéraire), choisissez Supprimer Supprimer, puis Ignorer.

Empaqueter et partager les données

Vous disposez maintenant de tous les composants nécessaires de votre carte de navigation pour les agents : pylônes électriques, routes privées, ressources pouvant faire l’objet d’une recherche, localisateur d’adresses général et un mode de déplacement personnalisé. Associez tous ces composants dans un seul fichier que vous pouvez partager avec les agents afin qu’ils l’utilisent en mode hors connexion dans Navigator. Une fois que vous avez partagé le paquetage de cartes mobiles avec les agents, ils peuvent le télécharger sur leur appareil, tout comme n'importe quelle autre carte dans Navigator.

Les points de vente, les routes, les ressources pouvant faire l’objet d’une recherche et un mode de déplacement personnalisé sont désormais accessibles aux inspecteurs. Associez tous ces composants dans un seul fichier que vous pouvez partager avec les inspecteurs afin qu’ils l’utilisent en mode hors connexion dans Navigator. Une fois que vous avez partagé le paquetage de cartes mobiles avec les inspecteurs, ils peuvent le télécharger sur leur appareil, tout comme n'importe quelle autre carte dans Navigator.

Remarque :

Extension ArcGIS Network Analyst est requis pour réaliser cette section de l’exercice.

Astuce:

Si vous devez réaliser plusieurs paquetages de cartes mobiles similaires, automatisez le processus avec Python à l’aide des outils de géotraitement Créer un paquetage de cartes mobiles et Partager un paquetage. Veillez à utiliser les mêmes paramètres pour créer et partager le paquetage que ceux indiqués dans cette section.

Notez que les opérateurs de terrain rechercheront le paquetage à l’aide du nom fourni dans le champ Output File (Fichier en sortie). Après son téléchargement, son nom correspondra à celui qui est fourni dans le champ Title (Titre).

  1. Dans l’onglet Share (Partager) du groupe Package (Paquetage), cliquez sur Mobile Map (Carte mobile) Nouveau paquetage de cartes mobiles.

    La fenêtre Package Mobile Map (Empaqueter la carte mobile) apparaît.

  2. Sous Start Packaging (Commencer l’empaquetage), sélectionnez Upload package to Online account (Télécharger le paquetage sur le compte en ligne).
  3. Dans le champ Name (Nom), indiquez un nom pour le paquetage que les inspecteurs vont rechercher dans Navigator.
  4. Les champs Summary (Résumé) et Tags (Balises) sont automatiquement renseignés avec le texte par défaut. La modification de ces champs est facultative.
  5. Appliquez un zoom sur l'étendue de carte souhaitée.
  6. Sous Options, sélectionnez Current Display Extent (Étendue actuellement affichée).
  7. Pour que le paquetage dans Navigator adopte l’étendue actuelle dans ArcGIS Pro, cochez la case Clip (Découper).

    Lorsque la case Clip (Découper) est cochée, les entités sont découpées de façon à correspondre à l’étendue d’affichage. Si la case Clip (Découper) n’est pas cochée, l’étendue d’affichage est utilisée pour sélectionner toutes les entités qui intersectent l’affichage.

  8. Si vous voulez ajouter un localisateur au projet, par exemple un localisateur d’adresses personnalisé, cochez la case Include Locator (Inclure le localisateur) et cliquez sur la flèche de la liste déroulante pour sélectionner le localisateur à utiliser.
    Remarque :

    Si vous avez créé le localisateur dans cette session, il apparaît dans le menu déroulant. Si vous l’avez créé dans une autre session ArcGIS Pro, cliquez sur le bouton de navigation pour le rechercher Parcourir.

    Si vous avez inclus plusieurs localisateurs, un localisateur composite est créé lorsque vous cliquez sur Package (Empaqueter).

  9. Utilisez le menu déroulant Folder (Dossier) pour spécifier l’emplacement de stockage du paquetage dans le contenu de votre portail. Par défaut, le paquetage est stocké à la racine de votre contenu. Vous pouvez également cliquer sur le bouton de navigation Parcourir pour créer un dossier ou choisir un dossier existant. Vous avez également la possibilité de saisir le nom du dossier souhaité dans la zone de texte.
  10. Cochez la case située en regard du nom de votre organisation pour partager le paquetage au sein de votre organisation.
    Astuce:

    Si vous choisissez de partager le paquetage avec des groupes spécifiques de votre organisation, vérifiez que les travailleurs mobiles appartiennent à ces groupes.

  11. Cliquez sur Analyser pour rechercher d'éventuels erreurs ou problèmes. Vous devez résoudre toutes les erreurs. Si des problèmes sont identifiés, ils apparaissent sous l'onglet Messages. Cliquez avec le bouton droit sur chaque message pour obtenir plus d'informations, lire l'aide relative à l'erreur ou l'avertissement, et accéder aux solutions suggérées.

    L’analyse se termine sans erreur ni avertissement.

  12. Cliquez sur Package (Empaqueter) pour créer votre paquetage de cartes mobiles.
    Remarque :

    L’exécution de l’outil Créer un paquetage de cartes mobiles peut prendre du temps.

    Un message indiquant que le paquetage de cartes mobiles a été créé apparaît. Le paquetage est désormais partagé avec votre organisation Les membres peuvent se connecter à Navigator, rechercher le paquetage et le télécharger sur leur appareil pour l’utiliser en mode hors connexion.

Tester la carte dans Navigator

Dans Navigator, testez votre carte pour vérifier que les inspecteurs peuvent afficher, rechercher et accéder aux magasins dans Paris. Voici certains éléments clés à tester. Pour en savoir plus, reportez-vous aux rubriques Référence rapide et Itinéraire dans Navigator.

Remarque :

Vous avez besoin d’un compte d’organisation ArcGIS avec des licences Navigator for ArcGIS pour tester votre carte. Vous avez également besoin d’un appareil mobile sur lequel Navigator for ArcGIS est installé.

  1. Recherchez, téléchargez et ouvrez votre carte.
    La carte des magasins et des routes de Paris que vous avez créée dans ArcGIS Pro apparaît. Il est possible que le message suivant s'affiche : Impossible d'accéder à l'emplacement. Votre emplacement se trouve en dehors de l'étendue de la carte. Cela ne pose pas de problème. Navigator essaie simplement d’utiliser votre emplacement GPS comme point de départ, mais comme vous allez spécifier un point de départ ultérieurement au sein de l’étendue de la carte, touchez OK pour fermer ce message.
  2. Vérifiez que vous pouvez rechercher dans Places (Lieux) un point de vente donné en fonction de son nom, par exemple ELYSEE 26.
    Astuce:

    Vous ne verrez pas les suggestions de recherche. Si vous avez besoin des suggestions de recherche, créez un localisateur d’adresses personnalisé au lieu de configurer une couche de ressources pour effectuer la recherche sur un champ en particulier.

  3. Générez un itinéraire vers ce point de vente pour voir si les inspecteurs peuvent générer une feuille de route vers les points de vente. Si vous n’êtes pas physiquement présent dans l’étendue de la carte, vous devez simuler votre emplacement de départ comme suit :
    • Sur appareils Android : touchez Back (Retour) Retour, touchez Profile (Profil) Profil, puis touchez votre nom d’utilisateur trois fois. Touchez Developer (Développeur) et Simulate location (Simuler la localisation). Une fois la carte chargée, appliquez un zoom avant et touchez un emplacement sur la carte pour l’utiliser comme point de départ. Touchez Done (Terminé) Terminé, touchez Back (Retour) Retour, puis fermez votre profil. Touchez votre carte active, le résultat de recherche que vous avez généré, puis Directions (Feuille de route).

      Pour effacer les paramètres de simulation de la localisation, quittez et redémarrez l’application, touchez Profile (Profil) Profil, puis touchez votre nom d’utilisateur trois fois pour fermer les paramètres Developer (Développeur).

    • Sur iPhone ou iPad : touchez Maps (Cartes), touchez Profile (Profil) Profil, puis touchez votre nom d’utilisateur trois fois. Sous Advanced Settings (Paramètres avancés), touchez Simulation & Logging (Simulation et journalisation) et Choose Location (Choisir un emplacement). Une fois la carte chargée, appliquez un zoom avant et touchez un emplacement sur la carte pour l’utiliser comme point de départ. Touchez Use (Utiliser), Profile (Profil) Profil, puis Done (Terminé). Touchez votre carte active, le résultat de recherche que vous avez généré, puis Directions (Feuille de route).

      Pour effacer les paramètres de simulation de la localisation, quittez et redémarrez l’application, touchez Profile (Profil) Profil, puis touchez votre nom d’utilisateur trois fois pour fermer les Advanced Settings (Paramètres avancés).

  4. Choisissez le mode de déplacement que vous avez créé pour voir si les inspecteurs peuvent générer des feuilles de route pour piétons vers les magasins.
    Remarque :

    Votre mode de déplacement apparaîtra sous Custom (Personnalisé) dans la liste répertoriant les autres modes de déplacement fournis avec Navigator. Cette expérience est légèrement différente de celle qui consiste à choisir un mode de déplacement lorsque vous n'avez pas créé le vôtre.

Vous avez créé une carte de navigation qui comprend des magasins et le jeu de données réseau de transport de votre organisation. Vous avez également permis aux inspecteurs de rechercher des magasins et d'obtenir des feuilles de route pour piétons vers les magasins à l'aide d'un mode de déplacement personnalisé. Vous avez ensuite empaqueté toutes les données dans un paquetage de cartes mobiles et l'avez partagé avec les inspecteurs. Ils peuvent désormais ouvrir la carte dans Navigator et afficher, rechercher et accéder aux magasins en mode hors connexion, sur le réseau de transport privé de votre organisation.