Skip To Content

What are the requirements?

To use Collector for ArcGIS, your device, ArcGIS account, and data must meet the requirements below. You can use the app in any of the supported languages.

Note:

Looking for information about Collector Classic on Android, iOS, or Windows? See Requirements for Collector Classic.

Device requirements

Collector is supported on iOS devices.

iOS

  • iOS 11 or later
  • iPhone, iPad, iPod touch

ArcGIS account requirements

Using maps in Collector requires an ArcGIS organizational account (ArcGIS Online or ArcGIS Enterprise) and being a level 2 member. The privilege to edit features (either through Features > Edit or Features > Edit with full control) is required. For details of the level and permissions, see Levels, roles, and privileges for ArcGIS Online or Levels, roles, and privileges for ArcGIS Enterprise.

Legacy:

Portal for ArcGIS 10.3.1 and 10.4.1 are also supported. Because user levels didn't exist at these versions, all users are supported. Users do need the privilege to edit features.

Data requirements

Maps used in Collector are accessed through ArcGIS Online or ArcGIS Enterprise. To appear in Collector, maps must contain at least one editable layer and a basemap. Optionally, you can include additional editable layers as well as provide additional context through noneditable, reference data.

Note:

In addition to the data requirements, a map appears in Collector if you created it or if you are a member of a group with which the map is shared in ArcGIS Online or ArcGIS Enterprise.

If your map is used offline (for example, in areas with a low, unreliable, or no data connection), it also needs to have all layers enabled for offline use. See the offline data requirements.

Editable data

Maps in Collector are driven by editable data. Without supported, editable data, the map won't appear in Collector. The following editable data sources are supported:

  • Feature layers hosted on ArcGIS Online
  • Feature layers hosted on ArcGIS Enterprise 10.5 or later or Portal for ArcGIS 10.4.1 or earlier

    Downloading features without their attachments requires ArcGIS Enterprise.

  • Related records

    Feature-to-table relationships, feature-to-feature relationships, and table-to-table relationships (where the first table is accessed through a feature) are supported in Collector. For each, one-to-one and one-to-many relationships are supported. Relationships can be up to three levels deep. It is recommended that you use GlobalIDs when defining relationships. User-maintained relationships are not recommended.

    Related records are supported for hosted feature layers and ArcGIS Server 10.3 or later feature services.

  • ArcGIS Server feature services

    Databases (including enterprise geodatabases) are supported for connected map use. An enterprise geodatabase is required for working offline. File geodatabases are not supported. The versions of ArcGIS Server and geodatabases that are required vary depending on the functionality you need. See the following table for details.

    Functionality you needSupported versions of geodatabasesSupported versions of ArcGIS Server
    Connected and offline map useConnected map useOffline map use

    Editable data—Nonversioned, archived

    All¹

    All

    10.2.2 or later

    Editable data—Versioned

    All¹

    All

    10.3 or later. If using 10.3.1, it is recommended that you use the ArcGIS 10.3.1 Feature Service Sync Performance patch.

    Sync options

    All

    N/A

    • Bidirectional support for features and attachments—10.2.2 or later
    • Downloading features without their attachments—10.5 or later
    • Downloading the schema only (without any features)—10.2.2 or later

    Related tables

    All

    10.3 or later

    10.3 or later. If using 10.3.1, it is recommended that you use the ArcGIS 10.3.1 Feature Service Sync Performance patch.

    Geometric networks²

    All

    10.3.1 or later

    10.3.1 or later

    ¹Global IDs are required for offline use.

    ²These require versioned data for editing. When used in Collector, all feature services that participate in a geometric network are treated as simple feature services, and the restrictions of the geometric network are ignored.

Caution:

Layers on ArcGIS Online, ArcGIS Enterprise, or Portal for ArcGIS must be hosted and not contained within the map. If you add your layer from a file (for example, a shapefile or a comma-separated values [CSV] file) to the map, the layer is stored in the map. Instead, publish it as a hosted feature layer if you want it editable in Collector. See Add your layer from a file in ArcGIS Online and Publish hosted feature layers in ArcGIS Online, or Add your layer from a file in ArcGIS Enterprise and Publish hosted feature layers in ArcGIS Enterprise.

Limitations

There are some limitations on the editable data that your map includes:

  • If the feature layer is z-aware, it must have a default z-value.
  • If the feature layer is m-aware, and you collect or update feature geometries, the m-values of the new geometries will be null.

Basemap and other reference data

You can include a basemap as well as other noneditable data in your map to provide context to mobile workers. The following data sources are supported for reference data:

  • Feature layers hosted on ArcGIS Online, ArcGIS Enterprise 10.5 or later, or Portal for ArcGIS 10.4.1 or earlier
  • Tile layers hosted on ArcGIS Online, ArcGIS Enterprise 10.5 or later, or Portal for ArcGIS 10.4.1 or earlier
    Note:

    Vector tile layers aren't supported in Collector Classic.

  • Files imported into ArcGIS Online, ArcGIS Enterprise 10.5 or later, or Portal for ArcGIS 10.4.1 or earlier (including GPX, CSV, and shapefiles)³
    Tip:

    To work with this data offline, publish it as a hosted feature layer instead of adding it directly to the map. See Publish hosted feature layers in ArcGIS Online or Publish hosted feature layers in ArcGIS Enterprise.

  • ArcGIS Server map services (tiled map services using ArcGIS Server 10.2.2 or later for offline use)
  • ArcGIS Server feature services (10.2.2 or later for offline use)
    Note:

    Databases are supported for connected map use. File geodatabases are not supported.

  • ArcGIS Server image services4
  • WMS data³

³Only supported for connected (online) use.

4Only supported for connected (online) use on Android and iOS. Supported offline on Windows.

Supported languages

Arabic, Catalan, Croatian, Czech, Danish, Dutch, English, Finnish, French, German, Greek, Hebrew, Hindi, Hungarian, Indonesian, Italian, Japanese, Korean, Norwegian, Polish, Portuguese (Brazil), Portuguese (Portugal), Romanian, Russian, Simplified Chinese, Spanish, Swedish, Thai, Traditional Chinese (Hong Kong), Traditional Chinese (Taiwan), Turkish, and Vietnamese.

The language used by the app is determined by your device's language setting.