Skip To Content

Workflows

This guide gives a hands-on description of the basic CityEngine modeling workflow. This page describes similar steps as when using the City Wizard. However, the different steps are listed manually below.

Create a new CityEngine scene

After at least one CityEngine project has been created, the first step is to create a new scene. This can be done in the main menu through File > New... > CityEngine > CityEngine scene. The name of the CityEngine scene can be entered and after pressing Finish, the new scene is created.

Create a city layout

The easiest way to create a city layout consisting of streets, blocks and lots is to start the Street Growth Wizard from the main menu Graph > Grow Streets... In this wizard, several growth parameters such as the intended number of streets or the street pattern can be selected. When completing the wizard, CityEngine creates a new Street Network layer (or extends an existing street layer, if selected) containing the graph network, blocks, and street and lot shapes. Later, the resulting shapes can be used as a starting point for the grammar-based modeling.

The created layout in the Viewport (generated with the default growth parameters):

Viewport shows street network and blocks.

Viewport shows street and lot shapes.

Street networks can also be edited manually by using the graph edit or transform tools in the main toolbar. You can press Delete to remove selected streets. By using the Inspector, attributes such as the width of the selected streets can be edited.

In addition, street networks can be designed in an external application such as Autodesk AutoCAD and then imported into the CityEngine. This can be done by using the import wizard in the File menu, File > Import... > CityEngine Layers > DXF Import for .dxf files, (see Import DXF). Alternatively, CityEngine also supports data from OpenStreetMap.

Similarly, arbitrary polygon meshes can be designed in an external application such as Autodesks Maya and then imported into the CityEngine. This can be done by starting the import wizard in the File menu, File > Import... > CityEngine Layers > OBJ Import for .obj files (see Import OBJ). The imported shapes can be used in the same way as shapes generated by CityEngine: You can edit them and you can assign CGA rule files in order to generate building models.

Use the City Wizard

The City Wizard is the easiest way to generate your first city within seconds. It integrates above steps - creating street networks, street and lot shapes - in a single user interface step and uses pre-defined parameter sets for the algorithms. It also assigns selected rule files to the created shapes. The created city is stored in a CityEngine scene file, and can be explored, modified and further extended.

The City Wizard is invoked from an existing workspace any time by selecting File > New .... Then select City Wizard, press Next and follow the self-explaining wizard pages.

The four City Wizard pages that guide the generation of different city types.

The schematic city type.

The sci-fi city type.

The textured city type.