Create an operation view

This is the second part of creating an operation view to use for emergency incident tracking and response following a simulated earthquake in Redlands, California. In the previous exercise, you created a map to use in the operation view. In this exercise, you'll author an operation view using the map you created and set up different panels of information made available during the incident tracking. In the final exercise, you'll share that operation view with others in your organization.

Create a new operation view

Now that you have a map, take the following steps to create a new operation view, turning your map into an operating picture.

  1. If you don't have Operations Dashboard installed, install it from ArcGIS Online.
  2. Start the Operations Dashboard app.
    Sign-in dialog box
  3. If you are connecting to your Portal for ArcGIS, type the URL for your organization in the URL text box. For example, https://myportal.company.com/arcgis.
    Portal URL
  4. Click Continue.
  5. Sign in using your ArcGIS organizational account.
    Sign-in dialog box with Username and Password populated
  6. Click Create a New Operation View.
    Create a New Operation View

    The New tab displays.

  7. Verify Multidisplay operation view is selected.
  8. In the panel to the right, click Create.
    Create a multidisplay operation view

    The Add Widget dialog box opens.

    Operation views are composed of a series of informational displays known as widgets. The Map widget is the most frequently used and often serves as the source of input data for other widgets. Other common widgets include bar or pie charts, lists, and indicators. The first widget you define is the Map widget. The basic process for adding widgets is the same: you choose the source information you want to display, specify the appearance, and set any other properties required for the particular widget.

    Continue with the next section to configure the widgets and provide the information the operation view displays.

Add a map

  1. On the Add Widget dialog box, choose Map if it is not already selected.
  2. Click OK.
    Add Widget dialog box with Map selected
  3. On the Choose Map dialog box, browse to the map you created in the Create a new map exercise, select it, and click Open.
    Choose Map dialog box with your map selected

    The Configure Map dialog box becomes active and populates with information from the map you selected. You can decide which map layers to use as data sources for the operation view. If a layer is regularly updated as information changes, or if you want to use its information in another type of widget, such as a list or chart, specify the layer as a data source. Layers can be set as dynamic or static. Because you set the refresh interval on the layers in the previous exercise, it is reflected in the Settings menu.

    Configure Map dialog box

    The following steps show examples of specifying data sources.

  4. On the Data Sources tab, under the Data Sources section, check the Reported Incidents - Dispatch check box.
    Reported Incidents - Dispatch in Data Sources
  5. In the Settings section of the Data Sources tab, with Reported Incidents - Dispatch selected in Data Sources, check that Dynamic is automatically set up for you. This is set based on the refresh interval specified in the map on that layer.
    Dynamic setting for Reported Incidents - Dispatch
  6. Repeat steps 4 and 5 for each of the available data sources, checking them on and checking their settings. You'll find the settings listed below:
    • Police—Set to Dynamic.
    • Ambulances—Set to Dynamic.
    • Fire—Set to Dynamic.
    • Emergency Facilities—Set to Static.
  7. Click the Capabilities tab on the Configure Map dialog box.
    Capabilities tab on the Configure Map dialog box

    On this tab, specify the capabilities available to the monitoring team as they work with the map in the operation view. As the author of the view, identify which tasks the team may need, such as following an emergency vehicle as it moves on the map or getting additional information about a particular incident. Enabled feature actions are presented to the user in a context menu when a feature is pressed and held or right-clicked. Enabling Feature Pop-ups in the Other section shows the pop-up when the user clicks a feature on the map, without use of a context menu.

  8. In the Feature Actions section, check the check boxes for Follow and Show pop-up.
    Follow and Show pop-up capabilities
  9. Click OK on the Configure Map dialog box to add the map to the operation view.
    The operation view with your map
  10. Click Add, remove, and configure map tools Add, remove, and configure map tools to set the tools available on the toolbar.
    Add, remove, and configure map tools

    The Configure map tools dialog box opens.

  11. In the list of available Map Tools, select Layer Filters and Map Contents to add them to the toolbar of the operation view's map.
    Layer Filters and Map Contents map tools
  12. Click Settings Settings for the Layer Filters.
    Layer Filters Settings

    The Configure Layer Filters dialog box opens.

    Configure Layer Filters dialog box

  13. Click the arrow next to Add and choose Unique values of a field from the drop-down menu.
    Unique values of a field in the Add drop-down menu

    The Create Filters from Field dialog box opens.

    Create Filters from Field dialog box

  14. In the Layer drop-down list, choose Reported Incidents - Dispatch.
    Reported Incidents - Dispatch layer

    Since the Reported Incidents - Dispatch layer has subtypes, a Type drop-down list appears below the layer drop-down list.

  15. Leave the Type drop-down list as Open, since you want to see the open incidents.
  16. In the Field drop-down list, choose Incident.
    Incident
  17. Click OK on the Create Filters from Field dialog box.

    Layer filters for each type of incident are created.

    Configure Layer Filters dialog box with layer filters

    The layer filters allow the team to filter incidents that show on the map when using the operation view. This provides a focus on a particular incident type. When the layer is filtered, all the widgets using the incidents (the same data source) also respect the applied filter.

  18. Click OK to close the Configure Layer Filters dialog box.
  19. Click Close to close the Configure map tools dialog box.

The map is now added to the operation view and configured with the tools and capabilities the team needs to monitor the emergency response operation. While the map contains the information you want to show as part of the operation view, you may want to highlight or summarize the information in a different form to make it more accessible and to quickly understand patterns from larger volumes of data. In the following sections, add more widgets to the operation view to display additional information to help the team, including a summary to monitor the total number of emergency incidents, a list containing the details of the incidents, and a graph showing the number of incidents organized by type.

Add an incident count

The team needs to know how many incidents are currently open. Use a summary widget to provide this count.

  1. Click Widgets and choose Add Widget.
    Add Widget

    The Add Widget dialog box opens.

  2. Choose Summary, and click OK.
    Add Summary widget

    The Configure Summary dialog box opens.

    Configure Summary dialog box

  3. In the Data Source drop-down list, choose Reported Incidents - Dispatch.
    Reported Incidents - Dispatch selected
  4. In the Title text box, type Number of Open Incidents.
    Summary title populated
  5. In the Display Type drop-down list, choose Count to view the total number of open incidents.
    Count selected
  6. Click the Appearance tab.
  7. Click the Color drop-down selector, set the color of the summary text to one of the green colors, and then click outside the color selector to close it.
    Green selected
  8. In the Trailing Text text box, type open incidents. Ensure you include a blank space before open incidents so there will be a space between the number and text.
    Trailing Text populated
  9. Click OK on the Configure Summary dialog box to add the configured summary widget to the operation view.
    Summary widget added to the operation view
  10. Click the title bar of the added summary widget's window and drag it to position it in the operation view. As you move it, positions where the window can be docked display. Place the pointer on the positional indicator for the left edge of the screen and release the mouse button.
    Left edge positional indicator selected

    The summary widget docks on the left side of the operation view. You can drag the line separating the map and the summary to change the amount of the operation view that each covers.

    Summary widget docked on the left edge

Display a list of incidents

The team may need to find the most recent incident and get information about it. In this case, using a map is not the best way to find the incident of interest. Instead, using a list sorted by date and time allows the incident to be more easily identified.

In this section, add a list widget to the operation view to show a sorted collection of features or rows. The list can include all features from a data source or can be limited to certain features. For this exercise, configure a list widget to show all open incidents sorted so the most recent is at the top of the list. In addition, provide the ability to interact with an incident from the list directly in the map by finding its location or displaying additional information about the incident.

  1. Click Widgets and choose Add Widget.

    The Add Widget dialog box opens.

  2. Choose List from the available widgets and click OK.
    List widget selected

    The Configure List dialog box opens.

    Configure List dialog box

  3. In the Data Source drop-down list, choose Reported Incidents - Dispatch if it is not already selected.
    Reported Incidents - Dispatch selected
  4. In the Title text box, type Open Incidents.
    Title populated
  5. In the Data tab, in the Sort Field drop-down list, choose Open Date.
    Open Date selected
  6. On the Data tab, in the Sort Order drop-down list, choose Descending so the most recent incident is at the top of the list.
    Descending selected
  7. On the Data tab, check Select the top item by default.
    Select the top item by default
  8. Click the Feature Display tab.
  9. Delete the current value of the Title text box.
  10. Next to the Title text box, click Insert Field Insert Field.

    The Insert Field menu opens, displaying the available fields.

  11. Choose Incident {incident} to show the incident type as the title of each incident as it displays in the list.
    Incident {incident} selected
  12. For the Description, choose Single Field, and in the drop-down list that appears, choose the Open Date field.
    Single Field and Open Date field selected
  13. Click the Feature Actions tab.

    When you configured the map, you included feature actions that would be available from a context menu on each feature on the map. Similarly, the feature actions configured for a list will be available to the team in a context menu on the incidents in the list.

  14. Check the check boxes for the Show pop-up and Highlight feature actions to make them available when working with the list.
    Show pop-up and Highlight feature actions selected
  15. Click OK on the Configure List dialog box to add the list widget to the operation view.
  16. Click the title bar on the added list widget's window and drag it to position it in the operation view. As you move it, positions where the window can be docked display. Place the pointer over the summary window to see the positions relative to that window, place the pointer on the positional indicator for the bottom of the screen, and release the mouse button.
    Bottom edge positional indicator selected

    The list widget docks on the left side of the operation view below the summary widget. You can drag the line separating the summary and the list to change the amount of the operation view that each covers.

    List widget docked below the summary

Display incident details

The team is interested in details of the most recent incident. You identified which incident this is in the previous section by sorting the list. In this section, add a feature details widget that displays information about the currently selected feature in the list. Since the list is configured to select the top incident, the most recent incident is automatically selected and its details will be displayed.

  1. Click Widgets and choose Add Widget.

    The Add Widget dialog box opens.

  2. Choose Feature Details from the available widgets and click OK.

    The Configure Feature Details dialog box opens.

  3. In the Data Source drop-down list, choose Reported Incidents - Dispatch Selection from the data sources exposed by the Open Incidents list.
    Reported Incidents - Dispatch Selection selected
  4. In the Title text box, type Incident Details.
    Title populated
  5. Leave the default settings for the Feature Description. Click OK on the Configure Feature Details dialog box to add the configured feature details widget to the operation view.
  6. Click the title bar on the added feature detail widget's window and drag it to position it in the operation view. As you move it, positions where the window can be docked display. Place the pointer over the list window to see the positions relative to that window, place the pointer on the positional indicator for the bottom of the screen, and release the mouse button.
    Bottom edge positional indicator selected

    The feature details widget docks on the left side of the operation view below the list widget. You can drag the line separating the list and the feature details to change the amount of the operation view that each covers.

    List widget docked below the summary

Add a chart of incident types

While monitoring the emergency response, the team may need to see a summary of the different types of open incidents to understand the types of incidents occurring and to identify patterns. While the map could be configured to provide a visual indication of which incidents are of which type, a chart widget can be added to the operation view to graphically display the values of the type attributes of the features. For this exercise, create a bar chart widget to display counts of open incidents by type.

  1. Click Widgets and choose Add Widget.

    The Add Widget dialog box opens.

  2. Choose Bar Chart from the available widgets and click OK.
    Add Widget dialog box with Bar Chart widget selected

    The Configure Bar Chart dialog box opens.

    Configure Bar Chart dialog box
  3. In the Data Source drop-down list, choose Reported Incidents - Dispatch if it is not already selected.
    Reported Incidents - Dispatch selected
  4. In the Title text box, type Open Incidents by Type.
    Title populated
  5. In the Display Type drop-down list, choose Display feature counts as bars.
    Display feature counts as bars selected
  6. On the Data tab, in the Value Field drop-down list, choose Incident so the incidents are grouped by incident type.
    Incident selected
  7. Click the Appearance tab.
  8. Check the Show Labels check box.
    Show Labels checked

    A count appears over each column in the chart.

  9. Check the Use color ramp check box.
    Use color ramp checked

    The color drop-down selector changes to show a color ramp instead of a single color.

  10. Click the Color drop-down selector and choose the third available color ramp.
    Third color ramp selected
  11. Click OK on the Configure Bar Chart dialog box to add the configured bar chart widget to the operation view.
  12. Click the title bar on the added bar chart widget's window and drag it to position it in the operation view. As you move it, positions where the window can be docked display. Place the pointer over the map to see the positions relative to that window, place the pointer on the positional indicator for the bottom of the screen, and release the mouse button.
    Bottom edge positional indicator selected

    The bar chart widget is docked on the bottom of the operation view below the map and beside the feature details widget. You can drag the line separating the map and the bar chart to change the amount of the operation view that each covers.

    Bar chart docked beside the feature details and below the map

Save the operation view

This operation view can now be saved to your account.

  1. Click File.
    File menu
  2. Click Save As if it is not already selected.
    Save As on the menu
  3. Under Target Device, choose Multidisplay device if it is not already selected.
    Multidisplay device selected
  4. In the Multidisplay device section, provide a title for the operation view, such as Redlands Earthquake Response.
  5. Provide a summary for the operation view, such as Monitor events during an earthquake in Redlands.
  6. Select a folder in your account where the operation view will be saved, for example, Tutorials.
  7. Provide a custom thumbnail if desired.
  8. Click Save.
    Populated Multidisplay device settings

You have now created a map and an operation view that uses the map. To share this operation view with others in your organization, continue with the Share the operation view exercise.

If you are ready to learn about using the operation view, see Monitor and respond to activities and events.