Notebook 入门

ArcGIS Notebooks 提供一个基于 Web 的多功能界面,可进行数据分析。 通过 Notebook,您可以执行分析、自动化工作流,并立即在地理环境中可视化数据和分析结果。 Notebook 将代码、实时可视化和地图以及数据工具进行了结合。 在 Notebook 编辑器中,您可以在同一个位置写入、归档和运行 Python 代码。

Notebook 在 Notebook 编辑器中创作,该 Notebook 可通过 ArcGIS Online打开。 本主题将介绍 Notebook 编辑器中的组件和菜单。

界面基础知识

Notebook 编辑器包含以下基本组件:

Notebook 编辑器组件

  1. 导航栏 - 浏览网站、从应用程序启动器打开其他应用程序、查看帮助资源以及登录或登出您的个人资料。 导航栏还会显示 Notebook 的标题,并指示该 Notebook 是否具有未保存的更改。
  2. 顶部功能区 - 执行关于您的 Notebook 的各种任务。 此功能区具有以下按钮:
  3. Notebook 菜单功能区 - 此功能区上的操作可在 Notebook 中直接进行。 您可以添加和删除单元格、更改 Notebook 外观、将 Notebook 返回到上一个检查点等。 此功能区还将显示 Notebook 是否受信任以及正在运行的 Python 版本。
  4. 工具栏 - 将这些工具用于 Notebook 中的常见任务。
  5. 工作空间 - Notebook 的内容将显示在此处,您也可以在此处修改内容。

Notebook 菜单功能区

Notebook 菜单功能区中的下拉列表提供了以下操作。

File

文件 Notebook 菜单中,您可以选择以以下一种格式下载 Notebook:

  • Python 代码 (.py)
  • Python Notebook (.ipynb)
  • Reveal.js 幻灯片 (.slides.html)
  • Markdown (.md)

您也可以从 Notebook 项目详细信息页面以 .ipynb 格式下载 Notebook。

编辑

编辑菜单中提供了以下项目:

  • 剪切单元格 - 从 Notebook 工作空间中剪切当前选定的单元格。
  • 复制单元格 - 在 Notebook 工作空间中复制当前选定的单元格。
  • 将单元格粘贴到上方 - 将复制的单元格粘贴到当前选定的单元格上方。
  • 将单元格粘贴到下方 - 将复制的单元格粘贴到当前选定的单元格下方。
  • 粘贴单元格并替换 - 粘贴复制的单元格,并用复制的单元格替换当前选定的单元格。
  • 删除单元格 - 删除当前选定的单元格。
  • 撤消删除单元格 - 反向恢复您删除单元格的操作;首先撤消最近的删除操作。
  • 拆分单元格 - 通过在指针当前位置的单元格内拆分内容,将一个单元格拆分为两个。
  • 合并上方单元格 - 将当前选定的单元格与其上方的单元格合并。
  • 合并下方单元格 - 将当前选定的单元格与其下方的单元格合并。
  • 向上移动单元格 - 在 Notebook 工作空间中,将当前选定的单元格向上移动一个位置。
  • 向下移动单元格 - 在 Notebook 工作空间中,将当前选定的单元格向下移动一个位置。
  • 查找和替换 - 打开一个弹出窗口,您可以在其中输入搜索查询。 您可以在 Notebook 中查找和替换特定值或字符串。
  • 复制单元格附件 - 复制选定的单元格中包含的附件。
  • 剪切单元格附件 - 剪切并复制选定的单元格中包含的附件。
  • 粘贴单元格附件 - 将复制的附件粘贴到选定的单元格中。
  • 插入图片 - 打开一个弹出窗口,您可通过该窗口浏览并添加包括 GIF 在内的图像(仅适用于 Markdown 单元格)。

视图

视图菜单中提供了以下项目:

  • 切换工具栏 - 隐藏或显示工具栏。
  • 切换行号 - 隐藏或显示 Notebook 工作空间中每个单元格中的行号。
  • 单元格工具栏 - 隐藏或显示 Notebook 工作空间中每个单元格的选定幻灯片工具栏选项。 选项如下:
    • - 不显示单元格工具栏。
    • 编辑元数据 - 使用 JSON 为每个单元格输入元数据。
    • 原始单元格格式 - 原始单元格允许您直接写入输出;Notebook 不评估这些单元格的内容。
    • 幻灯片 - 指定每个单元格在幻灯片中的显示方式。 此选项在显示代码时很有用。
    • 附件 - 管理 Notebook 工作空间中每个单元格的关联附件。
    • 标签 - 为 Notebook 工作空间中的每个单元格创建和管理标签。

插入

插入菜单中提供了以下项目:

  • 在上方插入单元格 - 在当前选定的单元格上方插入一个空单元格。
  • 在下方插入单元格 - 在当前选定的单元格下方插入一个空单元格。

单元格

单元格菜单中提供了以下项目:

  • 运行单元格 - 运行当前选定的单元格并将指针移动到下一个单元格。
  • 运行单元格并选择下方 - 运行当前选定的单元格,然后选择下面的单元格。
  • 运行单元格并插入至下方 - 运行当前选定的单元格,然后在选定单元格下方插入一个空单元格。
  • 运行全部 - 按顺序运行 Notebook 中的所有单元格。
  • 运行上方全部 - 运行当前选定的单元格上方的所有单元格,但不运行选定单元格。
  • 运行下方全部 - 运行当前选定的单元格及其下方的所有单元格。
  • 单元格类型 - 更改当前选定的单元格的类型。 选项为代码MarkdownRaw NBConvert。 请注意,标题类型将切换到 Markdown
  • 当前输出 - 允许您控制当前选定的单元格的输出。 其中包括以下选项:
    • 切换输出 - 隐藏或显示当前选定的单元格的输出。
    • 切换滚动 - 启用或禁用当前选定的单元格的滚动。
    • 清除输出 - 清除当前选定的单元格的输出。
  • 所有输出 - 控制 Notebook 工作空间内所有单元格的输出。 其中包括以下选项:
    • 切换输出 - 隐藏或显示所有单元格的输出。
    • 切换滚动 - 启用或禁用所有单元格的滚动。
    • 清除输出 - 清除所有单元格的输出。

菜单中提供了以下项目:

  • 中断 - 如果计算或分析花费的时间过长,则暂停正在运行的核。
  • 重新启动 - 通过重新启动核来重新启动整个计算过程。
  • 重新启动并清除输出 - 重新启动计算过程并清除 Notebook 中显示的任何输出。
  • 重新启动并运行全部 - 重新启动计算过程,然后按顺序运行所有单元格。
  • 重新连接 - 在核空闲时重新连接到核。
  • 关闭 - 关闭 Notebook 中的所有计算过程。
  • 更改核 - 更改核的类型。 在 ArcGIS Notebooks 中,仅支持 Python 3 核类型。

帮助

通过此列表可访问键盘快捷方式、用户界面以及与 ArcGIS Notebooks 和关键 Python 模块关联的多个帮助文档的相关信息。

用户界面快速浏览对于刚接触 Notebook 环境的用户特别有用。

Notebook 工具栏按钮

通过 Notebook 工具栏可以快速访问 Notebook 菜单功能区中最常用的操作。 可用按钮如下(从左至右):

  • 添加 - 在当前选定的单元格下插入一个单元格。
  • 剪切 - 剪切当前选定的单元格。
  • 复制 - 复制当前选定的单元格。
  • 粘贴 - 将复制的单元格粘贴到当前选定的单元格下方。
  • 向上箭头 - 将选定的单元格在 Notebook 序列中向上移动。
  • 向下箭头 - 将选定的单元格在 Notebook 序列中向下移动。
  • 运行 - 运行当前选定的单元格。
  • 停止 - 中断核。
  • 重新启动 - 重新启动核。
  • 快进 - 重新启动核并运行所有单元格。
  • 单元格类型 - 选择或更改当前选定的单元格的类型。
  • 键盘 - 打开命令选项板。
  • 图表 - 进入或退出幻灯片模式。