System requirements for Indoor Space Planner

Available for an ArcGIS organization licensed with the Indoors extension.

To use Indoor Space Planner, either an ArcGIS Enterprise base deployment or an ArcGIS Online organization licensed for the ArcGIS Indoors Maps and ArcGIS Indoors Spaces extensions is required. Refer to the Enterprise help for system requirements and instructions on how to install and configure an Enterprise deployment or to the ArcGIS Online help to set up an ArcGIS Online organization for use with Indoors.

Required ArcGIS software

The following ArcGIS software is required for Indoors on Enterprise:

  • ArcGIS Pro 3.0 or later
  • Portal for ArcGIS 11.0 or later licensed for ArcGIS Indoors Maps and ArcGIS Indoors Spaces
    Note:

    If you licensed Indoors using the older Indoors organization extension, it will be supported until expiration.

The following ArcGIS software is required for Indoors on ArcGIS Online:

  • ArcGIS Pro 3.0 or later
  • An ArcGIS Online organization licensed for ArcGIS Indoors Maps and ArcGIS Indoors Spaces
    Note:

    If you licensed Indoors using the older Indoors organization extension, it will be supported until expiration.

Branch versioning in Enterprise

If you are using Enterprise, branch versioning is required to change a plan's assignments in Space Planner. Branch versioning is supported by Enterprise 10.6.1 or later geodatabases that are created in ArcGIS Pro 3.0 or later. The database platform you use must also support branch versioning.

Learn more about branch versioning data for use with Space Planner

Note:

Branch versioning is not required if you are using ArcGIS Online.

Learn more about preparing a Space Planner map for use with ArcGIS Online

The following database platforms are supported:

DatabaseMinimum release that supports branch versioning
IBM Db2

10.5 Fix Pack (FP) 5

Microsoft SQL Server

13.0.1601.5 (2016)

Oracle

12.1.0.2

Note:

Branch versioning is not supported in user-schema geodatabases.

PostgreSQL

9.5.3

SAP HANA

2.0 Support Package Stack (SPS) 02

Avoid compatibility-related issues and benefit from the latest bug fixes and performance improvements by updating the geodatabase to a version that is compatible with the ArcGIS Pro version you are using. The ArcGIS Pro and geodatabase versions must match when using branch versioning. For example, if you are using ArcGIS Pro 3.0 with a 10.9 geodatabase, upgrade the geodatabase to 10.9.0.2.8.

You can use the Upgrade Geodatabase tool to upgrade your geodatabase. Learn more about upgrading a geodatabase in the following database platforms:

Supported browsers and devices

This app supports all of the browsers that ArcGIS organizations in Enterprise and ArcGIS Online support.

Note:
  • iPad mini is only supported with map image layer-based web maps.
  • iOS 12.0 or later is required to support the latest version of Google Chrome on iPhone.

Supported languages

This app supports all of the languages that the Enterprise portal and ArcGIS Online organization support.

The language used by the app is determined by your browser's language setting.