Skip To Content

Working with the Full Motion Video player

Available with Image Analyst license.

Note:

This tutorial requires ArcGIS Pro 2.3+ and the ArcGIS Image Analyst extension for ArcGIS Pro. If you don't have either ArcGIS Pro 2.3+ or the Image Analyst extension, get a free 21-day trial.

As part of the ArcGIS Image Analyst extension, Full Motion Video lets you view and exploit geospatially enabled video in ArcGIS Pro. This tutorial focuses on using the FMV player in Pro to view video. Learn more about all the capabilities of FMV.

You can work with your video data in the Full Motion Video player in different ways depending on your data. In this tutorial, you'll explore the main components of the FMV player in ArcGIS Pro using video data that tracks a semi-trailer truck (a "big rig") as it travels along a highway near Cheyenne, Wyoming. The truck is carrying a very important load and we want to be sure it is being transported safely.

When you add a video to your ArcGIS Pro project and you have the Image Analyst extension, tabs and interactive windows automatically open so you can interact with your video data directly in your project.

Before you get started, download and unzip a sample video to use with the tutorial.

Open the video

Add the video to a project in ArcGIS Pro.

  1. Start ArcGIS Pro. If necessary, sign in with your ArcGIS Online or ArcGIS Enterprise credentials.

    If you have a Named User license, you must sign in to use ArcGIS Pro. If you are already signed in, your username will appear in the upper right corner of the ArcGIS Pro window.

    If you have a Single Use or Concurrent Use license, you don't need to sign in to use ArcGIS Pro as a desktop-only application. However, you do need to sign in with ArcGIS Online or ArcGIS Enterprise credentials to share content to your portal or to access content from a portal. For example, you need to sign in to open the project package for this tutorial.

  2. Select Map under the Blank Templates list to create a new project with the Map template. In the Name box, type FMV Player and click OK.
  3. To check if the ArcGIS Image Analyst extension is available, click the Project tab, then click Licensing. Under Esri Extensions, find Image Analyst and confirm that under Licensed it says Yes. If it says No and you have a Named User license, check with your ArcGIS Online or ArcGIS Enterprise administrator to activate the license. If you have a Single Use license, see how to authorize an extension. Once you're done reviewing licenses, click the arrow in the top left corner to return to the map.
  4. The project opens with the World Topographic basemap already in the display. Click the Insert tab on the ribbon above the map view. Click Add Folder and navigate to the location where you downloaded the tutorial data. Select the FMV_Tutorial folder and click OK.
  5. From the Catalog pane, expand Folders, then expand the FMV_Tutorial folder you just added. Expand the Videos folder to see the different videos listed in the folder.
    If you do not see either the Contents or Catalog panes, click the View tab from the ribbon and choose the panes or windows you would like to see in your project.
  6. Drag and drop the Truck.H264 file into the Contents pane of the project.
    Three things will change in your project:
    • The video player automatically opens and is docked at the bottom of the ArcGIS Pro window.
    • The Truck video is added to the Contents pane under Standalone Videos.
    • A new contextual tab set appears in the ribbon at the top of the ArcGIS Pro window called Standalone Video. There are two tabs within the tab set: Data and View. Each has a set of tools to work with the video data you added to the project.
  7. Play the video.
  8. Right-click on the video in the Contents pane and select Video Metadata. Here you can see all the location, sensor and platform information that was delivered from the video. Scroll through the metadata or search for specific keywords to explore the information. Close the Video Metadata window.
  9. In the video player, click Close on the Truck video tab. Notice the video doesn't get removed from the Contents pane. Right-click on the video in the Contents pane again and select Open Video to restore it to the video player.

Control playing of the video

Use the digital video recording (DVR) controls to change how you want to play the video.

  1. Click the Play button on the video player.

    If the video player is too small, you can resize the player while docked, or right click the Truck tab and select Float to view the video player in its own window. Right click the Truck tab again and click Dock to return the player to its initial location.

  2. Click the Pause, Fast forward, Rewind, Go to beginning, and Go to end buttons and notice how they impact the playing of the video. Click the Step forward button. This control moves the video forward by a single frame or by a number seconds. Click it a few times to see how it works, then click the Step backward button a few times.
  3. From the Standalone Video tab set, open the View tab and look at the Video Step group. Here you can change the settings for the Step forward and Step backward controls.
    1. Change the video step type from Frame to Second using the drop-down menu.
    2. Type 10 to modify the Forward step time to 10 seconds. Do the same for the Backward step time.
    3. Click the Step forward and Step backward buttons in the video player. Watch the time displayed at the bottom-right of the video player to see how the time skips 10 seconds when using this control.
  4. Click Play to play the video. While the video is playing, you can adjust the speed or playback rate of the video to be faster or slower by using the slider below the DVR controls.
    1. Move the slider to the right to increase the speed of the video playback and see the rate of the playback next to the slider (e.g. move the slider until the playback rate is 2.50x).
    2. Move the slider to the left to slow down the playback rate.
    3. Pause the video and see the playback rate set to null.
  5. Click Play again. With your mouse hovering over the video, use your mouse's scroll wheel to zoom in on the video. Notice that a small box appears in the upper-left corner of the video, showing you the relative location of your zoomed-in view. Pan around the image and see the highlighted location within the box changes to reflect the location of your displayed extent.
  6. You might have noticed that when you click in the video, a notification appears in the upper-right corner of your ArcGIS Pro window. This is a built-in feature of FMV. For analysts that need quick coordinates, you can click anywhere in the video and the coordinates will automatically be copied to your clipboard for rapid pasting into a chat session or word processing software. The message looks something like this:
    1. Click somewhere in the video and watch for the message in the upper-right corner of the ArcGIS Pro window. Notice the coordinates are in decimal degrees.
    2. In the Contents pane, right-click on the Map heading and select Properties to open the Map Properties window.
    3. On the General tab, change the Display Units to Meters and click OK.
    4. Click somewhere in the video and watch again for the message to appear. Notice the coordinates are now in meters.

Visualize the video in your map view

You may have noticed some features in your map view as you interact with your video in the video player. Use the tools at the top of the video player to manage how you visualize the video in your map.

  1. With the video paused, click the Zoom to Video button. In the map, see that you are now looking at the area around the data in the video player. You will see (1) a polygon representing the outline of the frame you are currently visualizing in the video player, (2) a point indicating the location of the camera, (3) a solid line that updates regularly showing the movement of the sensor, and (4) a dashed line connecting the sensor and frame. These will be drawn in whatever color you've selected in the Color picker. Experiment with different basemaps and colors in the Color picker to see displays that work for you.
  2. In the video player, click Play and watch the graphics move along your map.
  3. Click Pause again and click Zoom to Frame. This shows you only the extent around the frame you are viewing.
  4. Use the video playback slider just above the DVR tools in the video player to display the video at approximately 1 minute and 8 seconds. The time display for the video will be 01:08/02:28, and you will see a white van passing the semi-trailer truck. We want to create a bookmark in the video here so that we can look into this frame a little later.
    1. Click the New Bookmark button on the video player toolbar.
    2. Enter a name and short description of the bookmark. Click OK.
  5. Click Play again. Notice that the video frame moves out of sight in the map because the map extent is not updating along with the movement of the truck. To enable this functionality, select the Follow Video option at the top of the video player. The map view updates to show the extent of the video and pans/zooms to account for movement.

Click the Follow Video button again to turn this functionality off and pause the video.

Export data from your video

You might need to export video frames and metadata into another format. Use the tools in the video player toolbar to quickly export data for visualization and analysis outside of ArcGIS Pro.

  1. On the ribbon at the top of the ArcGIS Pro window, select the Map tab. In the Navigate group, click the Bookmarks drop-down and select the bookmark you created earlier in this exercise. The map and the video will update to display the white van passing the truck. Click Zoom to Video to see the extent of the video frame and platform if necessary.
  2. The outline of the frame in your map is useful, but we want to get a snapshot of the video in this frame to help us reference the event. Click the Frame Snapshot tool to generate a JPG that has been georeferenced to your map. The JPG is added to the Contents pane. In the Catalog pane, expand the project folder. A container folder called FMV_Data has been created to store your FMV workflow data and exports. Expand this folder and expand the Images subfolder. See that an image has been stored in the folder for the Truck video.
    To modify the location of your exports, open the Data tab in the Standalone Videos tab set on the ribbon and select Configure Workspace.
    Additionally, to quickly locate an item on your disk from its location in the Catalog pane, right-click item in the Catalog pane and select Copy Path. Open Windows Explorer and paste the path to the file to open its location on disk.

    The JPEG is georeferenced on-the-fly by ArcGIS Pro; to view the image in other software, you'll need to Export the image.

  3. Play the video and click Frame Snapshot again. See that you can store images as you are watching the video progress.
  4. Select Pause, then Go to beginning.
  5. Open the Metadata to Features tool. Here you can set the parameters for storing the frame polygons, frame centroids, and camera locations for the video in a geodatabase.
    1. Modify the Frequency to 50 frames and change the Feature prefix to Truck_feat_.
    2. Make sure all the Features are selected and that Add To Map is also selected.
    3. The default geodatabase is the project geodatabase, but you can navigate to another geodatabase if necessary. When ready, click Select Geodatabase.
    4. Notice that the Metadata to Features tool is now highlighted on the toolbar. Click Play on the video. See that three feature classes are added to your Contents pane and map view, matching the color you selected in the Color picker: one for the outline of the frame, one for the center of the frame, and one for the camera location for that frame. A new record will be added to each feature class every 50 frames.
    5. Click Pause.
    6. Right click each feature class and open the attribute table to explore the metadata that's included with the feature data. Close the attribute tables.
    7. Navigate to the geodatabase you chose in the Catalog pane and see that the feature classes have been stored.
    8. Click the Metadata to Features tool again to turn it off.
  6. Open the Frames to Images tool. This tool allows you to set the parameters for exporting frames as images, along with their metadata, to a specified folder. You can set the frequency with which you want to generate the frames, and each frame will be stored with an image and metadata file.
    1. Set the Frequency to 50 frames.
    2. For Destination Folder, enter a name that will be used to prefix your new folder and the image files. By default, the frames are stored in a new folder in the project's FMV_Data > Images folder. You could also select a different folder.
    3. Select PNG as the image type.
    4. Click Save.
    5. Notice that the Frames to Images tool is now highlighted on the toolbar. Click Play on the video. After 30 seconds or so, click Pause. In the Catalog pane, navigate to the FMV_Data > Images folder, right-click and refresh it. See that a new folder was created in your destination folder containing images and CSV files with metadata. The folder is named with a unique ID to prevent overwriting images in existing repositories.
    6. Click the Frames to Images tool again to turn it off.
  7. Open the Metadata to CSV tool. This tool exports the metadata for every frame you view in the video to a .csv file. By default, it stores the file in the CSV_Metadata folder that is generated when you first add a video to your project.
    1. Enter Truck12seconds as the File name.
    2. Click Save.
    3. Click Play to play the video and Pause it after 12 seconds.
    4. Click the Metadata to CSV tool again to turn it off.
    5. Refresh the CSV_Metadata folder in the Catalog pane. Expand it and drag the new CSV into your Contents pane.
    6. Right click and open the table and see that approximately 60 records were created, containing the metadata for 60 video frames over 12 seconds of video. Close the table.
  8. To export those first 12 seconds of video to a shortened video clip with all the associated metadata, use the handles at either end of the video time slider so that only the first 12 seconds of video are between the two handles. Open the Export Video Clip tool and give your clip an output name. Then click Save. You can open this new video in your ArcGIS Pro project.
  9. You may want to create PowerPoint deliverables quickly from your video data. To do this, you can use the Export to PowerPoint tool.
    1. First, make sure you have a useful map view. Open the Bookmark you created earlier, showing the white van passing the truck. If you haven't done so already, use the Frame Snapshot tool to display the image of interest on the map.
    2. Now open the Export to PowerPoint tool to create a quick slide series with your imagery.
    3. You can use the Add Data button to browse to an existing PowerPoint presentation. Alternatively, if you already have the PowerPoint presentation open, you can select the title of the presentation in the Active PowerPoint Presentation window. If you want to create a new PowerPoint presentation, enter a name for it.
    4. Click OK.
    5. Open the PowerPoint Presentation you selected and see that the current map view extent, the map extent of the platform and frame together, and the image itself were all exported on consecutive slides for delivery.
    6. Back in the project, you can navigate to a different part of your video and click the Export to PowerPoint tool again. New snapshots and extents will be appended to the same PowerPoint presentation.

This tutorial showed you the basics of working with video data in the Full Motion Video player. See related tutorials below to find out more about what you can do with Full Motion Video in ArcGIS Pro.

Related topics