Skip To Content

Build reports

Build reports allows you to create custom report templates that you can use, run and share with others in your organization. Create report templates using Esri reports, reports you've created, shared reports from others in your organization and variables from the Data Browser. You can customize your reports by adding charts, images and text.

To access Build Reports, click the Reports tab and click Build Reports.

Build reports in three steps

The three step process described here provides the basics for building a report template. You can add report sections and variables and save the template. Advanced options are described in the next section.

Select a report

In the list below, browse the reports you've created, reports shared by others in your organization and Esri reports. Click the report that you want to use.

Select a report.

The report appears in step 2 below.

To use variables in your report, click the Select Variables tab. Select Variables tab

Using the Data Browser, you can browse variables and drag them to the right to the report template in step 3. You can also add site attributes that you may have customized when you created the project.

Caution:

When specifying site attributes as variables, avoid using reserved words such as SITE_NAME as variable names. If your site attributes include any reserved words, it is highly recommended to modify them in the report template. This is necessary, as otherwise the application will not recognize the difference between the site name (of the site for which the report is run), and the SITE_NAME that is actually an attribute of the site.

Drag selected variable to the right.

Click and drag sections of the report from step 2 to the report template on the right in step 3. Continue until you've selected all of the sections you want in the report template.

Drag variable from step 1 to step 2
Note:

There is a limit of 100 inches or 10 letter sized pages. If the limit is exceeded, you can't add more content.

You can copy and paste the entire report from step 2 in to step 3. Click Copy the whole report.

Copy the whole report.

The entire report appears in step 3.

Create a report template

Click Save Save button and name your report. Your report appears in step 1 under My Reports.

Here are some features to help you while working with build reports.

  • Find / Replace allows you to find and replace text in your report. Find / Replace button
  • Use undo and redo. Undo and redo buttons
  • Double click on the logo to change it.
  • Use Remove to remove a section. Remove a section
  • Use Split Table to split the table in a section. Split a table in a section
  • Use Create New to clear your report. Create New If you click Create New and have not saved your changes, the changes will be lost. A pop-up appears with the option to save them.
  • Click View Tutorials to access videos for building reports. View tutorial videos

Advanced options for building reports

Once you've created the report template, you can customize your report by adding charts and inserting images. You can edit the chart types, customize the colors and layout and create a series for your variables in the Chart Properties dialog box.

Select Reports tab

You can share, edit and delete reports in My Reports. Hover the pointer over the report name and the icons appear.

Share, edit and delete My Reports.
Note:

Options for sharing may vary depending on the security and roles of your organization. Once shared, these reports can be found in ArcGIS Online > My Content > Report Templates.

Create report template

As discussed in step 3 above, once you've selected report sections and variables, you can work with the report template on the right using the Preview, Sample Values and Edit buttons.

Preview, Sample Values and Edit buttons

Click Preview to preview the report you've created. The report formulas are shown.

Click Sample Values to view a sample report. The report shows sample values.

Click Edit to make adjustments and insert items into your report template. When the report is in Edit mode, you can make changes to the design and layout of the report. For example, you can adjust the table alignment, add additional rows and columns, change the font and report style and insert images. When in Edit mode, here are some editing options:

Click Section Options to change the horizontal lines between each section. Section Options

Click Table Properties to edit the table size, type and position. Table Properties You can choose from different table types:

General Data — Use to enter individual variables in to a table.

  • Column count is the number of columns.
  • Scale to fit width of section extends the table to fit the width of the section.
  • Scale to fit height of section extends the table to fit the height of the section.

Multi-Ring Table — Use this to display data for multiple ring sites side-by-side in a single page. For example, you can compare data for three rings around a site on a single page.

  • Fixed columns adds the first columns of the table. You can add the variable name and description and enter the name or description in the cell.
  • Dynamic columns are assigned to each ring. Each ring will have the same number of dynamic columns.
  • The ring count is the number of rings and is a maximum of three.
  • Row count is the number of rows.
  • Scale to fit width of section extends the table to fit the width of the section.
  • Scale to fit height of section extends the table to fit the height of the section.

The table below shows the results of the selections in the Table Properties dialog box above.

Split Table — Use to split the table in a section. Split table

Styling and calculation tools

Use Style Cell, Add Variable, Calculate Totals, Calculate Column, Create Chart and Modify Table to create custom variables for your report template.

To access the styling and calculation tools, click on a section, while in Edit mode, and the wrench icon appears. Click to access styling and calculation tools Press Crtl or Shift to select multiple sections.

Style Cell — Edit styles and add a hyperlink for your template.

Add Variable — Select a single cell in the template to build a custom variable or add your saved custom variables from My Data.

  • Build Custom Variable — Create a custom variable using data from the Data Browser. Drag variables from step 1 to step 2 and use the operators to create a custom variable. See create custom variables for use of operators.
  • Add from My Data — Add your saved custom variables.

Calculate Totals — Select multiple cells in the template to calculate the totals.

  • Sum Cells — Select the cells that you want to sum. The calculation appears in the cell below.
  • Add Average — Select the cells that you want to average. The calculation appears in the cell below.

Calculate Column — Select multiple cells in the template to add columns.

  • Percentage Column — Calculates percentage values for all selected cells in the column. The results appear in the new column on the right. This is enabled for variables with %. Percent button
  • Average Column — Calculates average values for all selected cells in the column. The results appear in the new column on the right. This is enabled for variables with Avg. Average button
  • Index Column — Calculates index values for all selected cells in the column. The results appear in the new column on the right. This is enabled for variables with Index. Index button
  • Margin of Error Column — Calculates the Margin for Error values for all selected cells in the column. The results appear in the new column on the right. This is enabled for ACS data with Reliability. Reliability button
  • Reliability Column — Calculates the reliability values for all selected cells in the column. The results appear in the new column on the right. This is enabled for ACS data with Reliability. Reliability button

Create Chart — Select the cells to create a chart for your template.

Modify Table — Cells, rows and columns can be added or deleted.

Insert item

Use the options in the drop-down menu to customize your report template.

Insert item drop-down menu

You can choose from:

  • Chart — Create a chart in a cell. Click Chart to access the Chart Properties dialog box where you can use the options in the Variables tab to customize your chart.
  • Chart from Selected — Selected variables will be used to generate the chart. The chart will be added below the variables. Click Chart from Selected to access the Chart Properties dialog box where you can use the options in the Variables tab to customize your chart. Click Apply.
  • Chart in Cell — Create a chart in a selected cell. Click the cell to access the Chart Properties dialog box where you can use the options in the Variables tab to customize your chart. Click Apply
  • Image Floating — Insert an image. Move the border to adjust the size of the image. You can move the image for your preferred placement within the section.
  • Image in Cell — Insert an image in the selected cell.
  • Map — Insert a map—for example, the location of your site or a web map showing all competitor locations. In Edit mode, move the pointer over the map element to see the additional options.
    Map options
    • Change map — choose a different available basemap or browse ArcGIS to select one.
    • Add other layers — add other layers from the current project or from ArcGIS.
    • Pin symbol — The default pin symbol comes from your setting under Preferences > General > Settings. Choose a different pin symbol or import a custom symbol.
  • Nearby location table — Add or create a filtered table or nearby locations based on chosen attributes.
  • Page Break — Insert a page break. This can be useful in creating separate pages when printing.
  • Table — Insert a table. Choose from different table types in Table Properties.
  • Text box — Insert a text box in the selected cell.

Chart Properties

The Chart Properties dialog box is accessed by selecting Chart, Chart from Selected and Chart in Cell from the Insert item drop-down menu. The Chart Properties dialog box contains the Choose Variables tab and the Chart Options tab.

Variables tab and Options tab

Choose Variables tab

Browse variables and drag to the right.

The Choose Variables tab opens the Data Browser where you can browse the variables. Drag the variables you want to use to the Variables section on the right.

Drag variables to create a data series
Note:

Press Shift and click on the variables to select multiple variables.

Select series and variables to change.

As you drag the variables under step 1 to the Variables section in step 2, a chart appears and a series is created.

Here are some features to help you while working with the variables in step 2.

Drag the variable to reorder.

Variables can be reordered.

Click on a chart type icon to change the chart type.

Chart type options

Double click the series name to change it.

Change series name

Click to add other series.Add Series button

Chart Options tab

In the Chart Options tab, you can customize the chart using the features described below.

  • Chart — Create a chart title and title alignment, select the background color, font and add and remove the background image.
  • Data Labels — Show and hide data labels, data values and data percents. You can set your decimals, with a maximum of 10, and select the font.
  • Horizontal Axis — Create a chart title, show and hide axis and ticks, change the horizontal axis of your chart or graph.
  • Vertical Axis — Create a chart title, show and hide axis and ticks, change the vertical axis of your chart or graph.
  • Grid Lines — Adjust the horizontal and vertical grid lines and center them.
  • Legend — Show and hide the legend and border, change the offset percentage and edit the font. You can also change the position of the legend.
  • Column Chart — Adjust the column thickness.

Change year labels for data updates

When the data is automatically updated, you will need to update the year labels for your report templates. If you've created custom variables, the year labels need to be updated to match the updated data.

As an example, your year label is 2017 but the data is 2018.Year label example

If updates are needed, the Data Update Notification dialog box appears when you log in.

  1. In the Data Update Notification dialog box, to update the year labels click Update Reports Now.

    If you don't want to update the reports now, click Update Reports Later.

  2. In the Update Custom Reports dialog box, the reports that need to be updated appear with the caution icon. Caution icon Use the following buttons to update the year labels.
    • Update This Report Later — This allows you to update the report at another time.
    • Leave This Report As Is — The report will not be updated and the year labels will not be changed. Once you've clicked, a confirmation dialog box appears. Click OK to leave it as is. If the report is left as is, it can't be undone.
    • Update This Report — Updates the highlighted report.
    • Update This & Remaining Reports — Updates the highlighted report and all reports in the list.

When a report has been updated, the caution icon changes to a check. Check icon

To make other changes, use Find/Replace.