Системные требования

Существуют определенные требования для запуска ArcGIS AppStudio и AppStudio Player, как и для любых приложений, созданных с помощью AppStudio.

Системные требования ArcGIS

Анонимные пользователи могут загружать общедоступные приложения в AppStudio Player или воспользоваться приложением, созданным в AppStudio, которое было установлено из магазина приложений и не требующее выполнения входа. Вы можете определять, у кого есть доступ к вашему приложению, опубликовав его в своей организации или группе.

Различные типы пользователей и различные роли в организации ArcGIS имеют доступ к различным функциям ArcGIS AppStudio. Подробная информация приведена в таблице ниже и в разделах Типы, роли и права пользователей для ArcGIS Online или Типы, роли и права пользователей для ArcGIS Enterprise.

Тип пользователяИспользование приложения, опубликованного в вашей организации в AppStudio PlayerСоздание своего приложения и его публикация в вашей организации для работы в AppStudio PlayerСоздание собственных файлов установки приложения для публикации в общедоступных магазинах приложений или публикация в организации в виде отдельных файлов или в системе MDM

Viewer

Да

Нет

Нет

Field Worker

Да

Нет

Нет

Editor

Да

Нет

Нет

Creator

Да

Да

Да (необходима лицензия ArcGIS AppStudio Developer Edition)

GIS Professional

Да

Да

Да (необходима лицензия ArcGIS AppStudio Developer Edition)

Для подключения приложения к данным ArcGIS Server или сервисам, используйте ArcGIS Server версии 10.0 или новее. Для использования данных ArcGIS Server, когда вы находитесь в автономном режиме, используйте ArcGIS Server 10.2.2 или новее.

AppStudio поддерживает ArcGIS Runtime 100.14.

Элементы приложения AppStudio можно сохранить в ArcGIS Online и ArcGIS Enterprise. Portal for ArcGIS 10.4 и новее также поддерживают возможность входа, создания и выгрузки приложений, а данные, сохраненные в Portal for ArcGIS 10.2 или новее можно использовать в ваших приложениях.

Поддерживаемые операционные системы

Поддерживаются следующие операционные системы (с минимальными версиями) для настольного приложения AppStudio:

Операционная системаВерсия ОС
Windows

  • Windows 11 Pro и Windows 11 Enterprise минимум версии 21H2 (64-разрядные)
  • Windows 10 Pro и Windows 10 Enterprise (32- и 64-разрядные) не ниже версии 1809
  • Windows Server 2016 ( 64-разрядная)
  • Windows Server 2019 ( 64-разрядная)

Ubuntu

18.04 LTS или позднее (64-разрядная)

macOS

10.15 Catalina или позднее (64-разрядная)

Поддерживаются следующие ОС (минимальные версии) для AppStudio Player:

Операционная системаВерсия ОС
Windows

  • Windows 11 Pro и Windows 11 Enterprise минимум версии 21H2 (64-разрядные)
  • Windows 10 Pro и Windows 10 Enterprise (32- и 64-разрядные) не ниже версии 1809
  • Windows Server 2016 ( 64-разрядная)
  • Windows Server 2019 ( 64-разрядная)

Ubuntu

18.04 LTS или позднее (64-разрядная)

macOS

10.15 Catalina или позднее (64-разрядная)

Android

6.0 Marshmallow или более поздняя версия (32-разрядная версия ARMv7 и 64-разрядная версия ARMv8)

iOS

13 или позднее (64-разрядная)

Внимание:

ОС поддерживается только в том случае, если она также поддерживается Qt SDK от The Qt Company.

DirectX

ArcGIS Runtime использует ANGLE, в котором для обеспечения быстрого отображения карты используется DirectX. DirectX обеспечивает поддержку аппаратного и программного отображения графики, и предоставляется на поддерживаемых платформах Windows. Программное отображение DirectX используется в случае отсутствия аппаратной поддержки DirectX (в том числе на виртуальных машинах).

Требования к аппаратному обеспечению

Ниже приведены минимальные требования для запуска ArcGIS AppStudio на устройствах Windows, macOS и Ubuntu.

ОборудованиеТребование

Частота процессора

Рекомендуется 2.2 ГГц и выше; Hyper-threading (HHT) или многоядерный

Процессор

Платформа

Процессоры Intel Pentium 4, Intel Core Duo или Xeon; SSE2 (или выше)

Windows: Запустите утилиту Microsoft из командной строки Windows для проверки процессора.

macOS: Поддерживаются только процессоры Intel; новый процессор Apple M1 не поддерживается. Чтобы определить, какой процессор у вашего устройства, см. статью службы поддержки Apple.

Память / ОЗУ

не менее 2 ГБ

Свойства отображения

Глубина цвета 24 разряда

Разрешение экрана

Для нормального размера (96 dpi) рекомендуется 1024x768 или выше.

Пространство для файла подкачки

Определяется операционной системой; минимум 500 МБ

ArcGIS Runtime во время работы создает файлы кэша; может потребоваться дополнительное место на диске.

Видео/графический адаптер

Минимум 64 МБ видеопамяти, рекомендуется не менее 256 МБ. Поддержка чипсетов NVIDIA, ATI и Intel.

Драйвер видеокарты с ускорителем

Для просмотра 2D-карт требуется OpenGL версии 2.1 минимум; для просмотра 3D-сцен требуется OpenGL версии 3.2. Рекомендуется Shader Model 3.0 или выше. Убедитесь, что вы используете новейший драйвер.

Интерфейс пользователя

Linux: X Windows с Gnome или KDE Desktop Environment

Примечание:

Хотя ANGLE поддерживается в ArcGIS Runtime 100.14, его поддержка полностью прекратится в последующих версиях. Вместо этого рекомендуется использовать режим рендеринга по умолчанию или OpenGL.

Поддерживаемые языки

В AppStudio поддерживаются следующие языки:

Арабский, боснийский, болгарский каталонский, хорватский, чешский, датский, голландский, английский, эстонский, финский, французский, немецкий, греческий, иврит, венгерский, индонезийский, итальянский, японский, корейский, латвийский, литовский, норвежский, польский, португальский (бразильский), португальский (португальский), румынский, русский, сербский, китайский (упрощенное письмо), словацкий, словенский, испанский, шведский, тайский, традиционный китайский (Гонконг), традиционный китайский (Тайвань), турецкий, украинский и вьетнамский.

Используемый язык определяется настройками языка вашего устройства.