Requisitos del sistema

Existen algunos requisitos de dispositivo para ejecutar ArcGIS AppStudioy AppStudio Player, además de algunos requisitos sobre los datos utilizados en la aplicación.

Requisitos de ArcGIS

Los usuarios anónimos pueden descargar aplicaciones públicas en AppStudio Player, o utilizar una aplicación creada con AppStudio que se haya instalado desde una tienda de aplicaciones que no requiera inicio de sesión. Puede controlar quién tiene acceso a su aplicación compartiéndola con su organización o con un grupo.

Los distintos tipos de usuarios y roles de las organizaciones de ArcGIS tienen acceso a distintas características de ArcGIS AppStudio. Consulte la siguiente tabla para obtener más detalles y, para obtener más información, consulte Tipos de usuarios, roles y privilegios de ArcGIS Online o Tipos de usuarios, roles y privilegios de ArcGIS Enterprise.

Tipo de usuarioUsar una aplicación que se haya compartido con su organización en AppStudio PlayerCrear su propia aplicación y compartirla con su organización para usarla en AppStudio PlayerCrear sus propios archivos de instalación de aplicaciones para publicarlos en una tienda de aplicaciones pública o compartirlos en su organización como archivos de instalación independientes o con un MDM

Viewer

No

No

Field Worker

No

No

Editor

No

No

Creator

Sí (también requiere una licencia de ArcGIS AppStudio Developer Edition)

GIS Professional

Sí (también requiere una licencia de ArcGIS AppStudio Developer Edition)

Para conectar su aplicación con datos o servicios de ArcGIS Server, use ArcGIS Server 10.0 o posterior. Para utilizar datos de ArcGIS Server cuando la aplicación está sin conexión, utilice ArcGIS Server 10.2.2 o posterior.

AppStudio admite ArcGIS Runtime 100.8.

Los elementos de aplicación de AppStudio se pueden guardar en ArcGIS Online y ArcGIS Enterprise. También se admite Portal for ArcGIS 10.4 y posteriores para el inicio de sesión y la creación y carga de aplicaciones, y puede usar en sus aplicaciones datos almacenados en Portal for ArcGIS 10.2 y posteriores.

Sistemas operativos compatibles

Los siguientes sistemas operativos (con sus versiones mínimas) son compatibles con AppStudio en el escritorio:

Sistema operativoVersión de SO
Windows

  • Windows 10 Pro y Windows 10 Enterprise (32 bits y 64 bits [EM64T]) versión mínima 1803
  • Windows 8.1, Windows 8.1 Pro y Windows 8.1 Enterprise (32 bit y 64 bit [EM64T])
  • Windows Server 2016 (64 bits)

Ubuntu

16.04 LTS o posterior (64 bits)

macOS

10.13 High Sierra o posterior

Los siguientes sistemas operativos (con sus versiones mínimas) son compatibles con AppStudio Player:

Sistema operativoVersión de SO
Windows

  • Versión mínima 1809 de Windows 10 Pro y Windows 10 Enterprise (32 bits y 64 bits [EM64T])
  • Windows 8.1, Windows 8.1 Pro y Windows 8.1 Enterprise (32 bits y 64 bits [EM64T])
  • Windows Server 2016 (64 bits)

Ubuntu

16.04 LTS o posterior (64 bits)

macOS

10.13 High Sierra o posterior

Android

5.0 Lollipop o posterior (ARMv7 32 bits), 6.0 Marshmallow o posterior (ARMv8 64 bits)

iOS

12 o posterior (64 bits)

Precaución:

La compatibilidad con iOS se limitó a dispositivos de 64 bits con AppStudio Player 3.0. Para obtener información sobre qué dispositivos iOS son compatibles, consulte la compatibilidad con arm64 en la documentación de desarrollador de Apple sobre compatibilidad de dispositivos.

Ha finalizado la compatibilidad con Windows 7 para AppStudio y AppStudio Player 4.2 debido a que Microsoft dio fin a su soporte ampliado para Windows 7 el 14 de enero de 2020. Para obtener más información, consulte el artículo de ayuda de Microsoft sobre la finalización del soporte de Windows 7.

Un sistema operativo solo puede ser compatible si también lo es con Qt SDK de The Qt Company.

DirectX

ArcGIS Runtime utiliza ANGLE, que se renderiza mediante DirectX para proporcionar representación en pantalla de mapas de alto rendimiento. DirectX ofrece compatibilidad con la representación de gráficos por hardware y software y se proporciona en las plataformas Windows compatibles. La representación en pantalla del software DirectX se usa si la compatibilidad con el hardware DirectX no está disponible (se incluyen las máquinas virtuales).

Requisitos de hardware

A continuación, se muestran los requisitos mínimos para ejecutar ArcGIS AppStudio en dispositivos Windows, macOS y Ubuntu.

HardwareRequisito

Velocidad de CPU

2,2 GHz como mínimo o superior; se recomienda Hyper-threading (HHT) o multinúcleo

Procesador

Plataforma

Procesadores Intel Pentium 4, Intel Core Duo o Xeon; SSE2 como mínimo

Windows: ejecuta esta utilidad de Microsoft desde la ventana de comando de Windows para comprobar su procesador.

Memoria/RAM

2 GB o superior

Propiedades de visualización

Profundidad de color de 24 bits

Resolución de pantalla

1.024 x 768 recomendada o superior a tamaño normal (96 ppp)

Espacio de intercambio

Determinado por el sistema operativo; 500 MB como mínimo.

ArcGIS Runtime creará archivos de caché cuando se utilice; es posible que se requiera más espacio en disco.

Adaptador de vídeo/gráficos

64 MB de RAM como mínimo; 256 MB de RAM recomendados como mínimo. Se admiten chipsets NVIDIA, ATI y Intel.

Controlador de tarjeta gráfica acelerada

Se requiere el tiempo de ejecución mínimo de la versión 2.1 de OpenGL para visualizar mapas 2D y la versión 3.2 de OpenGL para visualizar escenas 3D. Se recomienda Shader Model 3.0 como mínimo. Asegúrese de utilizar el controlador más actualizado disponible.

Interfaz de usuario

Linux: X Windows con Gnome o KDE Desktop Environment

Idiomas compatibles

AppStudio admite los siguientes idiomas:

Alemán, árabe, bosnio, catalán, checo, chino simplificado, chino tradicional (Hong Kong), chino tradicional (Taiwán), coreano, croata, danés, esloveno, español, estonio, finés, francés, griego, hebreo, húngaro, indonesio, inglés, italiano, japonés, letón, lituano, neerlandés, noruego, polaco, portugués (Brasil), portugués (Portugal), rumano, ruso, serbio, sueco, tailandés, turco, ucraniano y vietnamita.

La configuración de idioma del dispositivo determinará el idioma utilizado.