This is an archive related to a previous version of ArcGIS Maps for Office. If you need the current version go to http://doc.arcgis.com/en/maps-for-office/.

Add a dynamic map to a PowerPoint slide

ArcGIS Maps for Office provides a fully updated experience for enhancing your PowerPoint presentations with interactive, dynamic maps by making it simpler and quicker to search for content. Add maps directly to PowerPoint using content from your ArcGIS organization, or edit existing map slides. Insert the map into a slide and position it as desired—on its own or combined with other standard PowerPoint features such as charts, images, and text. In Slide Show mode, click Play on the map and it becomes fully interactive-you can zoom and pan across the map and select features to display detailed information.

Add a map to a slide

To add a map to a PowerPoint slide, do the following:

  1. On the PowerPoint ribbon, click the ArcGIS Maps tab to display the ArcGIS Maps ribbon.
  2. Click Sign in to sign in to your ArcGIS account.
  3. Create a new slide or browse to the slide to which you want to add a map.
  4. On the ArcGIS Maps ribbon, click Add Map.

    The Insert New Map wizard opens, displaying the first tab of the workflow, Browse for Maps.

    Browse for maps

  5. Search for a web map to add to your slide. Do one of the following:
    • Click the My Content tab to display content from your ArcGIS account. Click on a folder to display its contents.
    • Click Recent to list the last five maps that you used on the current computer.
    • Click Favorites to list the items that you've marked as a favorite in ArcGIS.
    • Type one or more keywords in the Search field and press Enter.
    • Click Groups to see content available to the ArcGIS groups to which you belong.

    The list pane on the right displays the results of your search or the contents of the selected folder. Click on a map listing to select it and click on the Info button (Info) to view details about the map.

  6. Click Next.

    The Choose Layers tab opens, listing all the layers available in the web map you selected.

  7. Check the box beside a layer to include it in your map slide. Clear the check box beside layers you don't want to include.

    Choose layers to include in your map slide

  8. Click Next.

    The Configure Legend tab opens, showing an empty Legend pane.

  9. To add map keys to the legend, click the Add button (+) beside the entry in the layers pane.

  10. To configure the map legend, do the following:
    • Click and drag map keys in the legend to change their order.
    • Click Edit (pencil) to change the name of the map key.
    • Click Delete (X) to remove the key from the legend.
    • Click the Theme button (Legend Theme) to change the theme for the Legend pane. Clicking the button toggles between Light (white background and black text) or Dark (grey background and white text).
  11. Click Next.

    The Choose Layout tab opens, showing various slide layout options.

  12. Choose the layout to use for the map-enabled slide.

    Choices include the following:

    • Default Layout—The map is added to the layout of the current slide
    • Fill Bottom—The map fills the bottom half of the slide's content area
    • Fill Right—The map fills the right side of the slide's content area
    • Fill Slide—The map fills the entire content area of the slide

  13. Click Next.

    The Review Map and Insert tab opens, showing a preview of the map and legend on the slide. Review the size, extent, and zoom level of the map make any necessary changes. Drag the legend to reposition it.

    Review map and insert

  14. Click Insert to add the map to the current slide.

    The wizard closes and the map-enabled slide appears. In Design mode, the map and legend appear as two static images; you can resize each image and reposition them on the slide as desired. To interact with the map, you must be Slide Show mode and activate the map to make it dynamic.

Edit an existing map

Using the Edit Map wizard, you can quickly edit a map that was previously added to a slide.

To edit an existing map slide, do the following:

  1. On the PowerPoint ribbon, click the ArcGIS Maps tab to display the ArcGIS Maps ribbon.
  2. Click Sign in to sign in to your ArcGIS account.
  3. In your presentation, browse to the slide that contains the map you want to modify and click on the map image on the slide.
  4. On the ArcGIS Maps ribbon, click Edit Map.

    The Edit Map wizard opens on the Review Map and Insert tab, displaying the current settings for your map.

  5. Click the appropriate tab to make the necessary modifications. Do one or more of the following:
    • To change the map itself, click Browse for Maps and choose a new map.
    • To change the layers that appear on your map slide, click Choose Layers and change the current selection.
    • To change the legend, click Configure Legend and change the configuration options.
    • To change the slide layout, click Choose Layout and choose a different layout from the available options.
  6. When you've completed your changes, click Review Map and Insert.

    Review the size, extent, and zoom level of the map and make any necessary changes. Drag the legend to reposition it.

  7. Click Insert.

    The wizard closes and the map is updated in the slide. To interact with the map, you must be in Slide Show mode and activate the map to make it dynamic.

Activate the map

When you add a map to a slide, the map and legend appear as two static images on the slide while you're working on the presentation. When you switch to Slide Show mode, clicking the Unlock Map button on the map brings the map to the forefront of the slide and makes it dynamic. The map legend remains a static image.

To activate a map on a slide, do the following:

  1. Open your PowerPoint presentation in Slide Show mode.
  2. On the map-enabled slide, click Unlock Map (Unlock Map) on the map.
    Click Unlock Map to make the map dynamic

    The map becomes fully dynamic, allowing you to zoom in and out, pan across the map, and click on features to display detailed information about locations.

  3. To place the map in full-screen mode, click the Full Screen button (View map in full-screen mode) on the map.

    The map expands to fill the entire display area, hiding the legend and any other elements on the slide.

  4. To view the Contents pane, click the double arrows (Show/Hide Contents) in the upper left corner of the map.

    The Contents pane shows all the layers available in the web map, including any layers that were turned off in the Add Map wizard. Check or uncheck the boxes beside the layer names to hide or display layers.

    Click the double arrows to close the Contents pane.

  5. To resume your presentation, deactivate the map by clicking the Lock Map (Lock Map) button on the map, or press the Escape key.