Mostrar tabelas (Map Viewer Classic)

Para visualizar informações sobre feições em uma camada, você pode exibir uma tabela interativa na parte inferior do mapa no Map Viewer Classic ou na guia Dados da página do item da camada de feição. A visualização tabular dos dados pode ser um caminho rápido para analisar informações e começar a tomar decisões. Você pode classificar, redimensionar, reordenar e ocultar os dados, como também, selecionar atributos específicos para visualizar no mapa. Por exemplo, você pode mostrar uma tabela para uma camada de crimes e ver os diferentes tipos de crimes aos quais seu distrito respondeu nos últimos dois anos.

Você pode visualizar e classificar os dados de atributos exibidos na tabela para ajudá-lo a entender melhor sua camada de feição. Você também pode obter mais informações sobre a camada visualizando quaisquer tabelas de dados relacionadas disponíveis, como também, quaisquer fotos relacionadas ou outros anexos de arquivo. Se você tiver privilégios para editar a camada, você poderá editar ou excluir valores de atributo e anexar fotos e arquivos relacionados. Consulte Editar tabelas para mais informações. Se você for o proprietário da camada, será possível executar operações de edição em massa, como calcular valores de campo e anexar dados . Como proprietário da camada, você também pode alterar os tipos de informações armazenadas na camada ao adicionar e excluir dados.

Dica:

Mostrar as tabelas pode ser um caminho útil para verificar quais feições aparecerão no mapa. Se a camada tiver feições que não são importantes para seu público, você poderá instalar uma visualização mais focada da camada por aplicação de filtros.

Mostrar uma tabela no Map Viewer Classic

Para mostrar uma tabela de atributo da camada de feição no Map Viewer Classic, faça o seguinte:

  1. Abra o mapa com a camada de feição cujo atributos você deseja visualizar em uma tabela.
  2. Clique em Detalhes e clique em Conteúdo.
  3. Procure pela camada de feição e clique em Mostrar Tabela Mostrar Tabela.

    A tabela aparece na parte inferior do seu mapa.

    Dica:

    Para redimensionar a tabela verticalmente, arraste a barra de divisão que está centralizada acima do título da tabela para cima ou para baixo.

  4. Clique em Ocultar Tabela Ocultar Tabela para fechar a visualização da tabela no mapa.

Mostrar uma tabela na página do item

Para mostrar uma tabela na página do item de uma camada de feição, faça o seguinte:

  1. Vá até a página do item da camada de feição cujo atributos você deseja visualizar em uma tabela.
  2. Clique na guia Dados.

Visualizar atributos e registros relacionados

Após a tabela estar aberta no mapa, você pode visualizar os atributos da camada. Se o proprietário da camada de feição criou um relacionamento entre a camada de feição e outra tabela, você também visualizará os atributos a partir das tabelas relacionadas. Os atributos das tabelas relacionadas são representados como colunas com cabeçalhos grifados no lado direito da tabela.

Dica:

Para criar uma camada de feição que contenha registros relacionados, publique camadas do ArcMap.

Você pode manipular a tabela das seguintes maneiras para ajudar a localizar os dados que deseja:

  • Para facilitar a localização dos valores de atributo específicos, classifique os atributos clicando no cabeçalho da coluna e selecionando Ordem Crescente ou Ordem Decrescente.

    Por exemplo, se deseja localizar todos os registros (linhas) dos roubo de veículo de motor em uma tabela de crimes em seu distrito, clique no cabeçalho da coluna de crime_type e selecione Ordem Decrescente. Os registros serão classificados em ordem alfabética invertida baseado em valores de crime_type e você poderá rolar por todos os registros do roubo de veículo de motor.

    Anotação:

    Serviços da web de algumas versões mais antigas do ArcGIS Server não suportam classificação.

  • Você pode ocultar colunas para dar lugar na visualização dos atributos que você precisa. Para ocultar ou mostrar os campos de atributos, clique em Opções e clique em Mostrar/Ocultar Colunas. Marque as caixas para mostrar as colunas de atributos. Desmarque as caixas para ocultá-las.

    Por exemplo, você pode ocultar as colunas de ID, latitude e longitude na tabela de crimes então você somente visualizará os dados de crime_type, date_time_reported, officers, arrest_made e case_number.

  • Para reorganizar as colunas, você deve editar os pop-ups da camada.
    1. Clique no botão Mais Opções Mais Opções na camada no painel Conteúdo.
    2. Clique em Configurar Pop-up e clique em Configurar Atributos.
    3. Selecione os nomes de campo das colunas que deseja reorganizar e utilize as setas Mover para cima e Mover para baixo para alterar a ordem das colunas. As colunas listadas de cima para baixo correspondem a sua visualização da esquerda para a direita na tabela.
    4. Clique em OK na caixa de diálogo Configurar Atributos e o painel Configurar Pop-up para aplicar suas alterações.
    Anotação:

    A reorganização das colunas é somente suportada no Map Viewer Classic.

  • Para visualizar registros relacionados, clique em Mostrar na célula da coluna correspondente ao registro do qual deseja visualizar os registros relacionados.

    Para exemplo, a camada de crime é relacionada à tabela de casos. Para visualizar os detalhes na tabela de casos que são relacionados a um crime em particular, clique em Mostrar na célula apropriada da coluna case_number. A partir daí, você pode explorar outros registros na tabela de casos. Se a tabela relacionada tiver registros relacionados propriamente, você também poderá examiná-los—por exemplo, se a tabela de casos tiver uma tabela relacionada de evidence_collected, clique em Mostrar para visualizar os registros de evidência relacionados.

  • Ao visualizar uma tabela relacionada, clique no botão (X) Fechar em qualquer momento para retornar à tabela anterior.
  • Você também pode ocultar ou mostrar as colunas em tabelas relacionadas. Clique no botão Opções Opções na tabela relacionada e clique em Mostrar/Ocultar Colunas. Marque as caixas para mostrar as colunas. Desmarque as caixas para ocultá-las.

Visualizar estatísticas para um campo numérico

Você pode visualizar informações sobre cada campo (coluna) em uma tabela de atributos. As informações disponíveis para você incluem o tipo e o tamanho dos dados de campo e se o campo é obrigatório, é editável ou tem uma restrição exclusiva aplicada a ele.

Se o campo armazenar dados numéricos, também será possível visualizar estatísticas, como o número de linhas, o valor mínimo e máximo, a soma de todos os valores, o valor médio e o desvio padrão de todos os valores.

Siga estas etapas para visualizar as estatísticas de um campo numérico:

  1. Clique no cabeçalho da coluna do campo que contém valores numéricos para os quais você deseja obter estatísticas.
  2. Faça um dos seguintes:
    • Se você estiver visualizando a tabela a partir da guia da página do item Dados, clique em Mostrar Visualização Detalhada. A tabela reduz para uma visualização mais focada do campo que você selecionou com as informações de estatística exibidas.
    • Se você estiver visualizando a tabela no Map Viewer Classic, clique em Estatísticas. A estatística calculada são exibidas.

Visualizar fotos e arquivos relacionados

As camadas de feição podem incluir fotos relacionadas ou outros arquivos como anexos, que podem ser visualizados na tabela de atributos.

Faça qualquer dos seguintes para visualizar fotos e arquivos relacionados:

  • Se a camada tiver fotos ou arquivos relacionados, visualize-os clicando em Mostrar na célula apropriada da coluna Fotos e Arquivos à direita da tabela.
  • Para ocultar ou mostrar as colunas de fotos e arquivos relacionados, clique no botão Opções Opções e clique em Mostrar/Ocultar Colunas. Marque as caixas para mostrar colunas. Desmarque as caixas para ocultá-las.

Selecionar e ampliar as feições

No Map Viewer Classic, você pode utilizar uma tabela de atributos da camada de feição para selecionar e ampliar as feições no mapa. Para fazer isto, siga um destes procedimentos:

  • Para ampliar uma feição no mapa, clique em um registro (linha) na tabela, clique no botão Opções Opções e clique em Centralizar na Seleção.
  • Para selecionar múltiplas feições no mapa, pressione a tecla Shift e selecione múltiplos registros ou intervalos de registros. Pressione a tecla Ctrl para selecionar dois ou mais registros não adjacentes.
  • Para limpar uma seleção, clique no botão Opções Opções e clique em Limpar Seleção. Esta opção é útil para limpar todos os registros selecionados.
  • Para criar uma expressão de consulta que filtra quais dados de feição aparecem no mapa e tabela, procure pela camada de feição com o filtro existente no painel Conteúdo e clique em Filtrar Filtrar.
  • Para selecionar rasters visíveis em uma camada de imagem em sua área de interesse atual e no tamanho de pixel atual, clique no botão Opções Opções e clique em Selecionar Rasters Visíveis.
  • Para exibir rasters selecionados em uma camada de imagem, clique no botão Opções Opções, selecione uma ou mais linhas de rasters e clique em Exibir Rasters Selecionados.
  • Para exibir rasters selecionados em uma camada de imagem, clique no botão Opções Opções, selecione uma ou mais linhas de rasters e clique em Exibir Rasters Selecionados e clique em Exibir Todos os Rasters. (Após selecionar Exibir Todos os Rasters, o nome do botão muda para Exibir Todos os Rasters.)

As considerações ao visualizar tabelas

Lembre-se do seguinte ao visualizar as tabelas:

  • Você pode utilizar uma tabela para visualizar estes tipos de camadas: serviços de mapa e de feição de um ArcGIS Server 10 SP1 ou site mais antigo, camadas de feição hospedadas, camadas de mosaico hospedadas com dados de atributo associados, shapefiles, arquivos GPX e CSV (arquivos e web).
  • A seleção e zoom nas feições não são suportadas em tabelas exibidas na guia Dados da página do item.
  • No Map Viewer Classic, as tabelas exibem os mesmos campos de atributos e formatação que são configuradas em pop-ups. Você pode alterar um nome de campo, editando o nome alternativo do campo na janela Configurar Atributos das Propriedades do Pop-up. Se você fizer atualizações na configuração pop-up enquanto a tabela estiver aberta, você deve ocultar e mostrar a tabela para ver as atualizações.
  • No Map Viewer Classic, se você selecionar um único registro para ampliar, o mapa ampliará na extensão da feição se a feição for uma linha ou polígono. Se a feição for um ponto, o mapa moverá até a feição, se necessário, ampliará na escala onde a feição é visível.
  • No Map Viewer Classic, se você selecionar múltiplos registros para ampliar, o mapa ampliará na extensão de todas as feições. Você não poderá visualizar todas as feições se a extensão de todas as feições selecionadas estiver fora da faxia de visibilidade da camada.
  • No Map Viewer Classic, se você selecionou um registro na tabela e abriu a janela pop-up no mapa, você limpará a seleção na tabela.
  • No Map Viewer Classic, se a camada estiver oculta no mapa, você não poderá ampliar na seleção.
  • A tabela de atributos das camadas em um mapa habilitado ao tempo sempre mostrará todos os registros, não somente aqueles que o mapa está mostrando na tela em um tempo fornecido.