Publier sur le web

Une fois que vous avez conçu un rapport cartographique, vous pouvez utiliser la fonction Power BI Publish to web (Publier sur le web) pour l’ajouter à un site web public ou à un article de blog. Bien que les concepteurs utilisent généralement Power BI Desktop pour créer des rapports, ce processus est également disponible dans le service Power BI (powerbi.com).

Conditions requises

Pour utiliser la fonction Publish to web (Publier sur le web) dans Power BI, les conditions suivantes doivent être remplies :

  • Vous devez être connecté à un compte ArcGIS valide avec le type d’utilisateur approprié.
  • Pour créer un rapport cartographique dans Power BI, vous devez être connecté à Power BI avec un compte Pro ou Premium. Les utilisateurs n’ont pas besoin d’être des utilisateurs Power BI pour consulter les rapports publiés.
  • Les données Power BI utilisées pour créer la carte ArcGIS for Power BI doivent utiliser coordonnées de latitude et de longitude pour les emplacements. Si le champ secondaire Location (Emplacement) contient des adresses ou des limites standard, la publication sur le web ne fonctionne pas.
  • Une carte publiée peut contenir 30 000 emplacements maximum.
  • La carte ne doit pas contenir de données sécurisées. Les cartes qui comportent des données sécurisées ne peuvent pas être publiées.
  • Vous devez exécuter la vérification préalable à la publication ArcGIS for Power BI avant de générer un code intégré pour le rapport.
  • Les utilisateurs ne peuvent pas se connecter à des rapports publiés.

Créer et vérifier un rapport cartographique

Utilisez ArcGIS for Power BI Desktop ou le service ArcGIS for Power BI (powerbi.com) pour créer un rapport cartographique.

Avant de pouvoir publier le rapport sur le web, exécutez la fonction Publish (Publier) et intégrez la vérification dans la visualisation ArcGIS for Power BI pour vous assurer que toutes les conditions sont remplies.

Pour vérifier un rapport cartographique à publier :

  1. Créez un rapport qui contient une carte ArcGIS for Power BI et enregistrez le rapport.
  2. Le visuel ArcGIS for Power BI étant actif, cliquez sur Settings (Paramètres) Paramètres pour afficher la fenêtre Settings (Paramètres).
    Remarque :

    Si nécessaire, cliquez sur Map tools (Outils cartographiques) Map tools pour développer le jeu d’outils.

  3. Dans la fenêtre Settings (Paramètres), dans la catégorie Embed and publish check (Vérification de l’intégration et de la publication), cliquez sur Validate (Valider).
    Remarque :

    Vous devez être connecté à compte d’organisation ArcGIS valide pour voir la section Embed and publish check (Vérification de l’intégration et de la publication) dans la fenêtre Settings (Paramètres)

  4. Dans la fenêtre Embed and publish check (Vérification de l’intégration et de la publication), cliquez sur Validate (Valider).

    La vérification permet de vérifier que toutes les conditions pour la publication de la carte ont été remplies. On compte les suivantes :

    • Les données de localisation Power BI sont exprimées en coordonnées de latitude et de longitude.
    • La carte contient uniquement les couches accessibles au public depuis ArcGIS.
    • Aucune couche ne contient de contenu sécurisé ou premium.

  5. Consultez le message qui s’affiche une fois la vérification terminée.

    Les couches qui remplissent toutes les conditions requises sont affichées avec une coche verte Réussite Si un élément ne remplit pas les conditions requises, une coche rouge Échec apparaît à côté de l’élément. Cliquez sur Show error details (Afficher les détails de l’erreur) pour afficher les informations concernant l’erreur.

  6. Corrigez des erreurs sur la carte, enregistrez le rapport et réexécutez la fonction Embed and publish check (Vérification de l’intégration et de la publication).

    Lorsque la vérification se termine correctement, un message s’affiche et indique que la carte a réussi cette étape et est prête à être publiée avec le rapport.

Publier un rapport cartographique sur le web

Une fois que vous avez créé et vérifié votre rapport cartographique, publiez-le sur la plateforme Power BI. Le rapport doit se trouver dans le service Power BI (powerbi.com) pour activer l’intégration ou la publication sur le web. Vous générez un lien intégré associé au rapport et copiez le code obtenu sur votre page web.

Pour intégrer un rapport cartographique sur le web, procédez comme suit :

  1. Dans le menu Power BI, cliquez sur File (Fichier) > Publish to Power BI (Publier dans Power BI). Vous pouvez également cliquer sur le bouton Publish (Publier) sur le ruban Power BI.
    Remarque :

    Vous pouvez également mettre à jour manuellement le fichier PBIX dans le service Power BI.

  2. Dans le fenêtre Publish to Power BI (Publier dans Power BI), sélectionnez My Workspace (Mon espace de travail) et cliquez sur Select (Sélectionner).

    Lorsque le rapport est publié correctement, un message de confirmation s’affiche.

  3. Fermez Power BI Desktop.
  4. Ouvrez le rapport dans le service Power BI et enregistrez le rapport.

    Vous devez ouvrir le rapport dans le service Power BI et enregistrer le rapport avant de pouvoir le publier sur le web ou l’intégrer dans un site web, qu’il s’agisse d’un nouveau rapport ou d’un rapport existant. Cela permet à ArcGIS for Power BI de vérifier que les conditions requises pour la publication ou l’intégration sont remplies.

  5. Pour sélectionner Publish to web (Publier sur le web) :
    • En mode Reader (Lecture), cliquez sur Share (Partager) pour afficher le menu contextuel et sélectionnez Publish to web (Publier sur le web) (public).
      En mode Reader (Lecture), cliquez sur le bouton Share (Partager) pour accéder à la fonction Publish to web (Publier sur le web).
    • En mode Edit (Édition), cliquez sur File (Fichier) > Publish to web (Publier sur le web).
      En mode Edit (Édition), développez le menu File (Fichier) pour accéder à la fonction Publish to web (Publier sur le web).
    Remarque :

    Si vous ne parvenez pas à voir les options du menu Publish to web (Publier sur le web), contactez votre administrateur Power BI pour demander l’autorisation de créer des codes intégrés.

  6. Dans la fenêtre Embed in a public website (Intégrer un site web public), cliquez sur Create embed code (Créer du code intégré).
  7. Lisez la mention sur le partage public en vous assurant que vous avez l’autorisation de partager publiquement le contenu du rapport. Si vous acceptez, cliquez sur Publish (Publier) ou sur Close (Fermer) pour annuler l’opération.
  8. Lorsque le code intégré a bien été généré, une confirmation s’affiche et répertorie les deux options utilisables pour intégrer le rapport sur un site Web public. Effectuez l'une des opérations suivantes :
    • Pour intégrer un lien dans un courrier électronique ou un article de blog, copiez le lien dans le premier champ et collez-le dans le corps du message électronique ou de l’article.
    • Pour intégrer le rapport dans une page web, copiez le code iFrame à partir du deuxième champ, à l’aide du menu déroulant pour spécifier la taille du cadre à utiliser pour contenir le rapport. Collez le code dans votre page web et publiez la page.

Le rapport s’affiche sur la page web publiée.

Copier du code intégré

Tous les rapports publiés doivent être associés à un code intégré correspondant. Ces codes sont stockés dans votre espace de travail Power BI et peuvent être gérés à tout moment. Lorsque vous supprimez du code intégré, le rapport associé n’est plus publié et ne s’affiche pas dans les pages où il a été publié.

Pour supprimer du code intégré, procédez comme suit :

  1. Ouvrez le rapport publié dans le service Power BI.
  2. Sur le ruban principal Power BI, cliquez sur More options (Autres options) Plus pour afficher le menu contextuel puis cliquez sur Settings (Paramètres) > Manage embed codes (Gérer les codes intégrés).

    Une liste de toutes vos codes actifs de publication sur le web s’affiche.

  3. Pour supprimer du code, sélectionnez-le dans la liste, cliquez sur More options (Autre options) Plus pour afficher le menu contextuel et sélectionnez Delete (Supprimer).
  4. Dans le message de confirmation qui s’affiche, cliquez sur Delete (Supprimer).

Lorsque le code a été supprimé correctement, le rapport associé à ce code n’est plus publié et ne s’affiche pas dans les pages web publiées.

Pour plus d’informations sur la publication sur le web, reportez-vous à la section Publier sur le web dans Power BI.