Skip To Content

Créer votre premier classeur

Dans cet exercice, vous êtes analyste d'affaires pour un consortium d'universités qui souhaite lancer une campagne marketing dans les Etats disposant d'universités prestigieuses. Vous disposez de données émanant du ministère américain de l’éducation que vous pensez pouvoir exploiter dans le cadre de votre campagne. Vous allez utiliser ArcGIS Insights pour examiner les données dont vous disposez et commencer à vous interroger à leur sujet. En moins de 30 minutes, vous effectuerez les tâches suivantes :

  • Ajouter des données à Insights.
  • Démarrer Insights et vous connecter à votre compte.
  • Créer un classeur et y ajouter des données provenant de votre propre contenu
  • Découvrir certains des boutons importants de votre classeur
  • Créer des cartes, des diagrammes et des tables pour vous familiariser avec vos données
  • Interagir avec les fiches, y compris par des zooms, des déplacements et des sélections

Remarque :

Pour terminer l’exercice, les spécifications de votre compte doivent être les suivantes :

  • Type d’utilisateur Creator, GIS Professional ou Insights Analyst
  • Rôle d’éditeur ou d’administrateur, ou rôle personnalisé équivalent
  • Licence Insights (non requise avec un type d’utilisateur Insights Analyst)

Pour plus d’informations, reportez-vous à la rubrique Administrer Insights in ArcGIS Enterprise et and Insights in ArcGIS Online.

Ajouter des données à votre organisation

Les données pour cette analyse ont été mises à la disposition du public sur le site Web ArcGIS, à partir duquel vous pouvez les télécharger sur votre ordinateur. Pour accéder aux données et les charger dans Insights, procédez comme suit :

  1. Cliquez sur le lien pour accéder à l’élément CollegeScorecard.
  2. Cliquez sur le bouton Download (Télécharger) pour télécharger l'élément sur votre ordinateur.
  3. Décompressez le dossier et enregistrez le fichier Microsoft Excel sur votre ordinateur, à un emplacement facile à trouver.
  4. Connectez-vous à votre organisation.
    • Connectez-vous à Insights in ArcGIS Online en procédant comme suit :
      1. Accédez à la page de destination de Insights in ArcGIS Online.
      2. Cliquez sur Sign in (Se connecter).
      3. Saisissez vos nom d’utilisateur et mot de passe.
      4. Cliquez sur Connexion.
    • Connectez-vous à Insights in ArcGIS Enterprise en procédant comme suit :
      1. Connectez-vous à votre compte Portal for ArcGIS via l’URL de votre organisation (par exemple, http://myserver.mycompany.com/portal/home). Si vous ne connaissez pas cette URL, contactez votre administrateur.
      2. Cliquez sur le bouton App launcher (Lanceur d’applications) pour afficher le menu de votre application.
        Bibliothèque d’applications
      3. Cliquez sur Insights.
      4. Saisissez de nouveau vos nom d’utilisateur et mot de passe, s’il y a lieu.
    • Connectez-vous à Insights desktop en procédant comme suit :
      1. Lancez Insights desktop sur votre ordinateur.
      2. Cliquez sur Sign In (Se connecter) en haut de la page.
      3. Saisissez votre nom d’utilisateur et votre mot de passe associés à votre connexion ArcGIS principale.
      4. Cliquez sur Connexion.

Une fois que vous avez lancé Insights, la page d’accueil apparaît. Si c’est la première fois que vous vous connectez à votre compte Insights, la fenêtre de bienvenue s’affiche. Vous pouvez parcourir le vidéorama ou accéder directement à la page d’accueil.

Créer un classeur

Dans Insights, vous réalisez une analyse dans un classeur. Un classeur stocke l’ensemble des pages, données et traitements de votre analyse. Procédez comme suit pour créer un nouveau classeur.

  1. Cliquez sur l’onglet Workbooks (Classeurs) Classeurs.
  2. Sur la page Workbooks (Classeurs), cliquez sur New workbook (Nouveau classeur).
  3. La fenêtre Add to page (Ajouter à la page) s’ouvre sur l’onglet Data (Données) Données. L’onglet Data (Données) regroupe les sources de données auxquelles vous avez accès dans votre déploiement actuel.
  4. Cliquez sur Upload file (Télécharger le fichier).
  5. Cliquez sur le bouton Browse my computer (Parcourir mon ordinateur) et ouvrez le fichier Excel ou faites-le glisser vers la fenêtre Add to page (Ajouter à la page). Cliquez sur Add (Ajouter).
  6. Le classeur s’ouvre avec le jeu de données CollegeScorecard.Table1 dans la fenêtre de données.
  7. Cliquez sur Classeur sans titre (Untitled Workbook), puis remplacez ce texte par un titre unique et descriptif comme Universités américaines - votre nom. Le fait d'inclure votre nom dans le titre rendra votre classeur plus facile à trouver si vous partagez votre travail. Cliquez sur le bouton Save (Enregistrer) Enregistrer dans la barre d’outils du classeur.

Explorer votre classeur

Cette section vous présente certains des aspects clés de l’interface utilisateur afin que vous soyez plus à l’aise avec son utilisation avant de commencer à examiner vos données. Si vous êtes déjà familiarisé avec les boutons et les contrôles de Insights, vous pouvez ignorer cette section.

  1. Examinez le classeur et prenez note de certaines des fonctionnalités clés :

    • Le bouton Add (Ajouter) Ajouter permet d’ajouter un nouveau jeu de données à votre page.
    • Les boutons Map (Carte) Carte, Chart (Diagramme) Diagramme et Table Table permettent de créer des fiches sans faire glisser les champs ou les jeux de données. Les trois boutons sont grisés, car aucune donnée n’a été sélectionnée.
    • Le bouton Create Relationships (Créer des relations) Créer des relations permet de joindre des jeux de données à l’aide de champs communs.
    • Les boutons Undo (Annuler) Annuler et Redo (Rétablir) Rétablirpermettent d’annuler et de rétablir des actions (par exemple, réaliser une analyse ou créer une fiche).
    • Le bouton Widget Widget permet d’ajouter d’autres types de fiches, tels que des fiches de texte et d’éléments multimédias, ou des filtres prédéfinis.
    • Le bouton Scripting (Script) Scripts (disponible dans Insights in ArcGIS Enterprise et Insights desktop) permet d’ouvrir l’environnement de script.
    • Le bouton Basemaps (Fonds de carte) Fonds de carte permet de changer le fond de carte de vos fiches de carte.
    • Le bouton Analysis view (Vue d'analyse) Vue de l'analyse permet d’afficher un modèle de votre analyse. Le modèle est créé automatiquement pendant que vous utilisez votre classeur.
    • Le bouton Page Settings (Paramètres de la page) Paramètres de la page permet de modifier des paramètres, tels que la couleur d’arrière-plan, pour l’ensemble de la page.

  2. Passez la souris sur le jeu de données dans la fenêtre de données et observez les deux boutons en regard du nom du jeu :

    • Le bouton Rename dataset (Renommer le jeu de données) Renommer le jeu de données est utilisé pour renommer le jeu de données.
    • Le bouton Dataset options (Options de jeu de données) Options du jeu de données permet d’ouvrir un menu contenant d’autres actions disponibles pour le jeu de données.

  3. Cliquez sur le bouton Dataset options (Options du jeu de données) correspondant au jeu de données. Le menu s’ouvre et affiche les options suivantes : Enable Location (Activer la localisation), View Data Table (Afficher la vue tabulaire), Advanced Filter (Filtre avancé), Remove Dataset (Retirer le jeu de données), Hide Selected Fields (Masquer les champs sélectionnés), Show Hidden Fields (Afficher les champs masqués), Copy to Workbook (Copier dans le classeur), Export (Exporter) et Share Data (Partager des données).
  4. Développez le jeu de données dans la fenêtre de données. Les champs du jeu de données s’affichent, ainsi que des symboles représentant le type de champ. Vous pouvez sélectionner les champs et les faire glisser vers la page pour créer des cartes, des diagrammes ou des tables. Vous pouvez également utiliser les boutons situés au-dessus de la fenêtre de données pour créer des cartes, des diagrammes et des tables.
  5. À présent que vous êtes familiarisé avec certains des contrôles de base de Insights, il est temps de commencer à explorer vos données.

Explorer votre carte

Cette section présente certaines des interactions élémentaires possibles avec les fiches de carte. Avant toute chose, vous devez activer l’emplacement sur votre fichier Excel.

  1. Cliquez sur le bouton Dataset options (Options du jeu de données) Options du jeu de données pour le fichier Excel et sélectionnez Enable Location (Activer la localisation) dans le menu.
  2. L’activation de la localisation est réalisée par défaut au moyen des coordonnées. Les champs LONGITUDE et LATITUDE du fichier Excel sont déjà renseignés par défaut.
  3. Cochez la case Repeat identical features (Répéter les entités identiques).

    Lorsque vous cochez la case Repeat identical features (Répéter les entités identiques), toutes les universités du jeu de données sont ajoutées individuellement sur la carte, même si certaines des entités sont répétées. Cette étape sera importante lors de la deuxième leçon, Résoudre un problème spatial.

  4. Cliquez sur Run (Exécuter).
  5. Développez le jeu d’entités dans la fenêtre de données, si nécessaire.
    Un champ d’emplacement est ajouté au jeu de données.
  6. Un nouveau champ d’emplacement nommé Coordinates (Coordonnées) a été ajouté au jeu de données.
  7. Faites glisser le jeu de données vers votre page et déposez-le dans la zone de déplacement Map (Carte) pour créer une carte d’emplacement des universités américaines.
    Créer une carte
  8. Astuce:

    Si vous préférez utiliser des boutons, vous pouvez sélectionner un champ dans le jeu de données et cliquer sur le bouton Map (Carte) Carte situé au-dessus de la fenêtre de données.

    Si le style Count of CollegeScorecard.Table1 est appliqué à votre carte, cela signifie que vous n’avez pas coché l’option Repeat identical features (Répéter les entités identiques) lors de l’activation de la localisation. Cliquez sur le bouton Undo (Annuler) Annuler jusqu’à ce que le champ Coordinates (Coordonnées) soit retiré du jeu de données, puis recommencez à partir de l’étape 1.

  9. Pour agrandir la carte, faites glisser ses coins. Vous pouvez également faire glisser la fiche vers un emplacement différent sur la page.
  10. Appuyez sur la touche Maj et tracez avec la souris un rectangle autour des États du territoire continental des États-Unis pour réaliser un zoom avant. Vous pouvez également utiliser le bouton Zoom tools (Outils de zoom) Outils de zoom situés sur la barre d’outils de la fiche pour réaliser un zoom avant ou arrière.
  11. Sélectionnez le champ TYPE dans la fenêtre de données et faites-le glisser jusqu’à votre carte.
  12. La carte s’actualise pour afficher les universités stylisées avec une couleur unique en fonction du type d’université.
  13. Ouvrez la fenêtre Layer options (Options de la couche) en cliquant sur le bouton Développer Développer la légende en regard de la couche TYPE de la carte.
    Développer la fenêtre Layer options (Options de la couche)
  14. La fenêtre Layer options (Options de la couche) présente les trois types d’établissements, Private For-Profit (Privé à but lucratif), Private Nonprofit (Privé à but non lucratif) et Public, ainsi que le nombre d’entités de chaque type. Il peut être bienvenu d’afficher ces informations continuellement en raison de leur utilité.
  15. Cliquez sur le bouton Pop out legend (Légende contextuelle) Légende contextuelle.
  16. La légende est affichée sous forme de fiche séparée en dessous de la carte. En fonction des dimensions de votre carte, vous pouvez être amené à faire défiler la page vers le bas pour afficher la légende.
  17. Redimensionnez la légende et déplacez-la en bas à gauche de votre carte.
  18. Dans Insights, la légende est interactive et utile pour comprendre les modèles de vos données.
  19. Cliquez sur Private For-Profit (Privé à but lucratif) dans la légende. Les établissements scolaires à but lucratif sont sélectionnés sur la carte, et les autres établissements scolaires se fondent dans l’arrière-plan.
    Sélectionner Private For-Profit (Privé à but lucratif) sur la légende
  20. Il peut être utile de faire des sélections sur la carte en utilisant la légende, pour observer les modèles.
  21. Zoomez et déplacez-vous autour de votre carte pour rechercher des modèles dans les établissements scolaires à but lucratif. Appliquez un zoom à l’aide des outils de zoom ou de la molette de défilement de la souris. Réalisez un déplacement en cliquant sur la carte et la faisant glisser. En cas de confusion, utilisez le bouton Default extent (Étendue par défaut) Etendue par défaut pour zoomer sur l’étendue générale des données.
    Remarque :

    Si besoin, vous pouvez changer de fond de carte pour rendre les étiquettes de ville et les symboles de carte plus visibles. Optez, par exemple, pour le fond de carte Light Gray Canvas (Nuances de gris). Vous pouvez changer le fond de carte en utilisant le bouton Basemaps (Fonds de carte) Fonds de carte.

  22. Les établissements scolaires à but lucratif sont généralement regroupés en milieu urbain et sont essentiellement situés dans la moitié est du territoire continental des États-Unis.
  23. Cliquez sur Private Nonprofit (Privé à but non lucratif) dans la légende pour modifier la sélection sur la carte. Zoomez et déplacez-vous une nouvelle fois autour de la carte pour rechercher des modèles dans les établissements scolaires à but non lucratif.
  24. Les universités à but non lucratif sont moins nombreuses que les universités à but lucratif, comme l’illustrent les valeurs Count (Total) de la légende, et sont moins concentrées dans des zones urbaines. Les universités privées à but non lucratif sont plus nombreuses en Alaska et à Hawaï que les universités privées à but lucratif. Les universités restent majoritairement implantées dans la moitié est des États-Unis.
  25. Cliquez sur Public dans la légende pour modifier la sélection sur la carte. Réalisez une nouvelle fois un zoom et un déplacement pour rechercher des modèles dans les établissements scolaires publics.
  26. La répartition des établissements scolaires publics est légèrement plus uniforme dans l’ensemble du pays, avec notamment un nombre plus élevé d’universités en Alaska, à Hawaï et dans tout le Midwest.
  27. Cliquez de nouveau sur Public pour effacer la sélection.
  28. Enregistrez votre classeur.

Créer des diagrammes et des tables

Il est certes important de rechercher les modèles spatiaux dans vos données, mais il peut également être judicieux de vous intéresser de plus près aux aspects non spatiaux de vos données. C’est possible avec les tables et les diagrammes.

  1. Si besoin, développez le jeu de données CollegeScorecard.Table1.
  2. Les champs du jeu de données sont répertoriés. Chaque champ comporte une icône indiquant le type du champ en fonction du type de données que le champ contient.
  3. Passez la souris sur le champ REGION (RÉGION) dans votre jeu de données, puis cliquez sur le cercle qui s’affiche. Procédez de la même manière pour le champ COST (COÛT). Les cercles bleus entourant les coches indiquent des champs sélectionnés.
  4. Faites glisser vos sélections vers la zone de déplacement Table.
    Créer une table
    Astuce:

    Si vous préférez les boutons aux champs à déplacer, cliquez sur le bouton Table Table au-dessus de la fenêtre de données une fois vos champs sélectionnés.

  5. Une table de synthèse s’affiche sous forme de fiche sur votre page. Chaque région y est répertoriée avec la somme des frais correspondant aux universités de la région.
  6. Il serait plus utile de connaître les frais moyens plutôt qu'une somme des frais. Pour la statistique COST (COÛT), remplacez sum (somme) par average (moyenne). Cliquez deux fois sur les flèches situées en regard de la statistique COST (COÛT) pour trier les frais universitaires dans l’ordre décroissant.
    Paramétrage de la table sur la moyenne et le tri décroissant
  7. La table présente maintenant les régions dans l’ordre décroissant, avec la région aux frais les plus élevés (Nouvelle-Angleterre) en premier et la région aux frais les moins élevés (Sud-Ouest) en dernier. Si la table permet de connaître les valeurs exactes des frais moyens, elle ne permet pas d’avoir un aperçu rapide des différences de frais moyens. Il est possible d’obtenir une représentation plus visuelle des frais en remplaçant la table par un diagramme.
  8. Cliquez sur le bouton Visualization type (Type de visualisation) Type de visualisation sur la fiche, puis sélectionnez Bar Chart (Diagramme à barres). La table s’actualise pour afficher un diagramme à barres.
  9. Maintenant que vous avez examiné les frais moyens par région, vous avez tout intérêt à étudier les frais moyens par type d’université.
  10. Cliquez sur REGION (RÉGION) sur l’axe y du diagramme à barres pour développer un menu de champs. Le champ REGION (RÉGION) est un champ de type chaîne, de sorte que tous les champs répertoriés dans le menu contiennent également des chaînes.
  11. Cliquez sur TYPE pour modifier la valeur sur l’axe. Le diagramme à barres représente maintenant le type d’université et les frais moyens.
  12. Les frais moyens sont les plus élevés dans les universités privées à but non lucratif, et sont les moins élevés dans les universités publiques. Vous pouvez également harmoniser le style du diagramme à barres avec celui de la carte.
  13. Cliquez sur le bouton Legend (Légende) Légende, puis sur l’onglet Options Options si besoin.
  14. Définissez le paramètre Symbol type (Type de symbole) sur Unique symbols (Symboles uniques). Fermez la fenêtre Layer options (Options de la couche).
    Type d’université stylisé avec des symboles uniques
  15. Enregistrez votre classeur.

Analyser vos données avec des statistiques

Vous connaissez maintenant les types d’universités qui facturent les frais les plus élevés. Il serait intéressant de déterminer l’incidence des frais universitaires sur les revenus des jeunes diplômés.

  1. Sélectionnez COST (COÛT) et EARNINGS (REVENUS) dans la fenêtre de données.
  2. Faites glisser les champs vers la zone de déplacement Charts (Diagrammes) et déposez-les sur Scatter Plot (Nuage de points).
    Créer un nuage de points
  3. Un nuage de points, représentant les frais sur l’axe x (horizontal) et les revenus moyens sur l’axe y (vertical), est créé.
    Remarque :

    Si votre nuage de points affiche les champs sur les mauvais axes, vous pouvez les changer à l’aide du bouton Switch axes (Permuter les axes) Permuter les axes.

  4. Cliquez sur Color by (Couleur par) sur l’axe x et sélectionnez TYPE.
  5. Il ressort du nuage de points une relation légèrement positive entre les frais universitaires et les revenus des diplômés. Certaines statistiques du diagramme peuvent vous aider à chiffrer plus précisément cette relation.
  6. Cliquez sur le bouton Chart statistics (Statistiques du diagramme) Statistiques du diagramme sur la barre d’outils de la fiche et sélectionnez Linear (Linéaire). Fermez la fenêtre Chart Statistics (Statistiques du diagramme).
    Ajouter des statistiques au nuage de points
  7. Une ligne de compromis est ajoutée au nuage de points, ainsi que l’équation de la ligne (y=0,51x22 340) et la valeur R² (0,299). La valeur R², que l’on appelle aussi le coefficient de détermination, est une mesure de la qualité de l’ajustement qui indique la force de la relation entre les variables du nuage de points. La valeur R² est comprise entre 0 et 1, les valeurs plus proches de 1 indiquant une relation plus forte. Dans le cas présent, la valeur R² tend vers 0, ce qui indique une faible incidence des frais universitaires sur les revenus des jeunes diplômés. Il serait intéressant de savoir si cette observation se vérifie pour chacun des types d’universités.
  8. Cliquez sur le bouton Enable cross filters (Activer les filtres croisés) Activer les filtres croisés du nuage de points. Unfiltre croisé vous permet de filtrer rapidement les données d’une fiche en effectuant une sélection sur une autre fiche.
  9. Cliquez sur Private For-Profit (Privé à but lucratif) dans la légende de la carte. Les universités à but lucratif sont sélectionnées sur la carte et le diagramme à barres, et le nuage de points est filtré de façon à limiter l’affichage aux établissements à but lucratif.
    Nuage de points filtré par universités à but lucratif
  10. Les statistiques sont recalculées pour les universités à but lucratif. La nouvelle ligne de compromis est toujours positive, mais la valeur R² est maintenant à 0,258. En d’autres termes, les frais de scolarité d’une université à but lucratif ont une très faible incidence sur les revenus des jeunes diplômés. Il ressort du nuage de points que, pour bon nombre d’universités, les revenus de leurs jeunes diplômés sont plus élevés que prévu par référence aux frais de scolarité.
  11. Sélectionnez Private Nonprofit (Privé à but non lucratif) et Public dans la légende de la carte, puis notez les valeurs R² de chaque type d’université.
  12. Les universités privées à but non lucratif et les universités publiques affichent chacune une valeur R² de 0,396. Ces valeurs sont meilleures que celles du jeu de données complet et des établissements scolaires privés à but lucratif, ce qui implique qu’il existe une relation plus forte entre les frais universitaires et les revenus des jeunes diplômés dans les universités à but non lucratif et les universités publiques que dans les universités à but lucratif.
  13. Enregistrez votre classeur. Si vous souhaitez passer à la leçon Résoudre un problème spatial, laissez le classeur ouvert. Sinon, revenez à la page d’accueil à l’aide du bouton Home (Accueil) Home ou quittez Insights.

Etapes suivantes

À présent que vous savez comment utiliser votre classeur, vous pouvez commencer à utiliser vos propres données et votre propre expertise afin de créer des classeurs ayant une importance pour vous.

Vous pouvez également poursuivre ce scénario en vous exerçant avec les leçons Résoudre un problème spatial et Partager votre analyse.