Afficher des tables

Pour voir des informations sur les entités d'une couche, vous pouvez afficher une table interactive au bas de la carte dans Map Viewer ou sur l'onglet Données de la page des éléments de la couche d'entités. L'affichage d'une vue tabulaire des données peut vous permettre d'analyser rapidement les informations et vous aider à prendre des décisions. Vous pouvez trier, redimensionner, réorganiser et masquer les données, ainsi que sélectionner des attributs spécifiques pour les voir sur la carte. Vous pouvez par exemple afficher une table correspondant à une couche de criminalité et voir les différents types de délits commis dans votre circonscription au cours des deux dernières années.

Vous pouvez afficher et trier les données attributaires affichées dans la table pour mieux comprendre votre couche d'entités. Vous pouvez également obtenir davantage d'informations sur la couche en affichant toute table de données correspondante disponible, ainsi que toute photo associée ou autre pièce jointe de fichier. Si vous avez des privilèges permettant de modifier la couche, vous pouvez modifier ou supprimer les valeurs attributaires et joindre des photos et des fichiers associés supplémentaires. Reportez-vous à la rubrique Mettre à jour des tables pour plus d'informations. Si vous êtes le propriétaire de la couche, vous pouvez effectuer des opérations de mise à jour en masse, telles que le calcul des valeurs de champs et l’ajout de données. En tant que propriétaire de la couche, vous pouvez également modifier les types d’informations stockées dans la couche en ajoutant et en supprimant des champs.

Astuce :

L'affichage de tables peut être utile pour voir quelles entités apparaîtront sur votre carte. Si la couche contient des entités qui ne sont pas importantes pour votre public, vous pouvez configurer un affichage plus centré de la couche en appliquant des filtres.

Afficher une table dans Map Viewer

Pour afficher la table attributaire d'une couche d'entités dans Map Viewer, procédez comme suit :

  1. Ouvrez la carte comportant la couche d'entités dont vous souhaitez afficher les attributs dans une table.
  2. Cliquez sur Détails et sur Contenu.
  3. Accédez à la couche d'entités et cliquez sur Afficher la tableAfficher la table. La table apparaît au bas de votre carte.
    Astuce :

    Pour redimensionner la table verticalement, faites glisser la barre de fractionnement qui est centrée au- dessus du titre de la table vers le haut ou le bas.

  4. Cliquez sur Masquer la tableMasquer la table pour fermer la vue tabulaire dans la carte Web.

Afficher une table sur la page des éléments

Pour afficher une table sur la page des éléments d'une couche d'entités, procédez comme suit :

  1. Accédez à la page des éléments de la couche d'entités dont vous souhaitez afficher les attributs dans une table.
  2. Cliquez sur l'onglet Data (Données).

Afficher les attributs et les enregistrements associés

Une fois la table ouverte sur la carte, vous pouvez afficher les attributs de la couche. Si le propriétaire de la couche d'entités a créé une relation entre la couche d'entités et une autre table, les attributs des tables associées sont également visibles. Les attributs des tables associées sont représentés sous forme de colonnes avec les en-têtes en italique sur le côté droit de la table.

Astuce :

Pour créer une couche d’entités contenant des enregistrements associés, publiez la couche depuis ArcMap.

Vous pouvez manipuler la table des façons suivantes pour trouver les données qui vous intéressent :

  • Pour simplifier la recherche de valeurs attributaires spécifiques, triez les attributs en cliquant sur l'en-tête de colonne et en sélectionnant l'option Tri croissant ou Tri décroissant.

    Par exemple, pour rechercher tous les enregistrements (lignes) correspondant à vol de véhicules à moteur dans une table des délits perpétrés dans votre district, cliquez sur l'en-tête de colonne crime_type et sélectionnez Tri décroissant. Les enregistrements sont triés par ordre alphabétique inverse en fonction des valeurs crime_type et vous pouvez parcourir tous les enregistrements correspondant à vol de véhicules à moteur.

    Remarque :

    Les services web de certaines versions antérieures d'ArcGIS Server ne prennent pas en charge le tri.

  • Vous pouvez masquer certaines colonnes pour que les attributs dont vous avez besoin apparaissent plus clairement. Pour masquer ou afficher des champs attributaires, cliquez sur Options et sur Afficher/Masquer les colonnes. Cochez les cases pour afficher les colonnes attributaires. Décochez les cases pour les masquer.

    Vous pouvez par exemple masquer les colonnes ID, latitude et longitude dans la table crimes afin de voir uniquement les données crime_type, date_time_reported, officers, arrest_made et case_number data.

  • Pour réorganiser les colonnes, vous devez modifier les fenêtres contextuelles de la couche.
    1. Cliquez sur le bouton Autres options Autres options sous la couche dans la fenêtre Contenu.
    2. Cliquez sur Configurer la fenêtre contextuelle et sur Configurer les attributs.
    3. Sélectionnez les noms de champ des colonnes que vous souhaitez réorganiser et utilisez les flèches Déplacer vers le haut et Déplacer vers le bas pour modifier l'ordre des colonnes. Les colonnes affichées de haut en bas correspondent à leur affichage de gauche à droite dans la table.
    4. Cliquez sur OK dans la boîte de dialogue Configurer les attributs et la fenêtre Configurer la fenêtre contextuelle pour appliquer vos modifications.
    Remarque :

    La réorganisation des colonnes est uniquement prise en charge dans Map Viewer.

  • Pour afficher les enregistrements associés, cliquez sur Afficher dans la cellule de la colonne correspondant à l'enregistrement pour lequel vous souhaitez afficher les enregistrements associés.

    Par exemple, la couche crime est associée à la table cases. Pour voir les détails de la table cases qui sont associés à un délit en particulier, cliquez sur Afficher dans la cellule appropriée de la colonne case_number. Vous pouvez ensuite explorer d'autres enregistrements de la table cases. Si la table associée dispose de ses propres enregistrements associés, vous pouvez également les consulter. Par exemple, si la table cases possède une table evidence_collected associée, cliquez sur Afficher pour voir ces preuves associées.

  • Lors de l'affichage d'une table associée, cliquez sur le bouton Fermer (X) à tout moment afin de revenir sur la table précédente.
  • Vous pouvez également masquer ou afficher les colonnes dans les tables associées. Cliquez sur le bouton Options Options sur la table associée et cliquez sur Show/Hide Columns (Afficher/Masquer les colonnes). Cochez les cases pour afficher les colonnes. Décochez les cases pour les masquer.

Afficher des statistiques pour un champ numérique

Vous pouvez afficher des informations sur chaque champ (colonne) d’une table attributaire. Les informations à votre disposition sont notamment le type et la longueur des données du champ, si celui-ci est obligatoire ou modifiable, ou si une contrainte unique lui est appliquée.

Si le champ contient des données numériques, vous pouvez également afficher des statistiques telles que le nombre de lignes, les valeurs minimum et maximum, la somme de toutes les valeurs, la valeur moyenne et l’écart type de toutes les valeurs.

Pour afficher des statistiques sur un champ numérique, procédez comme suit :

  1. Cliquez sur l’en-tête de colonne du champ qui contient les valeurs numériques sur lesquelles vous souhaitez obtenir des statistiques.
  2. Effectuez l'une des opérations suivantes :
    • Si vous consultez la table sur l’onglet Data (Données) de la page des éléments, cliquez sur Show Detailed View (Afficher la vue détaillée). La table offre une vue plus ciblée du champ que vous avez sélectionné, avec les informations statistiques affichées.
    • Si vous consultez la table dans Map Viewer, cliquez sur Statistiques. Les statistiques calculées s'affichent.

Afficher des photos et des fichiers associés

Les couches d'entités peuvent inclure des photos associées ou d'autres fichiers en tant que pièces jointes, lesquelles peuvent être visualisées à partir de la table attributaire.

Effectuez l'une des opérations suivantes pour afficher des photos et des fichiers associés :

  • Si la couche a des photos ou fichiers associés, affichez-les en cliquant sur Afficher dans la cellule appropriée de la colonne Photos et fichiers à droite de la table.
  • Pour masquer ou afficher les colonnes de photos et fichiers associés, cliquez sur le bouton Options Options et sur Afficher/Masquer la colonne. Cochez les cases pour afficher les colonnes. Décochez les cases pour les masquer.

Sélection d'entités et zoom sur ces entités

Dans Map Viewer, vous pouvez utiliser la table attributaire d'une couche d'entités pour sélectionner des entités sur la carte et zoomer dessus. Pour cela, procédez comme suit :

  • Pour zoomer sur une entité sur la carte, cliquez sur un enregistrement (ligne) dans la table, cliquez sur le bouton Options Options, puis sur Centrer sur la sélection.
  • Pour sélectionner plusieurs entités sur la carte, maintenez la touche Maj enfoncée et sélectionnez plusieurs enregistrements ou une plage d'enregistrements. Maintenez la touche Ctrl enfoncée pour sélectionner deux enregistrements non adjacents ou plus.
  • Pour effacer une sélection, cliquez sur le bouton Options Options et sur Annuler la sélection. Cette option est utile pour désélectionner tous les enregistrements sélectionnés.
  • Pour créer une expression de requête qui filtre les données d'entité qui apparaissent sur la carte et dans la table, accédez à la couche d'entités avec le filtre existant dans la fenêtre Contenu et cliquez sur Filtrer Filtrer.
  • Pour sélectionner les rasters visibles dans une couche d'imagerie au sein de votre zone d'intérêt actuelle et à la taille de pixel actuelle, cliquez sur le bouton Options Options et sur Sélectionner les rasters visibles.
  • Pour afficher les rasters sélectionnés dans une couche d'imagerie, cliquez sur le bouton Options Options, sélectionnez une ou plusieurs lignes de rasters, puis cliquez sur Afficher les rasters sélectionnés.
  • Pour afficher tous les rasters dans une couche d'imagerie, cliquez sur le bouton Options Options, sélectionnez une ou plusieurs lignes de rasters, puis cliquez sur Afficher les rasters sélectionnés et sur Afficher tous les rasters. (Une fois que vous avez sélectionné Afficher les rasters sélectionnés, le nom du bouton devient Afficher tous les rasters.)

Eléments à prendre en compte lors de la consultation des tables

  • Vous pouvez utiliser une table pour afficher ces types de couches : services de carte et d'entités d'un site ArcGIS Server 10 SP1 ou version ultérieure, couches d'entités hébergées, couches de tuiles hébergées avec données attributaires associées et fichiers de formes, fichiers GPX et CSV (fichiers et web).
  • La sélection et le zoom sur les entités ne sont pas pris en charge dans les tables affichées sur l'onglet Données de la page des éléments.
  • Dans Map Viewer, les tables présentent les champs attributaires et la mise en forme qui sont configurés dans les fenêtres contextuelles. Vous pouvez modifier le nom d'un champ en mettant à jour son alias dans la fenêtre Configurer les attributs de Propriétés de la fenêtre contextuelle. Si vous modifiez la configuration des fenêtres contextuelles alors que la table est ouverte, vous devez masquer et afficher la table pour voir les modifications.
  • Dans Map Viewer, si vous sélectionnez un seul enregistrement sur lequel vous voulez appliquer un zoom, la carte s'adapte à l'étendue de l'entité, si cette dernière est une ligne ou un polygone. Si l'entité est un point, la carte se déplace vers l'entité et, le cas échéant, applique un zoom à une échelle où l'entité est visible.
  • Dans Map Viewer, si vous sélectionnez plusieurs enregistrements sur lesquels appliquer un zoom, la carte s'adapte à l'étendue de toutes les entités. Toutes les entités ne seront peut-être pas visibles si l'étendue de toutes les entités sélectionnées se trouve hors de la plage d'échelle visible de la couche.
  • Dans Map Viewer, si vous avez sélectionné un enregistrement dans la table et ouvert une fenêtre contextuelle sur la carte, la sélection dans la table est effacée.
  • Dans Map Viewer, si la couche est masquée sur la carte, vous ne pouvez pas appliquer un zoom sur une sélection.
  • La table attributaire des couches figurant dans une carte temporelle présente toujours tous les enregistrements, pas seulement ceux que la carte affiche à l’écran à un moment donné.