Skip To Content

Classic locators deprecation

Starting the first quarter of 2021, the classic locators will be phased out and will no longer be included as part of ArcGIS StreetMap Premium. This will impact you if you use ArcMap, older versions of ArcGIS Enterprise, or have a custom workflow dependent on these locators. While Esri will continue to include the classic locators in the product until 2021, only the underlying data will be updated, and there will be no further enhancements to the locators. Classic locators are not supported in ArcGIS Enterprise 10.9.

The following software versions are required to use the new locators:

  • ArcGIS Pro 2.2.4 or later
  • ArcGIS Enterprise 10.6 or later

The following releases will be the last release of the classic locators in ArcGIS StreetMap Premium:

Region Final release versionFinal release date

Middle East/Africa

2020 R1

Q1 2021

North America

2021 R1

Q2 2021

Europe

2021 R1

Q2 2021

Asia Pacific

2021 R1

Q3 2021

Latin America

2021 R1

Q3 2021

Japan

2020 R1

Q1 2021

This transition allows Esri to concentrate on delivering the best content products. See the New Geocoding Locators for StreetMap Premium blog to learn more about the benefits of the new locators. It is Esri's continued goal to provide your organization with the best available map display, geocoding, and routing content through ArcGIS StreetMap Premium. Esri is confident that this change will bring long-term benefits to your organization. Contact your account manager or Esri Customer Service if you have any questions or concerns at +1-888-377-4575.

Note:

Locators created with the Create Address Locator (Geocoding toolbox) will not be supported after ArcGIS Runtime version 100.11. With the 100.12 release, only the locators created with the Create Locator (Geocoding toolbox) will be supported. The deprecated locator format is composed of the files .loc, .loc.xml, .locb, and .loz. The newer locator format is composed of the files .loc and .loz.