Create a project from scratch

This exercise explains how to create an ArcGIS QuickCapture project from scratch using ArcGIS Pro. You will create a pothole assessment project that will allow users to capture potholes of two sizes on different road surface types. As the user travels, they can capture the surface type of the road as a line feature, and when they come to a pothole, they can capture its location, distinguished by its size.

Create a feature service

To create a feature service in ArcGIS Pro, complete the following steps:

  1. Sign in to ArcGIS Pro and choose to create a new project using the Catalog template.
  2. Name the project Pothole Assessment and click OK.
  3. On the Catalog tab, select Databases.
  4. Right-click the Pothole Assessment.gdb file, hover over New and select Create new feature class.

    The Create feature class wizard opens.

  5. Do the following in the wizard:
    1. Name the feature class Pothole.
    2. For the feature class type, choose Point.

      Create Pothole feature class of type Point

    3. Click Next.
    4. Add a new field called Size and leave it as the default Text data type.

      Add field called Size

    5. Add the following fields: UserName (data type Text), Time (data type Date), Direction (data type Double), Speed (data type Double), Latitude (data type Double), and Longitude (data type Double).

      Later, you will configure these fields to automatically populate when a record is captured.

    6. Accept the defaults for the remaining parameters.
  6. Create another feature class for the road assessment, and name it Surface, and assign the Line feature class type.
  7. Add a field called SurfaceType and leave the data type as Text.
  8. Add StartTime and EndTime fields and use the data type Date.
  9. Accept the defaults for the remaining parameters.
  10. Right-click the database and select Domains.
  11. On the Domains tab, create two new domains.
    1. Create a domain named PotholeSize with two coded values: Large (Large >25cm) and Small (Small <25cm}.

      Large and small coded values

    2. Click Save.
    3. Create another domain named SurfaceType with four coded values: Bike Path, Footpath, Freeway, and Main Road.

      Surface type coded values

    4. Click Save.

    Two domains are created.

    Two domains are created.

  12. Add these domains to the appropriate feature class fields.
    1. In Catalog, browse to the Pothole Assessment.gdb file.
    2. Right-click the Pothole feature class, hover over Design, and select Fields to open the Fields tab.

      This tab shows the fields for the Pothole feature class.

    3. In the Domain column of the Size field, click in the intersecting box.

      A drop-down menu appears with the domains you created.

    4. Choose the Pothole Size domain.

      Select a domain

    5. Click Save.
  13. Return to the feature class menu in the catalog and repeat step 12 for the SurfaceType feature class, but this time choose the Surface Type domain.
  14. Click Save.
  15. Select the two layers, right-click the selected layers, and choose Add to new map.
  16. In the Contents pane, right-click the Pothole layer and click Symbology.
  17. Click the drop-down menu and symbolize your layer by category using the Unique Values option.

    Choose symbolize by unique values

  18. If Size does not automatically appear in the field 1 option, choose Size from the drop-down menu.
  19. Click the add all values button Add all values.

    The Pothole layer has unique symbology for small and large potholes.

  20. Repeat steps 17–20 for the SurfaceType layer, creating unique symbology for the different surface types.
  21. Click Save.
  22. Click the Share tab in ArcGIS Pro.
  23. Select Web Layer > Publish Web Layer.

    Publish as web layer

  24. Type Potholes for the map name, summary, and tags.
  25. Select Feature for the layer type.
  26. Select an ArcGIS folder in which to save the layer.
  27. On the Configuration tab, click the edit tool next to Feature.
  28. Select the Enable editing and allow editors to box.

    Enable editing

  29. Click Publish.

Publish confirmation

You now have a Pothole feature layer ready for use.

Create a layer view in ArcGIS

Creating a layer view from your hosted feature layer is recommended but optional. It is best suited for layers that you'll use in different applications. Using a layer view for your QuickCapture project means you can define symbology, or other properties, specifically suited to the project. In other applications, you may decide to use the original hosted feature layer or another layer view.

  1. Sign in to your ArcGIS account.
  2. Browse to the folder where you saved your Pothole Assessment and click the hosted feature layer.
  3. Click Enable Attachments on the Pothole layer.

    This allows you to capture points with a photo attachment.

  4. Return to the Potholes item page and click Create View Layer.
  5. Name your layer Pothole Assessment Project.
  6. On the Settings page, select Enable editing and click Save.

This ensures that you build your QuickCapture project from the view that is designed for its use. You can modify the symbology for this view layer for use in the project, and the original symbology can still be viewed in other apps.

Create a QuickCapture project

The following steps describe how to create a QuickCapture project from your feature service. This section covers the creation and design process, as well as downloading and capturing points on your device.

  1. Open the QuickCapture website. Sign in to your ArcGIS organizational account.

    Using ArcGIS Online with QuickCapture

    Go to https://quickcapture.arcgis.com and choose Sign in with ArcGIS Online.

    Using ArcGIS Enterprise with https://quickcapture.arcgis.com

    Go to https://quickcapture.arcgis.com and choose Sign in with ArcGIS Enterprise. Enter your portal URL, for example, https://host.domain.com/webadaptor/ (where host, domain, and webadaptor are replaced by your portal information) to continue.

    Using ArcGIS Enterprise (10.8 and later)

    Choose QuickCapture from the app launcher in your portal.

  2. Click New Project.
  3. Scroll down to Pothole Assessment Project and select it.
  4. Select Next.

    A dialog box appears where you can confirm the thumbnail, title and data recovery email.

  5. Accept the default settings for the thumbnail and title. The data recovery email is there so that if something happens to the feature layer (for example, it gets deleted), the data collected can be recovered and sent to you. Enter your email address for this setting.
  6. Click Create.

    Your QuickCapture project appears with the automatically generated capture buttons.

  7. Click the Pothole group label and configure the appearance of the group.
    1. Change the label of the group to Pothole Size.
    2. Keep the default number of columns, state, and colors.
    3. Click Save.
  8. Click the button labelled Large >25cm and hold down Shift and click the button labelled Small <25cm to add it to the selection. This ensures that subsequent changes to the appearance and data will be applied to both pothole buttons.
    1. Change the size of the button to the smallest size.
    2. Keep the default shape and colors.
    3. Click the Data tab (next to the Appearance tab).
    4. For each capture field (other than Size), click the drop-down arrow and choose Device Variable. Select the appropriate variables from the drop-down menu.

      For example, the Latitude variable is selected in the Latitude field.

      Select variable

    5. Leave the data values for the Size field as they are coded values that are different for each button.
    6. Click Save.
  9. Optionally, change the order of the buttons by dragging them.

    You cannot drop them into a different group.

  10. Click the Surface group label and change it to Surface Type.
  11. Change the order of the surface type buttons to Main Road, Freeway, Footpath, and Bike Path.
  12. Select each button in the Surface Type group by holding down Shift while clicking each button, and on the Data tab, add variables to each of the fields (similar to how you added variables for the pothole buttons).
    Capture time variables
    Note:

    You must fill in the capture fields with the variables or they will not automatically populate when the point is captured. This will leave blank spaces in your attribute table.

  13. Click Save.

    Your project preview looks similar to the following:

    Project buttons

  14. Select both pothole buttons and click the Data tab (next to the Appearance tab).
  15. Enable the Take Photo toggle button.

    Options will appear.

  16. Select Hide camera preview.
    Take photo

    This changes the camera mode to automatic, which allows you to capture the point and a photo without manually taking a picture. This option doesn’t allow a preview of the photo, so make sure when capturing your point, that your device’s camera is pointing at the pothole. This setting is best used when you need to capture the point quickly, for example, if you are driving a car and the camera position is already pointing to the road. If the Take Photo toggle button does not appear, confirm that you enabled attachments on your feature service.

    Your project preview looks similar to the following:

    Project buttons with photo icon

  17. Click Save.

    Next you will use the exclusivity groups options in the Settings menu to modify the surface type buttons. Exclusive groups prevent multiple line or polygon buttons from capturing data at the same time. In this example we will create an exclusivity group so you can't capture multiple surface types simultaneously.

  18. Click the Exclusive groups menu item Exclusive groups.
  19. Click New Group and name it Surface Type.
  20. Select all the buttons in the Surface Type group on the project preview, and then click Done.
  21. Click Save.

You can now download your project in the mobile app and test it. For others to be able to use your project, share it in your ArcGIS organization.