Skip To Content

Create your first workbook

In this exercise you are a business analyst for a consortium of colleges that wants to run a marketing campaign in states with high-value colleges. You've found data from the United States Department of Education that you think you can use for your campaign. You will use Insights for ArcGIS to explore and start asking questions about your data. In 30 minutes or less, you will do the following:

  • Add data to your ArcGIS Online organization so it can be used in Insights.
  • Launch Insights and sign in to your account.
  • Create a new workbook and add data from your content.
  • Learn about some of the important buttons in your workbook.
  • Create maps, charts, and tables to help you understand your data.
  • Interact with cards, including zooming and panning and making selections.

Note:

To complete this exercise, your account must have the following specifications:

  • Creator or GIS Professional user type
  • Publisher or Administrator role, or equivalent custom role
  • Insights license

For more information, see Administer Insights.

Add data to your organization

The data for this analysis has been provided publicly on the ArcGIS website, where it can be downloaded to your machine. Follow these steps to access and load the data to your ArcGIS Online organization:

  1. Follow the link to the CollegeScorecard item.
  2. Click the Download button to download the item to your machine.
  3. Unzip the folder and save the Microsoft Excel file on your computer in a location that you can find easily.
  4. Sign in to your ArcGIS Online account.
  5. Open Insights and sign in to your account if necessary.
    Tip:

    You can access Insights through the gallery of apps in ArcGIS Online.

    Gallery of apps

After you sign in, the Workbooks page appears. If this is your first time signing in to your Insights account, the welcome window will be displayed. You can navigate through the carousel or skip to go directly to the Workbooks page.

Create a new workbook

In Insights, your analysis is done in a workbook. A workbook stores all of the pages, data, and processes from your analysis. Follow these steps to create a new workbook.

  1. On the Workbooks page, click New workbook.
  2. The Add To Page pane opens on the Data tab. The Data tab includes Content, Groups, Organization, Living Atlas, Boundaries, and Excel or CSV.
  3. Click Excel or CSV.
  4. Click Browse my computer and open the Excel file or drag the file onto the Add To Page window. Click Add.
  5. The workbook opens with the CollegeScorecard.Table1 dataset in the data pane.
  6. Click Untitled Workbook and replace it with a unique and useful title, such as US Colleges - Your Name. Including your name in the title will make your workbook easier to find if you share your work. Click Save.

Explore your workbook

Using a new software product for the first time can be intimidating. This section walks you through some of the key aspects of the user interface so that you are more comfortable with it when you start to explore your data. If you are already familiar with buttons and controls in Insights, you can skip this section.

  1. Take a look at the workbook and notice some of the key features:

    • The Undo Undo and Redo Redo buttons in the upper left can be used to undo and redo processes such as performing analysis or creating a new card.
    • Add can be used to add a new dataset to your page.
    • The Map, Chart, and Table buttons can be used to create cards without dragging fields or datasets. The three buttons are dimmed because no data has been selected.
    • The Widget button can be used to add other card types, such as text and media cards, or predefined filters.
    • The Create Relationships button can be used to join datasets using common fields.
    • The Analysis view button Analysis view can be used to view a model of your analysis. The model is created automatically as you work in your workbook.
    • The Basemaps button Basemaps can be used to change the basemap for your map cards.
    • The Page Settings button Page Settings can be used to change settings, such as the background color, for the entire page.

  2. Hover over the dataset in the data pane and notice the two buttons beside the dataset name:

    • The Rename dataset button Rename dataset is used to edit the name of the dataset.
    • The Dataset options button Dataset options is used to open a menu containing more actions available for the dataset.

  3. Click the Dataset options button for the dataset. The menu opens to show the following options: Enable Location, View Data Table, Advanced Filter, Remove Dataset, Refresh Dataset, Hide Selected Fields, Show Hidden Fields, and Share Data.
  4. Expand the dataset in the data pane. The fields in the dataset are displayed, along with symbols indicating the field role. You can select fields and drag them to the page to create maps, charts, or tables. You can also use the buttons above the data pane to create maps, charts, and tables.
  5. Now that you are familiar with some of the basic controls in Insights, it's time to start exploring your data.

Explore your map

This section will walk you through some of the basic interactions you can make with map cards, but first you will have to enable location on your Excel file.

  1. Click Dataset options Dataset options for the Excel file and choose Enable Location from the menu.
  2. The default method of enabling location is using coordinates. The LONGITUDE and LATITUDE fields from the Excel file are already populated by default.
  3. Click Run.
  4. Expand the dataset in the data pane.
    A location field is added to the dataset
  5. A new location field called Coordinates has been added to the dataset.
  6. Drag the dataset onto your page and drop it on the Map drop zone to create a map of United States colleges.
    Create a map
  7. Tip:

    If you prefer to use buttons, you can select a field from the dataset and click the Map button above the data pane.

  8. Drag the corners of the map to make it larger. You can also drag the card to a different position on the page.
  9. Press Shift and draw a rectangle around the continental United States with your mouse to zoom in. You can also use the Zoom tools button Zoom tools from the card toolbar to zoom in and out.
  10. Select the TYPE field in the data pane and drag it to your map.
  11. The map updates to show the colleges styled by unique color based on the type of school.
  12. Open the Layer options pane using the expand button Expand legend next to the TYPE layer on the map.
    Expand the Layer options pane
  13. The Layer options pane displays the three college types, Private For-Profit, Private Nonprofit, and Public, and the number of features of each type. This information is useful, so it would be good to display it permanently.
  14. Click the Pop out legend button Pop out legend.
  15. The legend is displayed as a separate card under your map. Depending on the size of your map, you may need to scroll down on the page to see the legend.
  16. Resize the legend and move it to the bottom left corner of your map.
  17. In Insights, the legend is interactive and can be used to understand the patterns in your data.
  18. Click Private For-Profit on the legend. The for-profit schools are selected on the map and the other schools fade into the background.
    Select Private For-Profit on the legend
  19. Using the legend to make selections on the map can be useful for looking at patterns.
  20. Zoom and pan around your map to look for patterns in for-profit schools. Zooming can be done using the zoom tools outlined in step 6, or using the scroll wheel on your mouse. Panning is done by clicking and dragging the map. If you get lost, use the Default extent button Default extent to zoom to the full extent of the data.
    Note:

    If necessary, you may want to change your basemap so that city labels and map symbols are easy to see. The Light Gray Canvas is a good option. You can change the basemap using the Basemaps button Basemaps.

  21. The for-profit schools tend to be clustered around urban areas, and are mostly in the eastern half of the continental United States.
  22. Click Private Nonprofit in the legend to change the selection on the map. Zoom and pan around the map again looking for patterns in the nonprofit schools.
  23. There are fewer nonprofit colleges than for-profit colleges and they are less concentrated in large urban areas. There are more private nonprofit colleges in Alaska and Hawaii than there are private for-profit colleges. The colleges are still concentrated in the eastern half of the United States.
  24. Click Public in the legend to change the selection on the map. Zoom and pan again to look for patterns in the public schools.
  25. Public schools have a slightly more uniform distribution across the country, including more colleges in Alaska and Hawaii and across the Midwest.
  26. Click Public again to clear the selection.
  27. Save your workbook.

Create charts and tables

Finding spatial patterns in your data is important, but you may also want to learn more about the nonspatial aspects of your data. You can do that using tables and charts.

  1. If necessary, expand the CollegeScorecard.Table1 dataset.
  2. Fields from the dataset are listed. Each field has an icon that indicates the field's role, which is based on the type of data the field contains.
  3. Hover over the REGION field in your dataset and click the circle that appears. Do the same for the COST field. Blue circles around the check marks indicate selected fields.
  4. Drag your selections to the Table drop zone.
    Create a table
    Note:

    If you prefer buttons to dragging fields, click Table above the data pane after you select your fields.

  5. A summary table appears as a card on your page. Each region is listed with the sum of costs for the colleges in the region.
  6. Instead of a sum of costs, average costs would be more helpful to know. Change the COST statistic from sum to average. Use the arrows beside the COST statistic to sort the costs in descending order.
    Change the table to average and sort descending
  7. The table now shows the regions in order, with the most expensive region (New England) listed first and the least expensive (Southwest) listed last. The table is useful for seeing the exact values of the average cost, but it doesn't offer a quick view of the differences in average cost. Changing the table to a chart will give you a more visual representation of the costs.
  8. Click the Visualization type button Visualization type on the card and choose Bar Chart. The table updates to show a bar chart.
  9. Now that you've looked at the average cost by region, it would be good to also look at average cost by college type.
  10. Click REGION on the y-axis of the bar chart to expand a menu of fields. The REGION field is a string field, so all of the fields listed in the menu also contain strings.
  11. Click TYPE to change the value on the axis. The bar chart now shows the type of college and the average cost.
  12. Private nonprofit colleges have the highest average cost, and public colleges have the lowest average cost. You can also change the style of the bar chart so that it matches the style of the map.
  13. Click the Legend button Legend and click on the Options tab Options if necessary.
  14. Change the Symbol type to Unique symbols. Close the Layer options pane.
    College type styled by unique symbols
  15. Save your workbook.

Analyse your data with statistics

You now know which types of colleges have the highest costs. It would be good to know how much of an effect the costs have on earnings after graduation.

  1. Select COST and EARNINGS in the data pane.
  2. Drag the fields to the Charts drop zone and drop them on Scatter Plot.
    Create a scatter plot
  3. A scatter plot is created with the cost on the x-axis (horizontal) and the mean earnings on the y-axis (vertical).
    Note:

    If your scatter plot is displaying the fields on the wrong axes, you can change them using the Switch axes button Switch axis.

  4. Click Color by on the x-axis and choose TYPE.
  5. The scatter plot shows that there is a slight positive relationship between the cost of colleges and the earnings after graduation. Some chart statistics would help you quantify the relationship more accurately.
  6. Click the Chart statistics button Chart statistics in the card toolbar and choose Linear. Close the Chart statistics pane.
    Add statistics to the scatter plot
  7. A linear best fit line is added to the scatter plot, along with the line equation (y=0.51x+22,340) and R² value (0.299). The R² value, also called the Coefficient of Determination, is a goodness of fit measure that indicates the strength of the relationship between the variables on the scatter plot. The R² value is between 0 and 1, with values closer to 1 having a stronger relationship. In this case, the R² value is closer to 0, meaning that the cost of colleges does not have a strong effect on the earnings after graduation. It would be interesting to see if this is true for each type of college individually.
  8. Click the Enable cross filters button Enable cross filters on the scatter plot. A cross filter allows you to quickly filter data on a card by making a selection on a different card.
  9. Click Private For-Profit on the map legend. The for-profit colleges are selected on the map and bar chart, and the scatter plot is filtered to show only for-profit schools.
    Scatter plot filtered by for-profit colleges
  10. The statistics are recalculated for the for-profit colleges. The new line of best fit is still positive, but the R² value has dropped to 0.258, meaning that the cost of a for-profit college has very little influence on the earnings of graduates. You can see from the scatter plot that a lot of colleges have higher than expected earnings after graduation based on the cost.
  11. Select Private Nonprofit, then Public on the map legend and take note of the R² values of each college type.
  12. Private nonprofit and public colleges each have an R² value of 0.396. These values are better than the full dataset and private for-profit schools, which implies that there is a stronger relationship between cost and earnings after graduation in nonprofit and public colleges than in for-profit colleges.
  13. Save your workbook. If you want to continue to the Solve a spatial problem lesson, then leave the workbook open. Otherwise, return to the Workbooks page using the My Workbooks button My Workbooks or exit Insights.

Next steps

Now that you have learned how to use your workbook, you can start using your own data and expertise to create workbooks that matter to you.

You can also continue this scenario in Solve a spatial problem and Share your analysis.