Skip To Content

Bases de données prises en charge

La table suivante répertorie les bases de données prises en charge auxquelles vous pouvez vous connecter lorsque vous utilisez Insights for ArcGIS. Les connexions à une base de données vous permettent d'ajouter des données à Insights for ArcGIS à partir de ces bases de données.

Remarque :

Insights for ArcGIS vous permet de créer une connexion à une base de données Microsoft SQL Server ou Oracle prise en charge pour laquelle une géodatabase d’entreprise est définie. Actuellement, seules les tables utilisateur de géodatabase qui ne sont pas créées sous la structure utilisateur sde sont consultables et accessibles depuisInsights. Insights ne fonctionne pas directement avec les géodatabases fichier et personnelles.

Base de données prise en chargeDescriptionFichiers des fournisseurs requis

Microsoft SQL Server

Editions Standard/Enterprise :

  • Microsoft SQL Server 2017 (64 bits)
  • Microsoft SQL Server 2017 pour Linux (64 bits)
  • Microsoft SQL Server 2016 (64 bits)
  • Microsoft SQL Server 2014 (64 bits)
  • Microsoft SQL Server 2012 (64 bits)

Base de données Cloud en tant que service :

  • Microsoft Azure SQL Database

Microsoft JDBC Driver for SQL Server :

  • sqljdbc42.jar

Remarque :

La version JRE8 du pilote JDBC doit être utilisée pour les bases de données Microsoft SQL Server.

Oracle

Editions Standard/Standard One/Enterprise :

  • Oracle 11g R2 (64 bits) 11.2.0.4
  • Oracle 12c R1 (64 bits) 12.1.0.2
  • Oracle 12c R2 (64 bits) 12.2.0.1

Oracle JDBC driver :

  • ojdbc7.jar ou ojdbc8.jar

Remarque :

Vous devez utiliser la dernière version de Oracle JDBC driver qui est compatible avec votre Java Database Kit (JDK).

Oracle Spatial and Graph (Spatial Java Class API) :

  • sdoapi.jar
  • sdoutl.jar

SAP HANA

  • SAP HANA 1.0 SPS11*
  • SAP HANA 1.0 SPS12**
  • SAP HANA 2.0 SPS00*
  • SAP HANA 2.0 SPS01
  • SAP HANA 2.0 SPS02
Remarque :

Les vues de modélisation SAP HANA ne sont pas prises en charge.

SAP HANA JDBC driver :

  • ngdbc.jar

*SAP HANA 1.0 SPS11 et SAP HANA 2.0 SPS00 ne sont pas certifiés dans les versions Insights for ArcGIS postérieures à 2.1. Pour les bases de données spatialisées, SPS11 Revision 2 (1.00.112) ou version supérieure est requis afin d’éviter les erreurs du type 'Unregistered function name: "__cs_field_Geometry__"' au cours de certains workflows.

**SAP HANA 1.0 SPS12 n’est pas compatible avec Insights for ArcGIS version 2.2.1.

Les fichiers des fournisseurs requis (par exemple, le pilote JDBC) doivent être fournis pour pouvoir inscrire les types de stockage de données relationnelles auprès de ArcGIS Server. Voici plusieurs astuces pour obtenir ces fichiers :

FournisseurInstructions

Microsoft SQL Server

Le dernier pilote JDBC peut être téléchargé directement depuis le Centre de téléchargement Microsoft.

Oracle

Le dernier pilote JDBC peut être téléchargé depuis la plateforme Oracle Technology Network.

La dernière option logicielle Oracle Spatial and Graph peut être téléchargée depuis la plateforme Oracle Technology Network.

SAP HANA

Le pilote JDBC doit faire partie de l’installation client SAP HANA. Visitez le Store SAP pour plus de détails.

Remarque :

Certains fournisseurs peuvent avoir besoin d'un compte client pour télécharger des fichiers.

Lorsque vous disposez des fichiers fournisseurs, vous devez enregistrer chaque base de données comme banque de données relationnelle. Voir Configurer le portail pour la prise en charge d'Insights for ArcGIS pour connaître les étapes d'enregistrement d'une banque de données relationnelle.

Pour plus d'informations sur les données et les bases de données prises en charge, reportez-vous aux ressources suivantes :