Skip To Content

What are the requirements?

To use Navigator for ArcGIS, your device and ArcGIS account must meet the requirements below. You can use the app in any of the supported languages.

Device requirements

Navigator is supported on Android and iOS devices.

Android

  • Android 4.2 (Jelly Bean) or later
  • Processor: ARMv7 or later, or x86
  • OpenGL ES 2.0 support
  • Precise location (GPS and network-based) support

iOS

  • iOS 9 or later
  • iPad (fourth generation or later for best performance), iPhone (6 or later for best performance), iPod touch

ArcGIS account requirements

Navigator for ArcGIS is a premium app, and you must have an ArcGIS organizational account that has been configured with a Navigator for ArcGIS license to use the app. ArcGIS Online and ArcGIS Enterprise are supported. For details about using ArcGIS Online, see About Navigator for ArcGIS licensing. For details about using ArcGIS Enterprise, see Configure Navigator for ArcGIS licenses for your organization.

Legacy:

Portal for ArcGIS 10.4.1 is also supported.

You can use Esri-provided navigation maps or you can create your own. Esri-provided maps are available in ArcGIS Online and ArcGIS Enterprise and can be downloaded to your device. For more details on the provided maps, see Navigator Map coverage.

Creating or modifying a map for use in Navigator requires ArcGIS Pro 1.2 or later along with licenses that vary based on what you want to edit. See What licenses do I need to work with navigation maps? for licensing details.

Supported languages

Arabic, Dutch, English, Estonian*, French, German, Greek, Hebrew, Italian, Japanese, Korean, Latvian*, Lithuanian*, Portuguese (Brazil), Portuguese (Portugal), Russian, Simplified Chinese, Spanish, and Turkish.

The language used by the app is determined by your device's language setting.

*Android only