This is an archive related to a previous version of Esri Maps for SharePoint. If you need the current version go to http://doc.arcgis.com/en/maps-for-sharepoint/.

Configure the ribbon

When you start using the ArcGIS Map Web Part, you'll notice that most of the web part functionality is organized in the ribbon. The ribbon, a key feature of SharePoint that is leveraged extensively by the Web Part, is similar to what you see in Microsoft Office applications such as Word, Excel, PowerPoint, and Outlook.

The ribbon

If you have permissions to create or edit an ArcGIS Map Web Part, you can decide what web part functionality is available to the users of this Web Part by configuring the ribbon. Configuring the web part ribbon allows you to control which tabs, groups, and tools (buttons) are shown when the web part is not in Edit mode (all tabs, groups, and tools are shown in Edit mode).

Opening the Manage Ribbon dialog box

  1. Click the Web Part drop-down menu and click Edit Web Part.
    Edit Web Part
  2. Click Ribbon in the Manage group of the web part Application tab.

    The Manage Ribbon dialog box appears.

    Manage Ribbon dialog box

Showing or hiding tabs, groups, and tools

By default, only some tabs, groups, and tools are included on the ribbon when the Map Web Part is not in Edit mode. Some of the tools are included on the Application and Layer tabs, and the Symbols tab is not included at all.

To configure the ribbon, check and uncheck the check boxes in the Manage Ribbon dialog box. The three nodes below the Ribbon Configuration node represent the three tabs that are included with the Map Web Part by default. When you check the check box next to a tab, that tab and all groups and tools within it will be included when the Web Part is in run mode. When you uncheck the check box and it becomes empty, the tab will be excluded from run mode.

Expanding a tab node will reveal nodes that represent all the groups within that tab. When you check the check box next to a group, the group and all the tools within it will be included in run mode, provided the parent tab is also included. When you uncheck the check box and it becomes empty, the group will not be added to the tab.

Expanding a group node will reveal all the tools within that group. When you check the check box next to a tool, that tool will be included in run mode, provided the parent group and tab are also included. When you uncheck the check box, the tool will not be included.

Adding a tab

  1. In the Manage Ribbon dialog box, select the Ribbon Configuration (root) node and click Add.
    Manage Ribbon dialog box

    The Add New Tab dialog box appears.

  2. Type a title and a tooltip and click OK.
  3. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the new tab is included on the ribbon.

    New tab added to ribbon

Removing a tab

  1. In the Manage Ribbon dialog box, select the tab to remove.
    Remove tab
  2. Click Remove.

    The Confirm delete dialog box appears.

  3. Click OK.
  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tab is no longer included on the ribbon.

Changing tab order

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab you want to move. The appropriate Move Upand Move Down buttons become enabled as appropriate.
  2. Click the desired arrow to move the tab.
    Change tab order
  3. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tab order is updated as specified.

    Tab order changed on ribbon

Editing a tab

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab you want to edit.
  2. Click Edit.
    Edit tab

    The Edit Tab dialog box appears.

  3. Edit the title and tooltip as desired and click OK.
  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tab's title and tooltip are as specified in the Edit Tab dialog box.

Adding a group

You can add groups to any tab, regardless of whether it is one of the defaults. To add a group, complete the following steps:

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab where you want to add the group.
  2. Click Add.
    Add group

    The Add New Group dialog box appears.

  3. Type a title and a tooltip and click OK.

    If you add a group and do not add tools to that group, the group is not saved.

  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the new group is included in the specified tab on the ribbon.

Removing a group

  1. In the Manage Ribbon dialog box, select the group to remove.
  2. Click Remove.
    Remove group

    The Confirm delete dialog box appears.

  3. Click OK.
  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the group and its tools are no longer included on the ribbon.

Changing group order

  1. In the Manage Ribbon dialog box, select the group to move. The Move Up and Move Down buttons are enabled as appropriate.
  2. Click the desired arrow to move the group.
    Change group order
  3. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the order of groups on the ribbon is updated to reflect the change.

Editing a group

  1. In the Manage Ribbon dialog box, select the group to edit.
  2. Click Edit.
    Edit group

    The Edit Group dialog box appears.

  3. Edit the group's title and tooltip as desired and click OK.
  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the group's title and tooltip are as specified on the Edit Group dialog box.

Adding a tool

  1. In the Manage Ribbon dialog box, select the group where you want to add the tool.
  2. Click Add.
    Add control

    The Add New Control dialog box appears.

  3. Select the tool to add from the Tool drop-down menu. You can also change the label, add a tooltip, and change the icon if desired.
  4. Click OK.
    Add New Control dialog box

    For more information about the tools that appear in this drop-down menu, see Configure add-ins.

    If you are adding a geoprocessing tool or another tool that provides additional configuration options, you can click the Configure button to set up the tool. For more information about configuring geoprocessing tools, see Add Geoprocessing tasks.

  5. The new tool appears in the Manage Ribbon dialog box. To make the new tool available to your users, make sure the check box next to it is checked.
  6. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the new tool is included on the ribbon.

Removing a tool

Tools that are included on the Map Web Part ribbon by default cannot be removed.

  1. In the Manage Ribbon dialog box, select the tool to remove.
  2. Click Remove.
    Remove control

    The Confirm delete dialog box appears.

  3. Click OK.
    Confirm delete dialog box

    The tool is immediately removed from the list of tools in the Manage Ribbon dialog box.

  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tool is longer included on the ribbon.

Changing tool order

  1. In the Manage Ribbon dialog box, select the tool to move. The Move Up and Move Down buttons are enabled as appropriate.
  2. Click the desired arrow to move the tool.
    Change order control
  3. When the tool is positioned as desired, click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tool's position on the ribbon is updated to reflect the changes made on the Manage Ribbon dialog box.

Editing a tool

  1. In the Manage Ribbon dialog box, select the tool to edit.
  2. Click Edit .
    Edit control

    The Edit Control dialog box appears.

  3. Change the label, tooltip, icon, or additional configuration as desired and click OK.
    Edit Control dialog box
  4. Click OK or Apply in the properties pane to the right of the Web Part.

    When the Web Part loads, the tool reflects the changes.