Skip To Content

Use the World Elevation services in ArcGIS

Terrain

Once you've published the terrain image service, the service can be used in ArcGIS 10.3 or later and ArcGIS Online. Terrain is a dynamic image service comprising multiple sources and resolutions ranging from 1,000 meters to 2 meters. It can be used for visualization and analysis.

Use in ArcGIS for Desktop

  1. In the Catalog window, make an ArcGIS server connection to the server that is hosting the elevation services.
  2. Open ArcMap and add or drag the Terrain service to the map. By default, the service will render as an elevation (DEM) raster.
  3. Right-click Terrain and click Properties > Processing Templates.
  4. From the Function drop-down list, choose one of the functions defined on the service.
  5. Click OK.

Terrain service layer properties

The raster function will dynamically render the elevation derivative selected from the drop-down list.

Use Terrain for analysis

The Terrain service includes data with resolutions ranging from over 1,000 meters to approximately 2 meters in some limited areas, and each record (raster item) is populated with the Dataset_ID and ProductName tags, which can be used for filtering. Since the service is composed of multiple-resolution datasets, the records need to be filtered based on a single resolution (or dataset) before consuming it for analysis. Use the Make Image Server Layer tool to create a temporary layer to use in GP tools. In the following scenario, analysis is done in the Redlands, California, area.

  1. Add the Terrain service in ArcMap.
  2. Zoom to the Redlands area of interest (AOI) and click Identify on the Terrain service. A list of raster items is returned. Examine the LowPS (cell resolution in meters) values of rasters in the Identify result window.
  3. Determine the resolution you need to work with. Take note of the ProductName field value. This example is for the NED_1r3_arcsec dataset, which has a resolution of approximately 10.3 meters.

    Terrain service Identify results with NED_1r3_arcsec dataset selected

  4. Open the Make Image Server Layertool.
  5. Define the parameters:
    • Specify the input image service.
    • Set Expression to "ProductName" = 'NED_1r3_arcsec'.
    • Optionally set the output coordinates from the env setting, if the request being made is different from the image service coordinates (Web Mercator).
    • Specify the extent.
    • Specify the Output Cell Size value as 10.3.
    Make Image Service Layer dialog box for Terrain layer
  6. Click OK to run the tool.

This generates a temporary layer with cell size, coordinate system, extent, and expression parameters defined in the tool. This temporary elevation layer can now be used in other GP tools for further analysis.

The request size of the output layer is limited to 24,000 by 24,000 pixels (property defined on mosaic datasets).

For information on the Make Image Server Layertool, see Make Image Server Layer in the ArcGIS for Desktop help under Tools > Tool reference > Data Management toolbox > Layers and Table Views toolset.

For information on using mosaic datasets and image services in geoprocessing tools, see Using mosaic datasets and image services in geoprocessing tools in the ArcGIS for Desktop help under Manage Data > Datatypes > Raster and images > Processing and analyzing raster data.

Use in ArcGIS Online or Portal for ArcGIS

  1. Go to the REST endpoint of the Terrain service, for example, http://localhost:6080/arcgis/rest/services/Terrain/ImageServer.
  2. Click ArcGIS Online Map Viewer. The Terrain service opens in the map viewer in a browser. By default, it renders as elevation (DTM).
  3. Click Terrain > More Options > Image Display > Renderer to choose from the server functions defined on the service.

    More Options list for Terrain layer

  4. Choose Grayscale_Hillshade Renderer (that is, server raster function) from the drop-down list and click Apply.
The map renders the hillshade. Similarly, any other available renderer can be selected for visualization in the map viewer.

Data coverage map

You can explore the DataExtentsMap.mxd file located at \\<server-ip>\source_documents\data\WorldElevation\DataExtentsMap. This map provides the coverage extent of various datasets comprising the Terrain service. The map document (.mxd) can be published as a map service.

For information on publishing a map document (.mxd) as a map service, see Publishing a map service in the ArcGIS for Server help under Publish Services > Types of services > Image services.

Terrain3D

Use in ArcGIS Pro

  1. Launch ArcGIS Pro and choose the Global_Scene project template.
  2. On the Insert tab, choose Connections > New ArcGIS Server.
  3. Provide the server URL where you published the Terrain3D service.
  4. In the Contents pane, right-click Scene and click Properties.
  5. From Map Properties: Scene, click Elevation Surface.
  6. Expand Elevation Sources and click Add Elevation Source. The ArcGIS Online Terrain3D elevation service is the default ground surface.
  7. Expand Servers, double-click the server connection, and select the Terrain3D service. Optionally remove the default ArcGIS Online elevation layer.
  8. Zoom to any location and tilt the scene to view the oblique views.

With ArcGIS Pro, you can add your unique 2D and 3D data layers to the scene. Your data is added on the elevation surface. If your data has defined elevation (z-coordinates), this information is honored in the scene. You can then share your work as a web scene with others in your organization or the public.

For information on scenes in ArcGIS Pro, see Scenes in the ArcGIS Pro help under Maps > Author maps.

Use in ArcGIS Online or Portal for ArcGIS

  1. Open the web scene from ArcGIS Online or from your Portal for ArcGIS deployment.
  2. Sign in to the scene viewer.
  3. From the Contents pane, click Add Layer > Enter Layer URL.
  4. In the Enter Layer URL pane, enter the REST endpoint of the Terrain3D service published on your server, for example, http://localhost:6080/arcgis/rest/services/Terrain3D/ImageServer.
  5. Click Add to add the layer to your scene. The elevation surface is added as Ground.

With the ArcGIS Online 3D scene viewer, you can create and interact with 3D scenes. Your data is added on the elevation surface. If your data has defined elevation (z-coordinates), this information is honored in the scene. You can then share your work as a web scene with others in your organization or the public.

For information on using the 3D scene viewer, see View scenes in the scene viewer in the ArcGIS Online help.


In this topic
  1. Terrain
  2. Terrain3D