Skip To Content

Data Appliance 6.2 for ArcGIS system requirements

To get information for earlier versions, see Data Appliance 6.1 for ArcGIS system requirements.

The system requirements for all Data Appliance 6.2 for ArcGIS product options are noted below.

Esri product teams have a policy of supporting hardware, operating systems, compilers, web browsers, and web servers. For more information, see Supported Environment Policy.

Requirements for publishing

To host Data Appliance 6.2 for ArcGIS services, ArcGIS 10.1 SP1, 10.2, 10.2.2, 10.3, 10.3.1, or 10.4 for Server is required.

The following new services have special requirements:

  • To publish the Terrain and Terrain3D image services, ArcGIS 10.3, 10.3.1, or 10.4 for Server as well as the ArcGIS Image Extension for Server are required.
  • To publish the Elevation and ElevationSync geoprocessing services, ArcGIS 10.3, 10.3.1, or 10.4 for Server is required as well as ArcGIS 10.3 for Desktop or later with a Standard or Advanced license.
  • To publish the Esri_Places_World locator, ArcGIS 10.3, 10.3.1, or 10.4 for Server is required.
Note:

The instructions for publishing Data Appliance 6.2 for ArcGIS services also apply to ArcGIS 10.4 for Server.

Supported system configurations

Data Appliance for ArcGIS (Windows)

Data Appliance for ArcGIS for Windows is built on Microsoft Windows Storage Server 2012 R2 Standard.

ArcGIS for ServerOperating System for ArcGIS for Server

ArcGIS 10.1 SP1 for Server

Microsoft Windows Server 2008 R2 SP1 (64 bit) Standard and Enterprise

Supported

ArcGIS 10.2 for Server

Microsoft Windows Server 2012 R2 (64 bit) Standard and Datacenter

Supported

ArcGIS 10.2.2 for Server

ArcGIS 10.3 for Server

ArcGIS 10.3.1 for Server

Microsoft Windows Server 2008 R2 (64 bit) Standard, Enterprise, and Datacenter

Microsoft Windows Server 2012 (64 bit) Standard and Enterprise

Microsoft Windows Server 2012 R2 (64 bit) Standard and Datacenter

Supported

ArcGIS 10.4 for Server

Microsoft Windows Server 2012 R2 (64 bit) Standard and Datacenter

Supported

  • Data Appliance for ArcGIS may work in other environments supported by ArcGIS for Server, but Data Appliance 6.2 for ArcGIS has not been tested and certified on those environments.

For more information on ArcGIS 10.4 for Server system requirements, see ArcGIS 10.4 for Server system requirements .

For more information on ArcGIS 10.3 and 10.3.1 for Server system requirements, see ArcGIS for Server system requirements (10.3 and 10.3.1).

For more information on ArcGIS 10.2.x for Server system requirements, see ArcGIS 10.2.x for Server system requirements in ArcGIS 10.2 Help.

For more information on ArcGIS 10.1 SP1 for Server system requirements, see ArcGIS 10.1 for Server system requirements in ArcGIS 10.1 Help.

For more information on supported system configurations, send an email to dataapp@esri.com.