Skip To Content

Prerequisites for ArcGIS for Server

The following prerequisites must be met before you deploy Data Appliance 6.3 for ArcGIS to your GIS server:

  • To publish the map services, you must have ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server installed, configured, and running with the latest service packs installed. If ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server is not running, or if you have problems with the installation, for ArcGIS Server 10.5, see ArcGIS for Server (Windows) installation guide. For ArcGIS 10.4 for Server, see ArcGIS for Server (Windows) installation guide. For 10.3 for Server, see ArcGIS for Server (Windows) installation guide.
  • To publish the World Elevation services (Terrain and Terrain 3D), you must have ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Desktop and Server installed, configured, and running with the latest service packs installed. You also must have the ArcGIS Image Extension for Server. If ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server is not running, or if you have problems with the installation, see ArcGIS for Server (Windows) installation guide.
  • To publish the elevation geoprocessing services (Elevation and ElevationSync), you must have ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server with an Advanced license installed, configured, and running with the latest service packs installed. You also must have ArcGIS 10.3 for Desktop or later with a Standard or Advanced license. If ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server is not running, or if you have problems with the installation, see ArcGIS for Server (Windows) installation guide.
  • To publish the World Places Locator, you must have ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server installed, configured, and running with the latest service packs installed as well the geocoding patch for the version of ArcGIS that you are running. Suggestions functionality is available when using ArcGIS 10.3.1 for Server, or later, with the appropriate geocoding patch. You can find links to the geocoding patches on the ArcGIS for Server website. If ArcGIS 10.3, 10.3.1, 10.4, 10.4.1, or 10.5 for Server is not running, or if you have problems with the installation, see ArcGIS for Server (Windows) installation guide.