Skip To Content

System requirements

Community Analyst supports the following browsers:

  • Chrome (latest)
  • Internet Explorer 11
  • Firefox (latest)
  • Microsoft Edge (latest)
  • Safari (latest)