Publish hosted feature layers

You can publish feature layers from any of the following to be hosted on ArcGIS Online:

You can also publish an empty hosted feature layer so members of your organization can add features to it.

Feature layers are useful when you need to expose vector data for display, query, and editing on the web. Hosting a feature layer on ArcGIS Online is an easy way to share data with an Internet audience if your own GIS server cannot be made public. Maps, apps, and desktop map viewers can access your services from anywhere on the Internet if you choose to allow it.

Feature layers are most appropriate for operational layers that go on top of reference layers such as a basemap. For example, a feature layer might contain information about the street signs in your neighborhood. Each feature (street sign) might include the sign name, date installed, and a website URL for reporting problems to your local street department.

When publishing a CSV, shapefile, GeoJSON, feature collection, or file geodatabase, ArcGIS Online automatically sets the optimal visible range based on the data. When publishing a map from ArcMap or ArcGIS Pro, ArcGIS Online honors the existing scale range configured during the authoring process. When you create an empty hosted feature layer, it inherits the visible range of the feature layer or template you used to create it. To change the scale visibility of the hosted feature layer, open the layer in the map viewer and set the visible range.

You must have privileges to create content and publish hosted feature layers to create an empty hosted feature layer or publish from a file or map.

Publish a CSV file

To web-enable feature layers from CSV files, you upload them to Esri's cloud and have them hosted as services. These services are referred to as hosted feature layers. This is a useful workflow if you do not have any ArcGIS products installed locally.

The steps below outline how to publish features or tables from ArcGIS Online using a CSV file. Features are published in the WGS 1984 Web Mercator (Auxiliary Sphere) coordinate system.

  1. Verify that you are signed in and that you have privileges to create content and publish hosted feature layers. If you have a large file to publish, you should check Keep me signed in when signing in. This helps prevent the website from timing out before the feature layer has been created.
  2. Open My Content, click Add Item, and click From my Computer.
  3. Click Choose File and browse to the file on your computer.
  4. Select the file and click Open.
  5. CSV files must be formatted and saved as .csv. Other text-based file types cannot be published.

  6. Check the box next to Publish this file as a hosted layer.

    If you leave the box unchecked, your data file is added to My Content, but no hosted feature layer is published. You can publish the feature layer later if you want. See Add items for more information.

  7. Type a title.
  8. Type tag terms separated by commas.

    Tags are words or short phrases that describe your item and help people find your item when searching. Federal land is considered one tag, while Federal,land is considered two tags.

  9. Choose to locate features using latitude-longitude or address, or choose to create a nonspatial table.

    By default, ArcGIS Online geocodes addresses based on your organization's region.

  10. To change the country that ArcGIS Online uses to geocode addresses in a CSV file, select a different country from the Country drop-down list. If your file contains addresses from multiple countries or from a country not in the list, select World.
  11. Review the field types and location fields. You can change them if necessary.
    1. Click a Field Type cell to choose a different type.
    2. Click a Location Field cell to choose a different field.
  12. Choose a Time Zone for the date fields in your CSV file.

    By default, date fields are assumed to contain UTC date and time. If your date fields store values that use a different time zone, choose that time zone. Note that the time zone you select will be applied to all date fields in the CSV file. If you later overwrite the hosted feature layer using updated data, the time zone specified when you initially published is used.

    See CSV, TXT, and GPX files for information on time zone considerations and supported date and time formats.

  13. Click Add Item.

Your file is published as a hosted feature layer. It may take some time to upload the file. One way to test the new feature layer is to view it in the map viewer.

The data file and the feature layer are separately added to My Content. You can edit item details and share the items. The items are independent, so for example, if you change the thumbnail in the feature layer's item details, the thumbnail does not update on the file's item details.

If you published a CSV file containing addresses, you will be prompted to review and correct any records that were not placed on the map or were placed incorrectly. You can immediately review the addresses in the map viewer or choose to review the addresses at a later time. See Review addresses for more information.

By default, the hosted feature layer can only be accessed by the publisher. You can share the hosted feature layer and the file with everyone in your organization or members of specific groups.

Publish a shapefile or GeoJSON file

To web-enable feature layers from shapefiles (packaged in a .zip file) or GeoJSON files (.geojson or .json), upload your files to Esri's cloud and have them hosted as services. These services are referred to as hosted feature layers. This is a useful workflow if you do not have any ArcGIS products installed locally.

The steps below outline how to publish features from ArcGIS Online using a shapefile or GeoJSON file. The features are published in the WGS 1984 Web Mercator (Auxiliary Sphere) coordinate system.

  1. Verify that you are signed in and that you have privileges to create content and publish hosted feature layers. If you have a large file to publish, you should check Keep me signed in when signing in. This helps prevent the website from timing out before the hosted feature layer has been created.
  2. Open My Content, click Add Item, and click From my Computer.
  3. Click Choose File and browse to the file on your computer.
  4. Select the file and click Open.
  5. Shapefiles must be compressed as a .zip file containing at least the .shp, .shx, and .dbf files. If your shapefile does not include a .prj file and the x,y domain extent is between -180 and 180 degrees, the features will be published in the GCS_WGS_1984 coordinate system. If the data is not within this extent, you will receive an error, and you will need to delete the feature layer.

    If there are multiple shapefiles in the .zip file, they will all be included in the feature layer.

  6. Check the box next to Publish this file as a hosted layer.

    If you leave the box unchecked, your data file is added to My Content, but no hosted feature layer is published. You can publish the features later if you want. See Add items for more information.

  7. Type a title.
  8. Type tag terms separated by commas.

    Tags are words or short phrases that describe your item and help people find your item when searching. Federal land is considered one tag, while Federal,land is considered two tags.

  9. Click Add Item.

Your file is published as a hosted feature layer. It may take some time to upload the file. One way to test the new hosted feature layer is to view it in the map viewer.

The data file and the feature layer are separately added to My Content. You can edit item details and share the items. The items are independent, so for example, if you change the thumbnail in the feature layer's item details, the thumbnail does not update on the file's item details.

By default, the hosted feature layer can only be accessed by the publisher. You can share the hosted feature layer and the file with everyone in your organization or members of specific groups.

Publish a feature collection

If your data needs to be edited by multiple people, you can publish your feature collection as a hosted feature layer, share the layer, enable editing on it, and then use the feature layer in your map.

  1. Open the item details of the feature collection you want to publish as a hosted feature layer.
  2. Click Publish.
  3. You can use the default title for the hosted feature layer or type a new one.
  4. Type tag terms separated by commas.

    Tags are words or short phrases that describe your item and help people find your item when searching. public buildings is considered one tag, while public,buildings is considered two tags.

  5. Click Publish to create the hosted feature layer.

A hosted feature layer is created and added to your content.

Now you can share the hosted layer, enable editing, and add the feature layer to your map.

Publish from ArcMap

From ArcMap, you can publish a feature layer to be hosted on ArcGIS Online. The hosted feature layer will expose all vector datasets included in the map document.

An Internet connection is required to perform these steps. The speed and bandwidth of your connection affect how fast the feature layer will be published.

By default, editing is not enabled on hosted feature layers. You can enable editing from ArcMap when you initially publish or overwrite an existing feature layer.

Note that web browsers cannot display some of the more complex cartographic symbols you might have originally used when you authored the map in ArcMap. Most symbol types are available, but in some cases the symbols may be downgraded when you publish them. See Author feature services in the ArcGIS for Server help for more details about what symbols are supported and make any required changes to your map symbology prior to publishing.

  1. Start ArcMap and open the map you want to publish.
  2. Click File > Sign In.
  3. Type your name and password for ArcGIS Online and click Sign In.
  4. Click File > Share As > Service.
  5. Choose Publish a service and click Next.
  6. In the drop-down list of connection types, choose My Hosted Services. Type a name for your feature layer and click Continue.
  7. In the left pane of the Service Editor, click Capabilities and check Feature Access to expose your map as a feature layer. You can optionally also check Tiled Mapping, although in most scenarios, you would use a different set of layers and a different map document for publishing a tile layer.

    You can click the subitem Feature Access in the left pane of the Service Editor to set advanced properties relating to what clients can do with the hosted feature layer. To learn how to adjust the types of edits that end users can make to your hosted feature layer, see Editor permissions for feature services.

  8. Set other properties that you want for your hosted feature layer. You can choose what users can do with your feature layer and take fine-grained control of how the server will expose it.

    For information on how to best configure your hosted feature layer for deployment, see Tuning and configuring services. Some of the properties referenced in that topic apply only to ArcGIS for Server and are not applicable when working with feature layers hosted on ArcGIS Online. For example, with ArcGIS Online hosted layers, there is no option to set the minimum and maximum number of instances of the service, because Esri handles the service scaling for you.

  9. There are a few additional properties you must set that are specific to hosted feature layers. These are detailed in the following steps.
  10. In the left pane of the Service Editor, click Item Description and enter a summary and tags for your layer. You'll need to enter this information before you can publish. For more information, see Setting map service properties.
  11. In the left pane of the Service Editor, click ArcGIS Online and choose with whom the feature layer should be shared. By default, your hosted feature layer is private, meaning it is only accessible to you. Your hosted feature layer will always be visible in My Content, but you can also choose to share it with everyone or just members of certain ArcGIS Online groups.
  12. In the Service Editor, click Analyze Analyze.

    This examines your map to see if it can be published. You must fix the Errors Error in the Prepare window before you can publish. Optionally, you can fix the warnings and informational messages to further improve the performance and appearance of your hosted feature layer. For more information about resolving these issues, see Analyzing your GIS resource.

  13. Optionally, in the Service Editor, click Preview Preview. This can give you an idea of how your feature layer will look when viewed on the web.
  14. Once you've fixed the errors and optionally any warnings and messages, click Publish Publish.

Once your feature layer is published and hosted on ArcGIS Online, you'll see it when you expand the My Hosted Services node in the Catalog window.

By default, feature layers published from an ArcMap document only return 1,000 records. This limit is configurable in the publisher dialog box when publishing a new feature layer or overwriting an existing hosted feature layer.

Publish from ArcGIS Pro

From ArcGIS Pro, you can publish a feature layer to be hosted on ArcGIS Online.

An Internet connection is required to perform these steps. The speed and bandwidth of your connection affect how fast the feature layer will be published.

By default, editing is not enabled on hosted feature layers, but you can enable editing from ArcGIS Pro when you initially publish or overwrite an existing feature layer.

Note that web browsers cannot display some of the more complex cartographic symbols you might have originally used when you authored the map. Most symbol types are available, but in some cases the symbols may be downgraded when you publish them. See Author feature services in the ArcGIS for Server help for more details about what symbols are supported and make any required changes to your map symbology prior to publishing.

  1. Start ArcGIS Pro and open the project that contains the map or scene with the data you want to publish.
  2. Sign in to your organization from ArcGIS Pro using an account that has privileges to create content and publish hosted feature layers.
  3. To publish a feature layer, do one of the following:
    • Select the layers in the Contents pane. Right-click the selection set and click Share As Web Layer. When you publish selected layers, only a hosted feature layer is created on ArcGIS Online.
    • To share the map and publish all of its layers, click Web Map in the Share As group of the Share tab. When you share a map using ArcGIS Pro, the map layers are also published as hosted layers.

  4. Type a name for the feature layer. The layer is saved to My Content by default. You can save to a folder within My Content by either typing the folder name or browsing to an existing folder.
  5. Accept the default Layer Type option of Features.
  6. Provide a summary and tags for the feature layer.
  7. Specify how the feature layer will be shared. All layers you publish are automatically shared to your personal workspace in your organization (My Content). Your content is inaccessible to others until you share it with one or more of the following:
    • The name of your organization—You will see this option if you are signed in with an organizational account. Selecting this option allows the layer to be shared with all authenticated users in the organization.
    • Everyone—Selecting this option makes the layer available to the public.
    • Groups—You can share the layer with members of groups to which you belong.
  8. By default, the feature layer you publish is not editable, cannot be taken offline, and the data it contains cannot be exported. To allow others to perform these operations on your feature layer, click the Configuration tab and check the box next to the operations you want to allow:
    • Enable Editing—This operation enables members of your organization who have edit privileges to add, update, or delete features in your hosted feature layer.
    • Enable Sync—This allows people to download maps containing the hosted feature layer, edit the data, and synchronize their changes back to the hosted feature layer.
    • Export Data—The hosted feature layer owner and organization administrator can always export data from a hosted feature layer. Enabling this operation allows other members to export data from the hosted feature layer to a CSV, shapefile, file geodatabase, GeoJSON file, or feature collection.
  9. Click the Content tab to confirm your feature layer will include the data layers you intended.
  10. Click Analyze to check for any errors or issues.

    If any issues are discovered, they will be listed in the Messages tab. Right-click each message to get more information, read help for the error or warning, and access suggested fixes. You must fix the errors before you can publish. Optionally, you can fix the warnings to further improve the performance and appearance of your hosted feature layer.

  11. Once you've fixed the errors and optionally any warnings, click Publish.

When publishing completes, you can click Manage the web layer to open ArcGIS Online.

Publish the contents of a file geodatabase

To web-enable a feature layer from file geodatabase (packaged in a .zip file), you can upload the zipped file geodatabase to Esri's cloud and have its contents hosted as a service. This service is referred to as a hosted feature layer.

Publishing file geodatabase contents is a useful workflow if the geodatabase contains only a few datasets.

You can publish the following data types from a file geodatabase to a hosted feature layer:

  • Feature classes (x- and y-coordinates; m- and z-coordinates will be dropped)
  • Tables
  • Attachments
  • Relationship classes

Other data types—such as rasters, networks, and parcel fabrics—remain in the geodatabase but are not included in the published hosted feature layer. Domains also remain in the geodatabase, but are not accessible from the hosted feature layer.

Follow these steps to add a file geodatabase to the website and publish its contents as a hosted feature layer.

  1. Verify that you are signed in and that you have privileges to create content and publish hosted features.
  2. Open My Content, click Add Item, and click From my Computer.
  3. Click Choose File and browse to the file on your computer.

    The file geodatabase must be in a .zip file.

  4. Select the file and click Open.
  5. Check the box next to Publish this file as a hosted layer.

    If you leave the box unchecked, the file geodatabase is added to My Content, but no hosted feature layer is published. You can publish the features later if you want. See Add items for more information.

  6. Type a title.
  7. Type tag terms separated by commas.

    Tags are words or short phrases that describe your item and help people find the item when searching. Federal land is considered one tag, while Federal,land is considered two tags.

  8. Click Add Item.

The supported data in your file geodatabase is published as a hosted feature layer. It may take some time to upload the file. One way to test the new feature layer is to view it in the map viewer.

The data file and the feature layer are separately added to My Content. You can edit item details and share the items. The items are independent, so for example, if you change the thumbnail in the feature layer's item details, the thumbnail does not update on the file's item details.

By default, the hosted feature layer can only be accessed by the publisher. You can share the hosted feature layer and the file with everyone in your organization or members of specific groups.

Publish an empty hosted feature layer

The website allows you to create a hosted feature layer that is empty and available for editing. You can configure this feature layer to use the extent and schema of an existing feature layer. For example, you might have a feature layer displaying the perimeter of an existing wildfire. When a new wildfire occurs, you can create an empty feature layer from your existing one. You can then populate the new layer with the boundary and attributes of your new wildfire.

Follow these steps to create an empty hosted feature layer.

  1. Verify that you are signed in with an account that has privileges to create content and publish hosted feature layers and open My Content.
  2. Click Create and choose Feature Layer.
  3. Choose an existing hosted feature layer whose layers you would like to apply to the new feature layer. There are several approaches you can take:
    • Click the From Template tab, select one of the template feature layers provided by Esri, and click Next.
    • Click the Existing Layer tab to use a hosted feature layer from your organization. Search for or browse to the existing hosted feature layers you want to use, select it, and click Next.
    • Click the From URL tab, type the URL of an existing hosted feature layer, and click Next.

    No matter which approach you take, check the box next to each layer you want to include in your new feature layer. You must choose at least one layer.

    This step doesn't actually add or copy any features to your new hosted feature layer; you're just defining the layers (and associated attribute fields) that will be available.

    When you're done choosing layers, click Next.

  4. Pan the test map to the default extent you want for your new feature layer and click Next.

    This step helps you narrow the scope of the layer when it is first edited.

  5. Type a title, tags, summary, and location for your feature layer, and click Done. You're taken to the item details page of your new hosted feature layer.