Skip To Content

Show tables

To see information about features in a layer, you can display an interactive table at the bottom of the map in Map Viewer or on the Data tab of the feature layer's item page. Seeing a tabular view of the data can be a quick way to analyze information and start making decisions. You can sort, resize, reorder, and hide data, as well as select specific attributes to see on the map. For example, you could show a table for a crimes layer and see the different types of crime that your district responded to over the last two years.

You can view and sort the attribute data displayed in the table to help you better understand your feature layer. You can also get more information about the layer by viewing any available related data tables, as well as any related photos or other file attachments. If you have privileges to edit the layer, you can edit or delete attribute values and attach additional related photos and files. See Edit tables for more information. If you own the layer, you can perform bulk editing operations, such as calculating field values and appending data. As the layer owner, you can also change the types of information stored in the layer by adding and deleting fields.

Tip:

Showing tables can be a useful way to see which features will display in your map. If the layer contains features that aren't important to your audience, you can set up a more focused display of the layer by applying filters.

Show a table in Map Viewer

To show a feature layer's attribute table in Map Viewer, do the following:

  1. Open the map with the feature layer whose attributes you want to see in a table.
  2. Click Details and click Contents.
  3. Browse to the feature layer and click Show Table Show Table. The table appears at the bottom of your map.
    Tip:

    To resize the table vertically, drag the splitter bar centered above the table title up or down.

  4. Click Hide Table Hide Table to close the table view in the map.

Show a table on the item page

To show a table on the item page of a feature layer, do the following:

  1. Go to the item page of the feature layer whose attributes you want to see in a table.
  2. Click the Data tab.

View attributes and related records

Once the table is open in the map, you can view the layer's attributes. If the owner of the feature layer has created a relationship between the feature layer and another table, you will also see attributes from the related tables. Attributes from related tables are represented as columns with italicized headers on the right side of the table.

You can manipulate the table in the following ways to help you find the data you want:

  • To make it easier to find specific attribute values, sort the attributes by clicking the column header and selecting Sort Ascending or Sort Descending.

    For example, if you want to find all records (rows) for motor vehicle theft in a table of crimes in your district, click the column header for crime_type and select Sort Descending. The records will be sorted in reverse alphabetical order based on crime_type values, and you can scroll to all motor vehicle theft records.

    Note:

    Web services from some older versions of ArcGIS Server do not support sorting.

  • You can hide columns to make room in the display for the attributes you need. To hide or show attribute fields, click Options and click Show/Hide Columns. Check boxes to show attribute columns. Uncheck boxes to hide them.

    For example, you could hide the ID, latitude, and longitude columns in the crimes table so you only see the crime_type, date_time_reported, officers, arrest_made, and case_number data.

  • To rearrange the columns, you need to edit the layer's pop-ups.
    1. Click the More Options button More Options under the layer in the Contents pane.
    2. Click Configure Pop-up and click Configure Attributes.
    3. Select the field names of the columns you want to rearrange and use the Move up and Move down arrows to change the order of the columns. Columns listed from top to bottom correspond to their display from left to right in the table.
    4. Click OK on the Configure Attributes dialog box and the Configure Pop-up pane to apply your changes.
    Note:

    Rearranging columns is only supported in Map Viewer.

  • To view related records, click Show in the cell of the column corresponding to the record for which you want to view related records.

    For example, the crime layer is related to the cases table. To see the details in the cases table that are related to a particular crime, click Show in the appropriate cell of the case_number column. From there, you can explore other records in the cases table. If the related table has related records of its own, you can examine those as well—for example, if the cases table has a related table of evidence_collected, click Show to see related evidence records.

  • When viewing a related table, click the Close button (X) at any time to return to the previous table.
  • You can hide or show columns in related tables too. Click the Options button Options on the related table and click Show/Hide Columns. Check boxes to show the columns. Uncheck boxes to hide them.

View statistics for a numeric field

You can view information about each field (column) in an attribute table. Information available to you includes the field data type and length and whether the field is required, is editable, or has a unique constraint applied to it.

If the field stores numeric data, you can also view statistics, such as the number of rows, the minimum and maximum value, the sum of all values, the average value, and the standard deviation of all values.

Follow these steps to view statistics for a numeric field:

  1. Click the column heading for the field that contains numeric values for which you want to obtain statistics.
  2. Do one of the following:
    • If you are viewing the table from the item page Data tab, click Show Detailed View. The table shrinks to a more focused view of the field you selected with the statistics information displayed.
    • If you are viewing the table in Map Viewer, click Statistics. The calculated statistics are displayed.

View related photos and files

Feature layers can include related photos or other files as attachments, which you can view from the attribute table.

Do any of the following to view related photos and files:

  • If the layer has related photos or files, view them by clicking Show in the appropriate cell of the Photos and Files column on the right of the table.
  • To hide or show related photos and files columns, click the Options button Options and click Show/Hide Columns. Check boxes to show columns. Uncheck boxes to hide them.

Select and zoom to features

In Map Viewer, you can use a feature layer's attribute table to select and zoom to features on the map. To accomplish this, do any of the following:

  • To zoom to a feature on the map, click a record (row) in the table, click the Options button Options, and click Center on Selection.
  • To select multiple features on the map, hold down the Shift key and select multiple records or a range of records. Hold down the Ctrl key to select two or more nonadjacent records.
  • To clear a selection, click the Options button Options and click Clear Selection. This option is useful to clear all selected records.
  • To create a query expression that filters what feature data appears in the map and table, browse to the feature layer with the existing filter in the Contents pane and click Filter Filter.
  • To select the visible rasters in an imagery layer in your current area of interest and at the current pixel size, click the Options button Options and click Select Visible Rasters.
  • To display selected rasters in an imagery layer, click the Options button Options, select one or more rows of rasters, and click Display Selected Rasters.
  • To display all rasters in an imagery layer, click the Options button Options, select one or more rows of rasters, click Display Selected Rasters, and click Display All Rasters. (After you select Display Selected Rasters, the button name changes to Display All Rasters.)

Considerations when viewing tables

  • You can use a table to view these types of layers: feature and map services from an ArcGIS Server 10 SP1 or later site, hosted feature layers, hosted tile layers with associated attribute data, shapefiles, GPX files, and CSV (files and web).
  • Selecting and zooming to features is not supported in tables displayed on the Data tab of the item page.
  • In Map Viewer, tables display the same attribute fields and formatting that are configured in pop-ups. You can change a field name by editing the field alias in the Configure Attributes window of Pop-up Properties. If you make updates to the pop-up configuration while the table is open, you'll need to hide and show the table to see the updates.
  • In Map Viewer, if you select a single record to zoom to, the map zooms to the extent of the feature if the feature is a line or polygon. If the feature is a point, the map pans to the feature and, if necessary, zooms to a scale where the feature is visible.
  • In Map Viewer, if you select multiple records to zoom to, the map zooms to the extent of all the features. You may not see all the features if the extent of all the selected features is outside the visible scale range of the layer.
  • In Map Viewer, if you've selected a record in the table and open a pop-up in the map, you'll clear the selection in the table.
  • In Map Viewer, if the layer is hidden in the map, you cannot zoom to a selection.
  • The attribute table for layers in a time-enabled map will always show all records, not just those that the map is showing on the screen at a given time.